Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Beryl only available as root
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Bullet Dodger
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 230

PostPosted: Sat May 12, 2007 11:46 pm    Post subject: Beryl only available as root Reply with quote

Hi.

I'm not sure what i've done but beryl has stopped working.
The last thing i did was an emerge -uDaN world and noticed emeral was pulling in compiz, so i let it.
There was also a new gentoo kernel, so i compiled that and rebooted and everything was good. And beryl worked.
I turned the computer off after that and now when i come back to it beryl will not work.

I start beryl by logging in to KDE then running beryl-manager.

But when i ran it this time it went to the fallback -- Metacity.

If i then right click on the beryl icon on the kde bar --> select window manager --> beryl
It stills goes to metacity.

From an xterm
Code:

$ beryl
**************************************************************
* Beryl system compatibility check                           *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

[Warning ]: Relaunching beryl with __GL_YIELD="NOTHING"

**************************************************************
* Beryl system compatibility check                           *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

Segmentation fault

And all window borders disapear
Why the segfault?

But from a root xterm:
Code:

# beryl
**************************************************************
* Beryl system compatibility check                           *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

[Warning ]: Relaunching beryl with __GL_YIELD="NOTHING"

**************************************************************
* Beryl system compatibility check                           *
**************************************************************

Detected xserver                                : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension               : passed (v0.3)
Checking for XDamage extension                  : passed
Checking for RandR extension                    : passed
Checking for XSync extension                    : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig                  : passed
Checking for GLX_EXT_texture_from_pixmap        : passed
Checking for non power of two texture support   : passed
Checking maximum texture size                   : passed (4096x4096)

beryl: dbus_bus_get error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
beryl: Plugin 'dbus':initDisplay failed
beryl: Couldn't activate plugin 'dbus'
Couldn't initialize dbus. This should not happen!


And beryl is working. Although wid the default settings of course. And obiously its not right to have to be root to start beryl.

I can however right click --> select window manager --> compiz
and it works. But there is a lot of beryl that is still missing from compiz.
(I tried installing compcomm, but i'm not sure this has worked).
I like beryl's wall but compiz doesn't have it.

(They should make the wall one surface of the cube -- how good would that be :D)

And why is opacify under accessibility? Its an excellent feature

So whats wrong here?
Is there some kind of permissions problems?
I've never seen this problem before.

Cheers
Back to top
View user's profile Send private message
bLUEbYTE84
Guru
Guru


Joined: 21 Jul 2006
Posts: 566
Location: universe.tar.gz, src/earth.h, struct homo_sapiens_table

PostPosted: Sun May 13, 2007 8:08 pm    Post subject: Reply with quote

Try
Code:
gpasswd -a <username> video

And re-login with the user

AND

In the bottom of your xorg.conf file there shoul be three lines concerning the DRI permission. If you use DRI, check that those three lines are uncommented (it should say Mode 0666 or something like that)
_________________
Advanced Signature Camouflage System®(ASCS) v0.1
Back to top
View user's profile Send private message
Bullet Dodger
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 230

PostPosted: Sun May 13, 2007 9:43 pm    Post subject: Reply with quote

Already in the video group.

But i've since done an
Code:

emerge --sync;layman --sync ALL;emerge -uDaN world


This emerge the 9999 versions of beryl and dependancies.
Beryl now works with Aquamarine, but not emerald.

When i try to use emerald, beryl works, but there is not window borders.

I think eneral has stopped working since its dependancies changed to compiz.

Cheers
Back to top
View user's profile Send private message
Bullet Dodger
Apprentice
Apprentice


Joined: 16 Jul 2005
Posts: 230

PostPosted: Sun May 13, 2007 10:45 pm    Post subject: Reply with quote

And now the wall has disappeared from beryl?

How do i get my wall back and emerald working?

Cheers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum