Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Initng, init replacement for speedy-boot!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Sat May 07, 2005 8:39 am    Post subject: Reply with quote

Io l'ho sempre usata, ma initng va cmq MOLTO più veloce
_________________
about:mozilla
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Sat May 07, 2005 9:16 am    Post subject: Reply with quote

koma wrote:
comio io quell'opzione l'ho provata, non funziona molto semplicemente, non funziona incasina tutto.

Io l'ho provata, mi ha funzionato egregiamente, ma non ho rilevato alcuna diminuzione sensibile dei tempi di avvio.... :?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
hardskinone
Guru
Guru


Joined: 02 Jan 2004
Posts: 460

PostPosted: Sat May 07, 2005 9:17 am    Post subject: Reply with quote

comio wrote:
Qualcuno di voi ha fatto un confronto con l'opzione RC_PARALLEL_STARTUP in /etc/conf.d/rc?


Sì. Ho quell'opzione sempre attiva. Initng è più veloce.

Il "blocco" quando avvia coldplug sembra essere apparente, è non avvia la richiesta di login sulla prima consolle.
_________________
Playlinux.net
Back to top
View user's profile Send private message
gutter
Moderator
Moderator


Joined: 13 Mar 2004
Posts: 7160
Location: Aarau, Aargau, Switzerland

PostPosted: Sat May 07, 2005 9:18 am    Post subject: Reply with quote

Cazzantonio wrote:

Io l'ho provata, mi ha funzionato egregiamente, ma non ho rilevato alcuna diminuzione sensibile dei tempi di avvio.... :?


Idem, si recupera qualche secondo ma niente di particolarmente impressionante.
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
Guglie
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 240
Location: switzerland - zürich

PostPosted: Sat May 07, 2005 9:25 am    Post subject: Reply with quote

da me la velocità di avvio è aumentata molto: mi boota in 15 secondi
però non fa partire nessun demone.. i servizi che voglio fare partire devo specificarli a mano in /etc/initng/system.runlevel? o in /etc/initng/system?
_________________
A! Elbereth Gilthoniel! silivren penna míriel o menel aglar elenath!
Back to top
View user's profile Send private message
hardskinone
Guru
Guru


Joined: 02 Jan 2004
Posts: 460

PostPosted: Sat May 07, 2005 9:28 am    Post subject: Reply with quote

Guglie wrote:
da me la velocità di avvio è aumentata molto: mi boota in 15 secondi
però non fa partire nessun demone.. i servizi che voglio fare partire devo specificarli a mano in /etc/initng/system.runlevel? o in /etc/initng/system?


Code:

ng-update --help

_________________
Playlinux.net
Back to top
View user's profile Send private message
Benve
l33t
l33t


Joined: 13 Mar 2003
Posts: 897
Location: Italy Romagna

PostPosted: Sat May 07, 2005 9:43 am    Post subject: Reply with quote

Cazzantonio wrote:
koma wrote:
comio io quell'opzione l'ho provata, non funziona molto semplicemente, non funziona incasina tutto.

Io l'ho provata, mi ha funzionato egregiamente, ma non ho rilevato alcuna diminuzione sensibile dei tempi di avvio.... :?


Io sapevo che l'opzione c'era ma in realtà non era implementata
Back to top
View user's profile Send private message
Guglie
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 240
Location: switzerland - zürich

PostPosted: Sat May 07, 2005 9:55 am    Post subject: Reply with quote

grazie hardskinone, mi era sfuggito..
aggiungendo tutti i servizi ci mette circa 18 secondi invece di 30
_________________
A! Elbereth Gilthoniel! silivren penna míriel o menel aglar elenath!
Back to top
View user's profile Send private message
Lucacri
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jan 2005
Posts: 147
Location: 2a Curva di Lesmo!

PostPosted: Sat May 07, 2005 11:18 am    Post subject: Reply with quote

Purtroppo io non riesco a far partire tutti i servizi che mi servirebbero!! Qualcuno sa come fare a creare un proprio "servizio" con initng?
Back to top
View user's profile Send private message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Sat May 07, 2005 11:34 am    Post subject: Reply with quote

Io me ne sono fatto uno per la scheda di rete (anceh se quello p molto semplice). Cmq internamente sono piuttosto semplici, aprine uno simile e dovresti capire come farti il tuo.
_________________
about:mozilla
Back to top
View user's profile Send private message
mc619
Apprentice
Apprentice


Joined: 07 Dec 2004
Posts: 203

PostPosted: Sat May 07, 2005 5:23 pm    Post subject: Reply with quote

e' in portage
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Sat May 07, 2005 5:38 pm    Post subject: Reply with quote

Allora... fatemi capire. Usando questo initng, tutta la gestione dei file di init va riscritta? :S Questo mi turba.

ciao
_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
hardskinone
Guru
Guru


Joined: 02 Jan 2004
Posts: 460

PostPosted: Sat May 07, 2005 7:16 pm    Post subject: Reply with quote

comio wrote:
Allora... fatemi capire. Usando questo initng, tutta la gestione dei file di init va riscritta? :S Questo mi turba.


Se intendi che bisogna riscrivere i vari script che gestiscono i servizi la risposta è affermativa.
_________________
Playlinux.net
Back to top
View user's profile Send private message
Dhaki
Guru
Guru


Joined: 16 Jun 2004
Posts: 325
Location: Ticino - CH

PostPosted: Sat May 07, 2005 7:21 pm    Post subject: Reply with quote

È fuori la versione 0.0.8

Changelog: Added support for stdout and stderr in config file, a bugfix for pcmcia that delayd boot 2 secs complaining

http://jw.dyndns.org/initng/
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sat May 07, 2005 9:04 pm    Post subject: Reply with quote

L'ho provato ed è davvero velocissimo (in pratica impiega di più a fare non so quali controlli sul mio ReiserFS, succede anche a voi, all'avvio, prima che parta init in pratica?)

Mi turba un po' la mancanza di alcuni file di init... certo se venisse implementato come scelta di default alla fine non ci sarebbe più questo problema, sarebbe eccezionale! E poi non so se avete letto la discussione originale in inglese, all'inizio si parlava di qualcosa per imitare il Prefetch di Microsoft... poi non so se lungo la discussione l'argomento è stato mollato, ma pareva interessante!

Piuttosto allora... a me mancano mldonkey, irda e lisa... per gli ultimi due no problem, mentre il primo la vedo un po' più complicata!

E come la mettiamo secondo voi con le configurazioni in /etc/conf.d ? Non è che alla lunga, implementando le funzionalità che fornisce sysvinit, anche questo initng finisce per diventare lento come l'altro?

Ciao!

PS: È solo una mia impressione o i segnali di avvio possono essere MOLTO migliorati :D ?
PPS: So che è solo un hobby serale dell'autore, infatti tutto quello detto sopra non era per critica, anzi! Ho già riavviato due volte in mezz'ora (e credetemi, non ci sono più abituato :D ) per vedere come andava e son rimasto impressionato! Sarebbe fantastico se venisse sostenuto dai developer di Gentoo (e poi vuoi mettere l'anteprima che avremmo rispetto alle altre distro!!)
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
Guglie
Apprentice
Apprentice


Joined: 01 Mar 2004
Posts: 240
Location: switzerland - zürich

PostPosted: Sat May 07, 2005 9:55 pm    Post subject: Reply with quote

Thrain wrote:
Sarebbe fantastico se venisse sostenuto dai developer di Gentoo (e poi vuoi mettere l'anteprima che avremmo rispetto alle altre distro!!)

è stato inserito in portage dopo meno di una settimana, quindi immagino che avrà un buon futuro :)
_________________
A! Elbereth Gilthoniel! silivren penna míriel o menel aglar elenath!
Back to top
View user's profile Send private message
^Sporting^
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2003
Posts: 131
Location: 009°11'28'' E 045°36'39'' N

PostPosted: Sat May 07, 2005 10:50 pm    Post subject: Reply with quote

:D
stavo giusto reinstallando Gentoo sul mio notebook (l'ho mandato in assistenza x un problema e mi hanno formattato l'intero disco...)
nn manchero' di provarlo :lol:
Back to top
View user's profile Send private message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Sun May 08, 2005 6:12 am    Post subject: Reply with quote

Purtroppo (almeno secondo me) perchè funzioni bene deve essere supportato dai dev gentoo, l'autore non penso abbia tempo anche per fare tutti gli init script di tutti i pacchetti che lo richiedono. Cmq già alcuni file in conf.d li legge :wink:
_________________
about:mozilla
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sun May 08, 2005 10:45 am    Post subject: Reply with quote

daemon/?dm non funziona da utente normale con kde se prima non accedo da root... capita anche a voi?

Tra l'altro non ho capito come si fa a spegnere il pc... halt non funziona :D

PS: Va bene se posto qui i problemi o questo è solo un topic di discussione? Non vorrei finire OT :D

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
Dhaki
Guru
Guru


Joined: 16 Jun 2004
Posts: 325
Location: Ticino - CH

PostPosted: Sun May 08, 2005 10:47 am    Post subject: Reply with quote

Thrain wrote:
daemon/?dm non funziona da utente normale con kde se prima non accedo da root... capita anche a voi?

Tra l'altro non ho capito come si fa a spegnere il pc... halt non funziona :D

PS: Va bene se posto qui i problemi o questo è solo un topic di discussione? Non vorrei finire OT :D

Ciao

Dai un occhiata a ngc

Code:
root@Viki ~ $ ngc --help
Next Generetion init Control.
written by Jimmy Wennlund <jimmy.wennlund@gmail.com


usage: ngc -[gudfrj] service
       ngc -[lsxqpn]

 -g     get; output just the PID.
 -u     up; start service.
 -d     down; stop service.
 -f     father; find out father to process.
 -r     reload; service data from disk.
 -j     startform, stops all services, and start just this one.
 -z     zap, mark it as stop, and removed from active services.
 -l     history; print last history.
 -s     status; List all active processes.
 -q     quit; kill initng (hang).
 -x     restart; initng (warm reboot).
 -p     print; Dump service cache on console.
 -n     print percent; For how many percent is your system up?.


Cmq come ha detto Guglie, penso che sia ben visto dai dev di gentoo, e quindi a breve anche gli init script arriveranno, spero

EDIT: fuori la versione 0.0.9. http://jw.dyndns.org/initng/
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sun May 08, 2005 11:07 am    Post subject: Reply with quote

È questo il problema... allora, per riavviare non c'è problema, al massimo vado di ctrl+alt+canc, ma per spegnere non so come fare! Premetto che con init andava tutto bene, comunque ho provato:
Code:

ngc -q
halt

e continua a non volersi spegnere (mi appare il messaggio System Halted ma rimane tutto acceso...)

Idee??
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
SilverXXX
l33t
l33t


Joined: 18 Sep 2004
Posts: 885

PostPosted: Sun May 08, 2005 11:12 am    Post subject: Reply with quote

Mi sa che per il momento lo spegnimento non c'è proprio.....
MA tanto con la velocità con cui macina adesso, non ci metterà molto
_________________
about:mozilla
Back to top
View user's profile Send private message
mambro
l33t
l33t


Joined: 22 Mar 2004
Posts: 752
Location: Mira (VE) - Italy

PostPosted: Sun May 08, 2005 11:15 am    Post subject: Reply with quote

Ma nn sarebbe meglio far si che initng si adatti agli initscripts già esistenti piuttosto che riscriverli con sintassi diversa? :?
_________________
"The design of a worldwide, fully transparent distributed file system for simultaneous use by millions of mobile and frequently disconnected users is left as an excercise for the reader".
Andrew S. Tanenbaum, Distributed Operating Systems.
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sun May 08, 2005 12:33 pm    Post subject: Reply with quote

Già, lo spegnimento è completamente inaffidabile... ogni tanto va, ogni tanto non va... Penso che questo sia il problema maggiore ora come ora, e spero lo risolvano in fretta... per quanto riguarda tutto il resto va più che bene per essere alla release 0.0.9 :D !

mambro wrote:

Ma nn sarebbe meglio far si che initng si adatti agli initscripts già esistenti piuttosto che riscriverli con sintassi diversa? :?


Concordo ma penso ci sia qualche problema... e poi per init semplici la sintassi di initng sembra molto migliore (dal poco che ho visto)

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
Dhaki
Guru
Guru


Joined: 16 Jun 2004
Posts: 325
Location: Ticino - CH

PostPosted: Sun May 08, 2005 3:45 pm    Post subject: Reply with quote

SilverXXX wrote:
Premetto che mi dà alcuni errori e il comando ng-update manca del comando show, ma a parte questo è di una velocità disarmante (mi sono cadute le @@ pensando al vecchio init, e alla fine che si merita visto questo initng). Appena completerà il comando ng-update con show, si potrebbe integrare in gento0 (così ci mangiamo ogni altra distro in partenza :twisted: ), passando gli script degli ebuild da init a initng.

Ho scritto un piccolo hack per implementare il comando ng-update show. Per vedere: http://jw.dyndns.org/bugzilla/show_bug.cgi?id=9
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum