Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem installing on sun ultra 5: free_all_bootmem()
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Thu Apr 28, 2005 5:44 pm    Post subject: problem installing on sun ultra 5: free_all_bootmem() Reply with quote

Hi, I have problem installing gentoo on sun ultra 5. while I boot and select gentoo-2.4 booting stops after reaching "gentoo mem_init: Calling free_all_bootmem". Please help me. 10x in advance
Back to top
View user's profile Send private message
riposte
n00b
n00b


Joined: 17 Nov 2003
Posts: 69
Location: New Zealand

PostPosted: Fri Apr 29, 2005 1:31 am    Post subject: Reply with quote

Can you tell us the machine specs and the prom version.
Back to top
View user's profile Send private message
mydecay
n00b
n00b


Joined: 28 Apr 2005
Posts: 6

PostPosted: Fri Apr 29, 2005 7:10 am    Post subject: Reply with quote

and maybe a full dmesg should help us spotting out the problem
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Fri Apr 29, 2005 11:07 am    Post subject: Reply with quote

riposte wrote:
Can you tell us the machine specs and the prom version.


Sun Microsystems UltraSparc IIi 360 MHz
OpenBoot 3.31

Thanks in advance.
Back to top
View user's profile Send private message
Magic Michael
n00b
n00b


Joined: 02 Aug 2004
Posts: 47
Location: Berlin (West) / Deutschland

PostPosted: Mon May 02, 2005 7:05 pm    Post subject: Reply with quote

I've got the same OBP version in my Ultra5 270MHz, so that shouldn't be the problem. Which gentoo-CD did you use ? I had success with 2005.0 for sparc64.
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Mon May 02, 2005 7:06 pm    Post subject: Reply with quote

Magic Michael wrote:
I've got the same OBP version in my Ultra5 270MHz, so that shouldn't be the problem. Which gentoo-CD did you use ? I had success with 2005.0 for sparc64.


I use Gentoo 2005.0 for sparc. :(
Back to top
View user's profile Send private message
squash
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2002
Posts: 79

PostPosted: Mon May 02, 2005 7:51 pm    Post subject: Reply with quote

If you are using the sparc (sparc32) cd and not the sparc64 cd, you won't be able to boot.
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Mon May 02, 2005 9:03 pm    Post subject: Reply with quote

squash wrote:
If you are using the sparc (sparc32) cd and not the sparc64 cd, you won't be able to boot.


no, its sparc64 cd
meanwhile I installed netbsd on it, but I love gentoo.. any help will do
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Tue May 03, 2005 1:51 pm    Post subject: Reply with quote

Bootmem messages in the 2005.0 livecd are just debug info before running the kernel.
So basically you're not getting to the kernel, or somehow the output is going somewhere else (serial console instead of vga out or the other way around).
Can you see the livecd still working after that?
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Tue May 03, 2005 4:57 pm    Post subject: Reply with quote

gust4voz wrote:
Bootmem messages in the 2005.0 livecd are just debug info before running the kernel.
So basically you're not getting to the kernel, or somehow the output is going somewhere else (serial console instead of vga out or the other way around).
Can you see the livecd still working after that?


well, yes, it's spinig for a while, but I don't see much :(
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Tue May 03, 2005 10:40 pm    Post subject: Reply with quote

Using onboard framebuffer right?
What's the value of output-device in OBP?
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Wed May 04, 2005 8:49 am    Post subject: Reply with quote

gust4voz wrote:
Using onboard framebuffer right?
What's the value of output-device in OBP?


well, I am not that familular with sun. I know that I have addtitional grtaphic card tat I connect monitor to. Could you please explain to me how can I found oа info you asked me?

thanks in advance
Back to top
View user's profile Send private message
squash
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2002
Posts: 79

PostPosted: Wed May 04, 2005 12:56 pm    Post subject: Reply with quote

Hi Rup,

Go over this doc, http://www.gentoo.org/doc/en/gentoo-sparc-obpreference.xml and you will be able to get the info you need.

Squash
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Tue May 10, 2005 9:22 am    Post subject: Reply with quote

gust4voz wrote:
Using onboard framebuffer right?
What's the value of output-device in OBP?


output-device value = screen2 default value=screen

thanks in advance.
Back to top
View user's profile Send private message
Magic Michael
n00b
n00b


Joined: 02 Aug 2004
Posts: 47
Location: Berlin (West) / Deutschland

PostPosted: Tue May 10, 2005 1:34 pm    Post subject: Reply with quote

Do you have an additional framebuffer in your ultra5 ? If not, maybe setting screen as output-device would be better: "setenv output-device screen" from the ok-prompt or "eeprom output-device?=screen" from Solaris / Linux.

How is "screen2" defined ? "devalias" at the ok-prompt should show that.
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Tue May 10, 2005 5:18 pm    Post subject: Reply with quote

Magic Michael wrote:
Do you have an additional framebuffer in your ultra5 ? If not, maybe setting screen as output-device would be better: "setenv output-device screen" from the ok-prompt or "eeprom output-device?=screen" from Solaris / Linux.

How is "screen2" defined ? "devalias" at the ok-prompt should show that.


the output of devalias is

screen /pci@1f,0/pci@1,1/SUNW,m64B@2
screen2 /pci@1f,0/pci@1/TSI,gfxp@1

if I make screen default will I see anything on my screen?

thanks in advance
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Tue May 10, 2005 5:45 pm    Post subject: Reply with quote

screen2 or the TSI,gfxp entry sounds like a Raptor GFX, which isn't supported under linux for the console at least.
Try setting output-device to screen instead of screen2, and using the onboard vga out instead of that card.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
rup
n00b
n00b


Joined: 28 Apr 2005
Posts: 16

PostPosted: Wed May 11, 2005 10:16 am    Post subject: Reply with quote

gust4voz wrote:
screen2 or the TSI,gfxp entry sounds like a Raptor GFX, which isn't supported under linux for the console at least.
Try setting output-device to screen instead of screen2, and using the onboard vga out instead of that card.


10x a lot!! it worked. But will I still able to use with second card somehow in the future?
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Wed May 11, 2005 12:58 pm    Post subject: Reply with quote

If i remember right the raptor gfx cards are permedia 2, you *MAY* be able to use it in xorg.
Give it a shot, feedback is welcome, i think Ferris will be specially interested.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
Magic Michael
n00b
n00b


Joined: 02 Aug 2004
Posts: 47
Location: Berlin (West) / Deutschland

PostPosted: Sat May 14, 2005 12:52 pm    Post subject: Reply with quote

I´ve got a Raptor GFX8p (also sold as PGX32 by Sun) in my Ultra 5 with the onboard framebuffer disabled. Console and xorg are fine with the raptor.
When you enable both framebuffers, the obp output is displayed on the onboard fb only.
Multihead with both fbs worked fine in Solaris, didn't try that with Linux/xorg.
And yes, this raptor is a permedia 2, see here: http://www.techsource.com/products/datasheets/gfx8p.htm
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum