Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Fix OpenGL problems on ATI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Lucky B
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 235
Location: Florida

PostPosted: Thu Apr 21, 2005 7:34 pm    Post subject: HOWTO: Fix OpenGL problems on ATI Reply with quote

This is not exactly a howto but a list of possible problems with solutions:

(there are 30+ threads that solve exactly the same problem, don't believe me? do a quick search for "LIBGL_DRIVERS_PATH")


1. The obvious:
Make sure you've emerged ati-drivers and you've loaded the module.

Then make sure you're running the ati opengl drivers
Code:

# opengl-update --get-implementation
ati


"ati" is the reply of the program. If it doesn't say ati, then opengl-update ati.

2. 32bit problems:
If for example Enemy Territory or any other 32bit OpenGL app isn't working (et is most useful because it will complain when it's forced to load Mesa), you will have to fix an environment variable.

First test it out:
Code:
LIBGL_DRIVERS_PATH="/usr/lib32/modules/dri" <32 bit OpenGL program of choice>


if it works, yay!

We can't just blindly
Code:
export LIBGL_DRIVERS_PATH="/usr/lib32/modules/dri"
because it will make 64 bit libraries/programs fail to find the appropiate DRI and revert to Mesa Software Emulated OpenGL, and we don't want that.

So we have a variety of options (Gentoo is about options).

a. Change the way we load the program

We could add the appropiate
Code:
LIBGL_DRIVERS_PATH="<path>"
to the beginning of all your OpenGL programs, but this would be clunky at best.

b. change .bashrc and load all our programs from the terminal

Add
Code:
 LIBGL_DRIVERS_PATH="/usr/lib32/modules/dri:/usr/lib64/modules/dri"
to ~/.bashrc. This is also a bit quirky and you can forget that you have to load stuff from the terminal.

c. my favorite: add it to env.d



Add
Code:
 LIBGL_DRIVERS_PATH="/usr/lib32/modules/dri/:/usr/lib64/modules/dri/"
to /etc/env.d/99local (if it doesn't exist, then create it).

The reason I advocate 99local is so that you stay safe for apps updating the env.d's LIBGL_DRIVERS_PATH. You don't want to over-write it and run into problems if the directories ever change.

After that's done:
Code:

env-update
source /etc/profile


You might have to restart X or KDE in order to use programs from your WM menues.

This is definitely a work in progress and I've forgotten the rest of the tweaks I've used, so go ahead and reply here with more, see if we can solve all the OpenGL problems in one spot. (if anyone has nVidia problem solutions feel free to post them also and we'll make this thread universal)
_________________
We are Dyslexic of Borg. Fusistance is retile. Your ass will be laminated.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Apr 22, 2005 5:15 pm    Post subject: Reply with quote

You might also find more information here: http://forums.gentoo.org/viewtopic-t-282042.html
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum