Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot see Chinese
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese)
View previous topic :: View next topic  
Author Message
wuya
Apprentice
Apprentice


Joined: 16 Apr 2005
Posts: 195

PostPosted: Sat Apr 16, 2005 11:01 pm    Post subject: Cannot see Chinese Reply with quote

I cannot see the Chinese in this forum, I already have Chinese SCIM installed.
Back to top
View user's profile Send private message
EricHsu
Moderator
Moderator


Joined: 03 May 2004
Posts: 591
Location: Aragon Consulting Group, Beijing, China

PostPosted: Mon Apr 18, 2005 6:07 am    Post subject: Reply with quote

well, you need to re-compile you glibc to support Chinese locales (zh_CN*), and have Chinese fonts installed... We've discussed this topic, before I have some spare time to find them for you, you could check this forum's older threads and look for it yourself : )

edit:
here it is~

edit2:
oh.. after you have Chinese support enabled in your system, you will need to set your browser's characters encoding to UTF-8
_________________
- http://nkbit.com
- http://twitter.com/xuyihua
Back to top
View user's profile Send private message
bpxyz
n00b
n00b


Joined: 05 Apr 2004
Posts: 12
Location: ChongQing China

PostPosted: Mon Apr 18, 2005 3:27 pm    Post subject: Reply with quote

:D 谢谢EricHsu对我们的帮助,
我已经看过你所有有关locale的帖了,照做了,我的系统已经支持中文了,因为用putty在winxp里export LC_ALL=zh_CN后,可以看到中文的文件.可我的终端下(我用gentoo做的gateway,没有X)仍然没有中文可以显示出来,就如同DOS下看到中文一样.
你说还要安装中文字体,可我实在太菜了点,完全不知道linux下如何安装字体安装那种字体:P

希望你再帮帮我...
谢谢!
_________________
Router & BT: PIII550 256M 40G+80G Pro100x3
Workstation1: C 1.7G + 1G + 80G
Workstation1: E8400 + 2G + 500G + GF9500
Back to top
View user's profile Send private message
EricHsu
Moderator
Moderator


Joined: 03 May 2004
Posts: 591
Location: Aragon Consulting Group, Beijing, China

PostPosted: Tue Apr 19, 2005 1:36 am    Post subject: Reply with quote

不客气!

如果希望在 console 下也能显示中文, 可能需要用到 unicon patch, 不过我自己还没试过, 呵呵, 如果可行, 记得回来说说心得 ;)

edit:
噢, 至于安装字体, 就把字体的 .ttf 文件拷贝到 /usr/share/fonts/TTF/ 下面, 重新登陆你的桌面环境 (GNOME/KDE...), 在桌面环境提供的字体设置里应该就可以选择了. 至于使用哪个字体, 常见的是抠 windows 的 simsun.ttf (或 simsun.ttc) 过来 8)
_________________
- http://nkbit.com
- http://twitter.com/xuyihua
Back to top
View user's profile Send private message
wuya
Apprentice
Apprentice


Joined: 16 Apr 2005
Posts: 195

PostPosted: Tue Apr 19, 2005 12:22 pm    Post subject: Reply with quote

Can you elaborate this part please?:
Quote:
(or you could set those variables via /etc/env.d/99local which will result in system-wide Chinese locale support)

The first method didn't work for me.
Code:
startfluxbox
export LC_CTYPE=zh_CN

Currently using SCIM.
Back to top
View user's profile Send private message
EricHsu
Moderator
Moderator


Joined: 03 May 2004
Posts: 591
Location: Aragon Consulting Group, Beijing, China

PostPosted: Wed Apr 20, 2005 2:16 am    Post subject: Reply with quote

wuya wrote:
Can you elaborate this part please?:
Quote:
(or you could set those variables via /etc/env.d/99local which will result in system-wide Chinese locale support)

The first method didn't work for me.


  • make sure your system (glibc) supports Chinese locales:
    Code:

    $ locale -a

    if your system supports Chinese locales, you should see some "zh_CN*" locales in the output.
  • copy some Chinese fonts .ttf files to the /usr/share/fonts/TTF
  • create the /etc/env.d/99local if it doesn't exist
  • add the following lines to the 99local file:
    Code:

    LC_CTYPE=zh_CN
    XMODIFIERS="@im=scim"
    XIM=scim
    XIM_PROGRAM=scim

    (It should work, but I'm not sure, I'll re-confirm it once I get back home - I'm currently using windows...)
  • logout and re-login, you now should have a Chinese system :)


BTW, scim is an app for inputting Chinese only, you should have a Chinese support enabled system before you could use it :)
_________________
- http://nkbit.com
- http://twitter.com/xuyihua
Back to top
View user's profile Send private message
wuya
Apprentice
Apprentice


Joined: 16 Apr 2005
Posts: 195

PostPosted: Wed Apr 20, 2005 11:10 am    Post subject: Reply with quote

Code:
zh_CN
zh_CN.gb2312
zh_CN.utf8

Have it.

Any of the below Chinese fonts? This is my first time.
Code:
Vera.ttf      VeraMoIt.ttf   fonts.dir    luxirb.ttf   luxisr.ttf
VeraBI.ttf    VeraMono.ttf   fonts.scale  luxirbi.ttf  luxisri.ttf
VeraBd.ttf    VeraSe.ttf     luximb.ttf   luxirr.ttf
VeraIt.ttf    VeraSeBd.ttf   luximbi.ttf  luxirri.ttf
VeraMoBI.ttf  encodings.dir  luximr.ttf   luxisb.ttf
VeraMoBd.ttf  fonts.cache-1  luximri.ttf  luxisbi.ttf

Quote:
you should have a Chinese support enabled system before you could use it

How do I enable Chinese support? I can see Chinese in Chinese sites, but I cannot see Chinese in this forum so I must have not done something.
Back to top
View user's profile Send private message
EricHsu
Moderator
Moderator


Joined: 03 May 2004
Posts: 591
Location: Aragon Consulting Group, Beijing, China

PostPosted: Wed Apr 20, 2005 12:38 pm    Post subject: Reply with quote

wuya wrote:

Any of the below Chinese fonts? This is my first time.
Code:
Vera.ttf      VeraMoIt.ttf   fonts.dir    luxirb.ttf   luxisr.ttf
VeraBI.ttf    VeraMono.ttf   fonts.scale  luxirbi.ttf  luxisri.ttf
VeraBd.ttf    VeraSe.ttf     luximb.ttf   luxirr.ttf
VeraIt.ttf    VeraSeBd.ttf   luximbi.ttf  luxirri.ttf
VeraMoBI.ttf  encodings.dir  luximr.ttf   luxisb.ttf
VeraMoBd.ttf  fonts.cache-1  luximri.ttf  luxisbi.ttf



Well, seems no...

wuya wrote:

Quote:
you should have a Chinese support enabled system before you could use it

How do I enable Chinese support? I can see Chinese in Chinese sites, but I cannot see Chinese in this forum so I must have not done something.


With glibc has Chinese locales support and set your system's LC_CTYPE to Chinese locale, your system now should supports Chinese well...

And, since you can see Chinese in Chinese sites, that means you've already have Chinese fonts installed somewhere in your system (should be in the /usr/share/fonts/arphicfonts/ dir...).

Have you set your browser's character encoding to UTF-8 while browsing this forum?
_________________
- http://nkbit.com
- http://twitter.com/xuyihua
Back to top
View user's profile Send private message
wuya
Apprentice
Apprentice


Joined: 16 Apr 2005
Posts: 195

PostPosted: Thu Apr 21, 2005 7:05 am    Post subject: Reply with quote

How do I do that?

Currently using Firefox.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Thu Apr 21, 2005 9:28 am    Post subject: Reply with quote

wuya wrote:
How do I do that?

View :arrow: Character Encoding :arrow: Unicode (UTF-8)
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
wuya
Apprentice
Apprentice


Joined: 16 Apr 2005
Posts: 195

PostPosted: Thu Apr 21, 2005 4:11 pm    Post subject: Reply with quote

Thanks for all the help!

One more thing: Are there any Chinese fonts meant for Simplified *primarily*? I ask because I am now using a Chinese font primarily for Traditional, but I use Simplified.

I can see the fonts but some characters are missing in the Simplified chart.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum