Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.3 hangs after installing Radeon driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ezzy125
n00b
n00b


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sun Apr 17, 2005 5:32 pm    Post subject: KDE 3.3 hangs after installing Radeon driver Reply with quote

Since I'm a newbie I got locked up in a nasty situation. After spending the whole weekend behind the PC, I was able to install gentoo-2.6.11-r3 fine. Got KDE to work with a VESA driver. Than I thought let's update my video driver for the real one. I have Radeon X300 video adapter.

I used the following guide; http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html#2_kernelopts

After re-compiling my kernel and steps above I rebooted the system. Since than my KDE desktops starts does the first steps but than hangs with "Loading the panel 0%". Mouse is working but the system doesn't react on anything...

Please help, I'm completely lost now?

Thx
Back to top
View user's profile Send private message
dusdus
Apprentice
Apprentice


Joined: 20 Jan 2005
Posts: 208
Location: Netherlands

PostPosted: Mon Apr 18, 2005 7:19 am    Post subject: Reply with quote

Your system hangs...but does it respond to Alt+Control+Backspace? It should shut down the X-server. You could check Xorg.log for any error messages, or you can even try "startx > error.log" to get some messages in a file instead of on your screen.

You could also try to uninstall your ati-drivers to get X working, try to get a solution for your problem and get the radeon driver active again.

good luck
_________________
Sorry, I don't understand...
Back to top
View user's profile Send private message
atom.galaxy
Tux's lil' helper
Tux's lil' helper


Joined: 05 Nov 2004
Posts: 112
Location: Slovenia, Eu

PostPosted: Mon Apr 18, 2005 1:04 pm    Post subject: Reply with quote

Helo!??? It's not X that's the problem here :D

If it gets stuck at loading the panel, it's definitely KDE's fault.

1) etc-update
run etc-update, it might be a config file. Although... I don't think it's highly probable.
2) revdep-rebuild
Try running revdep-rebuild (from the gentoolkit package: emerge gentoolkit), it might be a broken dependency.
3)re-emerge KDE
(sorry, i know it's a shit-sandwich but you're gonna have to take a bite). Try doing it when you're off at school / job or something...

Anyway, this is all I can think of right now. You can also try and emerge kde-base only (waaay lower compile time, however still above one hour.) do this if you mean to be at home when you set it to work. Otherwise, emerge-kde is gonna do fine.

I'm sure you noticed that my solutions are all like killing flies with a bazooka, but that's the kind of person I am. :D Follow me at your own will.
_________________
Atoms are watching...
Back to top
View user's profile Send private message
Jengu
Guru
Guru


Joined: 28 Oct 2004
Posts: 383

PostPosted: Mon Apr 18, 2005 4:40 pm    Post subject: Reply with quote

atom.galaxy wrote:
Helo!??? It's not X that's the problem here :D


Try knowing what you're talking about before criticizing others.

If KDE works when he uses VESA, but doesn't when he uses radeon, that suggests this maybe an X problem. Checking for errors with startx > mylog.txt is not a bad idea. That the freeze happens when loading the panel doesn't necessarily mean it's KDE's fault. It could be the case that X is freezing after a certain period of time regardless of wm.

I'd also emerge another wm like openbox and see if it loads correctly. If it works then you know the problem is specific to KDE.
Back to top
View user's profile Send private message
atom.galaxy
Tux's lil' helper
Tux's lil' helper


Joined: 05 Nov 2004
Posts: 112
Location: Slovenia, Eu

PostPosted: Mon Apr 18, 2005 9:16 pm    Post subject: Reply with quote

Sory, my fault... I should have read that first post twice before posting. Sorry.

I don't get it... Why should KDE hang, and not X??? Loading panel... It's the last option, and I think that's where QT starts to get used. Might be a QT problem as well.
X is quite robust to my experience, and if it ever hangs it's the second you run it and not 10 seconds later???
_________________
Atoms are watching...
Back to top
View user's profile Send private message
dusdus
Apprentice
Apprentice


Joined: 20 Jan 2005
Posts: 208
Location: Netherlands

PostPosted: Tue Apr 19, 2005 10:38 am    Post subject: Reply with quote

I suggested to read the errormessages, and the errorlog of xorg. Of course KDE also spits errormessages, which you could see after shutting down the x-server.
Good luck
_________________
Sorry, I don't understand...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum