Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Could not run/locate "i386-pc-linux-gnu-gcc"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cchou123
n00b
n00b


Joined: 03 Apr 2005
Posts: 7

PostPosted: Sun Apr 03, 2005 10:04 pm    Post subject: Could not run/locate "i386-pc-linux-gnu-gcc" Reply with quote

Help! I have installed Gentoo 2.6.11-r3 on my EPIA box. However when I tried to do:

emerge gnome xscreensaver

I get the following error during build:

make[3]: Entering directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server'
/usr/bin/orbit-idl-2 --nostubs -I /usr/share/idl/bonobo-activation-2.0 ../server/GNOME_RemoteDesktop.idl
/usr/bin/orbit-idl-2 --nostubs -I /usr/share/idl/bonobo-activation-2.0 ../server/GNOME_RemoteDesktop.idl
orbit-idl-2 2.12.0 compiling
mode, show preprocessor errors, passes: skels common headers skel_impl imodule

orbit-idl-2 2.12.0 compiling
mode, show preprocessor errors, passes: skels common headers skel_impl imodule

gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
Error: Empty file

** (process:24347): WARNING **: ../server/GNOME_RemoteDesktop.idl compilation failed
make[3]: *** [GNOME_RemoteDesktop-common.c] Error 1
make[3]: *** Waiting for unfinished jobs....
gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
Error: Empty file

** (process:24346): WARNING **: ../server/GNOME_RemoteDesktop.idl compilation failed
make[3]: *** [GNOME_RemoteDesktop-skels.c] Error 1
make[3]: Leaving directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1'
make: *** [all-recursive-am] Error 2

!!! ERROR: net-misc/vino-2.8.1 failed.
!!! Function gnome2_src_compile, Line 40, Exitcode 2
!!! compile failure
!!! If you need support, post the topmost build error, NOT this status message.

My gcc is i686-pc-linux-gnu-gcc. How do I get gcc-config to recognize it should use i686-pc-linux-gcc instead of i386-pc-linux-gcc?
Back to top
View user's profile Send private message
rhill
Developer
Developer


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Sun Apr 03, 2005 10:07 pm    Post subject: Reply with quote

run

Code:
fix_libtool_files.sh `gcc -dumpversion` --oldarch i386-pc-linux-gnu

_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
cchou123
n00b
n00b


Joined: 03 Apr 2005
Posts: 7

PostPosted: Mon Apr 04, 2005 12:13 am    Post subject: Could not run/locate "i386-pc-linux-gnu-gcc" Reply with quote

done that.

still no good. same error:

make[4]: warning: Clock skew detected. Your build may be incomplete.
make[4]: Leaving directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server/libvncserver'
make[3]: warning: Clock skew detected. Your build may be incomplete.
make[3]: Leaving directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server/libvncserver'
make[3]: Entering directory `/var/tmp/portage/vino-2.8.1/work/vino-2.8.1/server'
/usr/bin/orbit-idl-2 --nostubs -I /usr/share/idl/bonobo-activation-2.0 ../server/GNOME_RemoteDesktop.idl
/usr/bin/orbit-idl-2 --nostubs -I /usr/share/idl/bonobo-activation-2.0 ../server/GNOME_RemoteDesktop.idl
orbit-idl-2 2.12.0 compiling
mode, show preprocessor errors, passes: skels common headers skel_impl imodule

orbit-idl-2 2.12.0 compiling
mode, show preprocessor errors, passes: skels common headers skel_impl imodule

gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
Error: Empty file

** (process:13225): WARNING **: ../server/GNOME_RemoteDesktop.idl compilation failed
make[3]: *** [GNOME_RemoteDesktop-common.c] Error 1
make[3]: *** Waiting for unfinished jobs....
gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
Error: Empty file
Back to top
View user's profile Send private message
rhill
Developer
Developer


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Mon Apr 04, 2005 12:49 am    Post subject: Reply with quote

hmm. what does 'gcc-config -l' show you. maybe try switching to a different profile and back, and then run 'env-update; source /etc/profile'.

have you switched compiliers lately?
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
cchou123
n00b
n00b


Joined: 03 Apr 2005
Posts: 7

PostPosted: Mon Apr 04, 2005 2:03 am    Post subject: Reply with quote

root@tutti gcc # gcc-config -l
[1] i686-pc-linux-gnu-3.3.5 *
[2] i686-pc-linux-gnu-3.3.5-hardened
[3] i686-pc-linux-gnu-3.3.5-hardenednopie
[4] i686-pc-linux-gnu-3.3.5-hardenednossp

When the error first occurred, I thought gcc needs update so I did a

emerge gcc

However it went into a no return loop during build so I killed it and rebooted.

How do I switch profile?
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Mon Apr 04, 2005 6:11 am    Post subject: Reply with quote

hmmm ... any solution's?
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Mon Apr 04, 2005 7:51 am    Post subject: Reply with quote

Let me guess - you changed the CHOST variable in make.conf when installing, but did not use stage 1.
That was a mistake. CHOST may only be changed on stage 1.
You're on your own, in a maze of twisty little passages, all different.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
smask
n00b
n00b


Joined: 06 Mar 2004
Posts: 3

PostPosted: Mon Apr 04, 2005 2:29 pm    Post subject: Reply with quote

Hi,

i've the same problem. I solved it with an "emerge dev-libs/libIDL"
Try it

Bye
Back to top
View user's profile Send private message
cchou123
n00b
n00b


Joined: 03 Apr 2005
Posts: 7

PostPosted: Mon Apr 04, 2005 11:07 pm    Post subject: Reply with quote

emerge dev-libs/libIDL

did it. I susccessfully emerged gnome and xscreensaver. Many thanks!
Back to top
View user's profile Send private message
rhill
Developer
Developer


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Tue Apr 05, 2005 12:15 am    Post subject: Reply with quote

bwah?
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
Laemel
n00b
n00b


Joined: 07 Apr 2005
Posts: 6
Location: California

PostPosted: Thu Apr 07, 2005 9:44 pm    Post subject: Reply with quote

I'm having the same problem... When I emerge certain packages (groff, php, and gnome to name a few) it chugs along calling i686-pc-linux-gnu-g++ hundreds of times, and then at some point it suddenly calls i386-pc-linux-gnu-gcc, which of course fails since I only have i686-pc-linux-gnu-gcc.
This a brand new install today, 2005.0 pentium4 Stage 3, I used genkernel, and I never touched the CHOST (it's "i686-pc-linux-gnu").

I've tried the following solutions that I found here on the forums:

Code:
# revdep-rebuild

This just fails with the same error: "Could not run/locate "i386-pc-linux-gnu-gcc"


Code:
# fix_libtool_files.sh `gcc -dumpversion` --oldarch i386-pc-linux-gnu

This corrected some stuff in KDE, but nowhere else, and it doesn't resolve the problem


Code:
# emerge dev-libs/libIDL

This didn't help anything


I'm not using distcc or anything like that, and I synced today.

gcc-config-l tells me this:
Code:
# gcc-config -l
[1] i686-pc-linux-gnu-3.3.5 *
[2] i686-pc-linux-gnu-3.3.5-hardened
[3] i686-pc-linux-gnu-3.3.5-hardenednopie
[4] i686-pc-linux-gnu-3.3.5-hardenednossp


This is what I get if I run the two compilers with no input:
Code:
# i686-pc-linux-gnu-gcc
i686-pc-linux-gnu-gcc: no input file
# i386-pc-linux-gnu-gcc
gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"


I'm pretty much out of ideas, and this is all I've found on the forums.
Back to top
View user's profile Send private message
rhill
Developer
Developer


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Fri Apr 08, 2005 5:11 am    Post subject: Reply with quote

you might want to try

Code:
fix_libtool_files.sh 3.3.5 --oldarch i386-pc-linux-gnu


just to cover all the bases. other than that, i stand at "bwah?".

hmm, as an afterthought, since it only happens with certain packages you might want to see if you can track down a common dependency between them and remerging it. http://gentoo-portage.com/ has a useful reverse-dependency tracker you can use.
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
Laemel
n00b
n00b


Joined: 07 Apr 2005
Posts: 6
Location: California

PostPosted: Fri Apr 08, 2005 8:47 am    Post subject: Problem Solved Reply with quote

Unfortunetly,
Code:
# fix_libtool_files.sh 3.3.5 --oldarch i386-pc-linux-gnu

gives the same result as
Code:
# fix_libtool_files.sh `gcc -dumpversion` --oldarch i386-pc-linux-gnu


I did however fix my problem last night with the help of a friend. Apparently, the problem stems from the precompiled version of X on the 2005.0 x86 Packages CD. I'm still not sure how my friend deduced this information, but I did an
Code:
# emerge xorg-x11
and now groff will compile fine, and it looks like my "emerge -uD world" is working fine now too.


A question, to anyone who knows: Since the problem was caused by the version of X on the official Packages CD, should this be (or is it already?) reported as a bug?
Back to top
View user's profile Send private message
lzap
n00b
n00b


Joined: 14 Jan 2004
Posts: 60

PostPosted: Fri Apr 08, 2005 9:59 am    Post subject: Reply with quote

Oh so the solution is to re-emerge xorg? OMG this will take a minute :-D

OK thanks

ps - same problem, G2005.0, stage 3 (i686)... cannot emerge e.g. tightvnc or other packages (same error)
_________________
Lukas Zapletal
Olomouc / Czech Republic
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Fri Apr 15, 2005 1:32 pm    Post subject: Reply with quote

Me three: during emerge gimp ...

Code:
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


Let me guess, everyone here is non-US it seems, so using some sort of internationisation options.

I see the error mentions " intltool"

I have USE="nls -unicode userlocales ......."

Looks to me like another case of 'only test US' QA.

rebuilding libIDL did nothing for me . The pb is identical.

The most signigicant change I did recently was change to 2005.0

I regard doing emerge -e system ...world etc etc every time portage screws up as about as credible as emerge -C gentoo && emerge win98 and reinstalling every time something goes wrong. (That latter is certainly faster!)


Identifying the bug would be better.

Properly tested profiles would be heaven.
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
Laemel
n00b
n00b


Joined: 07 Apr 2005
Posts: 6
Location: California

PostPosted: Fri Apr 15, 2005 2:25 pm    Post subject: Reply with quote

Quote:
Me three: during emerge gimp ...

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


Let me guess, everyone here is non-US it seems, so using some sort of internationisation options.



I've got the US version and I had the same error. All I had to do to fix it was:
Code:
# emerge XML-Parser



For the record, most of the horrible compiling problems I had can be traced back to the damn packages CD. I decided to reinstall Gentoo this week and I did a Stage 1 install, and didn't use any precompiled packages, and everything's been compiling much smoother since.
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Fri Apr 15, 2005 3:02 pm    Post subject: Reply with quote

Many thanks,

that seems to have cleared it. It's not done but it got past where it tripped out before.

8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
Storytobi
n00b
n00b


Joined: 06 Nov 2004
Posts: 32

PostPosted: Wed Apr 20, 2005 11:33 am    Post subject: Reply with quote

nope, that still wasn`t it.

still error
[...snip...]

gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
i386-pc-linux-gnu-gcc -O2 -fno-strength-reduce -fno-strict-aliasing -I./lib/Xt -I. -I/usr/include -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE -DFUNCPROTO=15 -DNARROWPROTO -DFONTPATH=\"/usr/share/groff/`cat /var/tmp/portage/groff-1.19.1-r2/work/groff-1.19.1/src/xditview/../../VERSION``sed -e 's/^0$//' -e 's/^[1-9].*$/.&/' /var/tmp/portage/groff-1.19.1-r2/work/groff-1.19.1/src/xditview/../../REVISION`/font:/usr/share/groff/site-font:/usr/lib/font\" -c -o xditview.o xditview.c
gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
make: *** [xditview.o] Error 1

!!! ERROR: sys-apps/groff-1.19.1-r2 failed.
!!! Function src_compile, Line 90, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

which package should i recompile? what was it you`ve said?
Back to top
View user's profile Send private message
flysideways
Apprentice
Apprentice


Joined: 29 Jan 2005
Posts: 151

PostPosted: Wed Apr 27, 2005 1:24 am    Post subject: Reply with quote

Many thanks to Laemel.

I did a 2005.0 GRP install on my laptop and after getting distcc setup with my desktop I decided it was time to recompile with my settings. (The few previous Gentoo installs that I had done were stage 1.) The world emerge didn't make it past groff. Yes it was looking for i386, but I hadn't used that stage during the install. Emerging xorg-x11 fixed it. At least groff now compiles. My emerge world is only now on 33 of 305 so there may still be problems but at least I'm past the first one.

The distcc is way cool, by the way. I've never used it before. Next the pii440bx celeron gets it!

Thanks again.

Update: The emerge -e world stopped at 276 of 305, cdrtools needed unicode added as a use flag. Fixed that and am off again.
Back to top
View user's profile Send private message
dillybat
n00b
n00b


Joined: 10 May 2005
Posts: 12
Location: Here, not there...

PostPosted: Thu May 12, 2005 9:47 pm    Post subject: Emerging xorg-x11 did it for me too... Reply with quote

After doing the
Code:
emerging xorg-x11
everything is fine now...
_________________
RTFM? WITFM?
Back to top
View user's profile Send private message
Benutzername
n00b
n00b


Joined: 09 May 2005
Posts: 1

PostPosted: Tue May 17, 2005 3:23 pm    Post subject: Reply with quote

I had the same problem (2005.0 stage 3 and Xorg from packages) when emerging gnome-light. But emerging libIDL solved it for me - at least I think so. Before I had problems with xce4 and some other ebuilds (can't remember which). Those disappeared after emerging XML-Parser. Just wanted to say that, cause emerging xorg-x11 is not always the solution. Since (re-)emerging libIDL and XML-Parser does nottake that long, I suggest to try those two first. One can still try xorg after that.
_________________
:wq
Back to top
View user's profile Send private message
vinky
Apprentice
Apprentice


Joined: 24 Feb 2005
Posts: 214
Location: Sweden

PostPosted: Thu May 19, 2005 12:51 pm    Post subject: Reply with quote

I have read this thread and understand the problem (have it to)
but why does groff want i386-gcc?
i got it almost compiling with i586-gcc but then it suddenly wanted i386-gcc
whats the problem?
Back to top
View user's profile Send private message
llama
n00b
n00b


Joined: 16 Jan 2005
Posts: 11

PostPosted: Tue May 31, 2005 1:20 am    Post subject: Reply with quote

So, for anyone that was following this thread, I have another solution to the problem that I was havin as well.

I'm doing Stage 1 install on a 1.1 Celeron. I was getting the 'can't run locate/run i386-X-X-X' as well as everyone else. I checked my /etc/make.conf file and changed the CHOST setting from i386-x-x-x to i686-x-x-x. That seems to have solved all of my issues thus far.

Hope that helps someone!

-Llama
Back to top
View user's profile Send private message
david.birch
n00b
n00b


Joined: 26 Nov 2004
Posts: 13

PostPosted: Tue May 31, 2005 1:34 pm    Post subject: package cd catches Reply with quote

maybe this is in doco somewhere (so much but haven't seen it). But i am figuring you are only mean to setup a system installed using packages with i386 basic support, i tried installing various versions of gcc & ran fix scripts until i thought the hard disk must surely die. all that needed doing was to recompile most of what i got from the package cd - yes most, not just 1 or 2 packages :(

So end result - i burnt my packge cd. As a developer who wants many more things than the package cd can supply, i got mega burnt, so much wasted time. Never again will i get lazy...
Back to top
View user's profile Send private message
dkaplowitz
Guru
Guru


Joined: 22 Nov 2003
Posts: 596
Location: Philadelphia, PA

PostPosted: Sun Apr 02, 2006 6:58 pm    Post subject: Reply with quote

smask wrote:
Hi,

i've the same problem. I solved it with an "emerge dev-libs/libIDL"
Try it

Bye


Wow...this has gotten me much further than the dozen or so other things I've tried (most of which took hours of compiling/recompiling). Thanks!

BTW, what gave me this error, I believe, wasn't changing my CHOST, but rather stupidly using the 386 tarball for the stage3 install but using the 686 CHOST in my make.conf.

Anyway, it looks like it saved me from having to start over, so thanks for the help.
_________________
http://dkap.info
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum