Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mozilla-Firefox für alle User in deutsch
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1596

PostPosted: Thu Mar 31, 2005 8:47 am    Post subject: Mozilla-Firefox für alle User in deutsch Reply with quote

Hallo Forum,

wie kann ich den Firefox für alle User in Deutsch einstellen?

Mit dem Language Switcher geht das immer nur für einen User.

G. Roland
Back to top
View user's profile Send private message
leo2k
Apprentice
Apprentice


Joined: 28 Mar 2005
Posts: 223
Location: karlsruhe

PostPosted: Thu Mar 31, 2005 11:51 am    Post subject: Reply with quote

zwischenfrage:
wie stellt man überhaupt die sprache in firefox ein?
ich benutze die binary version

gruß leo
Back to top
View user's profile Send private message
a_n_d_i
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2005
Posts: 88
Location: Muelheim an der Ruhr

PostPosted: Thu Mar 31, 2005 1:56 pm    Post subject: Reply with quote

Hi,

lade Dir das deutsche Sprachpaket runter:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0.2/linux-i686/xpi/de-DE.xpi
und dann im Firefox als Datei ausfueren und installieren.

firefox starten mit:
Code:

firefox -UILocale tr-TR -contentLocale TR

dann sollte alles tun.

Gruss
Andi
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3464

PostPosted: Thu Mar 31, 2005 1:58 pm    Post subject: Reply with quote

http://firefox.uni-duisburg.de/sprachpaket.php

Bei anderen Versionen als 1.0.2 die Download-URL entsprechend anpassen.

EDIT: arg... sekunden zu spät :-(
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Thu Mar 31, 2005 3:00 pm    Post subject: Reply with quote

hi
Edit 17:04 31.03.05 URL vom Sprachpaket geändert.
Quote:

wie kann ich den Firefox für alle User in Deutsch einstellen?

Edit 18:22 31.03.05 geht einfacher mit "-install-global-extension"
Probieren mal:
Spracherweiterung herunterladen ""http://tinyurl.com/6l9jx
als root:
Code:

firefox -install-global-extension /path/zu/de-DE.xpi

Und dann noch in der Datei "/usr/lib/MozillaFirefox/defaults/pref/firefox-l10n.js"
en-US durch de-DE ersetzen.
Bei Firefox 1.0.2 funktioniert das bei mir ohne probleme.
Quote:

firefox starten mit:
Code:

firefox -UILocale tr-TR -contentLocale TR

dann sollte alles tun.

Wenn der user das sprachpacket installiert hat kannst du auch
in die adressleiste "about:config" eingeben und die
option "general.useragent.locale" von en-US auf de-DE ändern
und du hast ihn in deutsch auch wenn du nur mit "firefox" startest.
mfg
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3464

PostPosted: Sat Jun 04, 2005 12:14 pm    Post subject: Reply with quote

Also entweder bin ich zu blöd oder irgendwas stimmt da nicht. Ich habe es nicht geschafft beim 1.0.4 das deutsche Sprachpaket zu installieren, daher mal das ebuild für einen dt. firefox-bin...

Code:
# /usr/local/portage/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.4.ebuild

inherit nsplugins eutils mozilla-launcher

IUSE="gnome"

DESCRIPTION="The Mozilla Firefox Web Browser (de-DE)"
SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/de-DE/firefox-${PV}.tar.gz"
HOMEPAGE="http://www.mozilla.org/projects/firefox"
RESTRICT="nostrip nomirror"

KEYWORDS="-* x86 amd64"
SLOT="0"
LICENSE="MPL-1.1 NPL-1.1"

DEPEND="virtual/libc"
RDEPEND="virtual/x11
        x86? (
                >=sys-libs/lib-compat-1.0-r2
                >=x11-libs/gtk+-2.2
        )
        amd64? (
                >=app-emulation/emul-linux-x86-baselibs-1.0
                >=app-emulation/emul-linux-x86-gtklibs-1.0
        )
        >=www-client/mozilla-launcher-1.28"

S=${WORKDIR}/firefox

# This is a binary x86 package => ABI=x86
# Please keep this in future versions
# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
has_multilib_profile && ABI="x86"

src_install() {
        # Install firefox in /opt
        dodir /opt
        mv ${S} ${D}/opt/firefox

        # Plugin path setup (rescuing the existing plugins)
        src_mv_plugins /opt/firefox/plugins

        # Fixing permissions
        chown -R root:root ${D}/opt/firefox

        # mozilla-launcher-1.8 supports -bin versions
        dodir /usr/bin
        cat <<EOF >${D}/usr/bin/firefox-bin
#!/bin/sh
#
# Stub script to run mozilla-launcher.  We used to use a symlink here but
# OOo brokenness makes it necessary to use a stub instead:
# http://bugs.gentoo.org/show_bug.cgi?id=78890

export MOZILLA_LAUNCHER=firefox-bin
exec /usr/libexec/mozilla-launcher "\$@"
EOF
        chmod 0755 ${D}/usr/bin/firefox-bin

        # Install icon and .desktop for menu entry
        if use gnome; then
                insinto /usr/share/pixmaps
                doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
                # Fix bug 54179: Install .desktop file into /usr/share/applications
                # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
                insinto /usr/share/applications
                doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
        fi

        # Normally firefox-bin-0.9 must be run as root once before it can
        # be run as a normal user.  Drop in some initialized files to
        # avoid this.
        einfo "Extracting firefox-bin-${PV} initialization files"
        tar xjpf ${FILESDIR}/firefox-bin-0.9-init.tar.bz2 -C ${D}/opt/firefox
}

pkg_preinst() {
        export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox

        # Remove the old plugins dir
        pkg_mv_plugins /opt/firefox/plugins

        # Remove entire installed instance to prevent all kinds of
        # problems... see bug 44772 for example
        rm -rf "${MOZILLA_FIVE_HOME}"
}

pkg_postinst() {
        export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox

        update_mozilla_launcher_symlinks
}

pkg_postrm() {
        update_mozilla_launcher_symlinks
}
Back to top
View user's profile Send private message
schotter
Guru
Guru


Joined: 30 Nov 2004
Posts: 478
Location: Germany, Bavaria, Bayreuth, Pottenstein, Tüchersfeld

PostPosted: Sat Jun 04, 2005 2:47 pm    Post subject: Reply with quote

Um dem Language Switcher nicht installieren zu müssen kann man auch about:config in die adressleiste eingeben, dann nach general.useragent.locale suchen und nach de-DE abändern. Das Sprachpaket muss natürlich installiert sein.
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3464

PostPosted: Sat Jun 04, 2005 2:52 pm    Post subject: Reply with quote

Hatte komischerweise alles nix gebracht. Hatte mir auch div. Language-Switscher installiert. Naja, jetzt gehts ja... wollte das halt nur posten falls es jemand benötigt.
Back to top
View user's profile Send private message
Rawk
n00b
n00b


Joined: 21 Dec 2003
Posts: 44

PostPosted: Sun Jun 05, 2005 10:48 am    Post subject: Reply with quote

fuchur wrote:

Code:

firefox -install-global-extension /path/zu/de-DE.xpi

Und dann noch in der Datei "/usr/lib/MozillaFirefox/defaults/pref/firefox-l10n.js"
en-US durch de-DE ersetzen.
Bei Firefox 1.0.2 funktioniert das bei mir ohne probleme.

Geht das auch irgendwie mit Thunderbird?
Code:

-install-global-extension

scheint es bei thunderbird nicht zu geben...
Back to top
View user's profile Send private message
OG SWAT RV
n00b
n00b


Joined: 19 Jun 2004
Posts: 33
Location: Gremany , NRW , RE

PostPosted: Sun Jul 10, 2005 3:10 pm    Post subject: Firefox Reply with quote

Hallo ,
Ich kriege es einfach nicht auf die Kette dem Firefox deutsch beizubringen . Ich habe unzählige treats gelesen :(

Ich gehe so vor :
emerge mozilla-firefox
downloaden des deutschen Sprachefile de-DE.xpi
Ich speichere es unter :/home/ralf/.mozilla/firefox/1vs9jof3.default/chrome & /usr/lib/MozillaFirefox/chrome
dann gebe Ich im firefoxbrowser : "about:config" ein und ändere "general.useragent.locale" auf "de-DE"
Aber alles bleibt auf englisch :?:
_________________
gentoo 2005.0/
ASUS A7V600-X , Geforce 6800GT , Athlon XP3000+
1024 MB RAM , SB Live
Back to top
View user's profile Send private message
bmuskalla
n00b
n00b


Joined: 14 Apr 2005
Posts: 61
Location: Mannheim

PostPosted: Sun Jul 10, 2005 3:18 pm    Post subject: Reply with quote

eventuell hilft dir folgendes weiter: http://benjamin.smedbergs.us/switch-locales/
Back to top
View user's profile Send private message
moe
Veteran
Veteran


Joined: 28 Mar 2003
Posts: 1289
Location: Potsdam / Germany

PostPosted: Sun Jul 10, 2005 4:21 pm    Post subject: Reply with quote

Und warum speicherst du das Sprachpaket und lässt Firefox es nicht selbst installieren?

Gruss Maurice

BTW Der Titel ist nicht besonders aussagekräftig.
Back to top
View user's profile Send private message
Earthwings
Administrator
Administrator


Joined: 14 Apr 2003
Posts: 7750
Location: Karlsruhe, Germany

PostPosted: Sun Jul 10, 2005 5:26 pm    Post subject: Reply with quote

Letzte drei Beiträge hier angehängt.
_________________
KDE 4.12 - Get It While It's Hot!
Back to top
View user's profile Send private message
OG SWAT RV
n00b
n00b


Joined: 19 Jun 2004
Posts: 33
Location: Gremany , NRW , RE

PostPosted: Sun Jul 10, 2005 7:04 pm    Post subject: Reply with quote

Ok ,
Und warum speicherst du das Sprachpaket und lässt Firefox es nicht selbst installieren?
Gruss Maurice


Das habe Ich jetzt gemacht ( wuste vorher garnicht das dass geht )
zuerst das Sprachpaket , und dan den Language Switcher , firefox restartet und unter Tools - Languages de - DE ausgewählt , restartet :
Immer noch alles in englisch :( obwohl unter Tools - Languages - de - DE ausgewählt ist .
Klappt auch nicht als root :(
_________________
gentoo 2005.0/
ASUS A7V600-X , Geforce 6800GT , Athlon XP3000+
1024 MB RAM , SB Live
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1596

PostPosted: Sun Jul 10, 2005 7:21 pm    Post subject: Reply with quote

OG SWAT RV wrote:
Ok ,
Und warum speicherst du das Sprachpaket und lässt Firefox es nicht selbst installieren?
Gruss Maurice


Das habe Ich jetzt gemacht ( wuste vorher garnicht das dass geht )
zuerst das Sprachpaket , und dan den Language Switcher , firefox restartet und unter Tools - Languages de - DE ausgewählt , restartet :
Immer noch alles in englisch :( obwohl unter Tools - Languages - de - DE ausgewählt ist .
Klappt auch nicht als root :(


Lösche mal das Mozilla Verzeichnis in Deinem Homeverzeichnis....und starte den Firefox wie oben beschrieben noch mal....

Hatte auch mal das Problem nach einem Update....

G. R.
Back to top
View user's profile Send private message
OG SWAT RV
n00b
n00b


Joined: 19 Jun 2004
Posts: 33
Location: Gremany , NRW , RE

PostPosted: Sun Jul 10, 2005 8:30 pm    Post subject: Reply with quote

Hallo ,

Lösche mal das Mozilla Verzeichnis in Deinem Homeverzeichnis....und starte den Firefox wie oben beschrieben noch mal....


Ok habe Ich gemacht . Ich musste die Sprachdatei aber nocheinmal herunterladen .
Es klappt aber immer noch nicht , das Firefox in deutsch startet .
Die einzige möglichkeit im Moment ist , das Ich zB im Kicker eine Verknüpfung für Firefox setze und diese bei Eigenschaften - Programm -UILocale tr-TR -contentLocale TR hinzufüge ,
dann startet Firefox in deutsch .

Aber wen Firefox von einem anderen Programm aus gestartet wird ( zB Realplayer ) startet er wieder in englisch ,
obwohl das Sprachpaket , Language Switcher und about:config eingestellt sind :?:
_________________
gentoo 2005.0/
ASUS A7V600-X , Geforce 6800GT , Athlon XP3000+
1024 MB RAM , SB Live
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1596

PostPosted: Sun Jul 10, 2005 8:58 pm    Post subject: Reply with quote

OG SWAT RV wrote:
Hallo ,

Lösche mal das Mozilla Verzeichnis in Deinem Homeverzeichnis....und starte den Firefox wie oben beschrieben noch mal....


Ok habe Ich gemacht . Ich musste die Sprachdatei aber nocheinmal herunterladen .
Es klappt aber immer noch nicht , das Firefox in deutsch startet .
Die einzige möglichkeit im Moment ist , das Ich zB im Kicker eine Verknüpfung für Firefox setze und diese bei Eigenschaften - Programm -UILocale tr-TR -contentLocale TR hinzufüge ,
dann startet Firefox in deutsch .

Aber wen Firefox von einem anderen Programm aus gestartet wird ( zB Realplayer ) startet er wieder in englisch ,
obwohl das Sprachpaket , Language Switcher und about:config eingestellt sind :?:


Noch ein Schuß ins Blaue...

hast Du selber kompiliert oder die bin Version?

tu mal deinstallieren...alles was Firefox heißt löschen

und neu installieren. Hatte wie gesagt auch mal das Problem nach einem Update.....da hatten dann irgendwo die rechte nicht mehr gestimmt

starte im Moment zur Sicherheit auch so:

/usr/bin/firefox -UILocale de-DE -contentLocale DE %U...und klappt auch...jetzt auch aus anderen Programmen...

G. Roland
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3464

PostPosted: Mon Jul 11, 2005 9:52 am    Post subject: Reply with quote

Tinitus wrote:
/usr/bin/firefox -UILocale de-DE -contentLocale DE %U...und klappt auch...jetzt auch aus anderen Programmen...

Genau so hatte ich das auch, aber dann hatte ich auch folgendes Problem
OG SWAT RV wrote:
... wen Firefox von einem anderen Programm aus gestartet wird ( zB Realplayer ) startet er wieder in englisch ,
obwohl das Sprachpaket , Language Switcher und about:config eingestellt sind :?:

Das kam daher das die Programme alle "direkt" /usr/bin/firefox aufrufen und sich nicht um die "Verknüpfung" kümmern welche ich mir dazu anlegt hatte.

Also habe ich das Script /usr/bin/firefox editiert und dort die Parameter für die Sprache eingefügt. Allerdings, entweder wars ein Denk-/Tippfehler meinerseits oder ein grundsätzliches Problem, sobald ich eine Firefox-Fenster offen hatte und per Ausführen von /usr/bin/firefox eine neues Fenster öffnen wollte, erkannte er das geöffnete Fenster nicht und meckerte immer das das aktuelle Profil in Benutzung sei.

Also habe ich dann Firefox mit dem oben geposteten ebuild als deutsches Binary installiert und seit dem keine Probleme mehr.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Tue Jul 19, 2005 12:38 am    Post subject: Reply with quote

Ok, was verpasse ich hier?

Ich habe soeben FireFox 1.0.5. frisch emerged. Ich benutze noch die 1.0.4 Sprachdatei. Unter einem Benutzer habe ich die deutschen Menüs und die dt. Oberfläche, in einem anderen Account allerdings nicht, obwohl ich auch dort die exakt gleichen Schritte unternommen habe. Die de-DE-locale-Einstellungen im "about:config" und im /usr/lib/.../pref/firefox-l10n.js habe ich bereits vorgenommen. Die de-DE.xpi liegt im Homeverzeichnis des betroffenen Accounts und gehört diesem auch.

Das Problem war auch schon im FireFox der Version 1.0.4 vorhanden. Im betreffenden Account habe ich bereits den .Mozilla-Ordner im Home-Verzeichnis gelöscht, um sicherzugehen, daß nicht irgendwelche obskuren Einstellungen mir querschießen.

Was kann ich noch tun? Mir persönlich wäre es ja egal, den FF in Englisch zu haben, aber der Account gehört dummerweise meiner Freundin, und die besteht nunmal drauf, Deutsch zu bekommen, weil ihr Englisch leider nicht so dolle ist! :)

Würde gern den Grund wissen, weshalb der Account partout nicht auf Deutsch den FireFox haben möchte.
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3464

PostPosted: Tue Jul 19, 2005 6:24 am    Post subject: Reply with quote

Es gibt Probleme bei der Version 1.0.5, allerdings weiß ich nicht wie sich das auf die Lokalisierung auswirkt:

http://www.heise.de/newsticker/meldung/61759 wrote:
Asa Dotzler, Chef der Mozilla-Qualitätssicherung, hat die Arbeitsgruppen, die sich mit Lokalisieren des Thunderbird-Mailclients beschäftigen, gebeten, die Anstrengungen für die Übersetzung der 1.0.5-Release einzustellen. Der Website der deutschen Übersetzer ist zu entnehmen, dass die Mozilla-Entwickler unbeabsichtigterweise eine API verändert haben, was dazu führt, dass Erweiterungen zu Thunderbird nicht mehr kompatibel sind.

...

Auch der Webbrowser Firefox ist von diesem Fehler betroffen und wird nicht in offizieller deutscher 1.0.5-Version erscheinen. Dies wird von den Entwicklern im Bugzilla-Bugtracking-System von Mozilla bestätigt. Auch hier soll bald eine 1.0.6-Release nachgeschoben werden.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Tue Jul 19, 2005 12:50 pm    Post subject: Reply with quote

slick wrote:
Es gibt Probleme bei der Version 1.0.5, allerdings weiß ich nicht wie sich das auf die Lokalisierung auswirkt:

http://www.heise.de/newsticker/meldung/61759 wrote:
Asa Dotzler, Chef der Mozilla-Qualitätssicherung, hat die Arbeitsgruppen, die sich mit Lokalisieren des Thunderbird-Mailclients beschäftigen, gebeten, die Anstrengungen für die Übersetzung der 1.0.5-Release einzustellen. Der Website der deutschen Übersetzer ist zu entnehmen, dass die Mozilla-Entwickler unbeabsichtigterweise eine API verändert haben, was dazu führt, dass Erweiterungen zu Thunderbird nicht mehr kompatibel sind.
...
Auch der Webbrowser Firefox ist von diesem Fehler betroffen und wird nicht in offizieller deutscher 1.0.5-Version erscheinen. Dies wird von den Entwicklern im Bugzilla-Bugtracking-System von Mozilla bestätigt. Auch hier soll bald eine 1.0.6-Release nachgeschoben werden.
Kurios, ich habe es gestern nämlich doch noch hinbekommen. Offensichtlich schert sich FireFox 1.0.5 nicht um die Einstellungen in "about:config", sondern dafür um die Einstellungen in der .bashrc im Home-Verzeichnis.

Dort hatte ich zuvor bereits für den "funktionierenden" Account die folgenden Einträge hinzugefügt, die beim "problematischen" User-Account fehlten:
Code:
export LANG="de_DE@euro"
export LANGUAGE="de_DE@euro"
export LC_ALL="de_DE"
Das in der ~/.bashrc eingetragen und "Presto!" es funktioniert!
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum