Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia-kernel problems with X.org, 2.6.11
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
andocser
n00b
n00b


Joined: 07 Apr 2004
Posts: 17
Location: Potsdam, NY

PostPosted: Thu Mar 31, 2005 5:21 am    Post subject: Nvidia-kernel problems with X.org, 2.6.11 Reply with quote

I'm having a problem getting the nvidia driver working. After I change the driver that xorg.conf calls from "nv" to "nvidia" and try to start X, my display goes blank and stays that way. The system does not respond to anything (alt+ctl+f2, SSH, etc.) and I must restart it.

Setup:
Dell Inspiron 2650C w/ Geforce2 Go
2.6.11-gentoo-r4 Kernel
X.Org 6.8.2-r1
nvidia-kernel 7167-r1 and nvidia-glx 7167-r1

Error Message:
Code:
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)


/etc/X11/xorg.conf:
Code:

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/lib/X11/rgb"
        ModulePath   "/usr/lib/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/CID/"
        FontPath     "/usr/share/fonts/75dpi/"
        FontPath     "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
        Load  "extmod"
        Load  "dbe"
#       Load  "dri"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/mouse"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "NoAccel"                   # [<bool>]
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "Rotate"                    # [<str>]
        #Option     "VideoKey"                  # <i>
        #Option     "FlatPanel"                 # [<bool>]
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        #Option     "FPScale"                   # [<bool>]
        #Option     "FPTweak"                   # <i>
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "NV11 [GeForce2 Go]"
        BusID       "PCI:1:0:0"
#       Option  "NoLogo"        "1"
#       Option  "RenderAccel"   "1"
#       Option  "NvAGP"         "1"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


What I've tried:
1. Adding nvidia to /etc/modules.autoload.d/kernel-2.6 - No change
2. Emerging stable version of kernel and glx - Merge fails

If anyone can offer me any help or suggestions on this issue it would be greatly appreciated. Thanks!
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2287
Location: Canada

PostPosted: Thu Mar 31, 2005 6:08 am    Post subject: Reply with quote

Try running

opengl-update

And did you run modules-update ?
Back to top
View user's profile Send private message
aesthesia
n00b
n00b


Joined: 17 Mar 2004
Posts: 45
Location: chapel hill, nc

PostPosted: Thu Mar 31, 2005 6:41 am    Post subject: Reply with quote

If you're using udev, you need to change your mouse line from "/dev/mouse" to "/dev/input/mice"

That fixed my identical problem.
Back to top
View user's profile Send private message
andocser
n00b
n00b


Joined: 07 Apr 2004
Posts: 17
Location: Potsdam, NY

PostPosted: Thu Mar 31, 2005 4:00 pm    Post subject: Reply with quote

Thanks for the suggestions. I ran opengl-update and modules-update and am still having the same problem.

While I was troubleshooting, I remembered something that may be of some importance that I did not mention in my original post. When I attempt to start X and the screen goes blank, I don't mean that the screen just displays black. The LCD backlights actually shut off and the screen goes completely dark. Hopefully this detail is of some help. Thanks again.
Back to top
View user's profile Send private message
Cheesefoam
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2003
Posts: 89

PostPosted: Thu Mar 31, 2005 4:36 pm    Post subject: Reply with quote

The binary module interface changed in 2.6.11 - which means, AFAIK, only the 7X series drivers work with 2.6.11 - as I am sure you already know.

Those of us with Geforce2Go's, however, are, well... screwed.

The only nvidia-kernel driver in portage that works is media-video/nvidia-kernel-1.0.6111-r3.ebuild

Anything higher that this locks the screen as you have observed. What this means is that we are pretty much stuck indefinitely with an old 2.6.10 kernel until nVidia fixes the problem (which may be never, as they have been very bad about fixing this problem before).

My suggestion is to mask everything above the 6111-r3 driver by doing:
Code:

echo \>media-video/nvidia-kernel-1.0.6111-r3 >> /etc/portage/package.mask


Then do likewise for MM-Sources, or whatever other kernel floats your boat (Gentoo-Sources works, pre 2.6.11):
Code:

echo \>sys-kernel/mm-sources-2.6.10-r1 >> /etc/portage/package.mask


For mm-sources, don't use anything higher than 2.6.10-r1. They'll break the nvidia drivers.

If any devs read this: PLEASE do not remove the media-video/nvidia-kernel-1.0.6111-r3 ebuild from portage until this problem is fixed.
Back to top
View user's profile Send private message
andocser
n00b
n00b


Joined: 07 Apr 2004
Posts: 17
Location: Potsdam, NY

PostPosted: Thu Apr 07, 2005 10:06 pm    Post subject: Reply with quote

I got so excited when I saw that Nvidia released a new driver which, according to their website, addresses an issue with onboard Geforce2 cards. Unfortounately, with this new driver I have the same problem as before. Is everyone else still having this issue, or is it just something I'm doing wrong? Thanks again.
Back to top
View user's profile Send private message
Cheesefoam
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2003
Posts: 89

PostPosted: Fri Apr 08, 2005 4:00 pm    Post subject: Reply with quote

In my experience, the consistency of drivers working with card like ours is a purely hit and miss affair. I remember back during the 4x.X series of drivers that things were much the same way. However, here the problem is more severe, because we're kernel limited until the problem is fixed (and judging from past history, I get the impression that nVidia really doesn't care too much about older cards, and especially laptops, under Linux).

Sadly enough, this is one of the most pressing issues which has lead to me not booting into Linux on my laptop in several weeks. I need at least passable 3D support to do some of my work (and decent 2D performance, neither of which the Xorg driver provides), and the lack of this plus problems I've had with older kernels has led me to boot into only Windows on my laptop to do work.

That's pretty sad.

Thankfully, the Geforce2MX in my server at home hums along just fine with the 7x drivers - that's because it isn't in a laptop.

My $0.02.

All I can say is I am really losing faith in nVidia these days.
Back to top
View user's profile Send private message
EmmEff
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 197

PostPosted: Fri Apr 08, 2005 7:54 pm    Post subject: Reply with quote

Cheesefoam wrote:
In my experience, the consistency of drivers working with card like ours is a purely hit and miss affair.


In Nvidia's defense, it's tough to point fingers given that the kernel just underwent (supposedly) major changes with respect to internal interfaces. Nvidia still obviously focuses on Windows so Linux will always be a second thought.

Quote:
All I can say is I am really losing faith in nVidia these days.


My experience from the start was bad. It took me a while to get drivers that made my 5700-based card work properly. Now that it's been working with 6629 for a little while, I tried upgrading to 7174 (and 2.6.11-gentoo-r5) and nothing works again.

I have no faith in Nvidia and even less in ATI for providing good Linux video drivers.
Back to top
View user's profile Send private message
kf4yfd
n00b
n00b


Joined: 10 Apr 2005
Posts: 1
Location: Anchorage, AK

PostPosted: Sun Apr 10, 2005 6:19 pm    Post subject: Reply with quote

I am here to confirm a previous post about using an older kernel and nvidia-kernel version.

NOTE: This howto is written for x86, kernel 2.6.x, and xorg. It should work for x86-64.
All other architectures should adjust the code examples to match their system.


The versions of packages that are compatible are a kernel < 2.6.11, nvidia-kernel-1.0.6111-r3, and nvidid-glx-1.0.6111-r1

I will go through the steps that I did to get my system working, and try to keep others from repeating my errors. 8O

First you must edit the package.mask file:
Code:
#Compatible packages for nvidia 3D
>media-video/nvidia-kernel-1.0.6111-r3
>media-video/nvidia-glx-1.0.6111-r1
>sys-kernel/gentoo-sources-2.6.10-r6
>sys-kernel/vanilla-sources-2.6.10


This is bad form for the package.mask file. It should be one package per block with a comment for each explaining why the package is masked.

Next you need to install a kernel older than 2.6.11:
Either kernel will work.

For gentoo patched kernel:
Code:
emerge -p gentoo-sources


OR

For unpatched kernel:
Code:
emerge -p vanilla-sources


Verify that the kernel to be installed is older than 2.6.11, if so remove the "-p" and re-execute the command.

After the kernel installs, you must configure, and compile it. You can use either genkernel or manual configuration.
If doing a manual configuration make shure to enable loadable module support and MTRR
For help see : http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=7

NOTE: You can install the nvidia-* packages to a specific kernel version without it currently running, but I do not know how.
if you do, please e-mail me or reply to this post and I will update it.


After the kernel compiles add it to your bootloader.
IMPORTANT:You should reboot into your new kernel (<2.6.11) before continuing.

Now make shure that the 'linux' link in /usr/src/ points to the right kernel
Code:
cd /usr/src
ls -l
lrwxrwxrwx   1 root root     23 May 11 10:07 linux -> linux-2.6.10-gentoo-r6/
drwxr-xr-x  19 root root   4096 May 10 23:29 linux-2.6.10-gentoo-r6
drwxr-xr-x  19 root root   4096 May 11 00:51 linux-2.6.11-gentoo-r5


In my case the link points to linux-2.6.10-gentoo-r6.
Make shure the links points to the kernel you are currently running. You should be in kernel 2.6.10* now.

If it does not then exec:
Code:
rm linux
ln -s /usr/src/<your kernel dir> linux




IMPORTANT
First remove any old versions of the nvidia and glx packages
Code:
emerge -C nvidia-kernel nvidia-glx


Now verify the versions of the packages to be installed:
Code:
emerge -p nvidia-glx


The output should show:
media-video/nvidia-kernel-1.0.6111-r3
media-video/nvidia-glx-1.0.6111-r1

If these are correct then remove the "-p" and re-execute the command.

Now, go into your xorg.conf and change Driver to nvidia:
Code:
Section "Device"
    Identifier  "Geforce4"
    Driver      "nvidia"
    VideoRam    32768

Leave Identifier as-is or you will have worse problems than before.

Now start X11:
KDE users
Code:
kdm


Gnome users
Code:
gdm


Feel free to reply with ways to better this. No updates for other arch's please, as I will have no way to verify :)
Back to top
View user's profile Send private message
thedangerouscrew
Tux's lil' helper
Tux's lil' helper


Joined: 03 Nov 2004
Posts: 98

PostPosted: Sun Apr 10, 2005 9:05 pm    Post subject: not nvidia's fault Reply with quote

ok guys this is a gentoo problem (not surprising), if you use the official nvidia driver it will work just fine.
i'm using the official NVIDIA-Linux-x86_64-1.0-7174-pkg2.run from nvidia's website and kernel 2.6.11.
after i did that i emerge the nvidia-glx pkg.

hope this helps some people
Back to top
View user's profile Send private message
Phancy Physicist
Apprentice
Apprentice


Joined: 10 Apr 2005
Posts: 193

PostPosted: Sun Apr 10, 2005 9:10 pm    Post subject: I'm a little slow Reply with quote

I have a new nvidia 6800 ultra are you guys saying it is impossible to get it working on 2.6.11?
X ran before I went though the install process for nvidia-kernel.
Now it craps out that
Code:
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!


I spent all weekend setting up this machine and I finally got it to boot and run right and now no video? I need a nap.

Thanks in advance for your input on this.

*EDIT*
Ha ha .. the post above was posted while i was typing this post .... i'm going to try that now!
I'll post to let you know what happens.
Back to top
View user's profile Send private message
Phancy Physicist
Apprentice
Apprentice


Joined: 10 Apr 2005
Posts: 193

PostPosted: Sun Apr 10, 2005 10:17 pm    Post subject: well looks like it might work Reply with quote

Well i tried the driver from nVidia and it seem as though it might work but ....
First thing it complains about the previous verson of the 7XXX driver all ready being there so if you haven't emerged the new drivers don't.
Also it complains about opengl driver. Tells you to remove third party drivers?
Lastly it complains about not being able to write to *.so files.
I removed all nvidia drivers and it still gives me the same problems, so I am re-emerging xorg then am going to try the offical driver installer again.
Back to top
View user's profile Send private message
asterix404
Apprentice
Apprentice


Joined: 05 Nov 2004
Posts: 213

PostPosted: Sun Apr 10, 2005 10:35 pm    Post subject: Reply with quote

Just as a very interesting question... I have never understood why someone whould actuilly go out and spend money on the nvidia fx 6800 or the ati radion 9800's... I mean these are serious cards that i have seen cost a lot of money. What are you guys doing in linux that my little geforce 2 card can't? I mean I upgraded to the ti4200 just cuz I could and haven't had an issue. IT's been tried and true from my experiance that no matter what the device linux doesn't really support it well for about a year. I Don't know you have had that issue but thats what I have discovered. So basicly why are you putting heuge bad ass graphics cards in linux boxes?
Back to top
View user's profile Send private message
Phancy Physicist
Apprentice
Apprentice


Joined: 10 Apr 2005
Posts: 193

PostPosted: Sun Apr 10, 2005 10:51 pm    Post subject: Problem solved Re: well looks like it might work Reply with quote

thedangerousscrew is most definatily right.
the official driver will work.
Phancy Physicist wrote:

Also it complains about opengl driver. Tells you to remove third party drivers?
Lastly it complains about not being able to write to *.so files.

these problems stemmed from the fact that I am running 100% 64bit native the installer asks you if you want to install the 32bit drivers and i said sure. It would work on my config if i do that just a heads up for anyone else running 64bits :)

In responce to asterix404's question: speed ... and to see if it can be done. I do heavy duty gaming and i like to see things like: can i get unreal and final fantasy XI and quake III arena to run at the same time. Also I do a bit of opengl programming and i like to model things like a million particles moving aroud a 3d box. I know it sounds crazy but hey I am running Gentoo :)

*EDIT*
I just remembered ... there is no need to emerge nvidia-glx or nvidia-settings after using the nvida-installer from their page ... the installer does that too :!:

just DL the scrpit and type
Code:
sh NVIDIA-Linux-x86_64-1.0-7174-pkg2.run
in the directory you DLed it to.
Good Luck!!!
Back to top
View user's profile Send private message
noup
l33t
l33t


Joined: 21 Mar 2003
Posts: 917

PostPosted: Mon Apr 11, 2005 8:54 am    Post subject: Reply with quote

asterix404 wrote:
What are you guys doing in linux that my little geforce 2 card can't?

Playing Enemy-Territory at 1680x1050 with the maximum quality at 90 stable fps? :lol: I would also mention doing some image/video work, but i'm not really into that. It's not a fact that all graphics cards are badly supported, some are (fortunately) pretty well supported and some are (unfortunately) pretty badly supported...
_________________
noup.
Back to top
View user's profile Send private message
LinuxLoader
n00b
n00b


Joined: 04 May 2005
Posts: 18
Location: Bulgaria

PostPosted: Wed May 04, 2005 7:43 pm    Post subject: Reply with quote

I have the same problem but with 0000:01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a4)
Back to top
View user's profile Send private message
phuqmnb
n00b
n00b


Joined: 29 Mar 2005
Posts: 68

PostPosted: Tue May 17, 2005 2:13 pm    Post subject: Reply with quote

How can I run the install from a CD? This is a big time n00b question. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum