Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sound on sun blade 100
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
microlaser
n00b
n00b


Joined: 07 Mar 2005
Posts: 10
Location: Philadelphia Metro

PostPosted: Thu Mar 31, 2005 3:01 am    Post subject: sound on sun blade 100 Reply with quote

Excuse me, I am a gentoo sparc newbie. I am trying to get my sound to work. When I try to emerge the alsa driver I get the following error

config.status: creating include/autoconf-extra.h
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
* PLEASE UPDATE TO YOUR PACKAGE TO USE linux-info.eclass
if [ ! -d include/sound -a ! -L include/sound ]; then \
ln -sf ../alsa-kernel/include include/sound ; \
fi
cp -auvf include/version.h include/sound/version.h
`include/version.h' -> `include/sound/version.h'
make dep
make[1]: Entering directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8'
make[2]: Entering directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore'
make -C ioctl32 fastdep
make[3]: Entering directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore/ioctl32'
/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/include/sndversions.h was updated
gcc -M -D__KERNEL__ -D__isapnp_now__ -DMODULE=1 -I/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/include -I/usr/src/linux/include -I/usr/src/linux/include -O2 -m64 -mno-fpu -mcpu=ultrasparc -mcmodel=medlow -ffixed-g4 -fcall-used-g5 -fcall-used-g7 -Wno-sign-compare -D__SMP__ -DCONFIG_SMP -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include ioctl32.c pcm32.c rawmidi32.c timer32.c hwdep32.c seq32.c > .depend
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
make[3]: *** [fastdep] Error 1
make[3]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore/ioctl32'
make[2]: *** [_sfdep_ioctl32] Error 2
make[2]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8/acore'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.8/work/alsa-driver-1.0.8'
make: *** [include/sndversions.h] Error 2

!!! ERROR: media-sound/alsa-driver-1.0.8 failed.
!!! Function src_compile, Line 86, Exitcode 2
!!! Make Failed
!!! If you need support, post the topmost build error, NOT this status message.

root@helios language #
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Fri Apr 01, 2005 4:16 am    Post subject: Reply with quote

Looks like you're using a 2.4 kernel. alsa-driver will only build successfully with a 2.6 kernel currently. Try building the "trident" or "ali5451" OSS modules in the kernel and see how that works.
Back to top
View user's profile Send private message
w.hill
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jan 2005
Posts: 133
Location: Perth, Western Australia

PostPosted: Sun Apr 17, 2005 8:51 am    Post subject: Reply with quote

Did you get sound working on your Sun Blade 100?

I tried without success. The best that I got was a lot of loud noise.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum