Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge: doesn't user latest versions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 333
Location: Berlin

PostPosted: Thu May 23, 2002 1:49 pm    Post subject: Emerge: doesn't user latest versions Reply with quote

Hi,

I'd like to update my kde 3.0.0 to kde 3.0.1 but do not succed :-(
Ether the ebuild isn't found (although it IS there) or the latestest packages are not even concidered.
I've done the following things:

(1) emerge --search "kde"
The output shows 3.0.r3 as being the latest version - but I've already updated portage and 3.0.1 is present on my harddisk...

> * kde-base/kdebase
> Latest version Available: 3.0-r3
> Latest version Installed: 3.0
> Homepage:
> Description:
> ${DESCRIPTION}Base

(2)
If I try to force the update like this the ebuild isn't found and I get an error message:

> emerge --pretend kde-base/kdebase/kdebase-3.0.1.ebuild
>
> These are the packages that I would merge, in order.
>
> Calculating dependencies \
>
> !!! ebuild kde-base/kdebase-3.0.1 not found (possibly blocked by
> package.mask)


(3) I am not really familliar to "package.mask" but here is what I stripped out:

> # kde 3.0.1 - not available for fetching yet, but we lucky packagers
> have it
[...]
> >=kde-base/kde-3.0.1

What can I do?

Thank You for any help!
Felix (Berlin, Germany)
Back to top
View user's profile Send private message
huw
Apprentice
Apprentice


Joined: 13 May 2002
Posts: 220
Location: UK

PostPosted: Thu May 23, 2002 3:28 pm    Post subject: Reply with quote

wait...

If an ebuild is masked there's usually a good reason, like it doesn't work, or it breaks lots of other apps. It'll be released as soon as the developers are happy....

If you're desparate for life on the bleeding edge you can always d/l the latest KDE CVS code and start from there :D
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Mon May 27, 2002 5:44 pm    Post subject: Reply with quote

if you want to use a file that is masked, you have to unmask it, by adding a # before the package name. then you should be able to emerge these files.

If you do an emerge rsync the 3.01 files should be no longer masked :-)
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum