Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200503-06 ] BidWatcher: Format string vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Raleigh, NC

PostPosted: Thu Mar 03, 2005 10:26 pm    Post subject: [ GLSA 200503-06 ] BidWatcher: Format string vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: BidWatcher: Format string vulnerability (GLSA 200503-06)
Severity: normal
Exploitable: remote
Date: March 03, 2005
Bug(s): #82460
ID: 200503-06

Synopsis

BidWatcher is vulnerable to a format string vulnerability, potentially allowing arbitrary code execution.

Background

BidWatcher is a free auction tool for eBay users to keep track of their auctions.

Affected Packages

Package: net-misc/bidwatcher
Vulnerable: < 1.3.17
Unaffected: >= 1.3.17
Architectures: All supported architectures


Description

Ulf Harnhammar discovered a format string vulnerability in "netstuff.cpp".

Impact

Remote attackers can potentially exploit this vulnerability by sending specially crafted responses via an eBay HTTP server or a man-in-the-middle attack to execute arbitrary malicious code.

Workaround

There is no known workaround at this time.

Resolution

All BidWatcher users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/bidwatcher-1.13.17"


References

CAN-2005-0158


Last edited by GLSA on Sun May 07, 2006 4:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum