Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Locales] accents, unicode et iso (presque résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
plut0nium
n00b
n00b


Joined: 07 May 2003
Posts: 51
Location: Mons [Belgium]

PostPosted: Mon Aug 18, 2003 10:16 am    Post subject: [Locales] accents, unicode et iso (presque résolu) Reply with quote

voilà, je viens de finir l'installation de base de ma Gentoo (à partir du stage1 :D)

et je bute sur le problème de la locale...

j'ai généré une variable unicode fr_BE.UTF-8, mais même en console (pas encore emergé X) et sous MC, les accents sont hyper-foireux, sauf si on aime l'ésotérisme, mais ce n'est pas mon cas...

le problème c'est que même avec une variable iso: fr_BE@euro les accents foirent aussi (moins qu'avec l'unicode, ici ils sont remplacés par des lettres grecques)...
j'ai bien sûr essayé fr_FR@euro et là encore, j'ai exactement le même probleme que avec la fr_BE@euro


donc, HELP :wink:
j'aimerais que tout fonctionne convenablement avant de passer à X, et ce n'est pas encore le cas :cry:
_________________
"Without evil there can be no good so it must be good to be evil sometimes..."
site | blog | ...


Last edited by plut0nium on Tue Aug 19, 2003 2:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
xr31Daisy
Guru
Guru


Joined: 19 Jul 2002
Posts: 326
Location: Paris, France

PostPosted: Mon Aug 18, 2003 11:54 am    Post subject: Reply with quote

Sans unicode, tu as visiblement au moins un bête problème de police de caractère. Tu peux ajuster ça dans rc.conf ( CONSOLEFONT ou qqch comme ça. ). Les polices dispos sont dans /usr/share/consolefonts. Et /etc/init.d/consolefont est le script à redémarrer.
Déjà ça devrait aller mieux.

Pour de l'unicode sous X, j'utilise gnome ( tout en UTF8 ), et gnome-terminal n'a pas l'air de poser de problème ( il se met dans le mode correspondant à la locale courante, soit en_US.UTF-8 dans mon cas. ).

Par contre, si quelqu'un a déjà vu ça, bash me fait un truc bizarre :
quand j'entre un caractère multi-byte ( au hasard 'é' ), et que je fais backspace, il n'efface qu'un seul octet, et pas le caractère en entier. ( NB : j'utilise le bash standard de gentoo, je n'ai pas essayé de patcher quoi que ce soit. )
_________________
#include "pictures.h"
Back to top
View user's profile Send private message
plut0nium
n00b
n00b


Joined: 07 May 2003
Posts: 51
Location: Mons [Belgium]

PostPosted: Mon Aug 18, 2003 12:05 pm    Post subject: Reply with quote

c'est possible d'être en unicode sous X et pas en mode texte ?
_________________
"Without evil there can be no good so it must be good to be evil sometimes..."
site | blog | ...
Back to top
View user's profile Send private message
xr31Daisy
Guru
Guru


Joined: 19 Jul 2002
Posts: 326
Location: Paris, France

PostPosted: Mon Aug 18, 2003 1:45 pm    Post subject: Reply with quote

Ben euh ...
ça dépend des applications. même si tu n'es pas en UTF-8 de base, certaines applications vont quand même fonctionner en UTF-8.

Ex1 : dans Gnome2, nautilus est forcément en UTF-8. (quels que soient tes réglages. Et je n'ai pas vu de paramètre pour changer ça.) Donc si tu mets des accents dans tes noms de fichier, tu ne vas pas les voir correctement en mode texte ( et si tu as 2 répertoires appelés "Léo Ferré" et "Lisa Gerrard", impossible en mode texte de rentrer le 'é' de Léo et d'aller dans le répertoire. )

Ex2 : toujours dans gnome-2, l'éditeur de texte (gedit) fait tout en UTF-8 par défaut ( mais est capable de faire du standard ).

Ex3 :gnome-terminal utilise par défaut ta locale courante. Mais il te laisse sélectionner ton encodage à la volée dans ses paramètres, ce qui te permet de te mettre en unicode ou en 8859-15 quand tu veux

Ca répond à ta question ?

Ceci dit, tu devrais quand même pouvoir arriver à avoir quelque chose de convenable sans X, en UTF-8, avec une bonne police. Tu peux aussi essayer de jouer un peu avec unicode_start et unicode_stop ...
_________________
#include "pictures.h"
Back to top
View user's profile Send private message
plut0nium
n00b
n00b


Joined: 07 May 2003
Posts: 51
Location: Mons [Belgium]

PostPosted: Mon Aug 18, 2003 1:51 pm    Post subject: Reply with quote

oki... bref, je vais rester en fr_BE@euro tant que l'unicopde sera pas un peu plus "standard"

par contre, j'ai essayé quelques polices de caractères en console et aucune ne me fait correctement les accents et/ou caractères spéciaux (et certaines sont horribles, je préfère la police par défaut)

je pensais à un truc, ça viendrait pas d'une option que j'aurais malencontreusement oublié dans mon noyal ?
_________________
"Without evil there can be no good so it must be good to be evil sometimes..."
site | blog | ...
Back to top
View user's profile Send private message
xr31Daisy
Guru
Guru


Joined: 19 Jul 2002
Posts: 326
Location: Paris, France

PostPosted: Mon Aug 18, 2003 2:51 pm    Post subject: Reply with quote

Il ya effectivement une option NLS dans le noyau, qui te permet de choisir les encodages supportés, ainsi que l'encodage par défaut. ( j'avais complètement oublié. )

Et latin 0 est une police 'kivabien' ( j'ai testé. )
_________________
#include "pictures.h"
Back to top
View user's profile Send private message
plut0nium
n00b
n00b


Joined: 07 May 2003
Posts: 51
Location: Mons [Belgium]

PostPosted: Tue Aug 19, 2003 12:30 pm    Post subject: Reply with quote

même en ayant recompilé le noyau avec iso8859-15 par défaut, je n'ai pas les accents :(, toujours les lettres grecques à la place (que ce soit fr_FR, fr_BE, fr_FR@euro ou fr_BE@euro),

je sais que ce n'est qu'un détail, mais ça marchait avec d'autres distribs, alors pq pas avec Gentoo ?


et vous, comment avez-vous configuré votre locale ?
_________________
"Without evil there can be no good so it must be good to be evil sometimes..."
site | blog | ...
Back to top
View user's profile Send private message
ossau
n00b
n00b


Joined: 11 Apr 2003
Posts: 21

PostPosted: Tue Aug 19, 2003 1:01 pm    Post subject: Reply with quote

perso dans mon rc.conf j'ai :

KEYMAP="fr-latin1"
(associé au script /etc/init.d/keymap)

EXTENDED_KEYMAP="widowkeys"

et

CONSOLEFONT="lat0-16"
(associé au script /etc/init.d/consolefont)

Pour ce qui est de la variable LANG j'utilise fr_FR@euro mais les accents fonctionnent quelque soit sa valeur !
Back to top
View user's profile Send private message
plut0nium
n00b
n00b


Joined: 07 May 2003
Posts: 51
Location: Mons [Belgium]

PostPosted: Tue Aug 19, 2003 2:26 pm    Post subject: Reply with quote

bon, y'a du progrès...

en rajoutant LANGUAGE="fr_BE@euro" et LC_ALL="fr_BE@euro", j'arrive à avoir les caractères minuscules accentués... mais pas encore les majuscules accentuées (notemment dans MC) :?

qqun à une idée pour ce dernier point ?
_________________
"Without evil there can be no good so it must be good to be evil sometimes..."
site | blog | ...
Back to top
View user's profile Send private message
ossau
n00b
n00b


Joined: 11 Apr 2003
Posts: 21

PostPosted: Tue Aug 19, 2003 5:47 pm    Post subject: Reply with quote

pour les majuscules accentuées essaye avec :

CONSOLEFONT="lat9w-16"

Par contre as tu le symbole euro en mode console, parce que chez moi nada ??
Back to top
View user's profile Send private message
gnoomy
n00b
n00b


Joined: 30 Jun 2004
Posts: 14
Location: france

PostPosted: Tue Mar 01, 2005 5:09 pm    Post subject: Reply with quote

bonjour tout le monde.... et merci parceque j'avais aussi quelques problèmes :D

le caractère euro sur la console je l'ai en faisant AltGr + $ ( la touche $£¤ à coté d'entrée )

par contre dans emacs, ou meme ls, rien n'est reconnu, il y a toujours une paire de caractères ésoteriques à la place des accents... j'avais déjà recompilé deux ou trois trucs après avoir parametré pour l'utf-8, mais pas emacs par exemple, est-ce que ça peut venir de ça?? Parce qu'étant sur un pentiumII 400 je suis pas très partant pour les emerge world hehe.
Back to top
View user's profile Send private message
Starch
Guru
Guru


Joined: 26 Feb 2003
Posts: 539
Location: Rennes, France

PostPosted: Wed Mar 02, 2005 11:01 am    Post subject: Reply with quote

normalement pour emacs tu dois paramétrer la police que tu utilises dans le .emacs

Me souvient plus de comment on fait :(
_________________
- Vous aurez beau dire... Y'a pas qu'd'la pomme... Y'aurait pas aussi d'la betterave ?
- Si, y'en a aussi
Back to top
View user's profile Send private message
gnoomy
n00b
n00b


Joined: 30 Jun 2004
Posts: 14
Location: france

PostPosted: Wed Mar 02, 2005 3:40 pm    Post subject: oui mais.... Reply with quote

�a ne doit pas �tre que �a parceque ls me le fait aussi par exemple, qd il donne la date de cr�ation de fichier il a du mal avec "f�v" et "ao�"... et emacs, sous gnome, n'affiche plus des caract�res louches mais des choses comme <E3><B6> ( ce n'est ni ces lettres ni ces chiffres mais j'en ai pas un souvenir pr�cis :? ) tout cela sent l'unicode, mais je parle encore moins l'unicode que mon emacs!

edit: je viens de me rendre contre que sous epiphany ( qui utilise le moteur de mozilla je crois, je suis sous gnome 2.8 ) les caractères de CETTE page sont des carrés.... à la place des accents. c'est le premier site sur lequel j'ai ça!!


Last edited by gnoomy on Wed Mar 02, 2005 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tony Clifton
l33t
l33t


Joined: 07 Jul 2004
Posts: 686
Location: Rennes

PostPosted: Wed Mar 02, 2005 3:55 pm    Post subject: Reply with quote

plut0nium wrote:
en rajoutant LANGUAGE="fr_BE@euro" et LC_ALL="fr_BE@euro", j'arrive à avoir les caractères minuscules accentués... mais pas encore les majuscules accentuées (notemment dans MC) :?


C'est pas plutôt LANG="fr_BE@euro" ?
_________________
La seule certitude que j'ai, c'est d'être dans le doute ! P. Desproges
Back to top
View user's profile Send private message
Starch
Guru
Guru


Joined: 26 Feb 2003
Posts: 539
Location: Rennes, France

PostPosted: Wed Mar 02, 2005 6:13 pm    Post subject: Re: oui mais.... Reply with quote

gnoomy wrote:
edit: je viens de me rendre contre que sous epiphany ( qui utilise le moteur de mozilla je crois, je suis sous gnome 2.8 ) les caractères de CETTE page sont des carrés.... à la place des accents. c'est le premier site sur lequel j'ai ça!!


en fait tu es la seule personne que je voies qui fasse planter les iconv de php. donc en gros, si tu édites ton post avec un autre encodage que celui utilisé normalement, ça passe pas
_________________
- Vous aurez beau dire... Y'a pas qu'd'la pomme... Y'aurait pas aussi d'la betterave ?
- Si, y'en a aussi
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 359
Location: Paris

PostPosted: Thu Mar 03, 2005 3:40 am    Post subject: [locales] UTF-8 + Français + € + É Reply with quote

hello, bon bah recapitulons tous ca avec unicode (utf8)

0) noyaux
Code:

File systems  ---> 
    Native Language Support  --->
         Base native language support
        (UTF-8) Default NLS Option
          <*>   Codepage 437 (United States, Canada)
          <*>   NLS ISO 8859-1  (Latin 1; Western European Languages)
          <*>   NLS ISO 8859-15 (Latin 9; Western European Languages with Euro)
          <*>   NLS UTF8


1) dans /etc/locales.build
Code:

fr_FR/ISO-8859-1
fr_FR@euro/ISO-8859-15
fr_FR.utf8/UTF-8

2) dans /etc/rc.conf
Code:

UNICODE="yes"
CONSOLEFONT="lat9w-16"
CONSOLETRANSLATION="8859-15_to_uni"

3)dans /etc/conf.d/keymaps
Code:

KEYMAP="-u fr-latin1"
EXTENDED_KEYMAPS="backspace keypad euro"


4)/etc/env.d/02locales
Code:

LANG="fr_FR.utf8"
LANGUAGE="fr_FR.utf8"
LC_ALL="fr_FR.utf8"


5) USE="nls unicode" , bah oui sinon c'est pas tres utile tous ca ;)
Back to top
View user's profile Send private message
gnoomy
n00b
n00b


Joined: 30 Jun 2004
Posts: 14
Location: france

PostPosted: Thu Mar 03, 2005 12:02 pm    Post subject: c'était donc ça!! Reply with quote

merci, j'ai remarqué qu'il manquait effectivement deux trois trucs ( comme unicode dans le USE.... :roll: et dans le noyau !!!)
Back to top
View user's profile Send private message
gregolak
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2003
Posts: 88

PostPosted: Thu Mar 03, 2005 12:09 pm    Post subject: Reply with quote

Comme j'ai de temps en temps qques petits problèmes de polices
(en console et dans emacs) j'ai fait tout cela, mais maintenant j'ai
ce message en lancant emacs :
Quote:
Warning: locale not supported by Xlib, locale set to C


ou encore ca en lancant gedit :
Quote:

(gedit:7599): Gdk-WARNING **: locale not supported by Xlib
(gedit:7599): Gdk-WARNING **: can not set locale modifiers


Il faut reemerger quelquechose je sens non ?
Back to top
View user's profile Send private message
gnoomy
n00b
n00b


Joined: 30 Jun 2004
Posts: 14
Location: france

PostPosted: Thu Mar 03, 2005 3:17 pm    Post subject: Reply with quote

emacs me l'a fait aussi ( j'ai pa encore fait l'emerge world qui soignerait tout cela)
Quote:
locale not supported by Xlib [...] Il faut reemerger quelquechose je sens non ?

oui, et je suggère que ce soit la xlib susmentionnée :wink:
Back to top
View user's profile Send private message
superman2001
Apprentice
Apprentice


Joined: 09 Dec 2004
Posts: 157
Location: Tubize (Belgique)

PostPosted: Thu Mar 03, 2005 3:26 pm    Post subject: Reply with quote

Euh... faut pas réemerger glibc des fois?
Back to top
View user's profile Send private message
gnoomy
n00b
n00b


Joined: 30 Jun 2004
Posts: 14
Location: france

PostPosted: Thu Mar 03, 2005 4:13 pm    Post subject: Reply with quote

surement (un emerge world serait tip top) vu que
Quote:
Warning: locale not supported by Xlib, locale set to C

sous-entend qu'on utilise la locale du c mais si elle aussi est foireuse... mais n'emerge pas que la glibc (je l'ai fait, ça n'a pas suffit)
Back to top
View user's profile Send private message
gregolak
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2003
Posts: 88

PostPosted: Thu Mar 03, 2005 4:20 pm    Post subject: Reply with quote

C'est bon j'ai tout repris calmement avec le howto localisation et
c'est revenu bien... Même les copié-collé entre emacs et les autres
programmes fonctionnent maintenant, c'est la fête 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum