Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.11-nitro0: Module Rodeo Until Dawn
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
chunderbunny
Veteran
Veteran


Joined: 31 May 2004
Posts: 1281
Location: 51°24'27" N, 0°57'15" W

PostPosted: Tue Mar 08, 2005 7:30 pm    Post subject: Reply with quote

I take it that means that you got a response from the FSF about the possibility of a GPL violation? Personally I thought having the nvidia/ati drivers as part of the kernel patch was a great idea (as long as it actually worked, I don't think the problems that were experience were unsolvable) but I can certainly see that it might be a violation of the GPL. After all, if nitro can make it that easy to install the nvidia/ati drivers then why wouldn't SuSE, Redhat and Mandrake do the same?
Back to top
View user's profile Send private message
pifactorial
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 77
Location: 3<x<4 on the gamma function

PostPosted: Tue Mar 08, 2005 7:34 pm    Post subject: Reply with quote

Darckness wrote:
And after this, there will be no more innovations.

No more innovation? No more creativity? :cry:
Say it ain't so!
Back to top
View user's profile Send private message
rowbin hod
n00b
n00b


Joined: 08 Jan 2005
Posts: 50

PostPosted: Tue Mar 08, 2005 7:40 pm    Post subject: Reply with quote

pifactorial wrote:

No more innovation? No more creativity? :cry:
Say it ain't so!


It would seem that these things are frowned upon :cry:
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Mar 08, 2005 7:45 pm    Post subject: Reply with quote

Oh no.... don't let creativity and innovation disappear from nitro just because of some bad apples.
Back to top
View user's profile Send private message
Gentoonie
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 205
Location: near Munich | Bavaria | Germany

PostPosted: Tue Mar 08, 2005 7:49 pm    Post subject: Reply with quote

Darckness wrote:
Alright, I've decided that while the nvidia/ati drivers were cool (AND WORKED ON MY BOX), it would be stupid to leave that patch in for future versions due to the problems some people are having using them, and also due to the lawyers. The next nitro is going to be slimmed down, with several features "missing" (not coming back). And after this, there will be no more innovations. Nitro-sources will return to the "here's the next release, nothing special" that everyone likes, and (hopefully) people will stop hating me for trying to improve upon it.

New "stable" pending.


Hey there's no need being defiant now. I loved the idea of putting the nvidia module into the kernel, and hell yea that was an innovation. Wheter it is legal or not is the other question, but if there's a solution to it, why not stick to that great idea.
I mean, for me the nvidia module doesn't work at the moment, but with further improvents there might be a way, and if its legal then you have sth to be proud of!
_________________
Do you know the secret hand shake - you best use it.

GCC 4, Kernel 2.6.14-ck7, NPTL
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Tue Mar 08, 2005 8:08 pm    Post subject: Reply with quote

I didn't get a response from fsf yet, but I know that it IS possible to resolve the license issues. I know how it can be done, I just don't know exactly how to do it. But the real reason I'm taking IT out is because it's just too much of a hassle. There seems to be no reason why it does or does not work, and thus we waste our time trying to hunt down the cause instead of doing real work.

Also, seppe is back.

EDIT:
chunderbunny: I think nitro stood out a bit too much with IT.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.


Last edited by discomfitor on Tue Mar 08, 2005 8:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
chunderbunny
Veteran
Veteran


Joined: 31 May 2004
Posts: 1281
Location: 51°24'27" N, 0°57'15" W

PostPosted: Tue Mar 08, 2005 8:44 pm    Post subject: Reply with quote

That seems like a real shame, a feature like IT would really make nitro stand out.
Back to top
View user's profile Send private message
mcoulman
n00b
n00b


Joined: 20 Sep 2002
Posts: 34
Location: Maui

PostPosted: Tue Mar 08, 2005 8:53 pm    Post subject: Reply with quote

Tiger683 wrote:
Heres the patch:
64_bit_fix-non_e-untested-1.patch

please report if it helped


It helped me. Compiled clean & running smooth. Thanks for the patch.
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2872
Location: Paris

PostPosted: Tue Mar 08, 2005 9:44 pm    Post subject: Reply with quote

Hi all, i tried a nitro kernel for the 1st time, especially for its win4lin/ATI patches. But... I can't get it compile, erf:
Code:
 LD      arch/i386/mki-adapter26/built-in.o
  CC [M]  arch/i386/mki-adapter26/mki-main.o
  CC [M]  arch/i386/mki-adapter26/mki26.o
arch/i386/mki-adapter26/mki26.c:121:10: #error MKI will not work if __PAGE_OFFSET is not >= MKI_END_USER_ADDR
make[1]: *** [arch/i386/mki-adapter26/mki26.o] Erreur 1
make: *** [arch/i386/mki-adapter26] Erreur 2


I didn't find any mention of win4lin in this thread, seems i'm the only one with this problem?
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Tue Mar 08, 2005 10:08 pm    Post subject: Reply with quote

El_Goretto wrote:
Hi all, i tried a nitro kernel for the 1st time, especially for its win4lin/ATI patches. But... I can't get it compile, erf:
Code:
 LD      arch/i386/mki-adapter26/built-in.o
  CC [M]  arch/i386/mki-adapter26/mki-main.o
  CC [M]  arch/i386/mki-adapter26/mki26.o
arch/i386/mki-adapter26/mki26.c:121:10: #error MKI will not work if __PAGE_OFFSET is not >= MKI_END_USER_ADDR
make[1]: *** [arch/i386/mki-adapter26/mki26.o] Erreur 1
make: *** [arch/i386/mki-adapter26] Erreur 2


I didn't find any mention of win4lin in this thread, seems i'm the only one with this problem?


If I remember correctly, and it has been a while since I patched win4lin into a ck-based kernel, there is a conflict with the lowmen patch.

The output is this conflict, so make sure you don't have the 1G lowmem enabled in the kernel config and try again.

I must admit I always reversed that particular patch as too many people were having the problems you describe. Anyway, see if ensuring the lowmem is not selected works.

HTH
_________________
usefuljaja.com - VPS Tutorials
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2872
Location: Paris

PostPosted: Tue Mar 08, 2005 10:32 pm    Post subject: Reply with quote

Pink wrote:

If I remember correctly, and it has been a while since I patched win4lin into a ck-based kernel, there is a conflict with the lowmen patch.
The output is this conflict, so make sure you don't have the 1G lowmem enabled in the kernel config and try again.
I must admit I always reversed that particular patch as too many people were having the problems you describe. Anyway, see if ensuring the lowmem is not selected works.


Thanks, it works indeed :) I admit i was damn tempted by the 1 Go lowmem option :)
I'll see more of nitro tomorow (particularly fglrx module).
Back to top
View user's profile Send private message
_kal_
l33t
l33t


Joined: 04 Mar 2005
Posts: 602
Location: Paris

PostPosted: Tue Mar 08, 2005 10:33 pm    Post subject: Reply with quote

Hi ppl ;)

I'm now on gentoo and i've correctly compiled kernel-2.6.11 patched with nitro0. But, when i make

Code:

emerge nvidia-glx


I have this error message :

Code:

make[3]: *** [/var/tmp/portage/nvidia-kernel-1.0.6629-r1/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.o] Erreur 1
make[2]: *** [_module_/var/tmp/portage/nvidia-kernel-1.0.6629-r1/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv] Erreur 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Erreur 1
make: *** [module] Erreur 2

!!! ERROR: media-video/nvidia-kernel-1.0.6629-r1 failed.
!!! Function linux-mod_src_compile, Line 417, Exitcode 2
!!! Unable to make                                  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux clean module.
!!! If you need support, post the topmost build error, NOT this status message.


any idea ?
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Tue Mar 08, 2005 11:33 pm    Post subject: Reply with quote

okey darkness i had issues with this one hardlocking please put the patch in for sk98lin in your next one non exprimenatl...
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Wed Mar 09, 2005 9:08 am    Post subject: Reply with quote

@_kal_: add the following 2 lines to your /etc/portage/package.keywords :
Code:
media-video/nvidia-kernel ~x86
media-video/nvidia-glx ~x86

This way you'll install the nvidia-drivers with the latest patches which should solve problems with kernels > 2.6.10.

rgsd
Benson
Back to top
View user's profile Send private message
qodsec
n00b
n00b


Joined: 23 Jan 2005
Posts: 43

PostPosted: Wed Mar 09, 2005 2:55 pm    Post subject: Reply with quote

changed the CFlags as was listed before for the NVidia drive an everything works fine, even the nvidia card.

Thank you
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Wed Mar 09, 2005 6:42 pm    Post subject: Reply with quote

Good news. I was playing with gensplash so I had to recompile the nitro0e kernel. I enabled all the gensplash stuff and emerge the latest nvidia-kernel and now unbelievable it works with the NVIDIA driver !! No more hard locking.

The e patch is a real succes with Reiser4. Porthole loads my ebuild db (9016 packages) much more quickly than before.

Thx INDs. ; )
Back to top
View user's profile Send private message
vgster
n00b
n00b


Joined: 02 Oct 2004
Posts: 11

PostPosted: Wed Mar 09, 2005 8:40 pm    Post subject: Reply with quote

Has anyone tried this patch with the 2.6.11.2 kernel release?

Regards
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Wed Mar 09, 2005 10:19 pm    Post subject: Reply with quote

a13x wrote:
Good news. I was playing with gensplash so I had to recompile the nitro0e kernel. I enabled all the gensplash stuff and emerge the latest nvidia-kernel and now unbelievable it works with the NVIDIA driver !! No more hard locking.

The e patch is a real succes with Reiser4. Porthole loads my ebuild db (9016 packages) much more quickly than before.

Thx INDs. ; )


mine hardlocks :(
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Gentoonie
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 205
Location: near Munich | Bavaria | Germany

PostPosted: Wed Mar 09, 2005 10:23 pm    Post subject: Reply with quote

here too. Without nvidia in the kernel but emerged as nvidia-kernel, my X totally crashes, i have to press the reset button then. Haven't found a solution to this yet.
_________________
Do you know the secret hand shake - you best use it.

GCC 4, Kernel 2.6.14-ck7, NPTL
Back to top
View user's profile Send private message
Morimando
Guru
Guru


Joined: 14 Feb 2005
Posts: 339
Location: Germany

PostPosted: Wed Mar 09, 2005 10:45 pm    Post subject: Reply with quote

I had some problems with burning CD's while music is running in the background, although memory/CPU usage wasn't too high so i suspect it was/is a problem with reiser4 or such (also have that problem with the 2.6.11-love sources (We are the borg-thing) ) as i prefer using nitro, do you know if that was/is an Reiser4 issue and is it solved?
_________________
That young girl is one of the least benightedly unintelligent organic life forms it has been my profound lack of pleasure not to be able to avoid meeting.
-- Marvin
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Wed Mar 09, 2005 11:11 pm    Post subject: Reply with quote

my comp hardlocks afterawhile or when playing Amercan Army dont know why i will use old nitr :) stable and secure heheh 2.6.11 doesnt work good for me yet..
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Legoguy
Apprentice
Apprentice


Joined: 22 Dec 2003
Posts: 165
Location: Gurnee, IL

PostPosted: Thu Mar 10, 2005 2:27 am    Post subject: Reply with quote

Hey Darckness, guess what? All of your releases with -r0 on them cannot be unmerged without unmerging all versions of nitro.

Nice going.

It automatically removes r0 (2.6.11_rc3-r0 -> 2.6.11_rc3) and therefore can't find the correct ebuild to unmerge.
I refuse to use nitro until you stop this r0 silliness. pre1, beta1, alpha1, whatever, just not the portage-[rule-]breaking r0.
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Thu Mar 10, 2005 12:10 pm    Post subject: Reply with quote

Gentoonie

Have you tried to enable all the gensplash stuff in the kernel ? This is what fixed it for me .... it seems. Check the gensplash tutorial in the Documentation, Tips & Tricks forum and enable all those things. Maybe it will work ...
Back to top
View user's profile Send private message
Morimando
Guru
Guru


Joined: 14 Feb 2005
Posts: 339
Location: Germany

PostPosted: Thu Mar 10, 2005 5:30 pm    Post subject: Reply with quote

Nvidia kernel won't work if in-kernel Nvidia is enabled, it keeps giving me errors, so i had to disable it in the kernel and emerge nvidia-kernel using ACCEPT_KEYWORDS.
_________________
That young girl is one of the least benightedly unintelligent organic life forms it has been my profound lack of pleasure not to be able to avoid meeting.
-- Marvin
Back to top
View user's profile Send private message
Morimando
Guru
Guru


Joined: 14 Feb 2005
Posts: 339
Location: Germany

PostPosted: Thu Mar 10, 2005 6:07 pm    Post subject: Reply with quote

Hm i also have some problems considering memory-usage (i think it's resulting from memory management?)
if anyone had some time peeking at this thread: http://forums.gentoo.org/viewtopic-t-305615.html , would be nice, because i myself am not experienced enough to solve it myself i'm afraid.. thx in advance for anyone so kind to have a look ;)
Using 2.6.11-nitro0 over here, CFQ scheduling enabled, Deadline/Anticipatory disabled.
However the boot-time of this kernel is really good ^^
_________________
That young girl is one of the least benightedly unintelligent organic life forms it has been my profound lack of pleasure not to be able to avoid meeting.
-- Marvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 12, 13, 14  Next
Page 13 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum