Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.11-nitro0: Module Rodeo Until Dawn
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
uman
Apprentice
Apprentice


Joined: 20 Dec 2004
Posts: 223

PostPosted: Wed Mar 02, 2005 8:55 pm    Post subject: Reply with quote

AWESOME! Although I am kind of annoyed that after struggling to install nvidia-kernel you guys make it unnecessary the next day. Yes, I try nitro and the next day they come out with a new version lol ... well anyway I'm off to try it! (posting this from a windows box at school, but I installed PuTTY so it's all good)
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Mar 02, 2005 8:55 pm    Post subject: Reply with quote

note to ati users (like me ;) )

you have to select agpgart as a module in order to build ati module!
Ive already fixed it by adding a big fat note appearing instead of selection for ati
when GART is not a module, but it was not that far at time of release. the updated Kconfig
will be in the experimental sometime tomorrow i hope....

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Wed Mar 02, 2005 9:30 pm    Post subject: Reply with quote

This kernel patch is Reiser4 friendly but the nvidia driver is giving me troubles.

Look at this:

Code:

via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt Link [ALKD] BIOS reported IRQ 0, using IRQ 23
ACPI: PCI Interrupt Link [ALKD] enabled at IRQ 23
ACPI: PCI interrupt 0000:00:12.0[A] -> GSI 23 (level, low) -> IRQ 185
eth0: VIA Rhine II at 0x1e000, 00:0a:e6:dc:b7:66, IRQ 185.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
nvidia: module license 'NVIDIA' taints kernel.
Unable to handle kernel NULL pointer dereference at virtual address 00000008
 printing eip:
c02b5c0e
*pde = 00000000
Oops: 0000 [#1]
PREEMPT
Modules linked in: nvidia via_rhine
CPU:    0
EIP:    0f20:[<c02b5c0e>]    Tainted: P      VLI
EFLAGS: 00010282   (2.6.11-nitro0)
EIP is at pci_register_driver+0xe/0x80
eax: d0fb1de0   ebx: 00000000   ecx: 00000003   edx: 00000000
esi: cf00e000   edi: d0fb2dc0   ebp: cf00e000   esp: cf00ff64
ds: 0f3b   es: 0f3b   ss: 0f28
Process modprobe (pid: 1183, threadinfo=cf00e000 task=cf60f570)
Stack: 00000009 d0fb2180 d0fb2dc0 d083605e 00000000 0000000c 0000001b 0000001a
       0000001c d0c49c14 d0bc315b d0bc323c d0fb2180 cf00e000 00000028 cf00e000
       c0139212 c0637e08 00000001 d0fb2180 b77fb008 0805a6b8 00000028 c010336f
Call Trace:
 [<d083605e>] nvidia_init_module+0x5e/0x44a [nvidia]
 [<c0139212>] sys_init_module+0x182/0x270
 [<c010336f>] sysenter_past_esp+0x58/0x79
Code: b4 26 00 00 00 00 8d bc 27 00 00 00 00 e9 0b fb ff ff 8d 74 26 00 8d bc 27 00 00 00 00 57 b9 03 00 00 00 53 83 ec 04 8b 5c 24 10 <8b> 43 08 8d 93 94 00 00 00 c7 43 2c 20 0f 58 c0 c7 83 80 00 00
 <6>it87: Found IT8705F chip at 0x290, revision 2
it87 0-0290: detected broken BIOS defaults, disabling pwm interface
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Mar 02, 2005 9:33 pm    Post subject: Reply with quote

hmm, got to ask darckness about this when he is available,
im only testing the ati stuff...
Did you put any extra cflags into the kernel build?

EDIT: and i think i shouldnt hide that everything running on reiser4 is suspicious for me.....

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Wed Mar 02, 2005 9:48 pm    Post subject: Reply with quote

Nope. Everytime I compile a new kernel for the first time I only put normal stuff without any insane things like: crazy stacks or extreme cflags. Only once in my life I touched the cflags. The result was indeed a fast kernel but my joy only lasted for a few minutes cuz it locked up suddenly and unsuspectingly and I had to hard reboot.
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Wed Mar 02, 2005 9:49 pm    Post subject: Reply with quote

sk98ln network driver STILL dosent work iam using my wlan now cause my patch didnt work for this one :(
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Mar 02, 2005 9:52 pm    Post subject: Reply with quote

@robin76

I have a fix for it, got to wait for darckness to come back....
PS: i have sk98lin too, for my yukon....
_________________
Retired gentoo user
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Wed Mar 02, 2005 9:54 pm    Post subject: Reply with quote

my name is robin79 cant you send it to me so i can patch myself dont want to remerge :( what MB do you use?

Edit: i have this one Ethernet controller: Marvell Technology Group Ltd. Gigabit Ethernet Controller (rev 15)
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Arainach
l33t
l33t


Joined: 08 Jul 2004
Posts: 609

PostPosted: Wed Mar 02, 2005 9:58 pm    Post subject: Reply with quote

Ah, I was one of the few people to notice when the "Accelerated Drivers" patch accidentally slipped into the rc5 release. It didn't work there, but I figure since 2.6.11 is now a "stable" release, I'll upgrade to these. Wow, 2 Kernel upgrades in 3 days for me.... I must be obsessed.

I'll keep you guys posted on how this stuff works out for me.
_________________
Gentoo: Stage3 w/ NPTL & udev, gcc 3.4.4 full rebuild
Kernel: 2.6.15-gentoo-r1 w/ 1G-Lowmem Patch
System: Athlon XP 2.2Ghz/1GB Corsair Value/160GB, 250GB WD IDE/128MB GeForce 6800/Sony 17" Trinitron G200 @ 1280x1024x75Hz
Back to top
View user's profile Send private message
forkboy
Apprentice
Apprentice


Joined: 24 Nov 2004
Posts: 200
Location: Blackpool, UK

PostPosted: Wed Mar 02, 2005 10:01 pm    Post subject: Reply with quote

I get the same kind of thing as a13x
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Wed Mar 02, 2005 10:03 pm    Post subject: Reply with quote

forkboy and a13x: please send your kernel .config files to cyrix12@cox.net so I can hunt this down.

Now back to painkillers and goofy drugs...
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
predatorfreak
l33t
l33t


Joined: 13 Jan 2005
Posts: 708
Location: USA, Michigan.

PostPosted: Wed Mar 02, 2005 10:13 pm    Post subject: Reply with quote

Darckness wrote:
forkboy and a13x: please send your kernel .config files to cyrix12@cox.net so I can hunt this down.

Now back to painkillers and goofy drugs...


Don't get too high darckness! :)
_________________
System: predatorbox
Distro: Arch Linux x86_64
Current projects: blackhole, convmedia and anything else I cook up.
Back to top
View user's profile Send private message
suineg
Apprentice
Apprentice


Joined: 02 Mar 2004
Posts: 200
Location: Los Angeles

PostPosted: Wed Mar 02, 2005 10:27 pm    Post subject: Reply with quote

does anyone have a reccomendation as to what cflags would be worthwhile to use when compiling the kernel?

or do I have to leave it alone if I want any sort of stability at all :)
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Wed Mar 02, 2005 10:41 pm    Post subject: Reply with quote

HARDLOCKED damm shit it locked my comp :( too bad.. i was emergeing and talking in skype
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Arainach
l33t
l33t


Joined: 08 Jul 2004
Posts: 609

PostPosted: Wed Mar 02, 2005 10:42 pm    Post subject: Reply with quote

While the kernel compiles just fine with the "ATI drivers" option enabled and an fglrx module is built, I do NOT get 3D Rendering with this kernel. Even after manually emerging ati-drivers (I use 8.8.25 still since I had random hard locks with 8.10.23), no 3D Acceleration. I'm going back to rc5 for now.
_________________
Gentoo: Stage3 w/ NPTL & udev, gcc 3.4.4 full rebuild
Kernel: 2.6.15-gentoo-r1 w/ 1G-Lowmem Patch
System: Athlon XP 2.2Ghz/1GB Corsair Value/160GB, 250GB WD IDE/128MB GeForce 6800/Sony 17" Trinitron G200 @ 1280x1024x75Hz
Back to top
View user's profile Send private message
uman
Apprentice
Apprentice


Joined: 20 Dec 2004
Posts: 223

PostPosted: Wed Mar 02, 2005 10:51 pm    Post subject: Reply with quote

For some reason it doesn't want to compile thhe nvidia kernel.
It gives me errors about "no such option":
Quote:
cc1: error: unrecognized option `-Wdeclaration-after-statement'
cc1: error: unrecognized option `-fno-unit-at-a-time'
make[2]: *** [drivers/accel3d/nvidia/nv.o] Error 1
make[1]: *** [drivers/accel3d/nvidia] Error 2
make: *** [drivers] Error 2
Back to top
View user's profile Send private message
Zephyrus
Apprentice
Apprentice


Joined: 01 Sep 2004
Posts: 202

PostPosted: Wed Mar 02, 2005 10:56 pm    Post subject: Reply with quote

This is a great kernel, very good work ;)

EDIT:
uman wrote:
For some reason it doesn't want to compile thhe nvidia kernel.
It gives me errors about "no such option":
Quote:
cc1: error: unrecognized option `-Wdeclaration-after-statement'
cc1: error: unrecognized option `-fno-unit-at-a-time'
make[2]: *** [drivers/accel3d/nvidia/nv.o] Error 1
make[1]: *** [drivers/accel3d/nvidia] Error 2
make: *** [drivers] Error 2


Are you using gcc 3.3.4? I get the same result if i use this version of gcc but with 3.4.3 there is no problem.


Last edited by Zephyrus on Wed Mar 02, 2005 11:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Mar 02, 2005 11:01 pm    Post subject: Reply with quote

please dont use custom cflags when building with 3d driver enabled

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
steve_d555
Guru
Guru


Joined: 07 Nov 2004
Posts: 458
Location: Belmont, Massachusetts

PostPosted: Wed Mar 02, 2005 11:04 pm    Post subject: Reply with quote

a13x wrote:
This kernel patch is Reiser4 friendly but the nvidia driver is giving me troubles.

Look at this:

Code:

via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt Link [ALKD] BIOS reported IRQ 0, using IRQ 23
ACPI: PCI Interrupt Link [ALKD] enabled at IRQ 23
ACPI: PCI interrupt 0000:00:12.0[A] -> GSI 23 (level, low) -> IRQ 185
eth0: VIA Rhine II at 0x1e000, 00:0a:e6:dc:b7:66, IRQ 185.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
nvidia: module license 'NVIDIA' taints kernel.
Unable to handle kernel NULL pointer dereference at virtual address 00000008
 printing eip:
c02b5c0e
*pde = 00000000
Oops: 0000 [#1]
PREEMPT
Modules linked in: nvidia via_rhine
CPU:    0
EIP:    0f20:[<c02b5c0e>]    Tainted: P      VLI
EFLAGS: 00010282   (2.6.11-nitro0)
EIP is at pci_register_driver+0xe/0x80
eax: d0fb1de0   ebx: 00000000   ecx: 00000003   edx: 00000000
esi: cf00e000   edi: d0fb2dc0   ebp: cf00e000   esp: cf00ff64
ds: 0f3b   es: 0f3b   ss: 0f28
Process modprobe (pid: 1183, threadinfo=cf00e000 task=cf60f570)
Stack: 00000009 d0fb2180 d0fb2dc0 d083605e 00000000 0000000c 0000001b 0000001a
       0000001c d0c49c14 d0bc315b d0bc323c d0fb2180 cf00e000 00000028 cf00e000
       c0139212 c0637e08 00000001 d0fb2180 b77fb008 0805a6b8 00000028 c010336f
Call Trace:
 [<d083605e>] nvidia_init_module+0x5e/0x44a [nvidia]
 [<c0139212>] sys_init_module+0x182/0x270
 [<c010336f>] sysenter_past_esp+0x58/0x79
Code: b4 26 00 00 00 00 8d bc 27 00 00 00 00 e9 0b fb ff ff 8d 74 26 00 8d bc 27 00 00 00 00 57 b9 03 00 00 00 53 83 ec 04 8b 5c 24 10 <8b> 43 08 8d 93 94 00 00 00 c7 43 2c 20 0f 58 c0 c7 83 80 00 00
 <6>it87: Found IT8705F chip at 0x290, revision 2
it87 0-0290: detected broken BIOS defaults, disabling pwm interface


Got this too, but if I took out the integreated nvidia and emerged nvidia-kernel it worked fine.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Wed Mar 02, 2005 11:18 pm    Post subject: Reply with quote

it might be a compiler issue, darckness had also some issues while choosing the
makefile cflags that work properly, aparently he could only test the ones for
his version of gcc... some informations about the compilers you use might be helpful for later releases.

cheers

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
uman
Apprentice
Apprentice


Joined: 20 Dec 2004
Posts: 223

PostPosted: Wed Mar 02, 2005 11:23 pm    Post subject: Reply with quote

I don't want to download gcc-3.4.3. It's -* masked, and rather than deal witch that I'm going to just keep self-installing the module.
Back to top
View user's profile Send private message
LucaSpiller
Apprentice
Apprentice


Joined: 10 Sep 2004
Posts: 188
Location: Censorship Land (aka England)

PostPosted: Wed Mar 02, 2005 11:39 pm    Post subject: Reply with quote

I get a similar Nvidia error, which I guess is because I am using custom cflags for the kernel (those below) - I will have a go tommorow without them and see what I get.

Quote:
nvidia: module license 'NVIDIA' taints kernel.
Unable to handle kernel NULL pointer dereference at virtual address 00000008
printing eip:
b02a998e
*pde = 00000000
Oops: 0000 [#1]
PREEMPT CFLAGS_EDIT
Modules linked in: nvidia
CPU: 0
EIP: 0060:[<b02a998e>] Tainted: P VLI
EFLAGS: 00010286 (2.6.11-nitro0)
EIP is at pci_register_driver+0xe/0x80
eax: d1819a40 ebx: 00000000 ecx: 00000003 edx: 00000000
esi: d1819dc0 edi: d181aa00 ebp: cf2b8000 esp: cf2b9f50
ds: 007b es: 007b ss: 0068
Process modprobe (pid: 5325, threadinfo=cf2b8000 task=cf253080)
Stack: d1819dc0 cf2b8000 d181aa00 d084005e 00000000 00000009 00000000 00000010
00000000 00000000 0000000c 0000001b 0000001a 0000001c d14b180c d142aedb
d142afbc cf2b8000 d1819dc0 00000028 cf2b8000 b0131585 b062ba88 00000001
Call Trace:
CFLAGS_EDIT
[<d084005e>] nvidia_init_module+0x5e/0x4fe [nvidia]
[<b0131585>] sys_init_module+0x175/0x250
[<b01031f9>] sysenter_past_esp+0x52/0x75
Code: b4 26 00 00 00 00 8d bc 27 00 00 00 00 e9 2b fb ff ff 8d 74 26 00 8d bc 27
00 00 00 00 57 b9 03 00 00 00 53 83 ec 04 8b 5c 24 10 <8b> 43 08 8d 93 94 00 00
00 c7 43 2c 80 81 57 b0 c7 83 80 00 00


Quote:
fe04 ~ # emerge info
Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.4.3-20050110, glibc-2.3.4.20050125-r0, 2.6.11-nitro0 i686)
=================================================================
System uname: 2.6.11-nitro0 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.6.9
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 16 2005, 13:01:06)]
dev-lang/python: 2.3.4-r1
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils: 2.15.92.0.2-r1
sys-devel/libtool: 1.5.10-r4
ACCEPT_KEYWORDS="x86"
CFLAGS="-O3 -march=athlon-xp -mtune=athlon-xp -fforce-addr -momit-leaf-frame-poi
nter -fomit-frame-pointer -ftracer -pipe"
CHOST="i686-pc-linux-gnu"

_________________
:: Luca :: Mac Fag :: Original Macbook, 2g RAM :: Closet Linux user (seasoned with salt and pepper) :: C2D E4400 @ 2ghz, 4g RAM (only 3.2g detected under 64bit...), Nvidia 9600GSO ::
Back to top
View user's profile Send private message
dillweed
n00b
n00b


Joined: 17 Dec 2004
Posts: 13

PostPosted: Wed Mar 02, 2005 11:47 pm    Post subject: Reply with quote

I'm sorry if this has been asked before, however, is there support for supermount in this patchset?

Thanks for the great work on this.
Back to top
View user's profile Send private message
predatorfreak
l33t
l33t


Joined: 13 Jan 2005
Posts: 708
Location: USA, Michigan.

PostPosted: Wed Mar 02, 2005 11:50 pm    Post subject: Reply with quote

dillweed wrote:
I'm sorry if this has been asked before, however, is there support for supermount in this patchset?

Thanks for the great work on this.


I don't believe there is, although darckness might have slipped it in.
_________________
System: predatorbox
Distro: Arch Linux x86_64
Current projects: blackhole, convmedia and anything else I cook up.
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Thu Mar 03, 2005 12:15 am    Post subject: Reply with quote

predatorfreak wrote:
dillweed wrote:
I'm sorry if this has been asked before, however, is there support for supermount in this patchset?

Thanks for the great work on this.


I don't believe there is, although darckness might have slipped it in.


Never.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, ... 12, 13, 14  Next
Page 2 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum