Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI-xorg-amd64-HOWTO
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
knue
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 139

PostPosted: Sun Feb 27, 2005 11:40 pm    Post subject: ATI-xorg-amd64-HOWTO Reply with quote

Since I encouterd several problems in configuring my xserver here my how-to so I can share my knowledge :D

- first of all: I had several problems (not just with xorg) with the unstable tree (~amd64) -- so use the stable one. It was even so worse that I was forced to make a new instalation (and this time I use amd64)

- Dont use xorg-6.8.2! It is currently unstable marked. It broke some symlinks and added some odd things...
EDIT: it was fixed I heard...

- Use gentoo-dev-sources-2.6.10. If you use the stable tree add this line to /etc/portage/packages.keywords:
Code:
sys-kernel/gentoo-dev-sources ~amd64
Otherwise you won't be able to modprobe the ati-driver

- Use these kernel-options (I activated them as a module):
Code:
Processor type and features  ---> Processor family (AMD-Opteron/Athlon64)
    [ ] IOMMU support

Device Drivers ---> Character devices  --->
    <M> /dev/agpgart (AGP Support)
    <M>   AMD Opteron/Athlon64 on-CPU GART support
You wil be able to select /dev/agpgart after having set up your Processor family.

- recompile your kernel and so on

- if you are in stable tree add this to your /etc/portage/package.keywords:
Code:
media-video/ati-drivers ~amd64
x11-base/opengl-update ~amd64


-Install ati-drivers:
Code:
emerge ati-drivers


- add your modules to your /etc/modules.autoload.d/kernel-2.6
Code:
agpgart
amd64-agp
fglrx


- Don't forget to run
Code:
modules-update


- run (as root)
Code:
/opt/ati/bin/fglrxconfig


- answer the questions. Normally the default answers do their job.

- You can use ddcxinfo-knoppix to get your hsync and vsync values. But it is a pitty that this package has a bug. It won't compile. So you have to use a linux livecd to run
Code:
ddcxinfo-knoppix -monitor

and remember the vsync and hsync values

- There is one really nasty option (xorg freezed my system because of a wrong value there...)
when fglrxconfig asks this:
Code:
Do you want to use the external AGP GART module?
Do not use the default answer there and answer YES. In other words... Your xorg.config must have this value:
Code:
    Option "UseInternalAGPGART"         "no"


- Run:
Code:
opengl-update ati


- Now (after rebooting or modprobing) a startx should work with 3D accelration

I hope I didnt forget sth nasty...

Enjoy!


Last edited by knue on Mon Feb 28, 2005 2:13 am; edited 8 times in total
Back to top
View user's profile Send private message
babo
Guru
Guru


Joined: 10 Aug 2004
Posts: 477
Location: Ljubljana

PostPosted: Mon Feb 28, 2005 12:08 am    Post subject: Reply with quote

what are the reasons for using the kernel AGP?
Back to top
View user's profile Send private message
knue
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 139

PostPosted: Mon Feb 28, 2005 12:30 am    Post subject: Reply with quote

I freezed my whole system without that. I just got a blank black screen and keyboard did not work.
When I did not use AGP my xserver only ran without dri (so no 3d acceleration and no tuxracer or crack-attack :D )
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Mon Feb 28, 2005 12:58 am    Post subject: Reply with quote

This is good, it'll answer a lot of questions people have. You might want to go through and correct a few typos though, like "gentoo-dev-sources-6.9.10"

Also, you're saying that you have the option to enable agpgart support? Interesting, for me it's not an option, it's just there.
Code:
--- /dev/agpgart (AGP Support)
I did have the option on x86 but not amd64.

If you do source /etc/profile after emerging ati-drivers you should be able to run fglrxconfig without typing in the path to it. You do have to access root using "su -" rather than "su" though because the latter doesn't give you root's path.

Lastly, I believe that symlink bug has been worked out of xorg 6.8.2. It had the symlink /usr/lib64 pointing to ../lib64 rather than ./lib. I'm running ati-drivers on xorg 6.8.2 right now after fixing that. But as it stands I do recommend staying away from running a system completely as ~amd64 because I've run into a lot more problems than I ever did running ~x86.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
knue
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 139

PostPosted: Mon Feb 28, 2005 1:12 am    Post subject: Reply with quote

donjuan wrote:
This is good, it'll answer a lot of questions people have. You might want to go through and correct a few typos though, like "gentoo-dev-sources-6.9.10"

Also, you're saying that you have the option to enable agpgart support? Interesting, for me it's not an option, it's just there.
Code:
--- /dev/agpgart (AGP Support)
I did have the option on x86 but not amd64.

If you do source /etc/profile after emerging ati-drivers you should be able to run fglrxconfig without typing in the path to it. You do have to access root using "su -" rather than "su" though because the latter doesn't give you root's path.

Lastly, I believe that symlink bug has been worked out of xorg 6.8.2. It had the symlink /usr/lib64 pointing to ../lib64 rather than ./lib. I'm running ati-drivers on xorg 6.8.2 right now after fixing that. But as it stands I do recommend staying away from running a system completely as ~amd64 because I've run into a lot more problems than I ever did running ~x86.


When you select your processor family porperly you will be able to set up AGP (see my edit).
Just typing "flgrxinfo" does not work if I log in as root. "su -" works. Anyway: "/opt/ati/bin/fglrxinfo" won't do any damage.
Well as I said above I agree: ~amd64 is a bit nasty...
Thank your for your response. I corrected 2 typos...
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Mon Feb 28, 2005 1:52 am    Post subject: Reply with quote

Hrm, deffinitely have AMD-Opteron/Athlon64 selected, maybe something's canged recently...I'll find out when I upgrade to 2.6.11, whenever that'll be.

You said "- if you are in unstable tree add this to your /etc/portage/package.keywords:" when you meant to say "if you are in the stable tree"

Also, people don't usually use "Edit:" in how-tos, it's just assumed that you have a good reason to change things and people don't ask why. The most I've ever seen is Bob P keeping a revision history at the bottom of his "Stage 1 NPTL on a Stage 3 Tarball" how-to.

I'll stop bugging you now and get back to my homework. Keep up the good work. :wink:
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
knue
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2004
Posts: 139

PostPosted: Mon Feb 28, 2005 2:14 am    Post subject: Reply with quote

You also have to deactivate IOMMU support to select agp stuff.
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Mon Feb 28, 2005 2:48 am    Post subject: Reply with quote

Okies, thanks. It has been enabling on-CPU agpgart support by default with IOMMU selected since IOMMU is a K8-specific option.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
babo
Guru
Guru


Joined: 10 Aug 2004
Posts: 477
Location: Ljubljana

PostPosted: Mon Feb 28, 2005 10:35 am    Post subject: Reply with quote

knue wrote:
I freezed my whole system without that. I just got a blank black screen and keyboard did not work.
When I did not use AGP my xserver only ran without dri (so no 3d acceleration and no tuxracer or crack-attack :D )


ok, I am asking couse it works for me without kernel AGP. It also works like so for my coworker and my girlfriend. So I thought you're suggesting it couse of some speed benefits.
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Mon Feb 28, 2005 6:13 pm    Post subject: Reply with quote

Most people who have dealt with ATI driver problems will suggest to using the kernel AGP support because, as happened to knue, the ATI AGP support frequently doesn't work. Using the kernel AGP support rather than the ATI AGP support is listed as a possible fix for several of the problems on Wedge_'s FAQ: http://odin.prohosting.com/wedge01/gentoo-radeon-faq.html

Wedge_'s FAQ is also a good source of information for anybody who might be having problems with the driver, though most of the info is x86-related.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
allanw
Arch/Herd Tester
Arch/Herd Tester


Joined: 02 Mar 2005
Posts: 60

PostPosted: Wed Mar 02, 2005 9:43 pm    Post subject: Reply with quote

Hmm, make modules_install doesn't seem to work for me when disabling IOMMU support. I get the following:

Code:
aw linux # make modules_install
  INSTALL drivers/acpi/ibm_acpi.ko
  INSTALL drivers/acpi/video.ko
  INSTALL drivers/net/8139cp.ko
  INSTALL drivers/net/8139too.ko
if [ -r System.map ]; then /sbin/depmod -ae -F System.map  2.6.10-gentoo-r7; fi
WARNING: /lib/modules/2.6.10-gentoo-r7/video/fglrx.ko needs unknown symbol dma_map_single
WARNING: /lib/modules/2.6.10-gentoo-r7/video/fglrx.ko needs unknown symbol no_iommu
WARNING: /lib/modules/2.6.10-gentoo-r7/video/fglrx.ko needs unknown symbol dma_unmap_single


Hmm, actually, it looks like it finished successfully, but with a few warnings. When I enable IOMMU support, make modules_install goes like this:

Code:
aw linux # make modules_install
  INSTALL drivers/acpi/ibm_acpi.ko
  INSTALL drivers/acpi/video.ko
if [ -r System.map ]; then /sbin/depmod -ae -F System.map  2.6.10-gentoo-r7; fi


Should I just use IOMMU, or disable it? It seems IOMMU automaticly turns on agpgart and the on-CPU GART support anyway.[/code]
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Thu Mar 03, 2005 12:08 am    Post subject: Reply with quote

In your case I would leave IOMMU turned on because it might save some trouble. And you are right, IOMMU does turn on agpgart automatically.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
jsnorman
Tux's lil' helper
Tux's lil' helper


Joined: 24 Feb 2005
Posts: 131

PostPosted: Thu Mar 03, 2005 4:06 pm    Post subject: IOMMU Reply with quote

donjuan wrote:
In your case I would leave IOMMU turned on because it might save some trouble. And you are right, IOMMU does turn on agpgart automatically.


In my case (2x Opteron Zmaxdp mb, Radeon 9550 chipset) I found turning IOMMU on broke X. Turning it off fixed all my problems (with AGPGART still on and optimizations for the opteron agp). YMMV.
Back to top
View user's profile Send private message
iandoug
Apprentice
Apprentice


Joined: 11 Feb 2005
Posts: 290
Location: Cape Town, South Africa

PostPosted: Fri Mar 04, 2005 2:13 pm    Post subject: Reply with quote

donjuan wrote:
Most people who have dealt with ATI driver problems will suggest to using the kernel AGP support because, as happened to knue, the ATI AGP support frequently doesn't work.


Um, how about PCI-x support ?

Any tips for getting that working?
Have a Radeon X600-based card on Asus AMD64 board.

Thanks, Ian
Back to top
View user's profile Send private message
mecolik
n00b
n00b


Joined: 06 Aug 2003
Posts: 21

PostPosted: Mon Mar 07, 2005 7:52 pm    Post subject: fglrxconfig not working Reply with quote

I have used all the instructions but there is an issue I cant understand on my computer.
fglrxconfig quit at the very end of the process (should I write xorg.conf) when I type y and restart again telling that it could not found a device on the bus and that I should specify the fglrx-BusID option in xorg.conf next time.
(sorry no log of this message, so a long phrase)

Then the /etc/X11/xorg.conf is like half-writed.
This issue occurs with Xorg stable on amd64 and ATI unstable.
I'm now compiling the masked Xorg to see if it could change something..

Here is the computer's lspci output :
Code:

0000:04:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-8151 System Controller (rev 14)
0000:04:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8151 AGP Bridge (rev 14)
0000:05:00.0 VGA compatible controller: ATI Technologies Inc R420 JI [Radeon X800PRO]
0000:05:00.1 Display controller: ATI Technologies Inc: Unknown device 4a69


I've tried to rebuild the xorg.conf at hand, by mixing the sample and the half Ati's one,
but the screen go black and there was nobody home (in the box).

It shines like a diamond with the always good working xorg driver but no 3D and I love 3D for the added D.
This computer has more than 4Gb of memory so it may be the reason of the PCI (AGP) bus troubles.
Back to top
View user's profile Send private message
lookup
n00b
n00b


Joined: 03 Feb 2005
Posts: 17

PostPosted: Mon Mar 07, 2005 9:35 pm    Post subject: Reply with quote

Maybe you wanne add that on some boards (especially on the Asus A8V Deluxe) a switch from 8xAGP to 4xAGP in the BIOS solves a few stability issues.
(Well, for me it was the only way to get my card working ;) )
Back to top
View user's profile Send private message
MrIch
Apprentice
Apprentice


Joined: 25 May 2002
Posts: 204

PostPosted: Tue Mar 08, 2005 1:49 pm    Post subject: Reply with quote

my bios does not allow me to select the agp mode :(

MSI KT8 FIR

how can I say agpgart to use only 4X? In windows I can select the agp mode in the catalyst driver and this helps alot.

Please help...
Back to top
View user's profile Send private message
mecolik
n00b
n00b


Joined: 06 Aug 2003
Posts: 21

PostPosted: Fri Mar 11, 2005 6:36 pm    Post subject: Reply with quote

As I"ve not got it to work,
I've installed the latest Ubuntu distro.
Now the Ati driver is working only in 2D (no DRI).
There some post telling to go back to the 2.6.10-2 kernel image to get it working properly.
BAck to 2.6.10-2, now Black Screen Of Death (win95 memories but with the class of Linux),
I mean Xorg start and freeze when initializing the screen (when the mouse cursor should appear).
fglrxconfig does its infernal loop also on Ubuntu..

Now going to modify the AGP settings..
Back to top
View user's profile Send private message
lookup
n00b
n00b


Joined: 03 Feb 2005
Posts: 17

PostPosted: Fri Mar 11, 2005 8:51 pm    Post subject: Reply with quote

@ MrIch:
in your Section "Device" try to add Option "AGPMode" "4"
Should change the AGPMode
Back to top
View user's profile Send private message
MrIch
Apprentice
Apprentice


Joined: 25 May 2002
Posts: 204

PostPosted: Sat Mar 12, 2005 2:40 am    Post subject: Reply with quote

Code:

plinux011 X11 # grep -i agp xorg.conf
    Option "UseInternalAGPGART"         "no"
    Option "AGPMode" "4"

plinux011 X11 # dmesg
...
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: X passes broken AGP3 flags (1f000b0e). Fixed.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
....


does not help :(
Back to top
View user's profile Send private message
Shadow Skill
Veteran
Veteran


Joined: 04 Dec 2004
Posts: 1023

PostPosted: Sat Mar 12, 2005 7:45 am    Post subject: Reply with quote

Uhhh this is going to sound really stupid but what do I need to see with glxinfo or lsmod to tell me I am running the ati drivers? glxinfo says im using mesa :( The install went just fine, I didnt use agp though since my card is PCIe should I just edit xorg.conf to read ati where it says vesa?
_________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.

"First there was nothing, so the lord gave us light. There was still nothing, but at least you could see it."
Back to top
View user's profile Send private message
lookup
n00b
n00b


Joined: 03 Feb 2005
Posts: 17

PostPosted: Sat Mar 12, 2005 11:16 am    Post subject: Reply with quote

@Shadow Skill
What does your Xorg.log say? Does it say you are using the fglrx driver? If not is the driver module loaded ? (try lsmod | grep "fglrx")
Two possible results:
1.If that says no, the kernel module fglrx has not been loaded. Do a modprobe fglrx. and then start X again.
2.If instead the kernel module is there, check your xorg.conf. Are you using the fglrx driver in the profile that you are using for you X11 sessions?

@Mlrch
That's weired. But I've searched for that issue a bit more and I came across a post in which a guy described the problem (unstable card, couldn't set AGP 4x 'Cause of board) but under
windows. The reply that he got was the card might be broken...
Are you using the newest bios? Maybe that might help...
Back to top
View user's profile Send private message
Shadow Skill
Veteran
Veteran


Joined: 04 Dec 2004
Posts: 1023

PostPosted: Sat Mar 12, 2005 11:48 pm    Post subject: Reply with quote

I'm an idiot I forgot that the symlink for the kernel is pointing to 2.6.11 and not to the 2.6.9 kernel I am using right now..................................But that Kernel has broken ntfs read for some unimaginable reason it simply refuses to read ntfs drives no matter how I compile the support..sigh lets see if X works under 2.6.11..........
_________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.

"First there was nothing, so the lord gave us light. There was still nothing, but at least you could see it."
Back to top
View user's profile Send private message
Shadow Skill
Veteran
Veteran


Joined: 04 Dec 2004
Posts: 1023

PostPosted: Sun Mar 13, 2005 1:40 am    Post subject: Reply with quote

Ok X still works under 2.6.11-gentoo-r3 [I even got the alsa drivers and ntfs read support to work, need to get sound mixing now.] however fglrx will not load modprobe says this when I try to do it manually
Code:
FATAL: Error inserting fglrx (/lib/modules/2.6.11-gentoo-r3/video/fglrx.ko): No such device
I have already emerged the ati-drivers so they would be built for this kernel yet I still cant use the driver is it something in my xorg.conf?
_________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.

"First there was nothing, so the lord gave us light. There was still nothing, but at least you could see it."
Back to top
View user's profile Send private message
Swatinem
Tux's lil' helper
Tux's lil' helper


Joined: 27 Oct 2004
Posts: 89
Location: Bad Reicnehall, Germany

PostPosted: Sun Mar 13, 2005 9:22 am    Post subject: Reply with quote

built the kernel and the ati drivers twice but i still get the same error message as shadow skill. any ideas?
[edit]
look at this bug:
http://bugs.gentoo.org/show_bug.cgi?id=84834
lets wait untill its fixed...
_________________
swatinux: default-linux/amd64/2006.0 x86_64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum