Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sonderzeichen in wget [amd64, ~x86]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
puchu
n00b
n00b


Joined: 15 Feb 2005
Posts: 15

PostPosted: Mon Feb 21, 2005 7:19 pm    Post subject: Sonderzeichen in wget [amd64, ~x86] Reply with quote

hallo,

mein problem ist folgendes: ich habe den gentoo lokalisierungsleitfaden befolgt and es funktioniert auch alles wie es sollte, ich hab umlaute in der Konsole und in allen programmen auch in X jedoch nicht bei cmd line progs mit nls support, dort scheinen die zeichen mit utf8 kodiert zu werden. jedoch will ich nicht auf utf8 umsteigen bzw hab ich das schon mal gmacht, jedoch mit keinem erfolg.

meine config ist folgende:

bash-2.05b$ locale
LANG=de_DE@euro
LC_CTYPE=de_DE@euro
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="de_DE@euro"
LC_PAPER="de_DE@euro"
LC_NAME="de_DE@euro"
LC_ADDRESS="de_DE@euro"
LC_TELEPHONE="de_DE@euro"
LC_MEASUREMENT="de_DE@euro"
LC_IDENTIFICATION="de_DE@euro"
LC_ALL=

bash-2.05b$ gzcat /proc/config.gz|grep -i nls |grep -v not
CONFIG_NLS=y
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_CODEPAGE_850=y
CONFIG_NLS_CODEPAGE_852=y
CONFIG_NLS_ASCII=y
CONFIG_NLS_ISO8859_1=y
CONFIG_NLS_ISO8859_15=y

und in rc.conf steht folgendes:

KEYMAP="de-latin1-nodeadkeys"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS=
CONSOLEFONT="lat9w-16"
CLOCK="local"
PROTOCOLS="1 2"
XSESSION="kde-3.3.2"


das wars. programme ohne nls support wie zb nano stellen sonderzeichen in den menüpunkten richtig dar. wget sieht zb. so aus:


bash-2.05b$ wget test
--20:18:39-- http://test/
=> `index.html'
Auflösen des Hostnamen »test«.... 195.34.133.83
Verbindungsaufbau zu test[195.34.133.83]:80...

ich wäre sehr dankbar wenn irgendjemand einen vorschlag hätte wie ich das problem aus der welt schaffen könnte.

mfg
puchu


Last edited by puchu on Fri Mar 18, 2005 12:27 pm; edited 4 times in total
Back to top
View user's profile Send private message
c07
Veteran
Veteran


Joined: 25 Oct 2002
Posts: 1091

PostPosted: Mon Feb 21, 2005 10:17 pm    Post subject: Re: Sonderzeichen in progs mit nls funktionieren nicht Reply with quote

Ist das direkt auf der Konsole oder in einem xterm o.Ä. oder überall?

In rc.conf ist u.U. noch das nötig:
Code:
CONSOLETRANSLATION="8859-15_to_uni"
Back to top
View user's profile Send private message
puchu
n00b
n00b


Joined: 15 Feb 2005
Posts: 15

PostPosted: Mon Feb 21, 2005 11:35 pm    Post subject: Reply with quote

das is überall, egal ob konsole oda sonst wo. bei allen cmd line progs mit nls support

hab nun etwas an der config geändert:

rc.conf:

CONSOLEFONT="default8x16"

CONSOLETRANSLATION="8859-1_to_uni"

und die default nls is nun wieda

CONFIG_NLS_DEFAULT="iso8859-1"

Back to top
View user's profile Send private message
ChL@Gentoo
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jun 2004
Posts: 94
Location: Heidelberg (Germany)

PostPosted: Tue Feb 22, 2005 8:05 pm    Post subject: Reply with quote

Geht das bei dir nun?
Ich habe seit kurzem auch das Problem, seit ich mein System komplett neu kompiliert habe.
Vielleicht hab ich ja da auch was aus versehen überschrieben...
Back to top
View user's profile Send private message
puchu
n00b
n00b


Joined: 15 Feb 2005
Posts: 15

PostPosted: Tue Feb 22, 2005 8:17 pm    Post subject: Reply with quote

nein leida net wennst rausfindest was bei dir los is sag mas bitte
Back to top
View user's profile Send private message
ChL@Gentoo
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jun 2004
Posts: 94
Location: Heidelberg (Germany)

PostPosted: Thu Feb 24, 2005 8:26 pm    Post subject: Reply with quote

Soviel ich rausgefunden habe, hat nur wget Probleme mit der Codierung. Alle anderen Programme gehen ohne Probleme. Werde einfach gettext und wget neu kompilieren und hoffen das es geht ansonsten...

EDIT: Es hat nicht funktioniert, aber das Problem wurde im Bugtracker bereits gemeldet: http://bugs.gentoo.org/show_bug.cgi?id=77138
Back to top
View user's profile Send private message
puchu
n00b
n00b


Joined: 15 Feb 2005
Posts: 15

PostPosted: Tue Mar 01, 2005 1:25 am    Post subject: Reply with quote

ich hab was herausgefunden das prob tritt nur bei amd64 und bei systemen mit ¨x86 keyword auf da wget 1.9.1-r2 nur auf amd64 stable is (nur gott weiß warum :)). ich hab nen amd64 :(.

ach ja mit dem eintrag

=net-misc/wget-1.9.1-r2


in /etc/portage/package.mask wird das packet maskiert und nur die noch funktionierende Version (1.9-r2) installiert

danke für eure hilfe
Back to top
View user's profile Send private message
Abroxa
n00b
n00b


Joined: 07 Jul 2004
Posts: 5
Location: Bremen, Germany

PostPosted: Thu Mar 17, 2005 1:04 pm    Post subject: Reply with quote

Bei mir tritt es ebenfalls auf, ich habe weder einen amd64, noch habe ich ~x86 verwendet :(
Aber ich versuche mal, wget auf die besagte Version downzugraden.

Gruß
Back to top
View user's profile Send private message
zeus-cu
n00b
n00b


Joined: 16 Mar 2005
Posts: 33

PostPosted: Fri Mar 18, 2005 11:20 am    Post subject: Reply with quote

Hallo,

keine Ahnung warum dieser Thread auf "solved" steht. Dies ist offensichtlich kein Bug in wget. Wenn ich z.B. "gst-launch-0.8 --help" bei mir auf der shell aufrufe bekomme ich folgende Ausgabe:

---------------------snip------------------------------
--gst-debug-help Verfügbare Debuggingkategorien ausgeben und
Programm beenden
--gst-debug-level=LEVEL Standarddebugginglevel von 1 (nur Fehler)
bis 5 (Alles) oder 0 für keine Ausgabe
--gst-debug=LIST Kommagetrennte Liste von Paaren

--------------------snip---------------------------------

Scheint also nicht nur ein Problem bei wget zu sein. Habe default nls im Kernel auf iso8859-1 stehen und das xterm, wo ich diesen Aufruf getätigt habe, steht ebenfalls auf ISO-8859-15. (Scheint hier allerdings utf8 kodiert zu sein ???)

Vielleicht kennt ja jemand die Lösung für dieses Problem???
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Fri Apr 01, 2005 8:56 pm    Post subject: Reply with quote

Abroxa wrote:
Bei mir tritt es ebenfalls auf, ich habe weder einen amd64, noch habe ich ~x86 verwendet :(
Aber ich versuche mal, wget auf die besagte Version downzugraden.

Gruß


ME2
bin auf ~x86 und habe keinen amd64, wie meine Signatur sagt :roll:

gst-launch-0.8 --help macht bei mir die gleichen Fehler wie bei zeus-cu


Werde auch mal testen ob der downgrade ne Lösung bei wget bringt.:wink:
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4
Back to top
View user's profile Send private message
voeck
n00b
n00b


Joined: 06 Apr 2004
Posts: 10

PostPosted: Fri Apr 08, 2005 12:07 pm    Post subject: Reply with quote

Hallo,

Es sind auf jeden Fall verschiedene Probleme. gst-launch-0.8 gibt wie alle GNOME-Programme nur UTF-8 aus. Warum weiß ich auch nicht, eigentlich sollten sie dass nicht tun. Liegt wahrscheinlich an der glib. Aber wenn ihr euer Terminal auf UTF-8 stellt, passt es. Aber bei wget ist es etwas anders. Der Fehler tritt auch mit UTF-8 auf. Ich denke, dass da irgendwo in wget der Wurm drin ist. Jedenfalls hat der eine Fehler nichts mit dem anderen zu tun.

Viele Grüße!
Back to top
View user's profile Send private message
Lenz
Veteran
Veteran


Joined: 17 Jul 2003
Posts: 1439
Location: Marburg [HE, D, EU]

PostPosted: Fri Apr 08, 2005 1:52 pm    Post subject: Reply with quote

Bei mir hat

Code:
USE="-nls" emerge wget


geholfen! Ich hab übrigens ein x86-System, also betrifft nicht nur AMD64.
_________________
.:: Lenz' Signature 1.7b ::.

| Gentoo Linux since v1.4 (08-2003) [Screenshot]
| NetHack Highscore: 5.476.380 Pts., Val-Dwa-Fem-Law, ~ ascended to demigoddess-hood ~
Back to top
View user's profile Send private message
pinky99
n00b
n00b


Joined: 19 Nov 2004
Posts: 45

PostPosted: Sun Apr 10, 2005 9:14 am    Post subject: Reply with quote

na gut, das hilft für das wget problem usw. wenn man NLS-support abschaltet. aber die sache is doch die, dass dann einfach wieder die standard-englisch version des programms verwendet wird, und nicht die übersetzte (is auf jeden fall bei mir so), was ja nicht sinn der sache sein sollte.

Gruß,
max
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum