Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
managed to break KDM....completely
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bläk-kahr
n00b
n00b


Joined: 19 Sep 2002
Posts: 8

PostPosted: Sun Feb 02, 2003 9:34 pm    Post subject: managed to break KDM....completely Reply with quote

I'm having trouble with kdm.

I log in via kdm and regardless of what session I choose I end up with a 80x24 xterm at +0+0 with no wm.

In trying to fix things I've removed all sessions except for /etc/X11/Sessions/kde-3.1 which just calls /usr/kde/3.1/bin/startkde. I have in my kdmrc SessionType=kde-3.1.

I'm completely lost here, anyone have some ideas?

cheers
--Ben
Back to top
View user's profile Send private message
madpenguin8
n00b
n00b


Joined: 19 Jun 2002
Posts: 38
Location: Detroit MI

PostPosted: Sun Feb 02, 2003 9:57 pm    Post subject: /usr/kde/3.1/share/config/kdm/kdmrc Reply with quote

Look there.
_________________
Have you ever stopped to think...............and never start again?
Back to top
View user's profile Send private message
iaaipjcm
n00b
n00b


Joined: 03 Feb 2003
Posts: 5
Location: Utah

PostPosted: Thu Feb 06, 2003 3:08 am    Post subject: Solved: kdm missing wm's and doesn't launch what I selected Reply with quote

Solved: kdm missing wm's and doesn't launch what I selected

I log in via kdm and there are no wm's listed. I fixed that by adding my wm's to the Session Types list. Use the same naming and capitalization as they are listed in the /etc/X11/Sessions/ folder. Here's how to get there via the KDE GUI:

Code:
K > Settings > Control Center > System Administration > Login Manager > Administrator Mode > Sessions


I also found how to do it manually, by adding my wm's to the SessionTypes= line in the [X-*-Greeter] section of /usr/kde/3.1/share/config/kdm/kdmrc (correct path as needed). For example:

Code:
SessionTypes=kde-3.1,fluxbox,icewm


But...

I log in via kdm and regardless of which wm/session I choose I end up with an 80x24 xterm at +0+0 with no wm (aka xsm).

I searched the forums and finally fixed my problem using axslinger's fix. Add the following lines to the [X-*-Core] section of /usr/kde/3.1/share/config/kdm/kdmrc (correct paths as needed):

Code:

Reset=/usr/kde/3.1/share/config/kdm/Xreset
Resources=/usr/X11R6/lib/X11/xdm/Xresources
Session=/usr/X11R6/lib/X11/xdm/Xsession
Setup=/usr/kde/3.1/share/config/kdm/Xsetup
Startup=/usr/kde/3.1/share/config/kdm/Xstartup


Note: I noticed also that if I click the Defaults button from this GUI:
Code:
K > Settings > Control Center > System Administration > Login Manager > Administrator Mode > Sessions


That the lines I added to fix the above problems are again lost. For that reason, I recommend keeping a backup of your kdmrc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum