Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI Rage 128 Pro BINNED, GeForce2 MX400 a good replacement?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
leej
Apprentice
Apprentice


Joined: 18 May 2002
Posts: 280

PostPosted: Mon May 20, 2002 11:24 am    Post subject: ATI Rage 128 Pro BINNED, GeForce2 MX400 a good replacement? Reply with quote

I'm so sick to death of my ATI Rage Fury Pro (Rage 128 Pro) chipset that I'm going to give it to somebody I hate! ;-) The R128 DRM code isn't in sync with the current kernel so DRI doesn't work; if I sync the code and recompile myself, DRI starts working but it crashes when using Xine with the Xv driver; attempting to use Gatos drivers means even MPeGLib can bring the whole system to a halt. The only distribution I've gotten it to work properly with is MDK8.2, but seemingly at the expense of slowing everything else down, but besides - I want to use Gentoo!

What would be a good replacement though? I'm considering an ABit card based on the NVidia GEForce2 MX400 chipset. The precise model is

Siluro GF2 T400 / MX400
http://www.abit.com.tw/abitweb/webjsp/english/pt_main_back.jsp?pPRODUCT_TYPE=Video+Card&pMODEL_NAME=Siluro+GF2+T400+%2F+MX400

I've chosen this because (i) I can get it cheap and (ii) I've not found many negative comments from Linux users with regards to this - seemingly widely used - chipset. Maybe I'm wrong?

I notice the NVidia drivers are available as an EBuild. Any complaints about those?
Back to top
View user's profile Send private message
Curious
Bodhisattva
Bodhisattva


Joined: 13 May 2002
Posts: 395
Location: Sydney, Australia

PostPosted: Mon May 20, 2002 11:57 am    Post subject: Re: ATI Rage 128 Pro BINNED, GeForce2 MX400 a good replaceme Reply with quote

leej wrote:
Maybe I'm wrong?


No, you're quite right. I've run cards on this chipset for my last few linux boxes, and they've been very good - and I buy these as the "base" card for new boxes I'm putting together for people as they're quite cheap. They're also quite widely compatible, which is more than can be said for the 4 series. :-P

The only caveats I'd offer you are be careful on SMP systems - the NVIDIA drivers have had a history of hard lockups on SMP systems, something my GF is finding out the hard way on my hand-me-down Dual P3-550.

Apart from that, setup is very easy. There is even a special piece of documentation at gentoo.org on setting up nvidia cards ( iirc ). Good luck with it!

Bryn.

P.S. I am going to buy a Ge3 Ti sometime soon, which should be even nicer. :-) I want those Dungeon Siege framerates! :-P
_________________
Are you down with the Hawk?
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Tue May 21, 2002 9:15 am    Post subject: Reply with quote

there is no comparison....ATi isnt even worth messing with in linux....i stuck my radeon 8500 in my freebsd system since there are no drivers for the nvidia on bsd anyway....but if you can run a geforece and use the drivers from nvidia or emerge them you are like 500% better off then using any ati card.....ati should atleast make an effort to produce drivers for other platforms ....although they have enough trouble doing it right for windblows
Back to top
View user's profile Send private message
leej
Apprentice
Apprentice


Joined: 18 May 2002
Posts: 280

PostPosted: Thu May 23, 2002 2:53 pm    Post subject: Reply with quote

Thanks for the info. I quickly made the decision to buy based upon both replies, and very few problem posts elsewhere (most problems seem to be new users with misconfiguration problems - which would've happened regardless of their hardware).

Anyway, I got the Siluro T400 which has the GEForce 2 MX400 chipset, 64MB SDRAM and a 200Mhz core clock, and I've suddenly got stable, fast XFree86! I would've got a more up to date GEForce based card but couldn't find much previous experience of them, so opted for this one.

The last GLTron to work with my Rage 128 Pro (Rage Fury Pro) card was version 0.59 and I would get 60-80fps frame rate. The latest version of GLTron (0.61) didn't work properly at all with the ATI card. It was obvious that the acceleration had suddenly broken (0-3 fps!) - despite acceleration (GLX/DRI) working fine for other games. With the GEForce MX400, not only does GLTron 0.61 work again, but I'm getting 290fps *average* frame rate!!!

Huge difference. Video isn't streaky anymore and Xine with the Xv driver? Well, my system does *NOT* lock up anymore! So, one Linux system minus ATI display card equals more stability. :-)

Very impressive. Very glad I binned the ATI card! :-)

I haven't tested the TVOut in the GEForce yet, but it'll be interesting to see what happens because it wasn't properly supported in the Rage Fury Pro (unless you like your monitor in sleep mode).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum