Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge system fails
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
hakejam
n00b
n00b


Joined: 29 Aug 2003
Posts: 4

PostPosted: Thu Feb 03, 2005 9:57 am    Post subject: emerge system fails Reply with quote

I have looked through the forums, and haven't found an answer to this one. I have complete the install through the guide, and I can get up to emerging the system, and then I get a md5 check sum error everytime.

Code:

emerge system
Calculating system dependencies ...done!
>>> emerge (1 of 11) app-arch/cpio-2.5 to /

!!! Digest verification Failed:
!!!    /usr/portage/distfiles/cpio-2.5.tar.gz
!!! Reason: Failed on MD5 verification


Any suggestions?
Back to top
View user's profile Send private message
infecticide
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 262
Location: Regina, SK Canada

PostPosted: Thu Feb 03, 2005 10:19 am    Post subject: Reply with quote

The download maybe corrupt or the checksum maybe incorrect, try this

cd /usr/portage/distfiles
rm cpio-2.5.tar.gz
emerge sync
emerge system

We are removing the offending file and sync portage to ensure all checksums are correct (incase any corrections have been made) and retrying the merge.
_________________
. : | iNFeCTiCiDe | : .
"Look at all the dead bodies listening to the music..."
Back to top
View user's profile Send private message
hakejam
n00b
n00b


Joined: 29 Aug 2003
Posts: 4

PostPosted: Thu Feb 03, 2005 2:00 pm    Post subject: Reply with quote

I tried your suggestion and I got this when emerging the system:

Code:

Calculating system dependencies ...done!
>>> emerge (1 of 11) app-arch/cpio-2.5 to /
>>> Downloading http://gentoo.osuosl.org/distfiles/cpio-2.5.tar.gz

>>> Resuming download...
>>> Downloading http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/cpio-2.5.tar.gz

curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.
>>> Resuming download...
>>> Downloading http://mirror.telentente.com/pub/gnu/cpio/cpio-2.5.tar.gz

curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.
>>> Resuming download...
>>> Downloading ftp://ftp.mirror.nl/pub/mirror/gnu/cpio/cpio-2.5.tar.gz
######################################################################## 100.0%

!!! Digest verification Failed:
!!!    /usr/portage/distfiles/cpio-2.5.tar.gz
!!! Reason: Failed on MD5 verification
Back to top
View user's profile Send private message
cmoad
n00b
n00b


Joined: 03 Aug 2003
Posts: 40
Location: Indianapolis, IN

PostPosted: Thu Feb 03, 2005 3:06 pm    Post subject: Reply with quote

If you trust that the file you are getting is correct you can always re-digest the ebuild.

Quote:
rm /usr/portage/distfiles/cpio-2.5.tar.gz
sudo ebuild /usr/portage/app-arch/cpio/cpio-2.5.ebuild digest
emerge cpio


Btw, cpio-2.6-r1 works fine for OSX fine for me.
Back to top
View user's profile Send private message
hakejam
n00b
n00b


Joined: 29 Aug 2003
Posts: 4

PostPosted: Fri Feb 04, 2005 10:56 am    Post subject: Reply with quote

Still no luck, this is the message I get:

Code:

Calculating dependencies ...done!
>>> emerge (1 of 1) app-arch/cpio-2.5 to /
>>> md5 src_uri ;-) cpio-2.5.tar.gz
>>> Unpacking source...
>>> Unpacking cpio-2.5.tar.gz to /var/tmp/portage/cpio-2.5/work

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

!!! ERROR: app-arch/cpio-2.5 failed.
!!! Function unpack, Line 373, Exitcode 2
!!! failure unpacking cpio-2.5.tar.gz
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
hakejam
n00b
n00b


Joined: 29 Aug 2003
Posts: 4

PostPosted: Fri Feb 04, 2005 11:38 am    Post subject: Reply with quote

Could this problem be due that I am behind a proxy?
Back to top
View user's profile Send private message
gnac
Guru
Guru


Joined: 30 Jun 2003
Posts: 302
Location: Columbia River Gorge

PostPosted: Tue Feb 08, 2005 2:31 am    Post subject: Reply with quote

hakejam,

I had a similar problem with museseq giving me the same error. This post showed me the problem.

Try doing an
Code:
emerge -f packagename
emerge packagename


The -f will try to fetch the package from the first mirror in /etc/make.conf. In my case the package from the first mirror had a bad checksum, so emerge -f automatically went to the second and then the third mirror until it found a "valid" package. The second emerge will install the package you already downloaded with the -f switch.
_________________
"I thought she'd steal my heart, instead she stole my kidney,
and now its for sale, on the black market in Sydney" - Better Abraham
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum