Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error with linux26-headers... PLEASE HELP!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
x2aws
n00b
n00b


Joined: 20 Oct 2004
Posts: 5

PostPosted: Wed Oct 20, 2004 11:37 am    Post subject: Error with linux26-headers... PLEASE HELP!! Reply with quote

Well, i am in the process os unmerging the linux24 headers and emerging the linux26 headers. I have gone through all the steps:
1. mkdir -p /etc/portage
2. emerge unmerge linux-headers
3. rm /usr/include/linux/dvb (no such dir)
4. cd /etc/portage
5. nano -w package.keywords
6. typed : sys-kernel/linux26-headers , and also tried sys-kernel/linux26-headers-2.6.7-*, and then even tried adding a ~x86 to the end.
7 control x, and y and enter
8. emerge -v linux26-headers, even tried emerge -vp linux26-headers, and even added -2.6.7-*, 2.6.*, 2.*, 2*, and even * to the end.

now here is the error i get:

Calculting dependencies
!!! all ebuilds that could sastify "linux26-headers (and all of my other combos up above) have been masked
!!! possible canidates are:

linux26-headers-2.6.6-r1 (masked by: -* keyword)
linux26-headers-2.6.4 (masked by: -*)
linux26-headers-2.6.6 (masked by: -*)
linux26-headers-2.6.1 (masked by: -*)
linux26-headers-2.6.7-r1 (maksed by: missing keyword)
then it goes to 2.6.5, and 2.6.3-r1.

what am i doing wrong?? I did a stage 3 install without a network. i used gentoo-dev-sources for the kernel, version 2.6.7, and did a manual configuration with the kernel. please help!! i have even tried genkernel to build the kernel, and still the same problems!! This is my 6th install, and i have tried so many possibilities and still get the same error!!
Back to top
View user's profile Send private message
Deranger
Veteran
Veteran


Joined: 26 Aug 2004
Posts: 1215

PostPosted: Wed Oct 20, 2004 1:05 pm    Post subject: Reply with quote

I assume you're using x86 arch:

This should do the job:
Code:

echo "sys-kernel/linux26-headers ~x86" >> /etc/portage/package.keywords

If it doesn't work, try replacing ~x86 with -*

HTH
Back to top
View user's profile Send private message
DAudioLink
n00b
n00b


Joined: 24 Feb 2004
Posts: 11

PostPosted: Wed Oct 20, 2004 7:36 pm    Post subject: similar Problem Reply with quote

I'm having a somewhat similar problem, only I can't unmerge the 2.4.20 kernels, I'm no longer using them, and I forgot about them. But now I can't update anything other than portage. I had the old "gaming" sources installed but then I moved up to the 2.6 kernels and I'm happy with those, but I never unmerged the gaming sources and now they are no longer in the portage tree, but they still block the linux26-headers
Code:
[blocks B     ] sys-kernel/linux26-headers (from pkg sys-kernel/linux-headers-2.4.22)
[blocks B     ] sys-kernel/linux-headers (from pkg sys-kernel/linux26-headers-2.6.8.1-r1)

I really want to update my system now and latter manually deleate the 2.4.22 kernels' files, is there anyway I could just deleate something in the portage tree (or just something related to portage) that would unblock the linux26-headers?
_________________
Linux n00b, but still a Linux Zealot!
What have YOU done to Promote Linux?
P.S. I have two walls to paint in my room, Anyone have some Linux related sugestions?
Back to top
View user's profile Send private message
x2aws
n00b
n00b


Joined: 20 Oct 2004
Posts: 5

PostPosted: Wed Oct 20, 2004 9:24 pm    Post subject: ok, tried that... Reply with quote

What that did was add sys-kernel/linux26-headers ~x86, and -* to the file package.keywords. nothing else. After trying to emerge it again, here is my errors:

#emerge -v linux26-headers-2.6.7-r1
Calculating dependencies
!!!Problem in sys-kernel/linux26-headers-2.6.7-r1 dependencies
!!"Specific key requires an operator (sys-kernel/linux26-headers-2.6.7-r1) (try adding an '=')"

if i leave out the -2.6.7-r1, and replace with either a -*, or a ~x86, or nothing at all, i egt the error i had before. Any other suggestions??
Back to top
View user's profile Send private message
DAudioLink
n00b
n00b


Joined: 24 Feb 2004
Posts: 11

PostPosted: Tue Nov 02, 2004 5:30 pm    Post subject: Fixed Reply with quote

If you have the old 2.4 kernels on your system still, but you're using the new 2.6 kernels, run as root:
Code:
# emerge -p depclean

You may need to tac on |less to see everything. After reviewing the list if there is anything you want or think you need to keep don't run depclean without the -p, instead run something like
Code:
# emerge -pC sys-kernel/gaming-sources

if you want to unmerge the 2.4 gaming-sources, or you could just add the packages that you want/need to the world list, which I have no idea where that is. you may also need to do this:
Code:
# USE="no-old-linux" emerge -pvu world

If you need to update module-init-tools, which is the only package I've found that uses the "no-old-linux" flag.
Here are all the comands I've put in the post, in order of execution:
Code:
# emerge -p depclean
# emerge -pC sys-kernel/gaming-sources
# USE="no-old-linux" emerge -pvu world

_________________
Linux n00b, but still a Linux Zealot!
What have YOU done to Promote Linux?
P.S. I have two walls to paint in my room, Anyone have some Linux related sugestions?
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5232
Location: France, Old Europe

PostPosted: Mon Jan 24, 2005 2:31 pm    Post subject: Reply with quote

Quote:
P.S. I have two walls to paint in my room, Anyone have some Linux related sugestions?


you could try:

emerge -uDp wallpaper


dont forget the -p option otherwise you will probably find your cieling falls on your head or you can no longer open the door to get out :lol:
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum