Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eix - Ebuild IndeX (search utility) - 0.2.2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 15, 16, 17, 18, 19  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Fri Jul 04, 2008 10:08 am    Post subject: Reply with quote

does the "-*" option not work in the current version? i tried "--pure-packages" too.
i did not use it in the past, so i am not sure if i get something wrong or ...
Code:
# eix eix
[I] app-portage/eix
     Available versions:  0.10.2 0.12.4 (~)0.13.1 {doc sqlite}
     Installed versions:  0.13.1(18:28:04 06/27/08)(sqlite -doc)
     Homepage:            http://eix.sourceforge.net
     Description:         Small utility for searching ebuilds with indexing for fast results

# eix --pure-packages eix
[I] app-portage/eix
     Available versions:  0.10.2 0.12.4 (~)0.13.1 {doc sqlite}
     Installed versions:  0.13.1(18:28:04 06/27/08)(sqlite -doc)
     Homepage:            http://eix.sourceforge.net
     Description:         Small utility for searching ebuilds with indexing for fast results

#


i do not know exactly what the output should look like, so i make a prophylactic feature request, because i think that "--pure-packages" does not really what i want.
sometimes i want to update my system to the newest versions (not what portage thinks is best). "eix -cu" shows what to update, which is very nice.
"eix -u --only-names" is good, but not really suitable, because the slot is missing, like here
Code:
# eix -u --only-names
mail-client/evolution
net-libs/xulrunner
# emerge -pv1 $(eix -u --only-names)

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] mail-client/evolution-2.22.3.1 [2.22.2-r2] USE="crypt dbus hal ssl -debug -ipv6 -kerberos -krb4 -ldap -mono -networkmanager -nntp -pda -profile -spell" 0 kB
[ebuild   R   ] net-libs/xulrunner-1.9-r2  USE="dbus gnome java -ipv6 -startup-notification" 0 kB

Total: 2 packages (1 upgrade, 1 reinstall), Size of downloads: 0 kB
# eix -e xulrunner
[U] net-libs/xulrunner
     Available versions: 
        (1.8)   1.8.1.11 1.8.1.14 (~)1.8.1.15
        (1.9)   (~)1.9-r2
        {dbus debug elibc_FreeBSD gnome ipv6 java startup-notification xinerama xprint}
     Installed versions:  1.8.1.14(1.8)(09:41:00 06/23/08)(gnome java -debug -elibc_FreeBSD -ipv6 -xinerama -xprint)
                          1.9-r2(1.9)(12:03:08 07/04/08)(dbus gnome java -elibc_FreeBSD -ipv6 -startup-notification)
     Homepage:            http://developer.mozilla.org/en/docs/XULRunner
     Description:         Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications

#

the only thing that is missing is ":1.8" after xulrunner, which should be easy to do.
maybe for this not a new commandline switch needs to be created, i think that adding the slot to "--only-names" has no drawbacks, but i could be wrong.
any comments welcome.
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 712

PostPosted: Fri Jul 04, 2008 12:42 pm    Post subject: Reply with quote

alex.blackbit, I would like to see that too but this may work for you?
[EDIT]
Code:
 eix -nu --format "<category>/<name>-<best>" --pure-packages


Last edited by Nerevar on Fri Jul 04, 2008 6:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Fri Jul 04, 2008 1:43 pm    Post subject: Reply with quote

alex.blackbit wrote:
does the "-*" option not work in the current version?

It does work, but it is not what you apparently think that it is: It omits printings things like "Found 2 packages" at the end.
Quote:
"eix -u --only-names" is good, but not really suitable, because the slot is missing

Anything else makes no sense, because you can advice eix only to select packages, not to select versions: There are no reasonable criteria to select versions, except for the "best" version and the "best" version for each slot. For both there are special format commands which print this (as DarrenSmith has suggested). BTW: The "grep" in DarrenSmith's posting is not necessary if you use --pure-packages: This is what this option is meant for...

And by the way, your approach is completely wrong: If "emerge -NaDu @world @system" does not install the best version which eix shows, then this is either because it is slotted and nothing in world/system would make use of the new slot, or the whole package is not needed by anything in world/system. In both cases, it would be completely silly to install an unneeded slot/package (in the second case you should actually remove the package); if you really want the package (and the newest slot) you should add it to @world.

So summarizing: If "emerge -NaDU @world @system" does not update everything for you it means that your world file is broken or that you should unmerge the non-updated package. Upgrading it (even automatically) is certainly the wrong policy.
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 345
Location: Wroclaw, Poland

PostPosted: Sat Sep 20, 2008 6:31 pm    Post subject: Reply with quote

Hi

there's something wrong with my eix:

Code:
 # update-eix
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading  50%terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare
Przerwane (core dumped)


from gdb:
Code:
# gdb update-eix
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) run
Starting program: /usr/bin/update-eix
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading  50%terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare

Program received signal SIGABRT, Aborted.
0xffffe424 in __kernel_vsyscall ()
(gdb) bt
#0  0xffffe424 in __kernel_vsyscall ()
#1  0x45a5c690 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x45a5ded8 in *__GI_abort () at abort.c:88
#3  0x45da0178 in __gnu_cxx::__verbose_terminate_handler () at /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libstdc++-v3/libsupc++/vterminate.cc:98
#4  0x45d9e0a5 in __cxxabiv1::__terminate (handler=<value optimized out>) at /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libstdc++-v3/libsupc++/eh_terminate.cc:43
#5  0x45d9e0e2 in std::terminate () at /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libstdc++-v3/libsupc++/eh_terminate.cc:53
#6  0x45d9e105 in __cxxabiv1::__unexpected (handler=Could not find the frame base for "__cxxabiv1::__unexpected(void (*)())".
) at /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libstdc++-v3/libsupc++/eh_terminate.cc:59
#7  0x45d9da48 in __cxa_call_unexpected (exc_obj_in=<value optimized out>) at /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libstdc++-v3/libsupc++/eh_personality.cc:750
#8  0x08082a32 in MetadataCache::readCategory (this=0x940d268, vec=@0x9eca7b8) at cache/metadata/metadata.cc:100
#9  0x0806cdd3 in update (outputfile=0x93fe09c "/var/cache/eix", cache_table=@0xbfb58db4, portage_settings=@0xbfb58cc4, will_modify=true, exclude_labels=@0xbfb58dc0) at update-eix.cc:484
#10 0x0806e16b in run_update_eix (argc=1, argv=0xbfb58f84) at update-eix.cc:418
#11 0x080e3dd2 in main (argc=1, argv=0xbfb58f84) at main/main.cc:126
(gdb)                                                       


Any ideas? (eix-0.13.4)
Back to top
View user's profile Send private message
isilia
Apprentice
Apprentice


Joined: 25 Feb 2008
Posts: 178
Location: The Netherlands

PostPosted: Sat Sep 20, 2008 7:02 pm    Post subject: Reply with quote

Hi, I got exactly the same problem after I ran eix-sync today. Downgrading to 0.12.4 (from 0.13.3) didn't help. I tried syncing again (using emerge --sync) but that didn't help either O.o.

Code:

Gentoo portage # update-eix
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading  51%terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare
Aborted



Edit: Syncing with another server didn't help either.
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Sat Sep 20, 2008 10:03 pm    Post subject: Reply with quote

peter4 wrote:
Code:
 # update-eix
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading  50%terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare
Przerwane (core dumped)
(eix-0.13.4)

The version number of media-fonts/ja-ipafonts-002.03 is not properly chosen: Formally, leading zeroes in the first component are admissible (therefore, it would probably not be correct to report it as a bug), but the version number is actually the same as 2.03.
Of course, eix should not choke on the "illegal" number. This is already fixed in eix svn trunk.
As a workaround until eix-0.13.5 is out you can either use the svn version or rename the file
Code:
/usr/portage/metadata/cache/media-fonts/ja-ipafonts-002.03

into one with a number which has no problems.
Back to top
View user's profile Send private message
acevery
n00b
n00b


Joined: 03 Nov 2005
Posts: 53
Location: Amoy, China

PostPosted: Sun Sep 21, 2008 1:13 am    Post subject: Reply with quote

mv wrote:
peter4 wrote:
Code:
 # update-eix
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
     Reading  50%terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::compare
Przerwane (core dumped)
(eix-0.13.4)

The version number of media-fonts/ja-ipafonts-002.03 is not properly chosen: Formally, leading zeroes in the first component are admissible (therefore, it would probably not be correct to report it as a bug), but the version number is actually the same as 2.03.
Of course, eix should not choke on the "illegal" number. This is already fixed in eix svn trunk.
As a workaround until eix-0.13.5 is out you can either use the svn version or rename the file
Code:
/usr/portage/metadata/cache/media-fonts/ja-ipafonts-002.03

into one with a number which has no problems.


thanks a lot, it works :D
Back to top
View user's profile Send private message
timotheus25
Apprentice
Apprentice


Joined: 27 Dec 2005
Posts: 162
Location: *upstate* New York, USA

PostPosted: Sun Sep 21, 2008 2:03 pm    Post subject: Reply with quote

mv wrote:
This is already fixed in eix svn trunk.
As a workaround until eix-0.13.5 is out you can either use the svn version or rename the file
Code:
/usr/portage/metadata/cache/media-fonts/ja-ipafonts-002.03

into one with a number which has no problems.


Do you have an ebuild for eix that checks-out the svn head, such as
eix-9999.ebuild ?
_________________
http://tstotts.net/linux/gentoopb.html
http://tstotts.net/linux/gentooinsp640m.html
Back to top
View user's profile Send private message
opensas
Guru
Guru


Joined: 24 Nov 2004
Posts: 408
Location: Buenos Aires - Argentina

PostPosted: Sun Sep 21, 2008 8:26 pm    Post subject: Reply with quote

there's already a version with this thinged worked out...

just

Code:

echo"=app-portage/eix-0.13.5" >> /etc/portage/package.keywords

emerge eix


saludos

sas

ps. oh, of course, emerge --sync first....
Back to top
View user's profile Send private message
rgk
Tux's lil' helper
Tux's lil' helper


Joined: 06 Apr 2007
Posts: 140
Location: ny

PostPosted: Sun Sep 21, 2008 8:40 pm    Post subject: Reply with quote

im so glad eix is working again (emerge --search just doesn't cut it :P )
_________________
MadGizmo.com is awesome.
Back to top
View user's profile Send private message
hydrapolic
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2008
Posts: 114

PostPosted: Mon Sep 22, 2008 6:13 am    Post subject: Reply with quote

Great eix is back, cannot live without it ;)
Back to top
View user's profile Send private message
cyberpatrol
Apprentice
Apprentice


Joined: 18 Sep 2003
Posts: 161
Location: Germany

PostPosted: Mon Sep 22, 2008 9:17 pm    Post subject: Reply with quote

Please forgive me, if this is alread asked, but I can't read the whole 16 pages.

Since eix-0.13.3 I can't run eix-sync anymore.

If I'm just running `eix-sync` without any parameters as I'm used to, when I want syncing the portage tree, I'm getting this error message:
/usr/bin/eix-sync: illegal option -- v
eix-sync [options]

And the complete eix-sync -h page.
The portage tree isn't synced.

Is this a bug or a new feature?
How can this be fixed?
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Mon Sep 22, 2008 9:25 pm    Post subject: Reply with quote

cyberpatrol wrote:
/usr/bin/eix-sync: illegal option -- v

eix-sync does not support option -v anymore since this is now the exclusive behavior ("magic" redirection to a logfile is now longer supported). I guess that you had added this option to /etc/eix-sync.conf, so you should remove it again.
Back to top
View user's profile Send private message
cyberpatrol
Apprentice
Apprentice


Joined: 18 Sep 2003
Posts: 161
Location: Germany

PostPosted: Tue Sep 23, 2008 1:15 am    Post subject: Reply with quote

mv wrote:
cyberpatrol wrote:
/usr/bin/eix-sync: illegal option -- v

eix-sync does not support option -v anymore since this is now the exclusive behavior ("magic" redirection to a logfile is now longer supported). I guess that you had added this option to /etc/eix-sync.conf, so you should remove it again.

No, I've never set this option, and I don't have this option set in /etc/eix-sync.conf. And I've never set this option as a command line parameter.

This is my eixrc:
Code:
DEFAULT_IS_OR='true'

This is my eix-sync.conf:
Code:
!layman -S

And I'm syncing my portage tree simply by running:
Code:
eix-sync
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Tue Sep 23, 2008 7:29 am    Post subject: Reply with quote

Maybe you have defined an alias, a function, or a wrapper script which passes this option? Here there is no such problem with similar data.
Back to top
View user's profile Send private message
cyberpatrol
Apprentice
Apprentice


Joined: 18 Sep 2003
Posts: 161
Location: Germany

PostPosted: Tue Sep 23, 2008 9:30 am    Post subject: Reply with quote

mv wrote:
Maybe you have defined an alias, a function, or a wrapper script which passes this option? Here there is no such problem with similar data.

This was the problem. Thanks. I seem to have forgotten some of my aliases, and haven't thought about looking at my .bashrc. Sorry. :oops:
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Mon Oct 13, 2008 3:53 pm    Post subject: Reply with quote

i am sorry for asking again what i already did a long time before, but unfortunately i still do not really get it.
this time i will try to be more precise.
is it possible to let eix output a list of packages that already have a installed version (slotted or not), where a higher version (in that slot) is available?.
obviously eix -u does something else, since it gives me e.g.
Code:
% eix -u
[U] dev-java/ant-eclipse-ecj
     Available versions: 
        (3.3)   3.3.0-r1
        (3.4)   (~)3.4
        {elibc_FreeBSD}
     Installed versions:  3.3.0-r1(3.3)(15:26:59 08/01/08)(-elibc_FreeBSD)
     Homepage:            http://www.eclipse.org/
     Description:         Ant Compiler Adapter for Eclipse Java Compiler

[U] dev-java/eclipse-ecj
     Available versions: 
        (3.2)   3.2.2 (~)3.2.2-r1
        (3.3)   3.3.0-r2 (~)3.3.0-r3
        (3.4)   (~)3.4-r2
        {doc elibc_FreeBSD gcj java6}
     Installed versions:  3.3.0-r3(3.3)(15:25:44 08/01/08)(-elibc_FreeBSD)
     Homepage:            http://www.eclipse.org/
     Description:         Eclipse Compiler for Java

Found 2 matches.
%

this is not what i want, because in these 2 cases a higher version within the slot is not available.
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Tue Oct 14, 2008 5:43 pm    Post subject: Reply with quote

Code:
UPGRADE_TO_HIGHEST_SLOT=false eix -u
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Tue Oct 14, 2008 9:49 pm    Post subject: Reply with quote

thanks, this is what i was searching for.
is it additionally possible to output the slot in which the upgrade will take place?
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Wed Oct 15, 2008 5:04 am    Post subject: Reply with quote

alex.blackbit wrote:
is it additionally possible to output the slot in which the upgrade will take place?

No. This requires dependency resolving which eix does not do.
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Tue Oct 21, 2008 7:46 am    Post subject: Reply with quote

mv wrote:
alex.blackbit wrote:
is it additionally possible to output the slot in which the upgrade will take place?

No. This requires dependency resolving which eix does not do.
Sorry, I misread the question: my answer was almost a reflex, because people usually complain that they want UPGRADE_TO_HIGHEST_SLOT for some packages but not for others - and there is no way to do this automatically "correctly" without dependency resolving. Since >=eix-0.14.2 you can use /etc/portage/package.slot_upgrade_{allow,forbid} to specifiy exceptions at least manually.

Concerning your original question, the answer is currently "no" anyway - there is currently no such mechanism in eix.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Tue Oct 21, 2008 3:25 pm    Post subject: Reply with quote

ok, i am glad you made that clear.
i didn't really get the point why dependency resolving would be necessary for what i want.
it should be quite easy i guess, because eix knows to what version i suggests to upgrade, so it is implicitly known what slot that is, right?
a patch for that should be quite easy to do, unfortunately my c++ skills are not high enough to do that.
would you like to put that on a maybe existing "wanted feature" list?

here is a example for what exactly i am searching for.
the current situation in my portage tree:
Code:
% UPGRADE_TO_HIGHEST_SLOT=false eix -u
[U] net-libs/xulrunner
     Available versions: 
        (1.8)   1.8.1.17
        (1.9)   (~)1.9-r2 (~)1.9.0.3 (~)1.9.1_alpha2-r1[1] (~)1.9.1_beta1-r1[1]
        {custom-optimization dbus debug elibc_FreeBSD gnome ipv6 java startup-notification xinerama xprint}
     Installed versions:  1.8.1.17(1.8)(22:58:45 09/24/08)(gnome java -debug -elibc_FreeBSD -ipv6 -xinerama -xprint)
                          1.9.0.3(1.9)(21:56:08 09/28/08)(dbus gnome java -custom-optimization -elibc_FreeBSD -ipv6 -startup-notif
ication)
     Homepage:            http://developer.mozilla.org/en/docs/XULRunner
     Description:         Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications

[U] www-client/mozilla-firefox
     Available versions:  2.0.0.17 (~)3.0-r1 (~)3.0.3 (~)3.1_alpha2[1] (~)3.1_beta1[1] {bindist custom-optimization dbus debug fil
epicker gnome iceweasel ipv6 java linguas_%-*} linguas_-/_} linguas_af linguas_ar linguas_be linguas_bg linguas_bn linguas_bn_IN l
inguas_ca linguas_cs linguas_da linguas_de linguas_el linguas_en linguas_en_GB linguas_en_US linguas_es linguas_es_AR linguas_es_E
S linguas_eu linguas_fi linguas_fr linguas_fy linguas_fy_NL linguas_ga linguas_ga_IE linguas_gl linguas_gu linguas_gu_IN linguas_h
e linguas_hi linguas_hi_IN linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kn linguas_ko linguas_ku ling
uas_lt linguas_mk linguas_mn linguas_mr linguas_nb linguas_nb_NO linguas_nl linguas_nn linguas_nn_NO linguas_pa linguas_pa_IN ling
uas_pl linguas_pt linguas_pt_BR linguas_pt_PT linguas_ro linguas_ru linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas
_sv linguas_sv_SE linguas_th linguas_tr linguas_uk linguas_zh linguas_zh_CN linguas_zh_TW mozdevelop moznopango restrict-javascrip
t startup-notification xforms xinerama xprint xulrunner}
     Installed versions:  3.0.3(18:47:34 10/05/08)(dbus gnome java linguas_de linguas_en mozdevelop xulrunner -bindist -custom-opt
imization -iceweasel -ipv6 -linguas_af -linguas_ar -linguas_be -linguas_bn -linguas_bn_IN -linguas_ca -linguas_cs -linguas_da -lin
guas_el -linguas_en_GB -linguas_en_US -linguas_es -linguas_es_AR -linguas_es_ES -linguas_eu -linguas_fi -linguas_fr -linguas_fy -l
inguas_fy_NL -linguas_ga -linguas_ga_IE -linguas_gl -linguas_gu -linguas_gu_IN -linguas_he -linguas_hi -linguas_hi_IN -linguas_hu
-linguas_id -linguas_is -linguas_it -linguas_ja -linguas_ka -linguas_kn -linguas_ko -linguas_ku -linguas_lt -linguas_mk -linguas_m
n -linguas_mr -linguas_nb -linguas_nb_NO -linguas_nl -linguas_nn -linguas_nn_NO -linguas_pa -linguas_pa_IN -linguas_pl -linguas_pt
 -linguas_pt_BR -linguas_pt_PT -linguas_ro -linguas_ru -linguas_si -linguas_sk -linguas_sl -linguas_sq -linguas_sr -linguas_sv -li
nguas_sv_SE -linguas_th -linguas_tr -linguas_uk -linguas_zh -linguas_zh_CN -linguas_zh_TW -restrict-javascript -startup-notificati
on)
     Homepage:            http://www.mozilla.com/firefox
     Description:         Firefox Web Browser

[1] "mozilla" /usr/portage/local/layman/mozilla

Found 2 matches.
%


shorter:
Code:
% UPGRADE_TO_HIGHEST_SLOT=false eix -u --only-names
net-libs/xulrunner
www-client/mozilla-firefox
%


what i would like to have:
Code:
% UPGRADE_TO_HIGHEST_SLOT=false eix -u --magic-feature
net-libs/xulrunner:1.9
www-client/mozilla-firefox
%


with the "--format" option i get almost where i want, because i do not really care if i get "net-libs/xulrunner:1.9" or "net-libs/xulrunner-1.9.1_beta1-r1"
Code:
% UPGRADE_TO_HIGHEST_SLOT=false eix -u "-*" --format "<category>/<name>-<bestshort>"                         
net-libs/xulrunner-(~)1.9.1_beta1-r1(1.9)[2]
www-client/mozilla-firefox-(~)3.1_beta1[2]
%

in this case the "(~)", "(1.9)" and "[2]" are spurious.
i can remove these by running sed, but for removing the 2 expressions enclosed in parentheses there is a better way for sure.
Code:
% UPGRADE_TO_HIGHEST_SLOT=false eix -u "-*" --format "<category>/<name>-<bestshort>" | sed 's/\[.*\]//' | sed 's/(~)//' | sed 's/(.*)$//'
net-libs/xulrunner-1.9.1_beta1-r1
www-client/mozilla-firefox-3.1_beta1
%

this way i get a list that i can use pass to emerge, and this is what i want.

so, mv, would you like to implement an eix feature that outputs one of these two variants?
Code:
net-libs/xulrunner:1.9
www-client/mozilla-firefox

Code:
net-libs/xulrunner-1.9.1_beta1-r1
www-client/mozilla-firefox-3.1_beta1
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Tue Oct 21, 2008 7:05 pm    Post subject: Reply with quote

alex.blackbit wrote:
is it additionally possible to output the slot in which the upgrade will take place?

Now I understand what you are planning to do: You want to use eix as a substitute of
Code:
emerge -NDu --with-bdeps y @world @system
I must tell you that almost surely you are doing something wrong in the administration of your system if you want this: The correct way is fix your world file and to use emerge --depclean to get rid of packages which have no dependencies (and which you do not want since they are not in your world file). New eix will probably contain anyway some such formats, since you are not the first one who asked for such a feature. However, once more: A script based on eix is not an appropriate substitute for the above emerge command.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2396

PostPosted: Wed Oct 22, 2008 7:45 am    Post subject: Reply with quote

martin, you already said that once in the past, but i do not really get the reason for that.
please describe your thoughts, here are mine.
eix (with the UPGRADE_TO_HIGHEST_SLOT=false option) says which packages are available in a higher (or better) version within that slot.
how can a situation evolve in that i have unneeded packages on my system by following the suggestions of the output of this eix command?
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4238

PostPosted: Wed Oct 22, 2008 4:20 pm    Post subject: Reply with quote

alex.blackbit wrote:
how can a situation evolve in that i have unneeded packages on my system by following the suggestions of the output of this eix command?

Suppose that package A needs library B (and assume for simplicity that nothing else on your system uses B).
Now if you upgrade A it might happen that the new version does not need B anymore, i.e. B is actually not needed by anything in your system (the same may also happen if you change useflags of A or unmerge A, or it may even happen if the previous dependency on B was a bug and was removed without revbump).
The right thing to do after the upgrade of A would be to remove B from your system. Upgrading B is completely useless since it is not needed on your system. Moreover, it is not only a waste of compile time: Keeping B on your system might even be an unneeded loss of security (if e.g. B contains an SUID program, your system is vulnerable to any possible exploit of B).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3 ... 15, 16, 17, 18, 19  Next
Page 16 of 19

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum