Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Memory leak ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
Toady
Apprentice
Apprentice


Joined: 21 Dec 2004
Posts: 161
Location: South Wales, UK

PostPosted: Sun Jan 09, 2005 2:23 pm    Post subject: Memory leak ? Reply with quote

My ultra 10 seems to have some sort of memory leak.

If I reboot the machine its using maybe 40Mb of RAM (looking at the value without buffers or cache) After a couple of day this goes to 180Mb !!

I use Squirrel mail with Courier IMAP, this with Apache2 does seem to use a stack of RAM BUT stopping / starting all of the above does not give me the memory back.

The machine has 512Mb of RAM and the same for swap, it never seems to break into the swap tho but just seems to consume ALL of the available RAM...

Any ideas ?

Kernel as below, 2004.3 Stage 3 build and updated and recompiled as required monthly.
_________________
Toady

Gentoo Laptop
3.1.10-gentoo-r1, Intel Core 2 Duo (32bit)
Gnome on the desk, Intel in the box, on-board everything, but it all works!
Back to top
View user's profile Send private message
nephros
Advocate
Advocate


Joined: 07 Feb 2003
Posts: 2135
Location: Graz, Austria (Europe - no kangaroos.)

PostPosted: Mon Jan 10, 2005 1:58 am    Post subject: Reply with quote

Are you sure you are not making this mis-assumption?
http://forums.gentoo.org/viewtopic.php?t=175419

In other words is anything bad happening, are you actually running out of memory?
_________________
Please put [SOLVED] in your topic if you are a moron.
Back to top
View user's profile Send private message
Toady
Apprentice
Apprentice


Joined: 21 Dec 2004
Posts: 161
Location: South Wales, UK

PostPosted: Mon Jan 10, 2005 9:54 am    Post subject: Reply with quote

OK I am officially thick..

Maybe its just that I am used to running much leaner machines than this one and with usually a lot less ram..

Scuse my stupidity :roll:
_________________
Toady

Gentoo Laptop
3.1.10-gentoo-r1, Intel Core 2 Duo (32bit)
Gnome on the desk, Intel in the box, on-board everything, but it all works!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum