Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IG4: Raccolta errori grub
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Wed Sep 22, 2004 10:32 pm    Post subject: IG4: Raccolta errori grub Reply with quote

Navigazione: [ back IG3: Dove posso trovare piu' informazioni su GRUB? ] [ next IG5: La partizione di /boot è necessaria? ] [ Installare Gentoo ] [ Indice ]

Raccolta errori grub

Visto che molti problemi nell'installazione sorgono al primo avvio con errori di grub eccovi la collezione degli errori piu' frequenti di grub.


Code:
# fdisk -l

vi dira' quante sono le partizioni e che numero hanno. Vi avverto che grub inizia a contare da 0. Quindi /dev/hda1 sara' (hd0,0), /dev/hda2 (hd0,1), hdb1 (hd1,0),...

  • Grub loading, please wait...
    Quando riavviate avete un messaggio e grub si blocca? Ma l'avvio con il floppy di grub funziona?
    Code:
    "GRUB loading stage 1.5."
    "GRUB loading, please wait..."

    Secondo the_bell dovreste cambiare l'ordine di avvio delle periferice dal vostro bios. Cambiate la priorita' di boot affinche' non sia quella del floppy la prima.

    penetrode scrive che puo' essere anche dovuto a delle CFLAGS settate male. Anche se l'ebuild di grub filtra la flag -fstack-protector che puo' causare problemi, ricompila grub con
    Code:
    CFALGS="" emerge grub
    se non e' stato di aiuto niente altro.


  • Grub error 12
    info grub wrote:
    12 : Invalid device requested This error is returned if a device string is recognizable but does not fall under the other device errors.
    Did you execute those two lines in the grub prompt?
    Avete eseguito queste duel linee nel prompt di grub?
    Code:
    grub> root (hd0,0) (La tua partizione di boot)
    grub> setup (hd0)

    o qualunque adatto adatto alla vostra installazione?
    verifica in questo thread



  • Grub error 15
    Dopo avere premuto return nel menu di grub ottenete qualche cosa di simile a questo?
    Code:
    Booting 'gentoo Linux'

    root (hd0,0)
    Filesystem type is ext2fs, partition type 0x83
    kernel (hd0,0)/boot/kernel-2.4.20 root=/dev/hda3 vga=792

    Error 15: File not found
    Press any key to continue...

    info grub wrote:
    15 : File not found
    This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.

    Se e' il kernel che manda (bzImage, kernel...): assicurati che il file sia presente nella tua partizione di boot.

    Per scoprire che nome ha esattamente il vostro kernel, prima avviate con il live-cd o con un'installazione linux gia' esistente. A questo punto montate la partizione di /boot se e' separata se no montate /. Poi si lancino questi comandi
    Code:
    cd /boot
    ls

    Questo elenchera' tutti i kernel (e altri file) che avete nella vostra partizione di boot.

    Tuttavia se questo errore lo avete mentre provate ad installare grub, ed e' simile a questo:
    Code:
    grub> root (hd0,0)
     Filesystem type is xfs, partition type 0x83

    grub> setup (hd0)
     Checking if "/boot/grub/stage1" exists... no
     Checking if "/grub/stage1" exists... no

    Error 15: File not found

    Prima di tutto assicurarsi che avete cambiato root (hd0,0) e setup (hd0) secondo le impostazioni del vostro sistema.

    Se avete fatto tutto nel modo corretto guardate questo. Sembra che una versione dell'ebuild di grub abbia un bug (0.93.20031222). La migliore soluzione e' quella di provare una versione diversa di grub. Una possibilita' per mascherare la versione che da problemi e':
    Code:
    echo "=sys-boot/grub-0.93.20031222" >> /etc/portage/package.mask
    emerge grub -p

    (NdT: questa versione di grub non e' piu' in portage ho riportato lo stesso l'errore perche' e' possibile incontrare ancore ebuild con bug)
    O altrimenti fai un tentativo con questa riga fornita da dirtboy
    Code:
    grub-install /dev/bootdevice



  • Grub error 17

    info grub wrote:
    17 : Cannot mount selected partition
    This error is returned if the partition requested exists, but the filesystem type cannot be recognized by GRUB.

    Assicurarsi che root(x,y) sia settato nel modo corretto nel vostro grub.conf
  • "GRUB GRUB GRUB GRUB..."
    Secondo airhead questo puo' essere causato se avete nel bios il riconoscimento dei dischi in automatico. Provate a mettere "User Type HDD" nel BIOS.

  • Uncompressing Linux... Ok, booting the kernel.
    Una soluzione possibile e' che ACPI non funziona nel modo corretto. Provate a disabilitare ACPI nel BIOS o nel kernel.


  • Dov'e' il mio grub.conf?
    Provate a dare i comandi:
    Code:
    mount /dev/hda1 /boot
    nano -w /boot/grub/grub.conf

    Questi comandi implicano che avete una partizione di boot separata e che sia la /dev/hda1, se no cambiate di conseguenza il primo comando.


  • Dopo avere premuto enter nel menu di grub il sistema si riavvia
    Provate a disabilitare il framebuffer nel vostro kernel.
    Se questo non aiuto disabilitate APM/APCI/ACP. (vedere questo post)


  • Dopo l'aggiornamento di grub ottenete solo il prompt di grub?
    Assicurarsi che il link a menu.lst esista
    Code:
    cd /boot/grub
    ln -s grub.conf menu.lst

    e eseguite
    Code:
    root (hd0,0)
    setup (hd0)

    in grub.
    Bug


  • Dopo l'aggiornamento di grub l'immagine di grub e' sparita?
    Prima di tutto controllate che il file a cui vi riferite esista realmente.
    Se e' questo il caso controllate l'ebuild di grub. Forse la linea che appluca la patch per la splashimage e' commentata nella versione che usate.


  • Cannnot open root device "hdaX"
    Avete ottenuto qualcosa come questo errore?
    Code:
    VFS: Cannot open root device "hda7" or 03:07
    Please append a correct "root=" boot option
    Kernel Panic: VFS: Unable to mount root fs on 03:07

    Assicurarsi che il vostro grub.conf abbia due volte la stessa voce (hd0, X) come
    Code:
    root(hd0,1)
    kernel (hd0,1)...

    nephros mi ha detto alcune cause possibili per questo problema:
    nephros wrote:
    Dalla mia esperienza, questo e' causato nel 80% delle volte da un kernel configurato male, di solito sono:
    [+]IDE chipset (o SCSI controller) support non compilato o compilato come modulo (e senza initrd).
    [+]filesystem support usato sulla partizione di root non compilato o come modulo (e senza initrd).
    [+]supporto per MSDOS partition tables non compilato (CONFIG_PARTITION_ADVANCED -> CONFIG_MSDOS_PARTITION)

    Nelle installazioni appena fatte e' causato spesso dal non avere editato /etc/fstab durante la fase di installazione e ancora contiene le linee "/dev/ROOT / ext2 defaults,noatime 0 0".

    Soluzione per entrambi i casi: avviare il sistema con LiveCD e modificare fstab o modificare la configurazione del kernel.


  • can not find [insert any filesystem] on ide0(3,5)
    Quando avvii il sistema avete questo errore?
    Code:
    sh-2021: reiserfs_read_super: can not find reiserfs on ide0(3,5)
    XFS: bad magic number
    XFS: SB validate failed
    Kernel Panic: VFS: Unable to mount root fs on 03:05

    Assicurarsi di avere messo la partizione di root giusta nel grub.conf.
    Leggi questo thread.


  • Avete usato genkernel ma non ricordate la versione del kernel?
    avviare il sistema con il liveCD.
    montare la partizione di boot.
    eseguire
    Code:
    cd /boot

    ls

    Questo elenchera' vari file che possono essere trovati sulle tue partizioni di boot. Uno dovrebbe iniziare con kernel-, un altro con initrd-. Il numero/testo davanti e' la versione del tuo kernel. Ora segui le istruzioni del manuale e cambia la versione del kernel d'esempio (campione) con quella installata da te.


  • Vedete soltanto la voce Windows nel menu di grub
    Leggete questo thread, ancora non sono giunti a una conclusione.


  • Non avvia il sistema in Windows
    Quando provate ad avviare un'altro OS, avete un errore di questo genere?
    Code:
    Booting 'Win2k'
    root (hd1,0)
    Filesystem type unknown, partition type 0x7
    chainloader +1

    Assicuratevi che la vostra voce di boot assomigli a quella che segue:
    Code:
    title=%$@@#$*
    root (hd0,0)
    chainloader (hd0,0)+1

    o
    Code:
    title=%$@@#$*
    rootnoverify (hd0,0)
    chainloader (hd0,0)+1

    specialmente il chainloader
    Vedere questo thread


  • Avviare Windows dal secondo harddrive
    Se incontrate problemi cosi' facendo, provate questo tip di cyrillic: cambiate la vostra voce di boot per Windows come quella che segue:
    Code:
    title Win2k
    map (hd0) (hd1)
    map (hd1) (hd0)
    chainloader (hd1,0)+1



Autore: idoneus (testo originale)
Traduttore: fedeliallalinea
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4533
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 04, 2005 5:50 am    Post subject: Reply with quote

Sto installando gentoo su una nuova macchina.
Come bootloader, sono attualmente costretto ad usare lilo.
Ogni tentativo di sistemare grub, infatti, si è stampato su un fantomatico errore 18.

Il manuale di grub recita:
Quote:
18 : Selected cylinder exceeds maximum supported by BIOS
This error is returned when a read is attempted at a linear block address beyond the end of the BIOS translated area. This generally happens if your disk is larger than the BIOS can handle (512MB for (E)IDE disks on older machines or larger than 8GB in general).

Va bene... ma adesso che faccio? :?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Mon Jul 04, 2005 8:52 am    Post subject: Reply with quote

metti la partizione di boot su un cilindro minore... del tipo la metti come prima partizione dell'hd e non ci pensi più...
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4533
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 04, 2005 11:40 am    Post subject: Reply with quote

Cazzantonio wrote:
metti la partizione di boot su un cilindro minore... del tipo la metti come prima partizione dell'hd e non ci pensi più...

In effetti, montando la mia root (che è anche partizione di boot) su hda3 funge. Evidentemente, sia colpa di grub o della bios, può leggere solo una parte dell'hd.
Rifiuta però di caricare l'initrd per lo splash, lagnando che gli intasa la memoria - che piaga.

Quando a non pensarci più... dovrò riorganizzare tutto l'assetto dell'hd, con una partizione di boot dedicata. uffa.

Grazie per la dritta.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum