Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP][EBUILD] Ed infine eccola msn e webcam per linux
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Feb 28, 2005 7:50 pm    Post subject: Reply with quote

si ma come vedi non è che siano "enormi" sono + che altro plugin o microutility
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Mon Feb 28, 2005 7:55 pm    Post subject: Reply with quote

Si discuteva di tutte quelle dipendenze nel bug relativo a Mercury: son necessarie per la policy di Gentoo riguardo ai file Jar. In pratica la policy richiede che ci sia un solo file Jar contenente una determinata libreria, non che ogni programma che usa quella libreria abbia la sua copia locale. Mercury utilizza una serie di librerie locali che in realtà son contenute in quelle dipendenze: quindi l'ebuild le emerge come dipendenze, e, in src_unpack, cancella le copie locali.

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Mon Feb 28, 2005 8:45 pm    Post subject: Reply with quote

nn posso emergerlo perchè mi da un errore con dev-java/commons-net che da quanto ho capito è dovuto al fatto che ho installato java 1.5.... di tornare indietro nn se ne parla, vedo se trovo la soluzione, magari domani ora sono stanco ^__^
_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Tue Mar 01, 2005 3:55 pm    Post subject: Reply with quote

sapete dirmi a cosa può essere dovuto questo errore con xalan??
Code:
>>> emerge (1 of 7) dev-java/xalan-2.6.0 to /
>>> md5 src_uri ;-) xalan-j_2_6_0-src.tar.gz
>>> Unpacking source...
>>> Unpacking xalan-j_2_6_0-src.tar.gz to /var/tmp/portage/xalan-2.6.0/work
tar: A lone zero block at 36857
>>> Source unpacked.
Buildfile: build.xml

prepare:
     [echo] Project:Xalan-Java version:2_6_0 build.xml $Revision: 1.206 $
    [mkdir] Created dir: /var/tmp/portage/xalan-2.6.0/work/xalan-j_2_6_0/build
    [mkdir] Created dir: /var/tmp/portage/xalan-2.6.0/work/xalan-j_2_6_0/build/classes

xml.compile:
     [echo] Compiling DTM implementation and utilities
    [javac] Compiling 186 source files to /var/tmp/portage/xalan-2.6.0/work/xalan-j_2_6_0/build/classes
    [javac] javac: target release 1.1 conflicts with default source release 1.5

BUILD FAILED
/var/tmp/portage/xalan-2.6.0/work/xalan-j_2_6_0/build.xml:256: Compile failed; see the compiler error output for details.

Total time: 1 second

!!! ERROR: dev-java/xalan-2.6.0 failed.
!!! Function src_compile, Line 33, Exitcode 1
!!! build failed

_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
G2k
l33t
l33t


Joined: 06 Mar 2004
Posts: 672
Location: Rome, Italy

PostPosted: Tue Mar 01, 2005 6:39 pm    Post subject: Reply with quote

mamma mia non sapete quanto mi piacerebbe poter programmare bene...:cry: cmqe sono felice che altri possano fare quello che mi serviva da tempo! peccato solo che faccio da spettatore
_________________
Animula vagula blandula,
Hospes comesque corporis,
Quae nunc abibis in loca
Pallidula rigida nudula,
Nec ut soles dabis iocos...
- Imp. Caesar Hadrianus
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Tue Mar 01, 2005 9:16 pm    Post subject: Reply with quote

io volevo almeno provarlo, nn posso fare neanche da spettatore :\
_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Wed Mar 02, 2005 12:12 pm    Post subject: Reply with quote

sono nelle stesse condizioni di raffo, ho compilato xalan usando blackdawn jdk ma ora mercury non parte... sto ebuild ha ancora bisogno di una bella revisione mi sa :wink:

[sfog-ot] ma perche' tutte le lvolte che c'entra java si impazzisce? Sono sfortunato io o e' un problema interinseco di tutte le sue miliardi di librerie?
/me che odia java
[/sfogo-ot]

direi che torno ad amsn
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Wed Mar 02, 2005 1:47 pm    Post subject: Reply with quote

Sì, secondo me è Java :lol: ...
a me francamente non piace affatto come linguaggio (anche se ho cominciato a programmare proprio da lì), ma certo ha qualche potenzialità. Il difetto maggiore secondo me è che è leeeento.

Comunque se riuscite a farlo partire provatelo perché è eccezionale. Soprattutto l'ultima release, la 1709.B7, con il supporto VERO alla webcam (in ricezione).

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
iridium103
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2004
Posts: 104
Location: Treviso

PostPosted: Wed Mar 02, 2005 1:58 pm    Post subject: Reply with quote

flocchini wrote:
[..]
[sfog-ot] ma perche' tutte le lvolte che c'entra java si impazzisce? Sono sfortunato io o e' un problema interinseco di tutte le sue miliardi di librerie?
/me che odia java
[/sfogo-ot]
[..]

no, è java che è frustrante :evil: :evil: :evil: :evil: , anche a me crea un bordello di problemi..
_________________
Imagination is more important than knowledge.
Albert Einstein
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Wed Mar 02, 2005 2:41 pm    Post subject: Reply with quote

sono riuscito a farlo andare... premetto che avevo java 1.5

1- compilo il compilabile con 1.5
2- switcho (con java-config -S) al vecchio 1.4 per compilare xalan
3- ri-switcho alla 1.5 e compilo il resto
4- tri-switcho alla 1.4 e facio partire mercury (altrimenti non trova una libawt, anche se ho provveduto a linkarla dove la richiede e persino a copiarla... nada)

e funge, anche se con caratteri un po' schifosi

Non ho capito se dipende dai miei 27000 pacchetti java installati o dai casini interinsechi che si porta dietro il linguaggio. Resta un peccato perche' il client secondo me ha delle ottime potenzialita'

Cmq sono contento di non essere solo nel mio odio :wink:
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Wed Mar 02, 2005 4:10 pm    Post subject: Reply with quote

l'odio è potente in me..... nn voglio ritornare alla 1.4 e nn capisco perchè nn debba andare con l'1.5...
_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
[hammerfall]
Apprentice
Apprentice


Joined: 27 May 2004
Posts: 243

PostPosted: Thu Mar 03, 2005 10:46 am    Post subject: Reply with quote

uhm io ho un problema un po' strano: smascherata l'ebuild la installo senza problemi (gran parte delle dipendenze le avevo gia' installate) lancio il programma da utente normale e vedo crearsi l'icona nel tray e aprirsi prima un popup (avviso dell'autore riguardante alcune modifiche) e poi comparire lo splash col logo del programma. a questo punto non va piu' avanti col caricamento dell'applicazione: non occupa risorse e non dice nulla in console. qualcuno sa come far generare un qualche log? Mi viene il dubbio che l'utente normale non abbia i privilegi per qualche compito richiesto da mercury, purtroppo da root non riesco a farlo partire perche' non ho nel path java :P a qualcuno capita la stessa cosa?
_________________
--------

Hammerfall ^_^
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Thu Mar 03, 2005 5:28 pm    Post subject: Reply with quote

ok, sono riuscito ad emergere xalan modificando l'ebuild, facendogli applicare una patch. se a qualcuno interessa posso postare il procedimento seguito.
ora però ho un problema con dev-java/commons-net che mi da questo errore:
Code:
 [javac] ^
    [javac] /var/tmp/portage/commons-net-1.2.2/work/commons-net-1.2.2/src/java/org/apache/commons/net/smtp/SMTP.java:440: as of release 1.5, 'enum' is a 
keyword, and may not be used as an identifier
    [javac] (try -source 1.4 or lower to use 'enum' as an identifier)
    [javac]         Enumeration enum;
    [javac]                     ^
    [javac] /var/tmp/portage/commons-net-1.2.2/work/commons-net-1.2.2/src/java/org/apache/commons/net/smtp/SMTP.java:447: enum types must not be local
    [javac]         enum = _replyLines.elements();
    [javac]         ^
    [javac] /var/tmp/portage/commons-net-1.2.2/work/commons-net-1.2.2/src/java/org/apache/commons/net/smtp/SMTP.java:447: <identifier> expected
    [javac]         enum = _replyLines.elements();
    [javac]              ^
    [javac] /var/tmp/portage/commons-net-1.2.2/work/commons-net-1.2.2/src/java/org/apache/commons/net/smtp/SMTP.java:447: '{' expected
    [javac]         enum = _replyLines.elements();
    [javac]                                      ^
    [javac] 100 errors

BUILD FAILED
/var/tmp/portage/commons-net-1.2.2/work/commons-net-1.2.2/build.xml:56: Compile failed; see the compiler error output for details.

Total time: 2 seconds

!!! ERROR: dev-java/commons-net-1.2.2 failed.
!!! Function src_compile, Line 32, Exitcode 1

sul forum ho trovato questo topic http://forums.gentoo.org/viewtopic-t-251170-highlight-commonsnet.html che consiglia di fare --oneshot... nn mi sembra una grande idea ma dicono che funziona... cosa mi consigliate?? ci provo??
_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
Raffo
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1019
Location: Anzio (RM)

PostPosted: Thu Mar 03, 2005 6:24 pm    Post subject: Reply with quote

ha funzionato, sto usando mercury... gradevole devo dire... meglio della versione da me precedentemente provata...
_________________
www.forumeye.it il 1° forum italiano di videogiochi
Back to top
View user's profile Send private message
ProT-0-TypE
Veteran
Veteran


Joined: 20 Dec 2003
Posts: 1624
Location: Cagliari

PostPosted: Sat Mar 19, 2005 12:31 pm    Post subject: Reply with quote

installato correttamente ma non parte:
Code:
$ mercury
Could not find package mercury
Exception in thread "main" java.lang.NoClassDefFoundError: com/dMSN/Main

_________________
[Vuoi guadagnare navigando?]
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sat Mar 19, 2005 1:27 pm    Post subject: Reply with quote

@ProT-0-TypE:

Installato manualmente o con emerge?

PS:

Provate la 1709_rc1 che è simpatica :P :D

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
ProT-0-TypE
Veteran
Veteran


Joined: 20 Dec 2003
Posts: 1624
Location: Cagliari

PostPosted: Sat Mar 19, 2005 3:30 pm    Post subject: Reply with quote

con emerge. La versione consigliata da te!
_________________
[Vuoi guadagnare navigando?]
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sat Mar 19, 2005 9:37 pm    Post subject: Reply with quote

Uhm... azz allora non so che dirti... a me va a meraviglia... e di errori Java non ne so niente e non ne voglio sapere niente :D ...

Googlato un po'? Forse trovi qualcosa nel forum... oppure chiedi lì...

Ciao
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
ProT-0-TypE
Veteran
Veteran


Joined: 20 Dec 2003
Posts: 1624
Location: Cagliari

PostPosted: Sun Mar 20, 2005 2:52 am    Post subject: Reply with quote

si ho googlato e ho cercato nel forum di mercury ma nulla. Che virtual machine hai? quella della Sun?
_________________
[Vuoi guadagnare navigando?]
Back to top
View user's profile Send private message
FMulder
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2004
Posts: 83
Location: Cagliari, Italy

PostPosted: Tue May 31, 2005 3:07 am    Post subject: Reply with quote

Ho sistemato il vecchio ebuild per l'utilizzo con l'ultima versione di questo client, la 1709 RC8.. dovrebbe essere l'ultima release candidate prima della 1709 final.

Questo è il link del bugzilla:
http://bugs.gentoo.org/show_bug.cgi?id=77141

Ricordo che mercury dalla 1709_rc7 supporta la piena ricezione e trasmissione di webcam e videoconferenza.

Con questo ebuild ho aggiunto due flag:

1- flag "cam", con cui potete abilitare il supporto per la TRASMISSIONE della webcam, e per la conversione degli stream della webcam in file quicktime. Ricordo che la ricezione avviene anche senza questa flag abilitata. Avete bisogno di scaricare alcuni file da mettere in /usr/portage/distfiles.. facendo un emerge avrete tutte le informazioni che cercate.

2- flag "flash", con cui potete ricevere e visualizzare correttamente i Winks animati. Senza questa flag non avrete alcuna segnalazione che avete ricevuto un wink. Preferisco mettere una flag perché nella versione originale dell'ebuild veniva rimosso un file relativo ai file flash, perché a quanto pare l'autore di Mercury ha usato una libreria trial o qualcosa del genere, per cui tra vedere e non vedere preferisco dare la possibilità di scelta... comunque nell'ebuild è spiegato.

Per installare mercury, dovete innanzitutto scaricare l'ebuild aggiornato (mercury-bin-1709_rc8.ebuild), e i due file "icon32.gif" e "mercury.sh Startup Script".

Andate nella cartella in cui avete scaricato i file, poi (supponendo che le cartelle indicate esistano, che altrimenti vanno create, e supponendo che il vostro make.conf indichi la cartella /usr/local/portage come portage overlay ecc)

Code:

cp mercury-bin-1709_rc8.ebuild /usr/local/portage/net-im/mercury-bin
cp icon32.gif mercury.sh /usr/local/portage/net-im/mercury-bin/files
ebuild /usr/local/portage/net-im/mercury-bin/mercury-bin-1709_rc8.ebuild digest


l'ebuild è hard masked per cui dovete dare
Code:

echo "=net-im/mercury-bin-1709_rc8" >> /etc/portage/package.unmask


dopodiché, se volete installare tutto, date
Code:

USE="cam flash" emerge mercury-bin

altrimenti se volete eliminare una delle due componenti extra, togliete la flag in questione dal USE.

Fatemi sapere se lo provate e se è tutto ok ;-)

EDIT: Scusate, avevo dimenticato il "digest" alla fine del comando di ebuild... cercate di capirmi, erano le 5 del mattino quando ho scritto il post :lol: :lol:
_________________
Chi rinuncia ai sogni, è destinato a morire
--> Jim Morrison


Last edited by FMulder on Wed Jun 01, 2005 12:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
elBivio
n00b
n00b


Joined: 22 May 2005
Posts: 13

PostPosted: Wed Jun 01, 2005 11:39 am    Post subject: Reply with quote

FMulder wrote:
Fatemi sapere se lo provate e se è tutto ok ;-)


Ti ringrazio per l'ebuild di Mercury, ma ho qualche problema dovuto alla mia niubbaggine, l'emerge finale dice che non trova il file Manifest

l'unico altro errore che ho precedentemente è

Code:

# ebuild /usr/local/portage/net-im/mercury-bin/mercury-bin-1709_rc8.ebuild
expecting two arguments.


grazie
elBivio
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Wed Jun 01, 2005 11:57 am    Post subject: Reply with quote

Code:
ebuild /usr/local/portage/net-im/mercury-bin/mercury-bin-1709_rc8.ebuild
expecting two arguments.


mettici un "digest" in fondo

Code:
ebuild /usr/local/portage/net-im/mercury-bin/mercury-bin-1709_rc8.ebuild digest

cosi' crea il manifest che chiede dopo :wink:
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
elBivio
n00b
n00b


Joined: 22 May 2005
Posts: 13

PostPosted: Wed Jun 01, 2005 12:45 pm    Post subject: Reply with quote

funziona a meraviglia!! grazie a fmoulder e fiocchini!

mi permetto di dare un consiglio a quelli piu niubbi di me, prima di installare questa ebuild, installate la precedente :roll:
non so se era scontato...

elBivio
Back to top
View user's profile Send private message
FMulder
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2004
Posts: 83
Location: Cagliari, Italy

PostPosted: Wed Jun 01, 2005 12:54 pm    Post subject: Reply with quote

elBivio wrote:
funziona a meraviglia!! grazie a fmoulder e fiocchini!

mi permetto di dare un consiglio a quelli piu niubbi di me, prima di installare questa ebuild, installate la precedente :roll:
non so se era scontato...

elBivio


Figurati :)

Più che altro... perché vuoi installare la precedente? :roll:
_________________
Chi rinuncia ai sogni, è destinato a morire
--> Jim Morrison
Back to top
View user's profile Send private message
elBivio
n00b
n00b


Joined: 22 May 2005
Posts: 13

PostPosted: Wed Jun 01, 2005 1:13 pm    Post subject: Reply with quote

FMulder wrote:

Più che altro... perché vuoi installare la precedente? :roll:


perchè senza non partiva mercury, l'installazione andava a buon fine ma poi lanciando mercury mi dava un'errore e diceva di andare a vedere nel log, ma ancora non aveva creato la cartella {HOME_DIR}/Mercury e quindi nemmeno il log,
così ho tolto tutto, reinstallato la rc_1 e upgratato con il tuo ebuild e tutto è andato a posto.

mi son fatto sto viaggio perchè ho pensato che il 1709_RC8.zip fosse solo un'aggiornamento e non l'intero prg, ma mica son sicuro di quello che dico :lol:

elBivio
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum