Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[What to do?] XFree86 will be obsoleted...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
Boris27
Guru
Guru


Joined: 05 Nov 2003
Posts: 562
Location: Almelo, The Netherlands

PostPosted: Fri Dec 31, 2004 1:04 pm    Post subject: [What to do?] XFree86 will be obsoleted... Reply with quote

http://www.gentoo.org/news/en/gwn/20041229-newsletter.xml#doc_chap2_sect6

Great. I still use Xfree. Not because I like it, but because it is the only thing that works with my radeon 9800 and fglrx.

Xorg 6.7.0 and fglrx has 3d acceleration, but a borked XV (i like to watch movies, thank you).
Xorg 6.8.0 is a no-go with fglrx.

I don't really care about 3d acceleration. I do care about XV and 2d acceleration. The fglrx driver is a leap ahead in terms of 2d speed, so the radeon driver is out. This excludes 6.8.0
XV excludes 6.7.0
So my only choice is Xfree. Or have I missed something?
_________________
we are microsoft, lower your firewalls and surrender your pc's. we will add your biological and technological distinctiveness to our own. your culture will adapt and service us. resistance is futile.
Back to top
View user's profile Send private message
Athas
Guru
Guru


Joined: 04 Sep 2003
Posts: 394
Location: Brøndby, Denmark

PostPosted: Fri Dec 31, 2004 1:06 pm    Post subject: Reply with quote

So? Sign up as maintainer, and make sure XFree86 stays buildable. :)
_________________
Emacs-optimized danish console keymap - My .emacs
Climacs - next generation Emacs.
Back to top
View user's profile Send private message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Fri Dec 31, 2004 1:15 pm    Post subject: Reply with quote

Heh, ATi is screwing you over good...

Also, doesn't the r200 driver have acceptable 2d performance for r300 cards? And how did you wind up with a R9800Pro if you only care about 2D?
Back to top
View user's profile Send private message
Swoosh
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 203

PostPosted: Fri Dec 31, 2004 1:19 pm    Post subject: Reply with quote

Xorg 6.8 compatible ATI drivers are coming out in January
Back to top
View user's profile Send private message
Boris27
Guru
Guru


Joined: 05 Nov 2003
Posts: 562
Location: Almelo, The Netherlands

PostPosted: Fri Dec 31, 2004 1:27 pm    Post subject: Reply with quote

racoontje wrote:
Heh, ATi is screwing you over good...

Also, doesn't the r200 driver have acceptable 2d performance for r300 cards? And how did you wind up with a R9800Pro if you only care about 2D?


I play my games in Windows. Thats why I have a 9800Pro. At the time (may 2004) I could get this card new with a 50% discount, making it cost me only 115 euros. For 115 euro I would have gotten a nVidia offering with much much lower performance.

Athas: There is no need for a maintainer. The current ebuild works, and can just stay in portage, IMO. Just put a warning in that the xfree ebuild is only there for people who desperately need it, and that it is not actively maintained. Also state that Gentoo strongly encourages you to use X.Org

Swoosh: Thats good news.
_________________
we are microsoft, lower your firewalls and surrender your pc's. we will add your biological and technological distinctiveness to our own. your culture will adapt and service us. resistance is futile.
Back to top
View user's profile Send private message
Swoosh
Apprentice
Apprentice


Joined: 19 Sep 2004
Posts: 203

PostPosted: Fri Dec 31, 2004 7:48 pm    Post subject: Reply with quote

Yep, it is good news.

But they were supposed to be released earlier this month. :(
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16102
Location: Colorado

PostPosted: Fri Dec 31, 2004 11:23 pm    Post subject: Reply with quote

Boris27 wrote:
The current ebuild works, and can just stay in portage, IMO. Just put a warning in that the xfree ebuild is only there for people who desperately need it, and that it is not actively maintained.
If it isn't being maintained, just put it in OVERLAY.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
Lokheed
Veteran
Veteran


Joined: 12 Jul 2004
Posts: 1295
Location: /usr/src/linux

PostPosted: Fri Dec 31, 2004 11:31 pm    Post subject: Reply with quote

Gotta upgrade sometime. Whats the point in wasting resources maintaining obselete packages. Dump them and move on...eventually things will get supported: growing pains we call them. No sense in whining about it. There is a slew of things I would like to be done in Linux but cant...I just bide my time and keep my ears and eyes open, eventually it will all be capable.

I find I have managed to work around a lot of the shortcomings of Linux...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum