Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can osx 10.2x be used for Gentoo on OSX?
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
cayenne
l33t
l33t


Joined: 17 Oct 2002
Posts: 886
Location: New Orleans

PostPosted: Wed Dec 29, 2004 4:23 pm    Post subject: Can osx 10.2x be used for Gentoo on OSX? Reply with quote

I've run into a bit of a conflict looking at the requirements.

On the Gentoo on OSX install doc, it lists:
Quote:
In order to install Gentoo for Mac OS X, you must have the following software already installed:

* Mac OS 10.2 or later
* XCode Tools 1.2 or later


However on the Apple developers site, for Xcode, it says it requires OSX 10.3 or higher.

What experience have ya'll found on this? I'd rather not buy 10.3 right now, as that Tiger is going to be out soon...and would want to wait to buy that upgrade. Besides, this is a G3 iBook I'm talking about...so, probably not going to go that much higher on OSX versions than Tiger...

Anyway, can someone help me out here...can I get started with 10.2 and use these tools?

TIA,

cayenne
_________________
Light travels faster than sound. This is why some people appear bright until you hear them speak.........
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Dec 30, 2004 11:17 am    Post subject: Reply with quote

You should be able to use portage, but it will require some work. I've heard that there are some python problems, but beyond that, I can't help you much. Give it a try and let us know how it goes.
Back to top
View user's profile Send private message
Danathan
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2004
Posts: 120

PostPosted: Thu Dec 30, 2004 5:14 pm    Post subject: Reply with quote

I'm currently syncing using 10.2 with the latest developer tools update that was available for 10.2. The first problem that I've encountered is that the version of python that Apple supplies is 2.2.

"True" and "False" weren't introduced until 2.2.1, though, and they're required for emerge to work properly.

I got around this by changing the shebang in /usr/bin/emerge from /usr/bin/python to /sw/bin/python, as I'm moving from fink. I'll let you know how the rest of it goes.
Back to top
View user's profile Send private message
Danathan
Tux's lil' helper
Tux's lil' helper


Joined: 08 Mar 2004
Posts: 120

PostPosted: Thu Dec 30, 2004 5:55 pm    Post subject: Reply with quote

...now debianutils won't install b/c it needs getopt.h, which does not seem to be present. any ideas?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum