Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome: Unable to resolve hostname
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tincan
Guest





PostPosted: Wed Apr 17, 2002 10:24 pm    Post subject: Gnome: Unable to resolve hostname Reply with quote

I've been trying to figure this one out for a couple of days now. When ever I log into gnome I keep getting this error, I've tried adding my hostname to 127.0.0.1 in the /etc/hosts file but no change. I'm running an Athlon XP with a G3 Ti200. Any ideas???
Back to top
fghellar
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 856
Location: Porto Alegre, BR

PostPosted: Wed Apr 17, 2002 11:40 pm    Post subject: Reply with quote

I also had this problem once, but adding this
Code:
127.0.0.1 my.machine.com
to /etc/hosts solved it for me. Notice that my.machine.com is actually what's in /etc/hostname.
_________________
| www.gentoo.org | www.tldp.org | www.google.com |
Back to top
View user's profile Send private message
Guest






PostPosted: Thu Apr 18, 2002 8:13 am    Post subject: Reply with quote

Better is

127.0.0.1 localhost
192.168.*.* my.machine.com my


where 192.168.*.* is your machines ip adres my.machine.com is what is in your /etc/hostname my speaks for itself
Back to top
tincan
Guest





PostPosted: Thu Apr 18, 2002 9:43 pm    Post subject: Reply with quote

I have already tried these.

I had this in /etc/hosts

127.0.0.1 my.client.com

and I also had this in /etc/hosts

127.0.0.1 localhost
192.168.1.1 my.client.com my

but none of these have resolved the issue! Still getting hostname not found on login.
Any other ideas??
Back to top
tincan
Guest





PostPosted: Fri Apr 19, 2002 10:25 pm    Post subject: Reply with quote

Well, I finally figured it out!!! I checked my logs and this is what I was getting.

[gdm] gdm_peek_local_address_list: Could not get address from hostname! Apr 18 23:04:17 [gdm] gdm_slave_xioerror_handler: Fatal X error - Restarting :0 Apr 18 23:04:17 [gnome-name-server] input condition is: 0x11, exiting Apr 18 23:04:22 [gdm] gdm_peek_local_address_list: Could not get address from hostname! Apr 18 23:04:23 [kernel] tty_io.c: process 2741 (X) used obsolete /dev/cua/0 - update software to use /dev/ttyS0
Apr 18 23:04:24 [kernel] tty_io.c: process 2741 (X) used obsolete /dev/cua/0 - update software to use /dev/ttyS0

So I changed my XF86config file wich had /dev/cua0 as the mouse, to to /dev/ttyS0, and bingo! Now it seems that Gnome is able to resolve my hostname, and performance has greatly increased as well. I never thought a mouse could cause such an problem. Now I can finally finish setting my client. :P
Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum