Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Denu 2.0 - GUI based menu editing.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
The New Guy
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2005
Posts: 136
Location: Behind you...

PostPosted: Tue Apr 12, 2005 11:51 am    Post subject: Reply with quote

Code:

#emerge -pev denu

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] sys-devel/patch-2.5.9-r1  -build -debug -static 0 kB
[ebuild  N    ] sys-libs/gpm-1.20.1-r4  (-selinux) 0 kB
[ebuild  N    ] sys-libs/ncurses-5.4-r6  -bootstrap -build -debug -doc +gpm -minimal -nocxx -unicode 2,103 kB
[ebuild  N    ] app-shells/bash-3.0-r9  -build -debug +nls 0 kB
[ebuild  N    ] sys-devel/binutils-config-1.8-r2  0 kB
[ebuild  N    ] sys-devel/gnuconfig-20050223  0 kB
[ebuild  N    ] sys-devel/gettext-0.14.2  -debug -emacs +nls 0 kB
[ebuild  N    ] sys-devel/binutils-2.15.92.0.2-r8  -debug -multislot -multitarget +nls -test 37 kB
[ebuild  N    ] sys-devel/m4-1.4.3  +nls 298 kB
[ebuild  N    ] sys-devel/bison-2.0  -debug +nls -static 0 kB
[ebuild  N    ] sys-apps/texinfo-4.8  -build -debug +nls -static 0 kB
[ebuild  N    ] sys-devel/gcc-config-1.3.10-r2  0 kB
[ebuild  N    ] sys-devel/gcc-3.4.3.20050110-r2  (-altivec) -bootstrap -boundschecking -build -debug +fortran -gcj +gtk -hardened (-ip28) (-multilib) -multislot (-n32) (-n64) +nls -nocxx -objc -static (-uclibc) 87 kB
[ebuild  N    ] sys-libs/libstdc++-v3-3.3.4  -debug +nls 0 kB
[ebuild  N    ] sys-kernel/linux-headers-2.4.22-r1  -build 28,836 kB
[ebuild  N    ] sys-libs/readline-5.0-r2  0 kB
[ebuild  N    ] sys-apps/sysvinit-2.86  -bootstrap -build (-selinux) 0 kB
[ebuild  N    ] sys-apps/sed-4.1.4  -bootstrap -build -debug +nls -static 0 kB
[ebuild  N    ] sys-libs/gdbm-1.8.3-r1  +berkdb -debug 0 kB
[ebuild  N    ] sys-devel/flex-2.5.4a-r6  -build -debug -static 0 kB
[ebuild  N    ] sys-devel/bc-1.06-r6  -debug +readline -static 0 kB
[ebuild  N    ] sys-apps/diffutils-2.8.7-r1  -debug +nls -static 0 kB
[ebuild  N    ] dev-libs/openssl-0.9.7e-r1  -debug -emacs (-uclibc) 0 kB
[ebuild  N    ] dev-libs/expat-1.95.8  -test 0 kB
[ebuild  N    ] dev-lang/python-2.3.5  +X +berkdb -bootstrap -build -debug -doc +gdbm +ipv6 +ncurses +readline +ssl -tcltk -ucs2 0 kB
[ebuild  N    ] dev-java/java-config-1.2.11  0 kB
[ebuild  N    ] media-libs/svgalib-1.9.19-r3  -build -debug 0 kB
[ebuild  N    ] media-libs/audiofile-0.2.6-r1  0 kB
[ebuild  N    ] sys-apps/tcp-wrappers-7.6-r8  +ipv6 115 kB
[ebuild  N    ] sys-devel/make-3.80-r1  -build -debug -hardened +nls -static (-uclibc) 899 kB
[ebuild  N    ] sys-kernel/gentoo-sources-2.4.28-r8  -build -doc -symlink 31,453 kB
[ebuild  N    ] media-sound/alsa-headers-1.0.9_rc2  1,949 kB
[ebuild  N    ] media-libs/alsa-lib-1.0.9_rc2-r1  -doc -jack 672 kB
[ebuild  N    ] media-sound/esound-0.2.34  +alsa +ipv6 +tcpd 0 kB
[ebuild  N    ] dev-lang/nasm-0.98.39  -build -doc 0 kB
[ebuild  N    ] dev-util/pkgconfig-0.15.0  -debug -hardened 0 kB
[ebuild  N    ] sys-libs/cracklib-2.8.2  0 kB
[ebuild  N    ] sys-devel/automake-1.5  0 kB
[ebuild  N    ] sys-devel/automake-1.8.5-r3  0 kB
[ebuild  N    ] sys-devel/automake-1.6.3  0 kB
[ebuild  N    ] sys-devel/automake-1.7.9-r1  0 kB
[ebuild  N    ] sys-devel/automake-1.4_p6  0 kB
[ebuild  N    ] sys-devel/automake-wrapper-1-r1  0 kB
[ebuild  N    ] sys-devel/automake-1.9.5  0 kB
[ebuild  N    ] sys-libs/pam-0.78-r2  +berkdb -debug -nis -pam_chroot -pam_console -pam_timestamp -pwdb (-selinux) 0 kB
[ebuild  N    ] sys-apps/shadow-4.0.7-r1  -debug +nls +pam (-selinux) -skey 0 kB
[ebuild  N    ] sys-apps/pam-login-3.17  -livecd +nls (-selinux) 0 kB
[ebuild  N    ] sys-fs/e2fsprogs-1.37  -debug -diet +nls -static (-uclibc) 3,425 kB
[ebuild  N    ] sys-apps/grep-2.5.1-r7  -build -debug +nls -pcre -static (-uclibc) 0 kB
[ebuild  N    ] sys-apps/gawk-3.1.4-r4  -build +nls -xml* 0 kB
[ebuild  N    ] app-crypt/hashalot-0.3  0 kB
[ebuild  N    ] sys-apps/util-linux-2.12q  +crypt -debug +nls -old-crypt +pam +perl (-selinux) -static 0 kB
[ebuild  N    ] media-libs/libpng-1.2.8  -debug 0 kB
[ebuild  N    ] media-libs/freetype-2.1.9-r1  -bindist -debug -doc +zlib 0 kB
[ebuild  N    ] sys-devel/libtool-1.5.14  0 kB
[ebuild  N    ] x11-misc/ttmkfdir-3.0.9-r2  -debug 0 kB
[ebuild  N    ] app-arch/bzip2-1.0.3  -build -debug -static 653 kB
[ebuild  N    ] x11-base/opengl-update-2.1.1-r1  0 kB
[ebuild  N    ] media-libs/fontconfig-2.2.3  0 kB
[ebuild  N    ] x11-base/xorg-x11-6.8.2-r1  -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server* -hardened -insecure-drivers +ipv6 -minimal -mmx +nls +opengl +pam -sdk -sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 0 kB
[ebuild  N    ] sys-apps/file-4.13  -build -debug +python 410 kB
[ebuild  N    ] sys-apps/which-2.16  122 kB
[ebuild  N    ] app-arch/cpio-2.6-r2  +nls 0 kB
[ebuild  N    ] app-arch/rpm2targz-9.0-r2  0 kB
[ebuild  N    ] sys-apps/utempter-0.5.5.5-r1  -debug 0 kB
[ebuild  N    ] x11-terms/xterm-200  -Xaw3d -debug -toolbar +truetype -unicode 0 kB
[ebuild  N    ] media-libs/libmad-0.15.1b  -debug 0 kB
[ebuild  N    ] dev-libs/glib-2.6.3  -debug -doc -hardened 0 kB
[ebuild  N    ] media-libs/libogg-1.1.2  0 kB
[ebuild  N    ] kde-base/kde-env-3-r3  0 kB
[ebuild  N    ] media-libs/libvorbis-1.1.0  -aotuv -debug 0 kB
[ebuild  N    ] media-libs/libid3tag-0.15.1b  -debug 0 kB
[ebuild  N    ] media-libs/jpeg-6b-r4  -debug 0 kB
[ebuild  N    ] media-libs/tiff-3.7.1-r1  0 kB
[ebuild  N    ] media-libs/lcms-1.13  +jpeg +python +tiff +zlib 0 kB
[ebuild  N    ] media-libs/libmng-1.0.8-r1  0 kB
[ebuild  N    ] net-print/cups-1.1.23-r1  -debug +nls +pam +samba -slp +ssl 0 kB
[ebuild  N    ] x11-libs/qt-3.3.4-r3  +cups -debug -doc -examples -firebird +gif -immqt -immqt-bc +ipv6 -mysql -nas -odbc +opengl -postgres -sqlite -xinerama +zlib 0 kB
[ebuild  N    ] kde-base/arts-3.4.0  +alsa +arts -artswrappersuid -debug +esd -hardened -jack -kdeenablefinal +mad +oggvorbis -xinerama 0 kB
[ebuild  N    ] media-libs/libsdl-1.2.8-r1  +X -aalib +alsa +arts -debug -dga -directfb +esd -fbcon -ggi -libcaca -nas -noaudio -nojoystick -novideo +opengl +oss +svga -xinerama +xv 0 kB
[ebuild  N    ] sys-libs/lib-compat-1.4  +sdl 0 kB
[ebuild  N f  ] dev-java/sun-jdk-1.5.0.02-r1  -doc +gnome -jce +kde -mozilla 0 kB
[ebuild  N    ] sys-libs/db-4.2.52_p2  -bootstrap -doc +java -nocxx -tcltk 0 kB
[ebuild  N    ] dev-libs/libxml2-2.6.18  -debug +ipv6 +python +readline 0 kB
[ebuild  N    ] dev-libs/popt-1.7-r1  +nls 561 kB
[ebuild  N    ] net-fs/samba-3.0.13  -acl +cups -debug -doc -kerberos -ldap -libclamav -mysql -oav +pam -postgres +python -quotas +readline (-selinux) -winbind -xml +xml2 15,218 kB
[ebuild  N    ] sys-apps/groff-1.19.1-r2  +X -debug 0 kB
[ebuild  N    ] sys-devel/libperl-5.8.6  +berkdb -debug +gdbm -ithreads -nocxx (-uclibc) 0 kB
[ebuild  N    ] dev-lang/perl-5.8.6-r4  +berkdb -debug -doc +gdbm -ithreads -perlsuid (-uclibc) 0 kB
[ebuild  N    ] sys-devel/autoconf-2.13  0 kB
[ebuild  N    ] sys-devel/autoconf-wrapper-2-r1  0 kB
[ebuild  N    ] sys-devel/autoconf-2.59-r6  0 kB
[ebuild  N    ] sys-process/cronbase-0.3.2  0 kB
[ebuild  N    ] sys-apps/man-1.5p  -debug +nls 0 kB
[ebuild  N    ] dev-perl/Locale-gettext-1.03  0 kB
[ebuild  N    ] sys-apps/help2man-1.35.1  +nls 0 kB
[ebuild  N    ] sys-apps/coreutils-5.2.1-r6  -acl -build -debug +nls (-selinux) -static (-uclibc) 88 kB
[ebuild  N    ] sys-apps/baselayout-1.11.10-r6  -bootstrap -build -debug -livecd -static (-uclibc) 0 kB
[ebuild  N    ] sys-libs/glibc-2.3.4.20050125-r1  -build -debug -erandom -hardened (-multilib) +nls -nomalloccheck -nptl -nptlonly -pic -userlocales 0 kB
[ebuild  N    ] sys-libs/zlib-1.2.2  -build -debug 0 kB
[ebuild  N    ] dev-python/python-fchksum-1.7.1  26 kB
[ebuild  N    ] sys-apps/debianutils-2.13.1-r1  -build -debug -static 121 kB
[ebuild  N    ] media-libs/glut-3.7.1  0 kB
[ebuild  N    ] dev-python/pyopengl-2.0.1.09  0 kB
[ebuild  N    ] x11-libs/pango-1.8.1  -debug -doc -static 0 kB
[ebuild  N    ] dev-libs/atk-1.9.1  -debug -doc -static 0 kB
[ebuild  N    ] dev-perl/XML-Parser-2.34  0 kB
[ebuild  N    ] dev-util/intltool-0.32.1  0 kB
[ebuild  N    ] x11-misc/shared-mime-info-0.14-r2  0 kB
[ebuild  N    ] x11-libs/gtk+-2.6.4-r1  -debug -doc +jpeg -static +tiff 0 kB
[ebuild  N    ] x11-libs/gtkglarea-1.99.0  -debug 0 kB
[ebuild  N    ] dev-python/numeric-23.7  0 kB
[ebuild  N    ] gnome-base/libglade-2.5.1  -debug -doc 0 kB
[ebuild  N    ] dev-python/pygtk-2.6.1  -debug -doc +gnome +opengl 0 kB
[ebuild  N    ] x11-misc/denu-2.3.2  0 kB

_________________
"I could tell that my parents hated me. My bath toys were a toaster and a radio."
--Rodney Dangerfield
_________________
Windows-free since Feb. 12, 2005
Registered Linux User #386012
Back to top
View user's profile Send private message
vonhelmet
l33t
l33t


Joined: 06 Apr 2004
Posts: 770
Location: Somewhere in a school

PostPosted: Thu Apr 14, 2005 11:00 am    Post subject: Reply with quote

forsen wrote:
I have a little problem with denu, i can't get it to run.

I've just emerged gnome 2.10, and denu.
When i try to run denu as a user, nothing happens:
Code:
forsen@glasscola ~ $ denu


Nothing happens. If i hit ctrl+c i get this:
Code:
forsen@boxcola ~ $ denu
Traceback (most recent call last):
  File "/usr/bin/denu", line 1207, in ?
    treeviewdndex = DenuGUI()
  File "/usr/bin/denu", line 1094, in __init__
    self.populate_installed('', 'yes')
  File "/usr/bin/denu", line 752, in populate_installed
    new_iter=self.installedstore.append(None, ['folder', 'New', '', self.pixbuf_manager('denu_folder.png'), ''])
TypeError: value is of wrong type for this column
forsen@boxcola ~ $

Any idea what i'm doing wrong?

EDIT: my entire system is ~x86


I get a very similar error... it looks like this:

Code:
Traceback (most recent call last):
  File "/usr/bin/denu", line 1207, in ?
    treeviewdndex = DenuGUI()
  File "/usr/bin/denu", line 1094, in __init__
    self.populate_installed('', 'yes')
  File "/usr/bin/denu", line 752, in populate_installed
    new_iter=self.installedstore.append(None, ['folder', 'New', '', self.pixbuf_manager('denu_folder.png'), ''])
TypeError: value is of wrong type for this column

_________________
My blog
nvtuner software - enhance your AGP Geforce 6800 or 6200!
Back to top
View user's profile Send private message
hatem
n00b
n00b


Joined: 05 Jun 2003
Posts: 72
Location: Florida

PostPosted: Thu Apr 14, 2005 11:12 pm    Post subject: Reply with quote

I've been using denu 2.3.2 with gnome 2.10, and it's great to finally have a way to edit the menus :D. The only problem I'm having is with the icons. If I add an icon to a menu category (like Archives/Editors/Emulation/...), gnome uses the default gnome folder icon instead. I do not have this problem when assigning an icon to individual menu entries (programs).

Is this a bug, or just not implemented yet? Any ideas on what may be wrong?
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Thu Apr 14, 2005 11:56 pm    Post subject: Reply with quote

Glad to hear it works decently on gnome. I have not heard about this until now. We're currently embarking on 3.x so we'll look at that while writing it. Thanks.
Back to top
View user's profile Send private message
The New Guy
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2005
Posts: 136
Location: Behind you...

PostPosted: Fri Apr 15, 2005 12:33 pm    Post subject: Reply with quote

TanNewt wrote:
Glad to hear it works decently on gnome. I have not heard about this until now. We're currently embarking on 3.x so we'll look at that while writing it. Thanks.


Not for all of us though. Any progress on why it's saying it can't find GTK when I know I have it?
_________________
"I could tell that my parents hated me. My bath toys were a toaster and a radio."
--Rodney Dangerfield
_________________
Windows-free since Feb. 12, 2005
Registered Linux User #386012
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Fri Apr 15, 2005 1:52 pm    Post subject: Reply with quote

I've been busy. Check other threads for that.
Back to top
View user's profile Send private message
The New Guy
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2005
Posts: 136
Location: Behind you...

PostPosted: Fri Apr 15, 2005 1:58 pm    Post subject: Reply with quote

TanNewt wrote:
I've been busy. Check other threads for that.


All of the other threads have said nothing further on fixing it. The other day you asked me to post the output of "emerge -pev denu" and I did so, but then nothing else. It's ok, I guess. I know this is free software and you are busy and all, but I just thought that I might get an answer posting here. I've unmerged denu since it doesn't work.

Thanks anyway, TanNewt. Denu looks great and I hope 3.x irons out all of the issues. :)
_________________
"I could tell that my parents hated me. My bath toys were a toaster and a radio."
--Rodney Dangerfield
_________________
Windows-free since Feb. 12, 2005
Registered Linux User #386012
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Sat Apr 16, 2005 12:37 am    Post subject: Reply with quote

Yeah, if I had more time. You may want to try in a couple weeks just to see if they've fixed the problem.
Back to top
View user's profile Send private message
caravela
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2004
Posts: 118

PostPosted: Tue Apr 26, 2005 5:24 pm    Post subject: Reply with quote

vonhelmet wrote:
forsen wrote:
I have a little problem with denu, i can't get it to run.

I've just emerged gnome 2.10, and denu.
When i try to run denu as a user, nothing happens:
Code:
forsen@glasscola ~ $ denu


Nothing happens. If i hit ctrl+c i get this:
Code:
forsen@boxcola ~ $ denu
Traceback (most recent call last):
  File "/usr/bin/denu", line 1207, in ?
    treeviewdndex = DenuGUI()
  File "/usr/bin/denu", line 1094, in __init__
    self.populate_installed('', 'yes')
  File "/usr/bin/denu", line 752, in populate_installed
    new_iter=self.installedstore.append(None, ['folder', 'New', '', self.pixbuf_manager('denu_folder.png'), ''])
TypeError: value is of wrong type for this column
forsen@boxcola ~ $

Any idea what i'm doing wrong?

EDIT: my entire system is ~x86


I get a very similar error... it looks like this:

Code:
Traceback (most recent call last):
  File "/usr/bin/denu", line 1207, in ?
    treeviewdndex = DenuGUI()
  File "/usr/bin/denu", line 1094, in __init__
    self.populate_installed('', 'yes')
  File "/usr/bin/denu", line 752, in populate_installed
    new_iter=self.installedstore.append(None, ['folder', 'New', '', self.pixbuf_manager('denu_folder.png'), ''])
TypeError: value is of wrong type for this column


I had the same error looked at the code and seems that denu trys to donwload some settings from the web , since i was behind a firewall and i didn't set the proxy settings , i set them up
with export http_proxy="http://blah" and runned denu again and it worked.
Back to top
View user's profile Send private message
Schwinni
Apprentice
Apprentice


Joined: 02 Sep 2004
Posts: 214
Location: quadrant1.earth. germany.wuerzburg

PostPosted: Mon May 02, 2005 10:50 am    Post subject: Reply with quote

I just emerged denu.
The program starts fine (I do from command line), also "Update" works, but I run into an erorr on "Sysupdate":
Code:
Traceback (most recent call last):
  File "/usr/bin/denu", line 155, in systemdata
    tmp = os.listdir(spath)
OSError: [Errno 20] Ist kein Verzeichnis: '/opt/bin/jad'

"Ist kein Verzeichnis" means "Is no directory"


Any help is appreciated! :)

Thanks in advance,
Chris

P.S.: I'm using Gnome 2.10 and denu 2.3.2
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Mon May 02, 2005 1:52 pm    Post subject: Reply with quote

There are two things you can do. One, remove '/opt/bin/jad' from your path variable. Or, you can add a clause in the above line in denu to make sure its a directory. I will do that later but don't have time this morning. Thanks.
Back to top
View user's profile Send private message
Schwinni
Apprentice
Apprentice


Joined: 02 Sep 2004
Posts: 214
Location: quadrant1.earth. germany.wuerzburg

PostPosted: Mon May 02, 2005 7:15 pm    Post subject: Reply with quote

Thanks for your answer.
Because /opt/bin/jad isn't a directory anyway, I think it should be no problem to remove from PATH...
Back to top
View user's profile Send private message
bladdo
Guru
Guru


Joined: 19 Jul 2004
Posts: 334
Location: NJ

PostPosted: Mon May 02, 2005 11:00 pm    Post subject: Reply with quote

Any chance for PekWM support?
_________________
Bladdo formerly >Milo<
bladdo.net - scripting and design
Creator of AIM Bot: Tiny Tiny Bot - the bot that learns
distro: gentoo | window manager: pekwm
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Mon May 02, 2005 11:14 pm    Post subject: Reply with quote

Any chance you could write it? ;-) I'm working on version 3.x which is completely new. I copied only a little code. It features a separate library and separate libraries per WM. There are three main files, libDenu.py, which contains all of the data and functions to manipulate the menu, denu.py, which provides a GUI which interfaces with libDenu.py and finally one or more denuWM_<wm>.py files. These files include configuration information and import, export, restore, backup and a misc functions. When I get to writing the rest of the denuWM_ modules I'll look into pekWM.

The current status is that libDenu.py is mostly written and may only need a minor reworking. The GUI is very limited seeing as I started on it yesterday. It is based off of a .glade file which is nice, and I also need to work internationalization support into it. I also have many inputs to link etc. As far as WM support goes fluxbox, the WM I use, is supported. The new interface (in the code) will allow more window managers to be supported. However, it takes longer to write the necessary file.

With that said, anyone who would like to help can help. Even if you've never coded, first and foremost Denu is a learning experience. Thanks.
Back to top
View user's profile Send private message
bladdo
Guru
Guru


Joined: 19 Jul 2004
Posts: 334
Location: NJ

PostPosted: Tue May 03, 2005 7:41 pm    Post subject: Reply with quote

TanNewt wrote:
Any chance you could write it? ;-) I'm working on version 3.x which is completely new. I copied only a little code. It features a separate library and separate libraries per WM. There are three main files, libDenu.py, which contains all of the data and functions to manipulate the menu, denu.py, which provides a GUI which interfaces with libDenu.py and finally one or more denuWM_<wm>.py files. These files include configuration information and import, export, restore, backup and a misc functions. When I get to writing the rest of the denuWM_ modules I'll look into pekWM.

The current status is that libDenu.py is mostly written and may only need a minor reworking. The GUI is very limited seeing as I started on it yesterday. It is based off of a .glade file which is nice, and I also need to work internationalization support into it. I also have many inputs to link etc. As far as WM support goes fluxbox, the WM I use, is supported. The new interface (in the code) will allow more window managers to be supported. However, it takes longer to write the necessary file.

With that said, anyone who would like to help can help. Even if you've never coded, first and foremost Denu is a learning experience. Thanks.

Damn :/ I am a perl guru but just hardly know hello world in python.
_________________
Bladdo formerly >Milo<
bladdo.net - scripting and design
Creator of AIM Bot: Tiny Tiny Bot - the bot that learns
distro: gentoo | window manager: pekwm
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Tue May 03, 2005 11:47 pm    Post subject: Reply with quote

Code:
print "Hello World."


Thats okay, just realize that if its on my todo list it will take a while. I'm busy besides finishing 3.0 . ;-)
Back to top
View user's profile Send private message
kicker
n00b
n00b


Joined: 03 May 2005
Posts: 47

PostPosted: Mon May 09, 2005 1:38 am    Post subject: Reply with quote

Hi there, I was looking at a way to edit gnome menu this afternoon, and found your program. Very nice by the way! :) It worked flawlessly on first shot on my machine.. I really didn't know what to do tho, it's not very intuitive (maybe label the steps, 1-2-3... ) anyway, i've clicked on update, sysupdate, and autofill, and seemed to have worked... i then generated the menu for gnome 2.10.. gnome was fine. Then later i went into kde.. at first, i was surprised.. the menu replicated there also. Weird, as i thought they didn't used the same menu file, usually they dont anyway, and i didn't generated a menu for kde (the point is, i had no K apps there, and control center was broken, was a blank page on the left) So kde became quite useless.. then I tried to look into the issue, rebuilded a menu with your tool for KDE, was the same, then i deleted a few dir in my home, .kde, .kde3.4, .config. Then my gnome menu was back to original. But not KDE. Then i logged into root, root was all fine. So i figured it's a local setting.. but couldn't find it.. as I've already erased both .kde and .config (also .kde3-4 cause it's the real directory, .kde is a symlink) at this point.. anyway, what i've done to fix it was move my home directory elsewhere, delete the user, create another one, and everything was fine again.. but still didn't had my updated menu as i've emerge a few stuff yesterday... so back to square one... what can i do to have proper menu in both kde and gnome, as I like to use both.. and then some others too :)

Anyway nice tool, and i'd like to help, you said no coding experience required, i've almost got none.. but anyway, reply to me by email if you want (pleclair at gmail dot com)

Thanks for your support, i know you must be very tired of working on this alone and supporting it altogether cause it seems alot of people had trouble with it... anyway! I just can't believe both kde nor gnome have a menu editor or at least drag n drop to and from menu, as with windows... damn it's really the basis on the gui, if there is no way to add your program which doesn't even add themselves.. i think we are still far from an enjoyable desktop experience... I dont want to spend 2 hours to customize my menu when it should really be done automatically when programs are added, or at least some tool to auto scan and add them, like kappfinder, but this completely isn't doing its job.

Anyway, if I can help you, i'd be glad

Pierre-Andre
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Mon May 09, 2005 1:57 am    Post subject: Reply with quote

I'll fire off an email to you. I just wanted to state that as of versions 3.4 of KDE and Gnome 2.10 they run off of the same menu file. Thats an issue we will have to look into for the 3.x series.

I understand the difficulty of the GUI and hopefully with 3.x that will no longer be an issue. An early screenshot and video can be found on http://denu.sf.net . I've got some of the core stuff working along with the "wouldn't it be cool if..." features mostly working. Much of it is tested only a bit. Once I get the Add, Edit, View functions working I'm planning an alpha release.
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Wed May 11, 2005 5:53 am    Post subject: Reply with quote

just a quick note. Denu 3.0 Alpha 1 is now on sourceforge. You must edit the files according to the notes to set the correct directory. It is very alpha, the basics work but much polishing is needed. Test it if you can edit the files comfortably. All that must be replace is the variable in the beginning of denu.py, libDenu.py and wms/denuWM_fluxbox.py. Change the filename specific to me, "/home/scott/..." to the directory that denu-3.x folder is in. Be sure to include "denu-3.x" as the last folder. Please post on the sourceforge denu-devel mailing list for help, or post here. Please note you must be subscribed to the list. Also note 3.x as of now only supports fluxbox, however I encourage anyone to write more modules. If you are interested I can give you the details. Thanks. link: http://sourceforge.net/project/showfiles.php?group_id=117449&package_id=127854&release_id=326527
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2570
Location: Richmond, BC, Canada

PostPosted: Tue May 17, 2005 4:27 am    Post subject: Reply with quote

I messed up my menus worse than gnome-2.10 did. The menus do not have icons, many of the apps dissaperared from the menu, but it did add others. How can I reset it back to the bad gnome-2.10 menu so I can start over.

[edit] Never mind, I found it. /home/~/.config [/edit]
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Tue May 17, 2005 5:13 am    Post subject: Reply with quote

Yeah, denu supports icons but does not have a lot of data on what icons are for what. With 3.x I'll bore myself to death entering that info.
Back to top
View user's profile Send private message
lanius
Retired Dev
Retired Dev


Joined: 08 Dec 2002
Posts: 160

PostPosted: Tue May 17, 2005 1:18 pm    Post subject: Reply with quote

Why does denu-3 use just another file format internally? Why not use the menu-specification that kde and gnome are using and converting to the other wm's from there? there is pyxdg which will help a lot with parsing this stuff.
Back to top
View user's profile Send private message
TanNewt
Retired Dev
Retired Dev


Joined: 26 Mar 2004
Posts: 339
Location: Seattle, WA

PostPosted: Tue May 17, 2005 2:00 pm    Post subject: Reply with quote

The FreeDesktop spec does not lend itsself to editing/customizing. Its main thing it does well is automatically updating for new programs. The problem is is that assumes the program provides a .desktop file.
Back to top
View user's profile Send private message
lanius
Retired Dev
Retired Dev


Joined: 08 Dec 2002
Posts: 160

PostPosted: Tue May 17, 2005 3:34 pm    Post subject: Reply with quote

TanNewt wrote:
The FreeDesktop spec does not lend itsself to editing/customizing.


Sorry, I don't understand what you mean. Of course it can be customized as well. Take a look at kmenuedit or SMEG (http://www.realistanew.com/projects/smeg/)

Quote:
The problem is is that assumes the program provides a .desktop file.


But you can simply create those DesktopFiles. There is not much needed, a Name and Executable is everything you need.


Last edited by lanius on Tue May 17, 2005 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
ryszardzonk
Apprentice
Apprentice


Joined: 18 Dec 2003
Posts: 182
Location: Rzeszów, POLAND

PostPosted: Tue May 17, 2005 4:40 pm    Post subject: mesed up menu Reply with quote

dol-sen wrote:
I messed up my menus worse than gnome-2.10 did. The menus do not have icons, many of the apps dissaperared from the menu, but it did add others. How can I reset it back to the bad gnome-2.10 menu so I can start over.

[edit] Never mind, I found it. /home/~/.config [/edit]


I am with You on this one as exactly same thing happend to me. It wasn't to big problem for as I was starting setting up the account so I deleted all gnome related configs, but I definetly would want to see an option in which one can import present options, so menu does not disspear completly, but one can edit it to their needs... Icons dissaper as well and this deffinetly is a big minus. Lets hope version 3.x fixes it for all Gnome 2.10 users :(
_________________
Sky is not the limit...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10, 11  Next
Page 9 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum