Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NTP nur wie?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Wed Dec 08, 2004 7:43 am    Post subject: NTP nur wie? Reply with quote

Ich hab ntp emerged... hab das ganze dann mit rc-update add ntp default zum init hinzugefügt...
nur werd ich nicht schlau, wie das ding nun synchronisiert... in meiner /etc/ntp.conf steht folgendes:

restrict default noquery notrust nomodify
restrict 127.0.0.1
restrict 192.168.0.0 mask 255.255.255.0
fudge 127.127.1.0 stratum 3
server ptbtime1.ptb.de
driftfile /var/lib/ntp/ntp.drift
logfile /var/log/ntp.log

und meine /var/log/ntp.log

8 Dec 08:38:57 ntpd[28795]: sendto(192.53.103.103): Bad file descriptor
8 Dec 08:38:59 ntpd[28410]: sendto(192.53.103.103): Bad file descriptor
8 Dec 08:39:05 ntpd[28421]: sendto(192.53.103.103): Bad file descriptor
etc.

was mache ich falsch? hab schon in man ntpd gelesen aber bin nicht wirklich schlau daraus geworden :(
Back to top
View user's profile Send private message
manicman
n00b
n00b


Joined: 30 Jun 2004
Posts: 19

PostPosted: Wed Dec 08, 2004 7:54 am    Post subject: Reply with quote

was sagt denn deine /etc/conf.d/ntpd ?
Back to top
View user's profile Send private message
Linuxpeter
Guru
Guru


Joined: 28 May 2004
Posts: 403
Location: Dresden, Germany

PostPosted: Wed Dec 08, 2004 11:45 am    Post subject: Reply with quote

So sieht meine /etc/ntp.conf aus (Kommentare entfernt):
Code:

server de.pool.ntp.org
server de.pool.ntp.org
server de.pool.ntp.org
driftfile   /var/lib/ntp/ntp.drift

Entsprechender Auszug aus /var/log/messages:
Code:

Dec  8 12:23:46 linux ntpd[7475]: synchronized to 62.206.102.82, stratum=2

_________________
Regards, Linuxpeter
Wenn "Windows" die Antwort ist, war es eine dumme Frage. ;-)
Is "Windows" the answer, then it was a stupid question. ;-)
Back to top
View user's profile Send private message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Wed Dec 08, 2004 12:17 pm    Post subject: Reply with quote

@ manicman
die ist leer
Back to top
View user's profile Send private message
rblock
l33t
l33t


Joined: 04 Apr 2004
Posts: 626
Location: Germersheim

PostPosted: Wed Dec 08, 2004 12:44 pm    Post subject: Reply with quote

Ähm, willst Du einen Timeserver erstellen oder nur Deine Zeit mit einem Timeserver synchronisieren? :roll:

Willst Du nur einen NTP-Client einrichten, wäre es sinnvoll, die "/etc/conf.d/ntp-client" einzurichten, sprich den oder die Timeserver (durch Leerzeichen getrennt) unter "NTPCLIENT_OPTS" anzugeben. Abschließend solltes Du mit "rc-update -a ntp-client default" den NTP-Client aktivieren. :)

Hinweisende Grüße
_________________
Reiner
--
"Wer fragt, ist ein Narr für fünf Minuten. Wer nicht fragt, bleibt ein Narr für immer." Chinesische Weisheit
"Erfolg hat, wer ihm entgegengeht, statt ihm nachzulaufen." Onassis, Aristoteles

Reiner Block
http://www.feba-software.de
Back to top
View user's profile Send private message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Wed Dec 08, 2004 5:49 pm    Post subject: Reply with quote

will eigentlich nur synchronisieren, keinen eigenen server aufmachen...
wie sollte die datei dann aussehen? in der steht nämlich gar nichts drinnen... (/etc/conf.d/ntp-client)
Back to top
View user's profile Send private message
bll0
Apprentice
Apprentice


Joined: 22 May 2004
Posts: 178

PostPosted: Wed Dec 08, 2004 6:56 pm    Post subject: Reply with quote

Ich synchronisiere auch mit ntp-client.

cat /etc/conf.d/ntp-client
Code:
NTPCLIENT_CMD="ntpdate"
NTPCLIENT_OPTS="-b 129.69.1.153"


Dazu kommt noch das ich den Zeitfehler meiner Systemuhr mit ntpd ausgleiche

cat /etc/conf.d/ntpd
Code:

NTPD_OPTS="-u ntp:ntp"


Diese sind in meinem default runlevel eingetragen, heißt, beim booten wird die Zeit mit ntp-client synchronisiert und im laufenden Betrieb mit ntpd ausgeglichen.

Gruß,
A

P.S. ein emerge ntpd musst du glaub ich schon machen....
Back to top
View user's profile Send private message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Wed Dec 08, 2004 8:00 pm    Post subject: Reply with quote

bekomm dann beim starten wieder folgenden fehler:

* Setting clock via the NTP client 'ntpdate' ...
8 Dec 20:58:14 ntpdate[23250]: the NTP socket is in use, exiting
* Failed to set clock [ !! ]
Back to top
View user's profile Send private message
bll0
Apprentice
Apprentice


Joined: 22 May 2004
Posts: 178

PostPosted: Wed Dec 08, 2004 10:43 pm    Post subject: Reply with quote

Ntpd darf nicht laufen, wenn du ntp-client startest! Die benutzen afaik den gleichen Socket (s. Fehlermeldung) und dann will das nicht.

Code:
 /etc/init.d/ntpd stop
/etc/init.d/ntp-client start
/etc/init.d/ntpd start

rc-update add ntp-client default
rc-update add ntpd default


So sollte es hinhauen...
Back to top
View user's profile Send private message
psyqil
Advocate
Advocate


Joined: 26 May 2003
Posts: 2767

PostPosted: Thu Dec 09, 2004 12:07 am    Post subject: Reply with quote

net-misc/rdate? :oops:

<tanz>Drei! Zu! Null!</tanz>
Back to top
View user's profile Send private message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Thu Dec 09, 2004 6:56 am    Post subject: Reply with quote

jippiii endlich ;) jetzt hoff ich mal das dann auch zukünftig alles gut geht *g*

borg ~ # /etc/init.d/ntpd stop
* ERROR: "ntpd" has not yet been started.
borg ~ # /etc/init.d/ntp-client start
* Setting clock via the NTP client 'ntpdate' ... [ ok ]
borg ~ # /etc/init.d/ntpd start
* Starting ntpd ... [ ok ]
borg ~ # rc-update add ntp-client default
* ntp-client added to runlevel default
* rc-update complete.
borg ~ # rc-update add ntpd default
* ntpd added to runlevel default
* rc-update complete.
Back to top
View user's profile Send private message
Dirk_G
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 144
Location: Wallerfangen

PostPosted: Thu Dec 09, 2004 10:33 am    Post subject: Reply with quote

Hi

b0rG wrote:
will eigentlich nur synchronisieren, keinen eigenen server aufmachen...
wie sollte die datei dann aussehen? in der steht nämlich gar nichts drinnen... (/etc/conf.d/ntp-client)


Wenn du nur Syncronisieren willst dann lass den Server (ntpd) aus und benutze nur den Client (ntp-client). Der ntpd stellt zwar auch die Uhr, läuft aber zusätzlich als Server!!! Also weg mit

Quote:
borg ~ # rc-update add ntpd default
* ntpd added to runlevel default
* rc-update complete.


Hier mal meine Config

Code:
# cat /etc/conf.d/ntp-client
NTPCLIENT_CMD="ntpdate"
NTPCLIENT_OPTS="-Q -b de.pool.ntp.org"
NTPCLIENT_TIMEOUT=30


Alternative kannst du auch NTPCLIENT_OPTS="-u -Q -b de.pool.ntp.org" benutzen, dann benutzt der Client einen Port oberhalb von 1024. Übrigens, die Dateien /etc/ntp.conf und /etc/conf.d/ntpd sind für den Server und die /etc/conf.d/ntp-client für den Client.


Dirk
Back to top
View user's profile Send private message
b0rG
n00b
n00b


Joined: 12 Jul 2004
Posts: 42

PostPosted: Thu Dec 09, 2004 8:44 pm    Post subject: Reply with quote

danke! gott sei dank funzt es... ;)
Back to top
View user's profile Send private message
rblock
l33t
l33t


Joined: 04 Apr 2004
Posts: 626
Location: Germersheim

PostPosted: Thu Dec 09, 2004 9:14 pm    Post subject: Reply with quote

psyqil wrote:
Hail Potato!

Ne, das heißt "Hail Caesar" und ist von AC/DC! ;)


Rockende Grüße
_________________
Reiner
--
"Wer fragt, ist ein Narr für fünf Minuten. Wer nicht fragt, bleibt ein Narr für immer." Chinesische Weisheit
"Erfolg hat, wer ihm entgegengeht, statt ihm nachzulaufen." Onassis, Aristoteles

Reiner Block
http://www.feba-software.de
Back to top
View user's profile Send private message
Berion
n00b
n00b


Joined: 10 Mar 2005
Posts: 15

PostPosted: Wed Mar 16, 2005 2:37 pm    Post subject: Reply with quote

Ich schliesse hier mal an diesen Thread an und hoffe mir kann jemand einen Tip geben.
Auch ich bekomme im log diese Bad file descriptor Messages und kann mir keinen Reim drauf machen.
Google ist diesbezüglich auch nicht besonders aussagekräftig..:(
Code:

16 Mar 15:10:35 ntpd[9618]: sendto(81.91.160.42): Bad file descriptor
16 Mar 15:13:32 ntpd[29422]: ntpd exiting on signal 15
16 Mar 15:13:45 ntpd[29591]: synchronized to 81.91.160.41, stratum=2
16 Mar 15:13:45 ntpd[29591]: time reset -0.398587 s
16 Mar 15:18:06 ntpd[29647]: synchronized to 81.91.160.41, stratum=2
16 Mar 15:18:06 ntpd[29647]: kernel time sync disabled 0041
16 Mar 15:24:33 ntpd[29647]: kernel time sync enabled 0001
16 Mar 15:27:23 ntpd[9613]: sendto(81.91.160.42): Bad file descriptor


Restrictions hab ich zum testen derzeit gar keine drin.

Ich brauche aber leider die genaue Zeit, und den Daemon.^^

Cheers

Berion
Back to top
View user's profile Send private message
blue.sca
l33t
l33t


Joined: 28 Aug 2003
Posts: 680
Location: Mainz, Germany

PostPosted: Wed Mar 16, 2005 3:14 pm    Post subject: Reply with quote

wenn es nur um zeitsynchronisation geht, dann kann man eigentlich nur den openntp client empfehlen. der ist dafür genau richtig und man hat nicht so ein config gefuddel...
_________________
geek by nature, linux by choice
i want my avatar back... thank you
:wq
Back to top
View user's profile Send private message
Bloody_Viking
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2005
Posts: 123
Location: Hemsbach BW

PostPosted: Wed Mar 16, 2005 3:41 pm    Post subject: Reply with quote

@psygill

Nutze ich auch ich auf meinen Servern auch.:wink:

Einfach:

Code:
rdate -s ptbtime1.ptb.de


in die crontab und fertig ist die syncronisierung!:wink:

Gruß

Bloody
Back to top
View user's profile Send private message
Berion
n00b
n00b


Joined: 10 Mar 2005
Posts: 15

PostPosted: Wed Mar 16, 2005 4:39 pm    Post subject: Reply with quote

:D :D

Ich hab jetzt die ntp-suite rausgeschmissen und openntpd emerged....funktioniert...soweit ich das derzeit beurteilen kann.

Zugriffe von aussen über Firewallregel...

THX fürs Posten
Back to top
View user's profile Send private message
blue.sca
l33t
l33t


Joined: 28 Aug 2003
Posts: 680
Location: Mainz, Germany

PostPosted: Wed Mar 16, 2005 6:21 pm    Post subject: Reply with quote

rdate hat den nachteil, dass es die zeit direkt verstellt. wenn dir uhr 10 minuten nachgeht, stellt rdate sie 10 minuten vor. ntp macht das in vielen kleinen schritten. wenn man aber anwendugen hat, die sich auf die zeit verlassen, und das kann eigentlich schon ein kernel compile sein, dann können die im schlimmsten fall anhalten, weil was nicht stimmt. wenn man das aber mit rdate nachmacht, viele kleine schritte, dann überlastet man die server.
also, bitte verwendet das ntp protokol, wenn euch eure kiste lieb ist, und seid nicht so faul ;)
_________________
geek by nature, linux by choice
i want my avatar back... thank you
:wq
Back to top
View user's profile Send private message
ro
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 287

PostPosted: Wed Mar 16, 2005 6:58 pm    Post subject: Reply with quote

rdate ist super, mit openntp hab ich schlechte erfahrungen betreffend stabilität und verlässlichkeit gemacht, ntp ist mir zu aufgeblasen bzw. zu viel config, aber net-misc/clockspeed ist auch ganz interessant.
_________________
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Back to top
View user's profile Send private message
sambatasse
Guru
Guru


Joined: 12 Mar 2004
Posts: 390
Location: bei Berlin

PostPosted: Thu Mar 17, 2005 10:06 pm    Post subject: Reply with quote

hallo

also habe den ntp-client jetzt am laufen klapt soweit ganz gut
heist beim starten synct er die zeit
nur solte ntp das nicht zyklisch wiederholen oder macht er das nur beim start ?

meine rechner uhr geht nehmlich etwas zu schnell ca 2 min in 1 stunde
das muss ich kompensieren

danke
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3489

PostPosted: Fri Mar 18, 2005 7:26 am    Post subject: Reply with quote

Quote:
meine rechner uhr geht nehmlich etwas zu schnell ca 2 min in 1 stunde
das muss ich kompensieren


also für solche Fälle, wenn der Rechner auch öfters mal aus ist und dann beim Neustart wieder die volkommen falsche Zeit hat, würde ich das wie folgt realisieren. Natürlich nur wenn der Rechner dauerhafte Netzanbindung hat.

beim Booten in der Reihenfolge, evt. ein eigenes initscript schreiben oder das ntpd-initscript ergänzen

- das in der /etc/ntpd.conf konfigurierte Driftfile löschen (/var/lib/ntp/ntp.drift, weiß nicht ob das zwingend nötig ist, aber bei mir hats mal geholfen)
- einmal mit ntpdate die Zeit setzen
- ntpd starten

Erklärung: Wenn der ntpd läuft wird die falsche Zeit "ständig" durch den ntpd korrigiert. Weicht jedoch die Systemzeit beim starten des ntpd zu sehr von der Zeit auf den Zeitserver ab startet ntpd evt. gar nicht bzw. braucht ewig um das zu korrigieren. Deswegen vorher einmal ntpdate starten.

Nachschauen wie der ntpd läuft:
Code:
ntpq -p
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2109
Location: Konradsreuth (Germany)

PostPosted: Fri Mar 18, 2005 11:16 am    Post subject: Reply with quote

blue.sca wrote:
wenn es nur um zeitsynchronisation geht, dann kann man eigentlich nur den openntp client empfehlen. der ist dafür genau richtig und man hat nicht so ein config gefuddel...

Mir war der ganze Server-Kram und Config-Kram & Co. auch zu blöd, deswegen hab ich vor längerer Zeit mal ein kleines PERL-Programm geschrieben, was sich einfach die aktuelle Zeit von der Physikalisch-Technischen Bundesanstalt holt und dann die Systemuhr danach stellt. Das starte ich per Script (über sudo) immer, wenn ich ins Internet gehe. Fertich :-)

<werbung>Runterladen könnt ihr das unter http://tl.h-workx.de/downloads/ </werbung> ;-)
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Tue Apr 12, 2005 7:57 am    Post subject: Reply with quote

Dirk_G wrote:

Wenn du nur Syncronisieren willst dann lass den Server (ntpd) aus und benutze nur den Client (ntp-client). Der ntpd stellt zwar auch die Uhr, läuft aber zusätzlich als Server!!!


Also so wie ich das verstanden habe setzt ntp-client nur einmalig durch Aufruf von ntpdate die Zeit, oder?

In dem Fall wäre es sinnvoll, sowohl ntp-client als auch ntpd in den default-Runlevel zu packen, damit ntp-client zuerst die korrekte Zeit einstellt und der ntpd dann laufend die Zeit korrigiert (denn irgendwas wurde in einem der letzten Kernel kaputtgefummelt, ich habe mit dem aktuellen Kernel teilweise mehrere Stunden Zeitabweichungen pro Woche, wenn der ntpd nicht läuft - und das auf mehreren verschiedenen Servern, also liegt's wohl eher nicht an der Hardware). Und da in /etc/init.d/ntpd schlauerweise after ntp-client steht, sollte das auch keine Konflikte geben...
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
xsteadfastx
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2004
Posts: 132
Location: germany/belgium

PostPosted: Wed Apr 13, 2005 12:41 pm    Post subject: Reply with quote

rblock wrote:
Ähm, willst Du einen Timeserver erstellen oder nur Deine Zeit mit einem Timeserver synchronisieren? :roll:

Willst Du nur einen NTP-Client einrichten, wäre es sinnvoll, die "/etc/conf.d/ntp-client" einzurichten, sprich den oder die Timeserver (durch Leerzeichen getrennt) unter "NTPCLIENT_OPTS" anzugeben. Abschließend solltes Du mit "rc-update -a ntp-client default" den NTP-Client aktivieren. :)

Hinweisende Grüße


reicht nicht rc-update -a ntp-client boot?
_________________
[ http://www.xsteadfastx.de ]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum