Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
hiroki
Guru
Guru


Joined: 29 Jul 2003
Posts: 327
Location: @home in germany

PostPosted: Sun Feb 06, 2005 11:18 pm    Post subject: Reply with quote

yaneurabeya wrote:
hiroki wrote:
maybe you should try "xi"... also works for "xtsu"? (ぃ|い)(っ|つ)


Awesome, thanks for the tip :). Now what about the dot (in Windows can be referenced with the forward slash key)?


what dot?
do you mean like in:
コンピューター・サイエンス
:?:

well, i don't know it for anthy 'cause i use SKK [i lot it, give it a try ;) ]
and there i type "/." + <space> to get it.
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Mon Feb 07, 2005 8:15 am    Post subject: Reply with quote

Nope, that doesn't work :(. I'll just look up some SCIM/Anthy documentation I suppose =\...
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Mon Feb 07, 2005 6:56 pm    Post subject: Reply with quote

z/ = ・

Emergeing anthy-5900-r1 now :D

EDIT:It works! Proper grammar inserted into howto.

-Sud.
_________________
...
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Tue Feb 08, 2005 10:36 pm    Post subject: Reply with quote

With fluxbox and xorg when I put
Quote:
export LANG=en_US.UTF-8
export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
in /etc/xprofile or in ~/.xprofile and startx there are no changes and "locale" does not show a change. When I put it in .xinitrc fluxbox takes a tremendously long time to load. I'm not using KDE or anything, just fluxbox. It does load eventually just after a long time.

What do you think?
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Tue Feb 08, 2005 11:18 pm    Post subject: Reply with quote

maiku wrote:
With fluxbox and xorg when I put
Quote:
export LANG=en_US.UTF-8
export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
in /etc/xprofile or in ~/.xprofile and startx there are no changes and "locale" does not show a change. When I put it in .xinitrc fluxbox takes a tremendously long time to load. I'm not using KDE or anything, just fluxbox. It does load eventually just after a long time.

What do you think?


Probably that means that /etc/xprofile and ~/.xprofile are not being refered to - I think this is a differnce of using a *dm versus startx.

The slowdown with fluxbox - simply put, it is obeying the LC_TYPE. If you use mostly GTK or QT apps, you don't need it. I am not usre if it is the japanese support that slows it down, or the UTF8 support - try using just LC_TYPE="ja_JP" in the .xinitrc. If it speeds up... er... lost train of thought.

You could also make sure fluxbox is using a Unicode font, like those in the link given near the begining. The font changes with the LC_TYPE also, does it not?

-Sud.
_________________
...
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Wed Feb 09, 2005 12:04 am    Post subject: Reply with quote

Actually yes, it does speed up it up when I change it to ja_JP. However this is probably not best otherwise it would have been included in the HOWTO. If you don't mind the question what functionality did I lose by changing it besides my Eterm font changing :).

I don't think the flux is using a unicode font. But that I can set no problem.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Wed Feb 09, 2005 12:57 am    Post subject: Reply with quote

My best guess, without examining source code, is that fluxbox and Eterm are trying to get a set that matched the whole Unicode set. GTK+ dows this rater transparently, piecing together the differents sets as best it can. Fluxbox is probably searching for a full font.

Try Arial Unicode, with the ja_JP.UTF8 ... other then that, take it up with the fluxbox people.

-Sud.
_________________
...
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Mon Feb 21, 2005 1:02 am    Post subject: Reply with quote

I'm having trouble with japanese input in both openoffice and firefox.
Openoffice (not ximian version) doesn't seem to notice the japanese input, just giving me english characters all the time. I set the LC_CTYPE variable but it doesn't sem to make any difference.
Firefox is even worse. It does one of two things seemingly at random with both canna and anthy: The first is it only lets me type english constonants, no vowels, and when I type more than one constonant the second replaces the first, so I can only have one letter at a time. None of the special keys work, only escape. The other is it lets me type in hiragana but none of the special keys work, so I can't convert it to anything else, and backspace doesn't work either.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Mon Feb 21, 2005 2:44 am    Post subject: Reply with quote

Biggles wrote:
I'm having trouble with japanese input in both openoffice and firefox.
Openoffice (not ximian version) doesn't seem to notice the japanese input, just giving me english characters all the time. I set the LC_CTYPE variable but it doesn't sem to make any difference.
Firefox is even worse. It does one of two things seemingly at random with both canna and anthy: The first is it only lets me type english constonants, no vowels, and when I type more than one constonant the second replaces the first, so I can only have one letter at a time. None of the special keys work, only escape. The other is it lets me type in hiragana but none of the special keys work, so I can't convert it to anything else, and backspace doesn't work either.


Openoffice: make sure you have use export LC_CTYPE=* before oowriter and the like. Also, oo.org requires manual configuration of fonts - I believe the program that does this is oopadmin or spadmin. Yet another advantage to using ximian.

Firefox: Er... you are describing standard japanese input. There are several modes to choose from, one represented by the あ in the scim-selector-bar-thing.

Are you in KDE or some other environment?

"Special Keys"? I have no idea what keyboard you are using, so this could mean many things.

Have you used japanese input in other evironments before? (Seriously, I'd like to know what your expectations are based off of)

Have you tried it out in somthing simple, like gedit or kwrite?

-Sud.
_________________
...


Last edited by Sudrien on Mon Feb 21, 2005 4:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Mon Feb 21, 2005 5:36 am    Post subject: Reply with quote

Sorry about the incoherent post. :)

I've used it in gnome-terminal (python wasn't happy about me throwing kanji at it), kedit, anjuta, thunderbird and x-chat. It worked fine in all of them. I think that covers GTK and Qt. I'm using KDE as my enviroment.

I previously used im-ja and canna for japanese input in GTK apps (it still goes now if I set the environment variables right), but I never got that working with Qt apps. (I've also used the windows stuff, if that really matters - it's quite nice.)

When I said "special keys" I was referring to the keys used to do special functions, eg press space to switch between hiragana and various kanji, enter to confirm, etc. In firefox it definitely shows the hiragana 'a' character.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
MrPixel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2004
Posts: 117
Location: Here & Now

PostPosted: Mon Feb 28, 2005 6:21 pm    Post subject: Reply with quote

I have tried repeatedly to follow the instructions above (except I don't need input for any Qt apps (or are Firefox and Thunderbird Qt?), so I skip that part), I but keep getting the same problem: SCIM crashes almost everything I try to run: gedit, Firefox, Thunderbird. When trying to run from a terminal, this error is generated:
Code:
*** glibc detected *** free(): invalid pointer: 0x08295f78 ***
I use XFCE (4.2), and have ACCEPT_KEYWORDS="~x86" in my make.conf. I also use GDM and only need Japanese input for myself - share the computer with my wife who only needs to read it. I've tried exporting XMODIFIERS and GTK_IM_MODULE from .xprofile, .xinitrc, and ~/Desktop/Autostart/xfce4.desktop. I have tried with and without exporting LC_CTYPE. And probably some other things that I can't think of at the moment. I'd really like to use SCIM, as I really need to be able to input from Firefox and Thunderbird, and I rather dislike GNOME and really dislike KDE (nothing against anyone who loves either of them) - so I don't want to install either of them, but ....

Anyone have any ideas what may be going on, and how I might fix it?
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Mon Feb 28, 2005 7:05 pm    Post subject: Reply with quote

MrPixel wrote:
I have tried repeatedly to follow the instructions above (except I don't need input for any Qt apps (or are Firefox and Thunderbird Qt?), so I skip that part), I but keep getting the same problem: SCIM crashes almost everything I try to run: gedit, Firefox, Thunderbird. When trying to run from a terminal, this error is generated:
Code:
*** glibc detected *** free(): invalid pointer: 0x08295f78 ***
I use XFCE (4.2), and have ACCEPT_KEYWORDS="~x86" in my make.conf. I also use GDM and only need Japanese input for myself - share the computer with my wife who only needs to read it. I've tried exporting XMODIFIERS and GTK_IM_MODULE from .xprofile, .xinitrc, and ~/Desktop/Autostart/xfce4.desktop. I have tried with and without exporting LC_CTYPE. And probably some other things that I can't think of at the moment. I'd really like to use SCIM, as I really need to be able to input from Firefox and Thunderbird, and I rather dislike GNOME and really dislike KDE (nothing against anyone who loves either of them) - so I don't want to install either of them, but ....

Anyone have any ideas what may be going on, and how I might fix it?



FIRST: ~x86 for a reason. :lol:

Second: I you are comfortable with keyboard shortcuts, you may wan to try streight UIM-anthy. Remove the GTK_IM_MODULE reference, and issue the following command form the terminal: touch ~/.uim && echo "(define default-im-name 'anthy)" >> ~/.uim. Restart X. UIM-anthy is now the default. Shift+space toggles the mode. This is the setup I am currently using, but many people like a place to click. :roll:


The other alternative is im-ja, in the old HOWTO: http://forums.gentoo.org/viewtopic.php?t=111387 - no support there, though.

Third: liuspider associates with SCIM, and http://www.scim-im.org/about says the version you have is in need of bug reports.

-Sud.
_________________
...
Back to top
View user's profile Send private message
MrPixel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2004
Posts: 117
Location: Here & Now

PostPosted: Mon Feb 28, 2005 9:47 pm    Post subject: Reply with quote

Sudrien wrote:

FIRST: ~x86 for a reason. :lol:
That makes perfect sense - but I kinda can't live without some of the things it provides (esp. XFCE 4.2)
Quote:
Second: I you are comfortable with keyboard shortcuts, you may wan to try streight UIM-anthy. Remove the GTK_IM_MODULE reference, and issue the following command form the terminal: touch ~/.uim && echo "(define default-im-name 'anthy)" >> ~/.uim. Restart X. UIM-anthy is now the default. Shift+space toggles the mode. This is the setup I am currently using, but many people like a place to click. :roll:
Perfectly fine with me ... I actually don't like the click interface with im-ja, and found it tedious to switch IMs with the mouse.
However, do I still need SCIM? Or ??? there's not package called uim-anthy. Can you point me to a howto or some other resource?
Quote:
Third: liuspider associates with SCIM, and http://www.scim-im.org/about says the version you have is in need of bug reports.

I just filed a bugreport with them. Thanks for the pointer.
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Mon Feb 28, 2005 10:08 pm    Post subject: Reply with quote

MrPixel wrote:
Sudrien wrote:

Second: I you are comfortable with keyboard shortcuts, you may wan to try streight UIM-anthy. Remove the GTK_IM_MODULE reference, and issue the following command form the terminal: touch ~/.uim && echo "(define default-im-name 'anthy)" >> ~/.uim. Restart X. UIM-anthy is now the default. Shift+space toggles the mode. This is the setup I am currently using, but many people like a place to click. :roll:
Perfectly fine with me ... I actually don't like the click interface with im-ja, and found it tedious to switch IMs with the mouse.
However, do I still need SCIM? Or ??? there's not package called uim-anthy. Can you point me to a howto or some other resource?


UIM-anthy is built if anthy is present when UIM is emerged. (I thought I already had this shortcut in the howto - will again soon). You can confirm it was built with cat /var/db/pkg/app-i18n/uim-*/CONTENTS | grep anthy

It does not require SCIM, so you can remove anything associated with SCIM in the name.

If UIM is installed, it becomes the default input method for GTK, so there is no GTK_IM_MODULE entry. The touch ~/.uim && echo "(define default-im-name 'anthy)" >> ~/.uim tells it to use anthy by default.


After classes I will try and throw together a quick way of how to set this up from scratch - though thtere should be enough info here to figure this out yourself.

(now if they'd only add that 'anthy' USE flag like I had asked...)

-Sud.
_________________
...
Back to top
View user's profile Send private message
MrPixel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2004
Posts: 117
Location: Here & Now

PostPosted: Tue Mar 01, 2005 2:35 am    Post subject: Reply with quote

Ok ... great!

uim-anthy is working with gedit ... does it not work with Firefox or Thunderbird? I suppose Ctrl+X, Ctrl+V will always work, but is there a way to get it there, too?
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Wed Mar 02, 2005 10:15 pm    Post subject: Reply with quote

MrPixel wrote:
Ok ... great!

uim-anthy is working with gedit ... does it not work with Firefox or Thunderbird? I suppose Ctrl+X, Ctrl+V will always work, but is there a way to get it there, too?


Compile the gtk/gtk2 flags into firefox and thunderbird in order to get gtk input support. Better yet though, just add USE="gtk gtk [...old flags here...]" to your /etc/make.conf file and just run emerge --newuse world. That will solve your input issue.
Back to top
View user's profile Send private message
Modano
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2004
Posts: 109
Location: Montpellier, France

PostPosted: Sat Mar 05, 2005 3:31 pm    Post subject: Reply with quote

Hum hello all !
Very very nice HOWTO. I successfully, without pain, managed to use the scim-uim in my XFCE4 install. No worry, all Kate, Kedit, etc etc work very well.
Japanese with Firefox is just the same, all runs smoothly.
But two questions :

The export of XMODIFIERS=@im=SCIM and QT_IM_MODULE can be put in /etc/xprofile (for all users), in order to export these variables at X startup. But here, it seems it just ignored the xprofile contents, I still have to export by hand... Any other file I should use ? (xorg, xfce4)...

I exported LC_CTYPE=ja_JA.UTF-8 ans started oowriter...but no way to write Japanese under Normal openoffice 1.1.3 (Asian Languages activated...). It doesn't seem to be a font problem by the way...


(by the way : test : おはよう ございます。) :)

Thanks again for the topic :)
_________________
2.6.12-gentoo-r10 Celeron² 900 MHz - 768 Registered / ECC SDRAM - Matrox G450 / Geforce 2MX
2.6.24-gentoo-r3 sur IBM ThinkPad T23

Modano@jabber.org
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Sat Mar 05, 2005 4:00 pm    Post subject: Reply with quote

Modano wrote:
The export of XMODIFIERS=@im=SCIM and QT_IM_MODULE can be put in /etc/xprofile (for all users), in order to export these variables at X startup. But here, it seems it just ignored the xprofile contents, I still have to export by hand... Any other file I should use ? (xorg, xfce4)...

I exported LC_CTYPE=ja_JA.UTF-8 ans started oowriter...but no way to write Japanese under Normal openoffice 1.1.3 (Asian Languages activated...). It doesn't seem to be a font problem by the way...


/etc/env.d/02locale is a new section, so I'm glad that works for you. Because it works, try the following:

echo 'QT_IM_MODULE=SCIM' >> /etc/env.d/02locale
echo 'XMODIFIERS=@im=SCIM' >> /etc/env.d/02locale


Now, from a PM I sent a little while ago:

Quote:
Ok, let's try oo.org - I am pretty sure it's a font issue. open up a terminal and run oopadmin - or type "oo" and hit tab. I think it's spelled like that. You should find a button mentioning fonts - all of yours should be in /usr/share/fonts/, up to you to find the right one. Add all it can find, to be safe.

Then restart oowriter or somthing and test.


And it is ja_JP.UTF-8, not ja_JA.UTF-8. (thought you should try it after you have installed the fonts witout any extra exports)


-Sud.
_________________
...
Back to top
View user's profile Send private message
Modano
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2004
Posts: 109
Location: Montpellier, France

PostPosted: Sat Mar 05, 2005 11:25 pm    Post subject: Reply with quote

Thanks Sud :) I'll clear out that later.

I'm not understanding why Gjiten does not seem to see my attempt to use scim (ctrl+space)...Nothing happens...I can copy/paste from Kiten, which runs well, but no way I can use the IM in gjiten.
I exported GTK_IM_MODULE...but nothing ?
_________________
2.6.12-gentoo-r10 Celeron² 900 MHz - 768 Registered / ECC SDRAM - Matrox G450 / Geforce 2MX
2.6.24-gentoo-r3 sur IBM ThinkPad T23

Modano@jabber.org
Back to top
View user's profile Send private message
Modano
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2004
Posts: 109
Location: Montpellier, France

PostPosted: Sun Mar 06, 2005 12:32 am    Post subject: Reply with quote

Mea Culpa, didn't exported properly the QT/GTK_IM_MODULE environment variables. Thanks a lot to this topic again :)
Love testing in gjiten/kiten etc :) like a child :p
_________________
2.6.12-gentoo-r10 Celeron² 900 MHz - 768 Registered / ECC SDRAM - Matrox G450 / Geforce 2MX
2.6.24-gentoo-r3 sur IBM ThinkPad T23

Modano@jabber.org
Back to top
View user's profile Send private message
Greisby
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jun 2003
Posts: 87
Location: Germany

PostPosted: Thu Mar 24, 2005 1:45 pm    Post subject: Reply with quote

Cool thread. I have now japanese.
But... dead keys and compose key doesn't work anymore.

Perhaps due to the fact that I have a german keyboard, but skim has only the following menu entries :
English/Keyboard -> English/European
English (American) -> M17N-en-ispell
Japanese -> lots of entries
Other -> unicode & raw code
Keyboard

Any clue why I don't have a German entry?

Here is my .xprofile :
Code:
export XPSERVERLIST="`/bin/sh /usr/sbin/xprint get_xpserverlist`"
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_SWITCHER=imsw-multi
export QT_IM_MODULE=scim


Here my .xinitrc :
Code:
export LANG="en_US.UTF-8"
export LC_CTYPE="en_US.UTF-8"


Extract from xorg.conf:
Code:
Section "InputDevice"
        Identifier  "Keyboard[0]"
        Driver      "kbd"
        Option      "Vendor"     "Dell"
        Option      "Name"       "Dell Keyboard"
        Option      "XkbLayout"  "de"
        Option      "XkbModel"   "pc105"
        Option      "XkbOptions" "compose:rwin"

        Option      "AutoRepeat" "500 5"
EndSection


And in KDE I have
-keyboard layout set to German with basic layout
-xkb options:
+Compose
+Right win key is compose
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Thu Mar 24, 2005 3:34 pm    Post subject: Reply with quote

Greisby wrote:
Cool thread. I have now japanese.
But... dead keys and compose key doesn't work anymore.

Perhaps due to the fact that I have a german keyboard, but skim has only the following menu entries :
English/Keyboard -> English/European
English (American) -> M17N-en-ispell
Japanese -> lots of entries
Other -> unicode & raw code
Keyboard

Any clue why I don't have a German entry?


Plain old "Keyboard" should work just fine for your dead keys. It could be labeled "Raw input", but more prople understand "Keyboard". :P

A suggestion: remove the xinitrc lines:
export LANG="en_US.UTF-8"
export LC_CTYPE="en_US.UTF-8"

make a file called /etc/env.d/02locale
and put the following lines in it:
LANG="en_US.UTF-8"
LC_CTYPE="de_DE.UTF-8"

then etc-update and restart X.


This might help with the keyboard without changing your language - if not, change the /etc/env.d/02locale's LC_CTYPE back to American English.


(the oft confused) -Sud.
_________________
...
Back to top
View user's profile Send private message
Greisby
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jun 2003
Posts: 87
Location: Germany

PostPosted: Thu Mar 24, 2005 7:36 pm    Post subject: Reply with quote

Ok thanks. I'll try that tuesday.
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Thu Mar 24, 2005 8:06 pm    Post subject: Reply with quote

Sudrien wrote:
make a file called /etc/env.d/02locale
and put the following lines in it:
LANG="en_US.UTF-8"
LC_CTYPE="de_DE.UTF-8"

then etc-update and restart X.
Where did you get the 02 in 02locale, if I may ask.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Sat Mar 26, 2005 5:51 am    Post subject: Reply with quote

maiku wrote:
Sudrien wrote:
make a file called /etc/env.d/02locale
and put the following lines in it:
LANG="en_US.UTF-8"
LC_CTYPE="de_DE.UTF-8"

then etc-update and restart X.
Where did you get the 02 in 02locale, if I may ask.


If you try that and run emerge you'll get errors =\...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, ... 10, 11, 12  Next
Page 2 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum