Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TOOL]-Unclepine-Recursive Unmerge & Cleaning Tool _b18
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Thu Apr 28, 2005 6:06 pm    Post subject: Reply with quote

qpkg is going away...

anyway equery depends doesn't work very well for me...
i compared unclepine and equery results and sometime they differ...

so.. i looked "manually" and found that unclepine was right..

did anybody else notice that?
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Kagerato
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2004
Posts: 81

PostPosted: Wed May 04, 2005 7:47 pm    Post subject: Reply with quote

Yeah, I seem to have come across what I can only deem as bugs in equery's reverse-dependency calculation. It identifies certain packages as dependent when they are not. for example. Examine "equery depends glib" for a practical manifestation of the problem. On my system, this reports gcc. However, gcc is not built with the gtk USE flag and therefore should have no dependency or dynamic linking of any sort related to glib.

qpkg did not make such a reporting, if I remember correctly.

In any case, unclepine seems to be a better tool overall. I never much liked the way equery outputted dependency information, either.
Back to top
View user's profile Send private message
kompressor
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2003
Posts: 127
Location: Randolph, VT

PostPosted: Fri May 13, 2005 2:03 pm    Post subject: Reply with quote

unclepine -u
Code:
~ Version 0.1_beta18

Analyzing....Please Wait
If you feel bored launch it with -v switch!


!!! Critical Error
!!! You miss this file : /var/db/pkg/dev-libs/glib-1.2.10-r5/DEPEND


emerge -s glib
Code:
 dev-libs/glib
      Latest version available: 2.6.4
      Latest version installed: 2.6.4
      Size of downloaded files: 2,321 kB
      Homepage:    http://www.gtk.org/
      Description: The GLib library of C routines
      License:     LGPL-2


Im a little hesitant to remerge glib-1.2.10-r5 just to fix this. Since emerge says I have 2.6.4 installed couldn't just deleteing /var/db/pkg/dev-libs/glib-1.2.10-r5 directory solve this problem?

or is it possible to have two different versions installed?

Rick S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Fri May 13, 2005 2:41 pm    Post subject: Reply with quote

it's better if you re-emerge it :)

yes.. slotted packages can co-exist.

bye
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Sat Jun 04, 2005 9:35 am    Post subject: Reply with quote

The following is when run in mixed mode
Code:
p4pe ~ # uncle -df qt
...
...
~ Version 0.1_beta18

Analyzing....Please Wait
If you feel bored launch it with -v switch!

Traceback (most recent call last):
  File "/root/unclepine", line 1585, in ?
    main()
  File "/root/unclepine", line 1537, in main
    resolve_deps()
  File "/root/unclepine", line 713, in resolve_deps
    database[x]=get_exact_deps(database[x],x)
  File "/root/unclepine", line 745, in get_exact_deps
    if x.strip(' ') and isvalidatom(x):
  File "/usr/lib/portage/pym/portage.py", line 3049, in isvalidatom
    mycpv_cps = catpkgsplit(dep_getcpv(atom))
  File "/usr/lib/portage/pym/portage.py", line 3578, in dep_getcpv
    if mydep[-1]=="*":
IndexError: string index out of range

and this in local mode..
Code:
p4pe ~ # uncle -df qt
...
...
~ Version 0.1_beta18

Analyzing....Please Wait
If you feel bored launch it with -v switch!


x11-libs/qt-3.3.4-r4
HAS THESE DEPENDENCIES:
        * media-libs/freetype-2.1.9-r1 (WS)
        * media-libs/glut-3.7.1 (W)
        * media-libs/jpeg-6b-r4 (W)
        * media-libs/libmng-1.0.4 (W)
        * media-libs/libpng-1.2.8 (WS)
        * media-libs/nas-1.7-r1 (W)
        * media-video/nvidia-glx-1.0.7664 (W)
        * net-print/cups-1.1.23-r2 (W)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/zlib-1.2.2 (S)
        * x11-base/xorg-x11-6.8.2-r1 (WS)

* ENTRY IN WORLD FILE

what could be causing the mixed mode problem?

I have 2 copies of the same version of gentoo accessing the same portage partition btw, and the same version of unclepine works ok in mixed mode when running on the other copy.

Mvh
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Jun 06, 2005 8:38 am    Post subject: Reply with quote

there's something strange in portage cache or something i didn't code well :lol:

maybe try with --debug and see where it stops.
Thank You

bye ;)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Mon Jun 06, 2005 10:22 am    Post subject: Reply with quote

Hei xchris

It stops with
Code:

Resolving DB package: media-libs/flac-1.1.2
   Resolving atom: *

I see there are 2 versions of flac installed according to eix..
Code:
# eix flac
* media-libs/flac
     Available versions:  1.1.0 1.1.0-r2 1.1.1 ~1.1.2-r1
     Installed:           1.1.2-r1 1.1.2

and porthole shows
Code:
Installed versions:
   Slot 0: 1.1.2-r1
   Slot : (1.1.2)

whatever that means...
if I pretend to unmerge flac it shows
Code:
# emerge -Cpv flac

>>> These are the packages that I would unmerge:

 media-libs/flac
    selected: 1.1.2-r1 1.1.2
   protected: none
     omitted: none

I'll wait until I hear from you before doing that tho'.
Mvh
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Jun 06, 2005 10:38 am    Post subject: Reply with quote

inspect this

Code:

/var/cache/edb/dep/usr/portage/media-libs/flac-1.1.2-r1


and see if it is corrupted...
maybe try a resync

bye :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Mon Jun 06, 2005 10:43 am    Post subject: Reply with quote

my portage is on hdb9..
Code:
# cat /var/cache/edb/dep/mnt/hdb9/portage/media-libs/flac-1.1.2-r1
ogg? ( >=media-libs/libogg-1.0_rc2 ) xmms? ( media-sound/xmms ) x86? ( dev-lang/nasm ) sys-apps/gawk doc? ( app-doc/doxygen ) !bootstrap? ( sys-devel/patch ) !bootstrap? ( sys-devel/patch )
ogg? ( >=media-libs/libogg-1.0_rc2 ) xmms? ( media-sound/xmms )
0
mirror://sourceforge/flac/flac-1.1.2.tar.gz

http://flac.sourceforge.net/
GPL-2 LGPL-2
free lossless audio encoder which includes an XMMS plugin
~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86
libtool multilib eutils flag-o-matic multilib eutils multilib toolchain-funcs multilib
3dnow debug doc ogg sse xmms debug

by resync do you mean emerge sync? because I did that this morning at 7am already.
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Jun 06, 2005 10:50 am    Post subject: Reply with quote

yes i meant an emerge sync...
but now i don't think it's the solution.

I would do:

Code:

quickpkg flac


so you have your binaries ready to be re-emerged.

and then remove the 1.1.2...

let me know :)

(i think there's a bad written dep string or maybe i did an error...)


EDIT: did you change your cache path recently? because unclepine is a little bit dumb and uses a fixed path.... (i will change it)

thank you :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Mon Jun 06, 2005 11:28 am    Post subject: Reply with quote

OK I did it as you asked above
Code:
# emerge -Cv =media-libs/flac-1.1.2

and all is now well with mixed doing '-db qt' & '-db flac' et al.
Many thanks :-)
Regards
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Jun 06, 2005 1:14 pm    Post subject: Reply with quote

good :)

however i must double check possible path issues.
(i did a 12 hour train travel... so... today i'm a little bit confused :))

bye and thanks!
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Jun 09, 2005 7:35 pm    Post subject: Reply with quote

xchris wrote:
good :)

however i must double check possible path issues.
(i did a 12 hour train travel... so... today i'm a little bit confused :))

bye and thanks!

Hei xchris

Have just upgraded to python-2.4.1 and, after a large python-updater cleanup, unclepine is giving me:
Code:
root@p4pe ~ # /root/unclepine -db qt
Segmentation fault

Should unclepine work OK with 2.4.1 OK?
Mvh

Edit: btw, etcat, usetool and portage_syntax_checker.py work OK still.. 'unclepine -h' does too.
More research.. running 'idle' the path browser doesn't show usetool (which works) or unclepine in /root or a copy I put in /bin, but it does show portage_syntax_checker.py..?
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Fri Jun 10, 2005 6:51 am    Post subject: Reply with quote

you have to upgrade psyco..

i guess you're using it... am I wrong?

Bye :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Fri Jun 10, 2005 8:11 am    Post subject: Reply with quote

xchris wrote:
you have to upgrade psyco..

i guess you're using it... am I wrong?

Bye :)

Ah! I think you are probably right..
it fails on two Gentoo copies, but works on the one I'm currently using, which I see doesn't have psyco. kio-locate shows me that the other two do, so I'll nip over and update them.
Thanks :-)

Well, before nipping off, I installed psyco-1.2 on this partition and get the same segmentation fault.
Updated it to 1.4 and all is well again!
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Fri Jun 10, 2005 8:44 am    Post subject: Reply with quote

yes.. somebody in Italian forum reported me this problem.

you need psyco 1,4 :)

Bye ;)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Dr-Munir
n00b
n00b


Joined: 14 Jun 2005
Posts: 17

PostPosted: Wed Oct 05, 2005 9:48 am    Post subject: Reply with quote

Code:
Goofy unclepine-release-0.1 # ./unclepine -u -d

                ********************** WARNING **************************
                *                 USE AT YOUR OWN RISK!!!!!             *
                *                                                       *
                * MISUSE OF THIS TOOL CAN BREAK YOUR GENTOO             *
                * ESPECIALLY IF NOT WELL MANTAINED                      *
                *********************************************************
         (__) *
         (@@)
  /-------\/
 / |Larry||
*  ||----||
   ^^    ^^             ~ http://www.xchris.net ~



~ Version 0.1_beta18

Analyzing....Please Wait
If you feel bored launch it with -v switch!


Unlinked Packages: 77

        * app-arch/ncompress-4.2.4-r1
        * app-crypt/gnupg-1.2.6
        * app-crypt/gpgme-0.9.0-r1
        * app-crypt/qca-1.0-r2
        * app-crypt/qca-tls-1.0-r2
        * app-dicts/aspell-en-0.51.1
        * app-office/openoffice-bin-1.1.4
        * app-shells/sash-3.7
        * app-shells/tcsh-6.12-r3
        * app-text/aspell-0.50.5-r4
        * app-text/enchant-1.1.3
        * app-text/gtkspell-2.0.4-r1
        * app-text/xpdf-3.00-r8
        * dev-lang/ocaml-3.08.1
        * dev-libs/fribidi-0.10.4
        * dev-libs/libgcrypt-1.1.94
        * dev-libs/libgpg-error-1.0-r1
        * dev-libs/libpcre-5.0
        * dev-libs/libxslt-1.1.9-r1
        * dev-libs/nspr-4.4.1-r2
        * dev-libs/nss-3.9.2-r2
        * dev-ml/lablgl-1.00
        * dev-ml/lablgtk-1.2.7
        * dev-python/dnspython-1.3.3
        * dev-python/numeric-23.7
        * dev-python/pygtk-2.6.1
        * dev-python/pyopengl-2.0.0.44
        * kde-base/arts-1.3.2
        * kde-base/kde-3.3.2
        * kde-base/kde-env-3-r3
        * kde-base/kdeaccessibility-3.3.2
        * kde-base/kdeaddons-3.3.2
        * kde-base/kdeadmin-3.3.2
        * kde-base/kdeartwork-3.3.2
        * kde-base/kdebase-3.3.2-r1
        * kde-base/kdeedu-3.3.2-r1
        * kde-base/kdegames-3.3.2
        * kde-base/kdegraphics-3.3.2-r2
        * kde-base/kdelibs-3.3.2-r5
        * kde-base/kdemultimedia-3.3.2
        * kde-base/kdenetwork-3.3.2
        * kde-base/kdepim-3.3.2
        * kde-base/kdetoys-3.3.2
        * kde-base/kdeutils-3.3.2
        * kde-base/kdewebdev-3.3.2
        * media-gfx/xloadimage-4.1-r2
        * media-libs/audiofile-0.2.6-r1
        * media-libs/giflib-4.1.3
        * media-libs/imlib-1.9.14-r3
        * media-libs/libao-0.8.5
        * media-libs/libart_lgpl-2.3.16
        * media-libs/libid3tag-0.15.1b
        * media-libs/libmad-0.15.1b
        * media-libs/libmikmod-3.1.11-r1
        * media-libs/libsdl-1.2.7-r3
        * media-libs/smpeg-0.4.4-r6
        * media-libs/svgalib-1.9.19-r3
        * media-libs/t1lib-5.0.2
        * media-libs/taglib-1.3.1
        * media-libs/tunepimp-0.3.0
        * media-sound/esound-0.2.34
        * media-sound/lame-3.96.1
        * media-sound/vorbis-tools-1.0.1
        * media-sound/xmms-1.2.10-r5
        * net-im/gaim-1.1.4
        * net-mail/mailbase-0.00-r8
        * sys-apps/ed-0.2-r6
        * sys-apps/eject-2.0.13
        * sys-apps/miscfiles-1.3-r1
        * sys-apps/setserial-2.17-r3
        * sys-kernel/gentoo-sources-2.6.11-r3 (W):  old slot
        * sys-libs/db-4.1.25_p1-r4 (S):  old slot
        * x11-libs/gtk+-1.2.10-r11
        * x11-libs/gtkglarea-1.2.3-r1
        * x11-libs/gtkglarea-1.99.0
        * x11-libs/openmotif-2.2.3-r3
        * x11-libs/startup-notification-0.7



This was My OUtput.

do you think it is safe ?
_________________
When Everything is Meant To Be Broken, I Just Want To Know Who I Am.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 05, 2005 10:13 am    Post subject: Reply with quote

i really cannot answer...

it depends on your gentoo and how it's administered.. :)

I suggest to do a quickpkg on bigger packages.... for safeness

Bye
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Dr-Munir
n00b
n00b


Joined: 14 Jun 2005
Posts: 17

PostPosted: Wed Oct 05, 2005 10:45 am    Post subject: Reply with quote

Hello,

A quick Reply INdeed.

BUt first let me apologise for the ambiguity in my previous post.

That was my fault.

anways, I was concerned about all those packages because I had recently managed to update my system to kernel 2.6.12-gentoo-r10 and the above paackages.

starngely after merging them they didnt got added in the world file.

and Now I think this is the same reason why revdep-rebuild was giving me problems.

I am doing emerge --sync for the second time after my Gentoo INstallation,

When I followed you advice to create a check list and then add the checklist items to world file, my task was made easier.

I could easily identify the unwanted packages.

THat was the problem on my behalf.

Now , could you tell me how to find the packages left after an uninstallation?

let me give an example, I today emerge mldonkey and then unmerged it. some of the dpendecies which I remembered were located and unmerged when i used unclepine, but I have forgotten about other dependencies.. How to use this script to find them?

also how do I locate " Orphan " depndencies, which are not used anymore, but are just occupying the space on hard disk?

Thanks In Advance Chris.
_________________
When Everything is Meant To Be Broken, I Just Want To Know Who I Am.
Back to top
View user's profile Send private message
Dr-Munir
n00b
n00b


Joined: 14 Jun 2005
Posts: 17

PostPosted: Wed Oct 05, 2005 11:13 am    Post subject: Reply with quote

another question Please.

what do the terms (S), (W) and (WS) mean when I run ./unclepine -sd -su. Here are a few examples to illustrate my point.

Code:
x11-base/opengl-update-2.2.1 has these dependencies: 3

        * app-arch/bzip2-1.0.3-r5 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/glibc-2.3.5-r1 (WS)


x11-base/xorg-x11-6.8.2-r2 has these dependencies: 14

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-libs/expat-1.95.8 (S)
        * media-libs/fontconfig-2.2.3 (S)
        * media-libs/freetype-2.1.9-r1 (S)
        * media-libs/libpng-1.2.8 (S)
        * sys-apps/sed-4.1.4 (S)
        * sys-apps/util-linux-2.12i-r1 (S)
        * sys-devel/flex-2.5.4a-r6 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/ncurses-5.4-r6 (S)
        * sys-libs/zlib-1.2.3 (S)
        * x11-base/opengl-update-2.2.1 (S)
        * x11-misc/ttmkfdir-3.0.9-r3 (S)
        * x11-terms/xterm-200-r3 (S)


x11-libs/gtk+-1.2.10-r11 has these dependencies: 6

        * dev-libs/glib-1.2.10-r5
        * dev-util/intltool-0.34.1
        * sys-devel/gettext-0.14.4 (S)
        * sys-devel/gnuconfig-20050602 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)


x11-libs/gtk+-2.6.8 has these dependencies: 12

        * dev-libs/atk-1.10.1
        * dev-libs/glib-2.6.5
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * media-libs/jpeg-6b-r5
        * media-libs/libpng-1.2.8 (S)
        * media-libs/tiff-3.7.3
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)
        * x11-libs/pango-1.8.1-r1
        * x11-misc/shared-mime-info-0.16


x11-libs/gtkglarea-1.99.0 has these dependencies: 7

        * dev-util/pkgconfig-0.17.2-r1 (S)
        * media-libs/glut-3.7.1
        * sys-apps/sed-4.1.4 (S)
        * sys-devel/gnuconfig-20050602 (S)
        * sys-libs/glibc-2.3.5-r1 (WS)
        * x11-base/xorg-x11-6.8.2-r2 (WS)
        * x11-libs/gtk+-2.6.8 (W)


x11-libs/openmotif-2.2.3-r3 has these dependencies: 6

        * sys-apps/sed-4.1.4 (S)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.4_p6 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/glibc-2.3.5-r1 (WS)
        * x11-base/xorg-x11-6.8.2-r2 (WS)


x11-libs/pango-1.8.1-r1 has these dependencies: 7

        * dev-libs/glib-2.6.5
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * media-libs/fontconfig-2.2.3 (S)
        * media-libs/freetype-2.1.9-r1 (S)
        * sys-apps/sed-4.1.4 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)


x11-libs/qt-3.3.4-r3 has these dependencies: 10

        * dev-db/mysql-4.0.25-r2
        * media-libs/freetype-2.1.9-r1 (S)
        * media-libs/glut-3.7.1
        * media-libs/jpeg-6b-r5
        * media-libs/libmng-1.0.8-r1
        * media-libs/libpng-1.2.8 (S)
        * net-print/cups-1.1.23-r1
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/zlib-1.2.3 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)


x11-libs/startup-notification-0.7 has these dependencies: 1

        * x11-base/xorg-x11-6.8.2-r2 (WS)


x11-misc/shared-mime-info-0.16 has these dependencies: 5

        * dev-libs/glib-2.6.5
        * dev-libs/libxml2-2.6.20-r2
        * dev-util/intltool-0.34.1
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * sys-devel/patch-2.5.9 (S)


x11-misc/ttmkfdir-3.0.9-r3 has these dependencies: 6

        * media-libs/freetype-2.1.9-r1 (S)
        * sys-devel/flex-2.5.4a-r6 (S)
        * sys-devel/libtool-1.5.18-r1 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/glibc-2.3.5-r1 (WS)
        * sys-libs/zlib-1.2.3 (S)


x11-terms/xterm-200-r3 has these dependencies: 3

        * sys-apps/utempter-0.5.5.6 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)
kde-base/arts-1.3.2 has these dependencies: 17

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-libs/glib-2.6.5
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * kde-base/kde-env-3-r3 (W)
        * media-libs/audiofile-0.2.6-r1 (W)
        * media-libs/libid3tag-0.15.1b (W)
        * media-libs/libmad-0.15.1b (W)
        * media-libs/libogg-1.1.2
        * media-libs/libvorbis-1.1.0
        * media-sound/esound-0.2.34 (W)
        * sys-apps/portage-2.0.51.22-r2 (S)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/make-3.80-r2 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-kernel/gentoo-sources-2.6.12-r10 (W)
        * x11-libs/qt-3.3.4-r3


kde-base/kde-3.3.2 has these dependencies: 15

        * kde-base/kdeaccessibility-3.3.2 (W)
        * kde-base/kdeaddons-3.3.2 (W)
        * kde-base/kdeadmin-3.3.2 (W)
        * kde-base/kdeartwork-3.3.2 (W)
        * kde-base/kdebase-3.3.2-r1 (W)
        * kde-base/kdeedu-3.3.2-r1 (W)
        * kde-base/kdegames-3.3.2 (W)
        * kde-base/kdegraphics-3.3.2-r2 (W)
        * kde-base/kdelibs-3.3.2-r5 (W)
        * kde-base/kdemultimedia-3.3.2 (W)
        * kde-base/kdenetwork-3.3.2 (W)
        * kde-base/kdepim-3.3.2 (W)
        * kde-base/kdetoys-3.3.2 (W)
        * kde-base/kdeutils-3.3.2 (W)
        * kde-base/kdewebdev-3.3.2 (W)


kde-base/kde-env-3-r3 has these dependencies: 1

        * sys-apps/portage-2.0.51.22-r2 (S)


kde-base/kdeaccessibility-3.3.2 has these dependencies: 9

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * kde-base/kde-env-3-r3 (W)
        * kde-base/kdelibs-3.3.2-r5 (W)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/make-3.80-r2 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-libs/qt-3.3.4-r3


kde-base/kdeaddons-3.3.2 has these dependencies: 16

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * kde-base/arts-1.3.2 (W)
        * kde-base/kde-env-3-r3 (W)
        * kde-base/kdelibs-3.3.2-r5 (W)
        * kde-base/kdemultimedia-3.3.2 (W)
        * kde-base/kdepim-3.3.2 (W)
        * media-libs/libsdl-1.2.7-r3 (W)
        * media-libs/svgalib-1.9.19-r3 (W)
        * media-sound/esound-0.2.34 (W)
        * media-sound/xmms-1.2.10-r5 (W)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/make-3.80-r2 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-libs/qt-3.3.4-r3


kde-base/kdeadmin-3.3.2 has these dependencies: 11

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * kde-base/kde-env-3-r3 (W)
        * kde-base/kdebase-3.3.2-r1 (W)
        * kde-base/kdelibs-3.3.2-r5 (W)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/make-3.80-r2 (S)
        * sys-devel/patch-2.5.9 (S)
        * sys-libs/pam-0.78-r2 (S)
        * x11-libs/qt-3.3.4-r3


kde-base/kdeartwork-3.3.2 has these dependencies: 11

        * dev-lang/perl-5.8.6-r5 (S)
        * dev-util/pkgconfig-0.17.2-r1 (S)
        * kde-base/kde-env-3-r3 (W)
        * kde-base/kdebase-3.3.2-r1 (W)
        * kde-base/kdelibs-3.3.2-r5 (W)
        * sys-devel/autoconf-2.59-r6 (S)
        * sys-devel/automake-1.9.6 (S)
        * sys-devel/make-3.80-r2 (S)
        * sys-devel/patch-2.5.9 (S)
        * x11-base/xorg-x11-6.8.2-r2 (WS)
        * x11-libs/qt-3.3.4-r3


_________________
When Everything is Meant To Be Broken, I Just Want To Know Who I Am.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 05, 2005 12:02 pm    Post subject: Reply with quote

Dr-Munir wrote:
Hello,

A quick Reply INdeed.


you're right..
but you didn't explain that much :) (as you stated)

Dr-Munir wrote:

starngely after merging them they didnt got added in the world file.

and Now I think this is the same reason why revdep-rebuild was giving me problems.

This is very strange..
How did you emerged them?

Dr-Munir wrote:

Now , could you tell me how to find the packages left after an uninstallation?


Two approches:

use --deep-unmerge package (before removing it)
use --unlinked (after having removed it phisically or from world file)

Second one will find ALL orphans... so it will find also pending dependencies...

W: means it is in world file
S: means it is in System Profile (but sometimes it is not perfect... due to OR dependencies... it'a little bit complicated to explain)


however...
PAY ATTENTION! Unclepine is an unsupported Software and maybe UNRELIABLE!!!
You should alway DOUBLE-CHECK :)

(excuse my disclaimer but i do not want to break your gentoo ;) )

Bye
xchris
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Dr-Munir
n00b
n00b


Joined: 14 Jun 2005
Posts: 17

PostPosted: Wed Oct 05, 2005 1:06 pm    Post subject: Reply with quote

xchris wrote:

This is very strange..
How did you emerged them?


I believe for most of them I used the packages CD that came with the Universal Installation CD.

and others were emerged after I ran emerge --sync , and then emerge -auftDN world.

I just dun know why they were not added to world file.

Though after every emerge the system told me that it was added to world file.

may be its another world file?

how can I check if there are many world files on MY system in different locations?

Code:
>> /usr/share/doc/psyco-1.4/examples/test5.py
>>> /usr/share/doc/psyco-1.4/COPYING.txt.gz
>>> /usr/share/doc/psyco-1.4/MANIFEST.gz
>>> /usr/share/doc/psyco-1.4/README.txt.gz
 * Byte compiling python modules for python-2.3 .. ...                                                                                                   [ ok ]
>>> Regenerating /etc/ld.so.cache...
>>> dev-python/psyco-1.4 merged.
>>> Recording dev-python/psyco in "world" favorites file...



See?

But its not there in world file!!!!

/var/lib/portage/world . if this is the file we are talking about
_________________
When Everything is Meant To Be Broken, I Just Want To Know Who I Am.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Oct 05, 2005 3:51 pm    Post subject: Reply with quote

which is your world file path?

if it is not recording in world file... it's a portage bug... but i've never seen it!
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
radfoj
Guru
Guru


Joined: 31 Dec 2004
Posts: 490
Location: Tísek, Czech Republic

PostPosted: Sun Oct 09, 2005 12:27 am    Post subject: Reply with quote

Hi,

dev-lang/python-2.4.1-r1 was marked stable few hours ago, so I emerged it and run /usr/sbin/python-updater then.

Now, running unclepine gives me:

Code:
# unclepine -u
Neoprávněný přístup do paměti (SIGSEGV)
#

# export LANG=en_US
# unclepine -u
Segmentation fault
#


Is it related to python upgrade? Any workaround? Its hard for me to imagine life without unclepine :D ..... Thanks
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Oct 10, 2005 8:33 am    Post subject: Reply with quote

Upgrade your psyco... :)

read few post up :)

Bye ;)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 6 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum