Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RAID 5 wird nicht gemounet START_ARRAY ioctl - HPT374
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ank666
Guru
Guru


Joined: 12 May 2004
Posts: 319
Location: CO/BY/DE

PostPosted: Thu Nov 03, 2005 10:07 pm    Post subject: RAID 5 wird nicht gemounet START_ARRAY ioctl - HPT374 Reply with quote

Hi,

brauche Hilfe, bei mir brennt es ziemlich, auf Grund eines Stromausfalls, werden meine beiden RAID5 Arrays nicht mehr gemountet,
beide Arrays bilden ein LVG per LVM und werden per NFS geshared.

Code:
/etc/raidtab
#/srv (RAID 5)
raiddev                 /dev/md8
raid-level              5
nr-raid-disks           4
nr-spare-disks          0
chunk-size              64
persistent-superblock   1
device                  /dev/hdf
raid-disk               0
device                  /dev/hdh
raid-disk               1
device                  /dev/hdj
raid-disk               2
device                  /dev/hdl
raid-disk               3

#/srv (RAID 5)
raiddev                 /dev/md9
raid-level              5
nr-raid-disks           4
nr-spare-disks          0
chunk-size              64
persistent-superblock   1
device                  /dev/hde
raid-disk               0
device                  /dev/hdg
raid-disk               1
device                  /dev/hdi
raid-disk               2
device                  /dev/hdk
raid-disk               3


Beim Controller handelt es sich um einen HPT370, allerdings sind an ihm nur die Platten angeschlossen, die Verwaltung etc übernimmt dabei der Kernel.
RAID bus controller: Triones Technologies, Inc. HPT374 (rev 07)

Fehler lt. dmesg bzw. syslog ist
Code:
devfs_mk_dev: could not append to parent for md/8
md: raidstart(pid 5083) used deprecated START_ARRAY ioctl. This will not be supported beyond 2.6
md: could not open unknown-block(1,182).
md: autostart failed!
devfs_mk_dev: could not append to parent for md/9
md: raidstart(pid 5083) used deprecated START_ARRAY ioctl. This will not be supported beyond 2.6
md: could not open unknown-block(1,182).
md: autostart failed!


Hat jemand sachdienliche Hinweise für mich?
_________________
Auf der Verpackung stand benötigt Windows 9x/2000/XP oder BESSER, deshalb hab ich Linux installiert
Back to top
View user's profile Send private message
ank666
Guru
Guru


Joined: 12 May 2004
Posts: 319
Location: CO/BY/DE

PostPosted: Fri Nov 04, 2005 11:16 am    Post subject: Reply with quote

Dann eben ein Monolog...

Wie kann man sich den Status eines RAID anzeigen lassen,
möchte mal wissen ob evtl. Platten beim Crash gestorben sind.

Habe die raidtools und mdadm installiert, aber beides ist nicht so verbose,
da er nicht auf die /dev/hd* Devices kommt?!
_________________
Auf der Verpackung stand benötigt Windows 9x/2000/XP oder BESSER, deshalb hab ich Linux installiert
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1149

PostPosted: Fri Nov 04, 2005 5:55 pm    Post subject: Reply with quote

ank666 wrote:
[url]
Habe die raidtools und mdadm installiert, aber beides ist nicht so verbose,
da er nicht auf die /dev/hd* Devices kommt?!


Es wäre schon interessant die Meldungen zu sehen. Ich denke als erstes übrigens nicht an das Raid sondern an das LVM, das abgeschmiert ist.

[EDIT]
cat /proc/mdstat wäre eine Möglichkeit.

[Noch ein EDIT]
Wenig erbauliches zu LVM. Siehe letzter Satz von 1.1
Quote:
Jedoch steigt analog zu RAID 0 die Ausfallwahrscheinlichkeit, wenn sich das Dateisystem und die darunter befindliche virtuelle Partition über mehrere Festplatten erstreckt, da nur eine Festplatte ausfallen muss, um die ganzen Daten zu verlieren.

_________________
Test Adobe Flash Player
The Indian Shankar Drum Ganesh Machine
Back to top
View user's profile Send private message
ank666
Guru
Guru


Joined: 12 May 2004
Posts: 319
Location: CO/BY/DE

PostPosted: Sat Nov 05, 2005 11:49 am    Post subject: Reply with quote

Marlo wrote:
Es wäre schon interessant die Meldungen zu sehen. Ich denke als erstes übrigens nicht an das Raid sondern an das LVM, das abgeschmiert ist.

raidstart liefert nur invalid argument

Marlo wrote:
cat /proc/mdstat wäre eine Möglichkeit.

Nichts! Die beiden Arrays werden nicht mehr angezeigt

Marlo wrote:
Wenig erbauliches zu LVM. Siehe letzter Satz von 1.1
Quote:
Jedoch steigt analog zu RAID 0 die Ausfallwahrscheinlichkeit, wenn sich das Dateisystem und die darunter befindliche virtuelle Partition über mehrere Festplatten erstreckt, da nur eine Festplatte ausfallen muss, um die ganzen Daten zu verlieren.

Deshalb erstreckt sich das LVM ja über zwei RAID5 Arrays um die Fehlertoleranz zu erhöhen,
IMHO können gleichzeitig 2 HDDs ausfallen (1x pro RAID5) ohne das es das LVM beeinträchtigen würde.
_________________
Auf der Verpackung stand benötigt Windows 9x/2000/XP oder BESSER, deshalb hab ich Linux installiert
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum