Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ÅÄÖ-problem som root
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Lillstrumpa
n00b
n00b


Joined: 10 Dec 2003
Posts: 29
Location: Örebro, Sweden

PostPosted: Tue Nov 23, 2004 1:12 pm    Post subject: ÅÄÖ-problem som root Reply with quote

Har ett litet underligt problem.

När jag använder Gnome-konsollen och skriver t.ex. å och sen ska radera bort det (backspace) så kan jag sudda två steg tillbaka istället för bara ett, resultatet blir alltså att jag kommer för långt tillbaka. För varje å ä eller ö jag skriver jag jag radera bort ett extra tecken, alltså åäö gör att jag är inne och suddar på själva prompten..

Det här uppträder bara när jag är inloggad som root.

Har även problem med output från kompilering m.m., där visas alla svenska tecken som fyrkanter.

I konsoll-läge fungerar allt bra. Och i program verkar det inte vara något problem heller.

$ locale ger följande:
Code:
LANG=sv_SE.UTF-8
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE


rc.conf
Code:
KEYMAP="sv-latin1"

SET_WINDOWKEYS="no"

EXTENDED_KEYMAPS=
#EXTENDED_KEYMAPS="backspace keypad"

CONSOLEFONT="lat9v-14"

CONSOLETRANSLATION="8859-1_to_uni"


exempel på output-problemet (visas inte med fyrkant här dock)
Code:
$ su
Password:
su: Authentication failure
Tyv�rr.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Sat Nov 27, 2004 11:50 am    Post subject: Reply with quote

Problemet är att du blandar UTF-8 med ISO-8859-1. Exempelvis raderar backspace en byte, medan åäö är två byte i UTF-8. Samma sak bör hända med piltangenterna.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Lillstrumpa
n00b
n00b


Joined: 10 Dec 2003
Posts: 29
Location: Örebro, Sweden

PostPosted: Wed Dec 01, 2004 11:59 am    Post subject: Reply with quote

Har inte så stor koll så skulle du / nån kunna ge tips om vad jag kan ändra på?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Wed Dec 01, 2004 1:15 pm    Post subject: Reply with quote

Jag skulle rekommendera samma inställning på LANG och LC_ALL. Kolla även
Code:
locale charmap

och inställningarna i gnome-terminal (Terminal > Set Character Encoding).
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum