Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Some ebuilds won't compile ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
quarus
n00b
n00b


Joined: 12 May 2002
Posts: 39

PostPosted: Wed May 15, 2002 2:57 pm    Post subject: Some ebuilds won't compile ? Reply with quote

Hi !

I have problems with 2 ebuilds, which won't compile (ZNES and celestia).
Configure is creating a Makefile, but the compilation quits after a while.
The error messages don't tell me, why compilation stops.
I know there are many reasons for this , but what could be the most probable ?
Are some of my packages too old ?
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Fri May 17, 2002 12:28 pm    Post subject: Reply with quote

Can you post some of the error messages? It is hard to help with so little info.
Back to top
View user's profile Send private message
quarus
n00b
n00b


Joined: 12 May 2002
Posts: 39

PostPosted: Mon May 20, 2002 4:32 pm    Post subject: Reply with quote

You're right, sorry.
Well, i waited a few days and now at least ZSNES compiles and works. (I really would like to know what the problem was). However celestia still won't compile. I guess it has something to do with this "previous declaration of '---------" error. I get tons of messages this kind.

glext.h:606: `void (* glVertexAttribs4ubvNV)(unsigned int, int, const GLubyte *)' redeclared as different kind of symbol
/usr/include/GL/gl.h:2767: previous declaration of `void glVertexAttribs4ubvNV(unsigned int, int, const GLubyte *)'
glext.h:620: `void (* glColorTableEXT)(unsigned int, unsigned int, int, unsigned int, unsigned int, const GLvoid *)' redeclared as different kind of symbol
/usr/include/GL/gl.h:2158: previous declaration of `void glColorTableEXT(unsigned int, unsigned int, int, unsigned int, unsigned int, const GLvoid *)'
make[3]: *** [3dsmesh.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/celestia-1.2.4/work/celestia-1.2.4/src/celengine'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/celestia-1.2.4/work/celestia-1.2.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/celestia-1.2.4/work/celestia-1.2.4'
make: *** [all-recursive-am] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 24, Exitcode 2
!!! (no error message)

Any idea ?
Back to top
View user's profile Send private message
gregcoit
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2002
Posts: 101

PostPosted: Thu Jun 20, 2002 11:53 pm    Post subject: fix for celestia Reply with quote

This post (http://forums.gentoo.org/viewtopic.php?t=2133&highlight=celestia) has the answer as to why celestia won't compile and includes the fix!
_________________
"Life would be so much easier if we could see the source code"
Back to top
View user's profile Send private message
quarus
n00b
n00b


Joined: 12 May 2002
Posts: 39

PostPosted: Wed Jun 26, 2002 1:40 pm    Post subject: Reply with quote

Thanks gregcoit !
I'll try it !
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Wed Jun 26, 2002 5:42 pm    Post subject: Reply with quote

That fix works fine, too bad everything isn't that simple :)
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum