Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TOOL] - Unclepine - Dipendenze e Pulizia _beta18
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 13, 14, 15  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Sun Mar 13, 2005 1:25 pm    Post subject: Reply with quote

Gaspyd wrote:
Ho tentato con -su -du idesk è mi ha suggerito la disinstallazione di startup-notifications
Solo che il pacchetto era necessario a gaim ..... :?
Cmq a parte questo piccolo inconveniente, si è sempre comportato benissimo, mi ha tolto l'inero gnome senza danni :)

Può essere che come nel mio caso si tratti di un bug da qualche parte ;)
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Sun Mar 13, 2005 1:35 pm    Post subject: Reply with quote

lavish wrote:

Può essere che come nel mio caso si tratti di un bug da qualche parte ;)

Era cmq la beta15 ora ho piazzato la 16 e cmq cerco sempre di monitorarne il comportamento. Ottimo tool strano che non venga inserito
di default nel portage
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Sun Mar 13, 2005 1:41 pm    Post subject: Reply with quote

casi come questi sono spesso dovuti a ebuild scritti male.

Unclepine e' molto conservativo...soprattutto in mix mode!

ispeziona l'ebuild di gaim e se pensi che unclepine sia in torto non esitare a postare :)

ciao e grazie a tutti!


edit:

mi sono dimenticato di dire che -cn supporta -x (exec)

Code:

unclepine -cn -x > download
. download


recupera la versione aggiornata.
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Sun Mar 13, 2005 1:46 pm    Post subject: Reply with quote

xchris wrote:

ispeziona l'ebuild di gaim e se pensi che unclepine sia in torto non esitare a postare :)

Non sono un'esperto ma effettivamente non mi sembra ci siano riferimenti a startup-notifications nell'ebuild in questione :roll:
Back to top
View user's profile Send private message
btbbass
Apprentice
Apprentice


Joined: 15 Feb 2005
Posts: 287
Location: Asti o Torino

PostPosted: Sun Mar 13, 2005 9:15 pm    Post subject: Reply with quote

E' un pò che uso lo zio Pino , e sono sempre più convinto che debba essere messo in portage, in mezzo ai gentools (ammesso che nn lo sia già...), o come pacchetto indipendente!!!
Semplice e infallibile :!:
_________________
Chi dice che è impossibile non interrompa chi lo sta facendo

-Proverbio Cinese -
___________________________________
Back to top
View user's profile Send private message
=DvD=
Veteran
Veteran


Joined: 25 Mar 2004
Posts: 1338
Location: ITALY between Pisa and Versilia

PostPosted: Sun Mar 13, 2005 9:44 pm    Post subject: Reply with quote

Gentoo non sarebbe la stessa senza lo zio (e senza xchris ;) ) per me.
_________________
Guida per i nuovi arrivati a.k.a. Potresti avere la risposta tra le mani
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Mar 14, 2005 7:27 am    Post subject: Reply with quote

cosi' mi fate arrossire :oops:

cmq a scanso di equivoci vorrei dire che unclepine non e' infallibile..

a volte sbaglia pure lui.
Il punto e' che quando fallisce, fallisce in modo abbastanza safe (o per lo meno spero)

Puo' capitare che non elenchi qualche cosa per la rimozione.
(non dovrebbe invece capitare che elenchi qualche cosa di necessario)

Se vi interessa posto piu' tardi l'elenco delle magagne e il funzionamento di base. (per chi non avesse voglia di spulciarsi il corposo (ormai) source)


ciao e grazie ancora :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Mon Mar 14, 2005 7:45 am    Post subject: Reply with quote

xchris wrote:
Se vi interessa posto piu' tardi l'elenco delle magagne e il funzionamento di base. (per chi non avesse voglia di spulciarsi il corposo (ormai) source)

A me interesserebbe molto (lo so che ti porterebbe via un bel pò di tempo :oops: )
Quote:

ciao e grazie ancora :)

Uhè scherziamo?! Grazie a te!!! :D

;)
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
mouser
Veteran
Veteran


Joined: 10 Aug 2004
Posts: 1418
Location: Milano

PostPosted: Mon Mar 14, 2005 8:36 am    Post subject: Reply with quote

=DvD= wrote:
Cazzantonio wrote:
Anch'io non uso le gui... solo che a forza di usare tutti il terminale (o la console) ci si becca la flag di "distribuzione difficile" :roll:
Le gui a qualcuno piacciono e servono, per cui ben vengano... dov'era che avevo letto "gentoo is all about choices" o qualcosa di simile? :roll: :D

Mi inchino. :D

Anch'io non utilizzo mai le gui...... ed in effetti, l'unico motivo per cui installo un'interfaccia grafica e' per avere tanti e tanti terminali aperti contemporaneamete....
Mi trovo pero' a vivere in casa con un fratello che "preferisce installare mandrake" perche', anche se di buona volonta', "gentoo e' difficile da usare"!
Io gli ho spiegato che sono 2/3 comandi da imparare per utilizzare gentoo, e tutto il resto non cambia da altre distro, ma, come disse qualcuno, "E' piu' facile spezzare un atomo che combattere un pregiudizio" (Albert Einstein).
Insomma, anch'io non userei la gui, ma per le persone similari a mio fratello, sarebbe un colpo in piu' contro lo stesso!

Ditemi voi........ se a qualcuno servirebbe posso anche pensare di iniziare un po' a guardare cosa riesco a tirare fuori!

Ciriciao
mouser :wink:
_________________
Della serie: "Informatica for dummies":

Io: "Premi il tasto Invio" - Risp: "Ma il tasto Invio è quello con scritto Enter sopra?"
Io: "Scrivi T maiuscolo" - Risp: "Questa tastiera non ha le lettere maiuscole..."
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Mon Mar 14, 2005 8:36 am    Post subject: Reply with quote

già che siamo ai settaggi fini ti voglio fare una domanda:
come mai in "portage mode" (modo che certo non uso spesso, se non per fare un po' di testing) mi dice
Code:
>>> Reading dependencies files from /var/cache/edb/dep/usr/portage/ (portage mode)
!!! Using only info from /var/db/pkg for: x11-misc/wmakerconf-2.11
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
>>> Resolving dependencies
>>> Reading world file in /var/lib/portage/world
>>> Reading system packages and dependecies

non mi interessa tanto la riga di wmakerconf, che è in overlay, ma il fatto che non trova virtual/alsa....

ovviamente l'errore (se di errore si tratta) non esiste in mixed e in local mode
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Mar 14, 2005 11:26 am    Post subject: Reply with quote

complimenti.
mi hai dato qc da fare LOL

e' un bug.
ed e' pure bastardo!

indago
grazie :)


EDIT: corretta

non dovresti + avere quel problema.
Non andava in fallback su local per i virtual.

Dalla 0.1_beta16 provate
Code:

unclepine -cn


vi restituisce la riga di wget per prendere l'ultima disponibile.

Grazie mille Cazzantonio ;)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Mon Mar 14, 2005 1:35 pm    Post subject: Reply with quote

grazie lo dico io a te :wink:
piuttosto.... mi sa che il link con wget è sbagliato....

[EDIT]
Code:
star_platinum root # unclepine -u -v
....
~ Version 0.1_beta17

>>> Psyco enabled! ;)
>>> Considering Build time Use
>>> Considering RDEPEND files
>>> Considering DEPEND files
>>> Considering PDEPEND files

>>> Reading portage parameters
>>> Inherited Useflags excluding make.conf ones : aalib bash-completion berkdb cups curl emboss esd fam foomaticdb gdbm gpm imagemagick imlib junit ldap libwww mad mikmod motif ncurses nls oggvorbis opengl pam pdflib perl png python readline sdl slang speex ssl svga tcltk tcpd tetex X xml xml2 xmms zlib
        ARCH:           x86
        PORTDIR:        /usr/portage
        USEFLAGS:       88
>>> Building Virtuals
!!! Building Virtual From /var/db/pkg for: /var/db/pkg/x11-misc/wmakerconf-2.11
>>> Reading dependencies files from /var/cache/edb/dep/usr/portage/ (portage mode)
!!! Using only info from /var/db/pkg for: x11-misc/wmakerconf-2.11
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa
>>> Resolving dependencies
>>> Reading world file in /var/lib/portage/world
>>> Reading system packages and dependecies

Unlinked Packages: 1

        * dev-libs/libxml-1.8.17-r2

rispetto a prima è cambiato solo il fatto che mi trova un paccheto unlinked.... ma quello me lo trova anche in local e mixed mode

potrebbe essere che il problema è mio con alsa?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Mar 14, 2005 1:56 pm    Post subject: Reply with quote

quale link e' sbagliato?

alsa e' attiva come useflag?
Non comprendo come mai ti dia problemi... uhmmm

ciao

EDIT:lancialo in debug mode --debug
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4477
Location: In giro

PostPosted: Mon Mar 14, 2005 2:13 pm    Post subject: Reply with quote

Code:
star_platinum root # emerge info
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 16 2005, 19:03:57)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -mcpu=athlon-xp -mmmx -msse -m3dnow -mfpmath=sse -fomit-frame-pointer -pipe -frename-registers"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mcpu=athlon-xp -mmmx -msse -m3dnow -mfpmath=sse -fomit-frame-pointer -pipe -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.easynet.nl/mirror/gentoo/ http://mirror.switch.ch/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/"
LANG="it_IT@euro"
LC_ALL="it_IT@euro"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow X aalib acpi alsa apm avi bash-completion berkdb bitmap-fonts cdr crypt cups curl directfb dvd dvdr emboss encode esd fam fbcon flac font-server foomaticdb fortran gdbm gif gpm gtk gtk2 imagemagick imlib ipv6 java jikes jpeg junit ldap libg++ libwww mad mikmod mmx motif mozilla mp3 mpeg ncurses nls nptl offensive oggvorbis opengl pam pdflib perl png ppds python quicktime readline sdl slang speex spell sse ssl svg svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts unicode usb wmf xml2 xmms xv xvid zlib linguas_it"
Unset:  ASFLAGS, CBUILD, CTARGET


Se ti può aiutare....
alsa è attivo e funzionate, anche se ultimamente mi da dei problemi... non vorrei che i problemi che ho con alsa (che sostanzialmente hanno a che fare con il corretto caricamento dei moduli all'avvio) fossero correlati con quelli segnalati da unclepine (che invece dovrebbe avere a che fare solo con portage e i files di installazione dei pacchetti)
Non so benissimo come funzionino i virtuals, so solo che questo problema si vede solo in portage mode

Se vuoi butto in un file l'output di unclepine -u -v --debug e te lo spedisco per mail... postarlo mi costerebbe l'espulsione dal forum :) (è lunghetto)

queste sono le righe interessanti che ho trovato spulciando:

Code:
--------------- Starting Building Virtuals ----------------------

!!! Building Virtual From /var/db/pkg for: /var/db/pkg/x11-misc/wmakerconf-2.11
app-dicts/aspell-en virtual/aspell-dict
app-text/xpdf virtual/pdfviewer
dev-lang/python virtual/python
app-text/ghostscript virtual/ghostscript
mail-client/mailx virtual/mailx
mail-mta/ssmtp virtual/mta
sys-kernel/gentoo-dev-sources virtual/linux-sources
sys-fs/udev virtual/dev-manager
app-editors/vim virtual/editor
app-office/openoffice-bin virtual/ooo
sys-process/vixie-cron virtual/cron
net-www/elinks virtual/textbrowser
sys-kernel/linux26-headers virtual/kernel
sys-kernel/linux26-headers virtual/os-headers
sys-boot/grub virtual/bootloader
app-cdr/cdrtools virtual/cdrtools
x11-base/xorg-x11 virtual/x11
x11-base/xorg-x11 virtual/opengl
x11-base/xorg-x11 virtual/glu
x11-base/xorg-x11 virtual/xft
net-misc/dhcpcd virtual/dhcpc
app-text/ggv virtual/psviewer
app-admin/fam virtual/fam
x11-libs/openmotif virtual/motif
app-text/gv virtual/pdfviewer
app-text/gv virtual/psviewer
net-www/lynx virtual/textbrowser
dev-java/blackdown-jdk virtual/jdk-1.4.2
dev-java/blackdown-jdk virtual/jre-1.4.2
dev-java/blackdown-jdk virtual/java-scheme-2
sys-libs/glibc virtual/glibc
sys-libs/glibc virtual/libc
app-admin/syslog-ng virtual/logger
app-editors/nano virtual/editor
app-arch/gzip virtual/gzip
net-misc/openssh virtual/ssh
sys-apps/module-init-tools virtual/modutils
app-text/tetex virtual/tetex
net-p2p/bittorrent virtual/bittorrent
app-editors/gvim virtual/editor
net-print/cups virtual/lpr
media-libs/libquicktime virtual/quicktime
sys-apps/baselayout virtual/baselayout
media-video/nvidia-glx virtual/opengl
app-dicts/aspell-it virtual/aspell-dict
media-libs/glut virtual/glut

--------------- Finished Building Virtuals ----------------------



Raw dependencies for  sys-devel/make-3.80-r1 ['sys-devel/gettext', 'sys-devel/gnuconfig', 'sys-devel/patch', 'sys-libs/glibc']
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa

..........................

Raw dependencies for  media-libs/faad2-2.0-r3 ['>=media-sound/xmms-1.2.7', '>=sys-apps/sed-4.0.7', 'media-libs/id3lib', 'sys-devel/autoconf', 'sys-devel/automake', 'sys-devel/patch']
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa

.......................

Raw dependencies for  media-sound/vorbis-tools-1.0.1 ['>=media-libs/libao-0.8.2', '>=media-libs/libvorbis-1.0', '>=net-misc/curl-7.9', 'media-libs/flac', 'media-libs/speex', 'sys-devel/gcc', 'sys-devel/gettext', 'sys-devel/patch']
!!! Virtual not found: virtual/alsa
!!! Virtual not found: virtual/alsa



può essere che se non emergi il pacchetto con i driver ma usi quelli del kernel lui faccia casino?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Mar 14, 2005 2:38 pm    Post subject: Reply with quote

si prova a mandarmi il file di dedub...

a occhio direi che il tuo kernel non fornisce il virtual-alsa :)
(da dir /usr/portage)
mentre sotto /var/db/pkg lo fornisce...

non vorrei che fosse qc scritto nel ebuild... che solo se emerso setta il virtual....
mi auguro non sia cosi' altrimenti saro' costretto ad abbandonare il portage mode. (che cmq non ha molto senso di esistere)

Ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Mar 15, 2005 12:42 pm    Post subject: Reply with quote

risolto un brutto bug..
e uno minore introdotto nella 17

Scusate per la rottura.

dalla 16 in poi
Code:

unclepine -cn >update
. update


ciao

EDIT:fra qualche giorno implementero' una routine extra per ripulire alcune cosette restie :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Tue Mar 15, 2005 1:17 pm    Post subject: Reply with quote

Non faccio in tempo a scaricarne una che ne esce subito un'altra 8O
A parte tutto grazie per l'ottimo lavoro che svolgi, sinceramente non riesco + a farne a meno :D
P.S.
Dove piazzate l'applicativo ?
Io per ora l'ho in ~/bin/ con modifiche al mio PATH ma non è molto comodo dato che devo loggarmi da root per usarlo.
Lo sposto in /usr/sbin o in bin nella home di root ?
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Mar 15, 2005 1:19 pm    Post subject: Reply with quote

io lo tengo in una cartella a parte (di sviluppo) e ho messo un link in /usr/sbin che punta sempre al file unclepine :)

direi che puoi fare come preferisci :)

ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Tue Mar 15, 2005 1:25 pm    Post subject: Reply with quote

xchris wrote:
io lo tengo in una cartella a parte (di sviluppo) e ho messo un link in /usr/sbin che punta sempre al file unclepine :)
ciao

Si il link mi sembra una buona idea. Faro così anche io tnx :)
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Tue Mar 15, 2005 1:41 pm    Post subject: Reply with quote

Code:

darshan root # less /usr/local/portage/net-p2p/amule/amule-2.0.0_rc8.ebuild
......
DEPEND="gtk2? ( >=x11-libs/wxGTK-2.5.3 )
        !gtk2? ( >=x11-libs/wxGTK-2.4.2-r2 )
        >=net-misc/curl-7.11.0
        >=sys-libs/zlib-1.2.1
        stats? ( >=media-libs/gd-2.0.26 )
        gd? ( >=media-libs/gd-2.0.26 )
        !net-p2p/xmule"
.........

Le wxGTK sono espressamente richieste ma
Code:

darshan root # unclepine -su -u
Unlinked Packages: 2

        * sys-devel/gcc-3.4.2-r2 (S):  old slot
        * x11-libs/wxGTK-2.4.2-r2

Eppure:
Code:

darshan root # unclepine -su -db wxGTK
x11-libs/wxGTK-2.4.2-r2
NEEDED BY:

Code:

darshan root # unclepine -su -df amule
net-p2p/amule-2.0.0_rc8
HAS THESE DEPENDENCIES:
        * net-misc/curl-7.13.1
        * sys-libs/zlib-1.2.2 (S)

Chiaramente non cancello le wxGTK ma come mai me le segna come eliminabili ?
amule compilato con use -gtk2 +unicode mentre wxGTK con +gtk2
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Mar 15, 2005 2:58 pm    Post subject: Reply with quote

emerge info | grep USE | grep gtk2 ?

prova senza -su se il problema fosse quello.

Eventualmente lancialo in debug mode (--debug > debug) e mandami via mail il file debug.

Ciao :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Tue Mar 15, 2005 4:40 pm    Post subject: Reply with quote

xchris wrote:
emerge info | grep USE | grep gtk2 ?

Code:

darshan root # emerge info|grep USE|grep gtk2
USE="amd64 X aalib acpi alsa avi bash-completion berkdb bitmap-fonts cdr crypt cups curl dvd dvdr dvdread flac font-server foomaticdb fortran gif gimpprint gphoto2 gpm gtk gtk2 imagemagick imap imlib ipv6 java jp2 jpeg libwww lm_sensors lzw lzw-tiff mad mikmod mime motif mozilla mp3 mpeg mpeg4 multilib ncurses nls nptl nptlonly nvidia oggvorbis opengl pam perl png ppds python readline rtc scanner ssl svg tcpd tetex tiff truetype truetype-fonts type1-fonts usb userlocales wmf xml2 xmms xpm xprint xrandr xv zlib linguas_it"

xchris wrote:

prova senza -su se il problema fosse quello.

Eventualmente lancialo in debug mode (--debug > debug) e mandami via mail il file debug.

Effettivamente ho un output differente:
Code:
darshan root # unclepine -u
Unlinked Packages: 2

        * media-libs/flac-1.1.0-r2
        * sys-devel/gcc-3.4.2-r2 (S):  old slot

Stavolta mi piazza flac :?:
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Mar 15, 2005 6:53 pm    Post subject: Reply with quote

puoi mandarmi via mail

Code:

unclepine -u -su --debug > debuf_file_per_xchris


sia con -su che senza.

hai cambiato il modo di funzionamento? portage,local,mix?
Ha questo comportamento dalla 17/18 o anche con la 16 fa lo stesso?
(se puoi scarica la 16 e vedi)

Ciao e grazie
Chris

EDIT:eri in fase di emerge?
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Gaspyd
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 242
Location: Brindisi, Italy

PostPosted: Tue Mar 15, 2005 8:09 pm    Post subject: Reply with quote

xchris wrote:
puoi mandarmi via mail

Code:

unclepine -u -su --debug > debuf_file_per_xchris


sia con -su che senza.

hai cambiato il modo di funzionamento? portage,local,mix?
Ha questo comportamento dalla 17/18 o anche con la 16 fa lo stesso?
(se puoi scarica la 16 e vedi)

EDIT:eri in fase di emerge?

Te li posto immediatamente.
Non ho toccato assolutamente nulla nel sistema e non ero in fase di emerge.
Scarico la 16 e ti faccio sapere.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Mar 15, 2005 8:17 pm    Post subject: Reply with quote

non postare qui il debug che e' kilometrico :)
manda tutto via mail!

ciao :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 13, 14, 15  Next
Page 10 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum