Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200410-20 ] Xpdf, CUPS: Multiple integer overflows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Thu Oct 21, 2004 6:53 pm    Post subject: [ GLSA 200410-20 ] Xpdf, CUPS: Multiple integer overflows Reply with quote

Gentoo Linux Security Advisory

Title: Xpdf, CUPS: Multiple integer overflows (GLSA 200410-20)
Severity: normal
Exploitable: remote
Date: October 21, 2004
Updated: November 06, 2004
Bug(s): #69662
ID: 200410-20

Synopsis


Multiple integer overflows were discovered in Xpdf, potentially resulting
in execution of arbitrary code upon viewing a malicious PDF file. CUPS
includes Xpdf code and therefore is vulnerable to the same issues.


Background


Xpdf is an open source viewer for Portable Document Format (PDF) files. The
Common UNIX Printing System (CUPS) is a cross-platform print spooler that
includes some Xpdf code.


Affected Packages

Package: app-text/xpdf
Vulnerable: <= 3.00-r4
Unaffected: >= 3.00-r5
Architectures: All supported architectures

Package: net-print/cups
Vulnerable: <= 1.1.20-r4
Unaffected: >= 1.1.20-r5
Architectures: All supported architectures


Description


Chris Evans discovered multiple integer overflow issues in Xpdf.


Impact


An attacker could entice an user to open a specially-crafted PDF file,
potentially resulting in execution of arbitrary code with the rights of the
user running Xpdf. By enticing an user to directly print the PDF file to a
CUPS printer, an attacker could also crash the CUPS spooler or execute
arbitrary code with the rights of the CUPS spooler, which is usually the
"lp" user.


Workaround


There is no known workaround at this time.


Resolution


All Xpdf users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.00-r5"

All CUPS users should also upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=net-print/cups-1.1.20-r5"


References

CAN-2004-0888
CAN-2004-0889


Last edited by GLSA on Wed Oct 31, 2012 4:17 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum