Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP] Ventole rumorose [Sorto problema]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Tue Oct 19, 2004 12:56 pm    Post subject: [TIP] Ventole rumorose [Sorto problema] Reply with quote

Volevo segnalare questo topic:
QUI
Dove viene spiegato come controllare le ventole grazie agli lm-sensors.

Dateci un occhio e potrete chiuderli tutti e due andando a letto ;)
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]


Last edited by koma on Tue Dec 21, 2004 1:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
sorchino
Apprentice
Apprentice


Joined: 08 Jul 2003
Posts: 242
Location: Bologna/Treno/Fano

PostPosted: Tue Oct 19, 2004 2:21 pm    Post subject: Reply with quote

Do un'occhiata per quanto le mie ventole al momento siano silenziose ;)
Comunque (non ho ancora letto) credo serva la compatibilità della scheda madre per la specifica funzione.
_________________
"Colui al quale avete dato il nome di Gesu` in realta` non era che il capo di una banda di briganti i cui miracoli che gli attribuite non erano che manifestazioni operate secondo la magia e i trucchi esoterici." Celso.
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Tue Dec 21, 2004 1:01 pm    Post subject: Reply with quote

Ciao :) riapro questo vecchio post su consiglio di randomaze :)

Allora il problema che mi si pone è che non riesco a controllare entrambe le ventole.

dal sensor:
Code:
fan1:        0 RPM  (min =  458 RPM, div = 32)                     
fan2:     2481 RPM  (min =  231 RPM, div = 32)                     
fan3:     4218 RPM  (min =  585 RPM, div = 64)                     
temp1:       -48°C  (high =  +127°C)                     sensor = thermistor           
temp2:     +45.5°C  (high =   +80°C, hyst =   +75°C)   sensor = diode           
temp3:     +38.5°C  (high =   +80°C, hyst =   +75°C)   sensor = thermistor     
Si comprende che ho la rpima ventola e la prima temperatura scollegata. e tutto bene
il problema che mi si pone è che con pwmconfig non riesco a controllarle entramb.
Questo è il mio /etc/fancontrol
Qualcuno SA come inserirle entrambe nel config? Su dai postate i vostri!
Code:
INTERVAL=10
FCTEMPS= 1-0290/fan2_pwm=1-0290/temp2_input
FCFANS= 1-0290/fan2_pwm=1-0290/fan3_input
MINTEMP= 1-0290/fan2_pwm=35
MAXTEMP= 1-0290/fan2_pwm=75
MINSTART= 1-0290/fan2_pwm=100
MINSTOP= 1-0290/fan2_pwm=50

Vi passo anche un LS dei vari controlli che ho in
/sys/bus/i2c/devices/1-0290
Code:
#  ls /sys/bus/i2c/devices/1-0290/
alarms        fan2_input  in1_max    in4_min    in8_input       temp2_max
beep_enable   fan2_min    in1_min    in5_input  in8_max         temp2_max_hyst
beep_mask     fan2_pwm    in2_input  in5_max    in8_min         temp2_type
cpu0_vid      fan3_div    in2_max    in5_min    name            temp3_input
detach_state  fan3_input  in2_min    in6_input  power/          temp3_max
fan1_div      fan3_min    in3_input  in6_max    temp1_input     temp3_max_hyst
fan1_input    in0_input   in3_max    in6_min    temp1_max       temp3_type
fan1_min      in0_max     in3_min    in7_input  temp1_max_hyst  vrm
fan1_pwm      in0_min     in4_input  in7_max    temp1_type
fan2_div      in1_input   in4_max    in7_min    temp2_input

_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
/\/\auri
n00b
n00b


Joined: 18 Dec 2004
Posts: 12

PostPosted: Tue Dec 21, 2004 1:47 pm    Post subject: Reply with quote

il tuo /etc/fancontrol mi pare pasticciato parecchio, e cmq ci sono i comandi di una sola ventola, non di due

il mio è
Code:

INTERVAL=2
FCTEMPS=1-0290/fan2_pwm=0-004c/temp1_input 1-0290/fan1_pwm=0-004c/temp2_input
FCFANS=1-0290/fan2_pwm=1-0290/fan2_input 1-0290/fan1_pwm=1-0290/fan1_input
MINTEMP=1-0290/fan2_pwm=30 1-0290/fan1_pwm=30
MAXTEMP=1-0290/fan2_pwm=40 1-0290/fan1_pwm=40
MINSTART=1-0290/fan2_pwm=10 1-0290/fan1_pwm=10
MINSTOP=1-0290/fan2_pwm=5 1-0290/fan1_pwm=5


quando lanci il pwmconfig quanti ventole ti rileva?
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Tue Dec 21, 2004 3:38 pm    Post subject: Reply with quote

3 se vuoi posto tutto il log :) anzi lo faccio mi scuso con i lettori.
Code:
#  pwmconfig
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following PWM controls:
   1-0290/fan1_pwm
   1-0290/fan2_pwm

Found the following fan sensors:
   1-0290/fan1_input     current speed: 0 ... skipping!
   1-0290/fan2_input     current speed: 2481 RPM
   1-0290/fan3_input     current speed: 4218 RPM

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue:

Testing pwm control 1-0290/fan1_pwm ...
  1-0290/fan2_input ... speed was 2481 now 2481
    no correlation
  1-0290/fan3_input ... speed was 4218 now 4218
    no correlation

No correlations were detected.
There is either no fan connected to the output of 1-0290/fan1_pwm,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)?

Testing pwm control 1-0290/fan2_pwm ...
  1-0290/fan2_input ... speed was 2481 now 2481
    no correlation
  1-0290/fan3_input ... speed was 4218 now 4218
    no correlation

No correlations were detected.
There is either no fan connected to the output of 1-0290/fan2_pwm,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? y

Testing is complete.
Please verify that all fans have returned to their normal speed.

The fancontrol script can automatically respond to temperature changes
of your system by changing fanspeeds.
Do you want to set up its configuration file now (y)? y
What should be the path to your fancontrol config file (/etc/fancontrol)?
Loading configuration from /etc/fancontrol ...

Select fan output to configure, or other action:
1) 1-0290/fan2_pwm     3) Just quit           5) Show configuration
2) Change INTERVAL     4) Save and quit
select (1-n): 5

Common Settings:
INTERVAL=10

Settings of 1-0290/fan2_pwm:
  Depends on 1-0290/temp2_input
  Controls 1-0290/fan2_input
  MINTEMP=30
  MAXTEMP=40
  MINSTART=10
  MINSTOP=5

select (1-n): 4

Saving configuration to /etc/fancontrol...
Configuration saved

( o )-(root)-(~)# 
Il problema è che solo le prime due sono pilotabili.... devo vedere se posso spostare qualche cavetto o sono proprio le ventole che non osno pilotabili in se stesse (a 2 cavetti anzichè 3)
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
/\/\auri
n00b
n00b


Joined: 18 Dec 2004
Posts: 12

PostPosted: Tue Dec 21, 2004 3:48 pm    Post subject: Reply with quote

ti rileva 2 solo ventole, di cui una non controllabile (almeno così mi sembra di capire dai log)
per me, o cambi quella non controllabile oppure ne controlli una sola
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Tue Dec 21, 2004 8:11 pm    Post subject: Reply with quote

sono entrambi a triplo contatto quindi controllabili ... mi sa che sono i drivers messi alla cazzo :P
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Wed Dec 22, 2004 1:05 am    Post subject: Reply with quote

Quote:
... mi sa che sono i drivers messi alla cazzo

Lascia stare, quando lancio sensor-detect, alla fine il simpatico programmino mi dice una roba tipo "Scusa, ma per il tuo sensore (mi dice il modello del chip) non esistono ancora i driver"...
E la mobo nn è certo recente...

/me frustrato dal non poter sapere la velocità delle sue ventoline...
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
skakz
Guru
Guru


Joined: 03 Jul 2004
Posts: 380
Location: Ischia/Napoli/Italia/Terra

PostPosted: Mon Jun 06, 2005 11:33 am    Post subject: Reply with quote

salve

ho i seguenti moduli i2c build-in nel kernel (così niente modprobe etc etc):
eeprom i2c-isa it87 i2c-viapro

sensors funziona bene:
Code:

omega linux # sensors
it8712-isa-0290
Adapter: ISA adapter
VCore 1:   +1.66 V  (min =  +1.42 V, max =  +1.57 V)   ALARM
VCore 2:   +0.00 V  (min =  +2.40 V, max =  +2.61 V)   ALARM
+3.3V:     +3.66 V  (min =  +3.14 V, max =  +3.46 V)   ALARM
+5V:       +5.05 V  (min =  +4.76 V, max =  +5.24 V)
+12V:     +12.03 V  (min = +11.39 V, max = +12.61 V)
-12V:     -17.36 V  (min = -12.63 V, max = -11.41 V)   ALARM
-5V:      -6.64 V  (min =  -5.26 V, max =  -4.77 V)   ALARM
Stdby:     +5.08 V  (min =  +4.76 V, max =  +5.24 V)
VBat:      +4.08 V
fan1:     3590 RPM  (min =    0 RPM, div = 8)
fan2:     3276 RPM  (min = 2657 RPM, div = 2)
fan3:        0 RPM  (min = 2657 RPM, div = 2)          ALARM
CPU Temp:    +42°C  (low  =   +15°C, high =   +40°C)   sensor = thermistor
CPU Temp:    +40°C  (low  =   +15°C, high =   +45°C)   sensor = thermistor
Temp3:        -1°C  (low  =   +15°C, high =   +45°C)   sensor = disabled

eeprom-i2c-1-52
Adapter: SMBus Via Pro adapter at e800
Memory type:            DDR SDRAM DIMM
Memory size (MB):       512


ho la solita MB a7v600-x che sul sito http://www.almico.com/forumindex.php sembra supportare il fan control.
sensors version 2.9.0 with libsensors version 2.9.0.
2.6.11 kernel.
CoolerMaster ASBV83 JET 7 con una manopola sul frontalino davanti per controllare la velocità della ventola. (dite voi che c'entra...boh non lo so...)


per creare il config che serve a fancontrol faccio:
Code:

omega root # pwmconfig
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following PWM controls:
   0-0290/pwm1
   0-0290/pwm2
   0-0290/pwm3

Found the following fan sensors:
   0-0290/fan1_input     current speed: 3668 RPM
   0-0290/fan2_input     current speed: 3276 RPM
   0-0290/fan3_input     current speed: 0 ... skipping!

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue:

Testing pwm control 0-0290/pwm1 ...
  0-0290/fan1_input ... speed was 3668 now 3668
    no correlation
  0-0290/fan2_input ... speed was 3276 now 3276
    no correlation

No correlations were detected.
There is either no fan connected to the output of 0-0290/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n
...


non ho sentito nulla,non è successo nulla.. premo "n"

Code:

...
Testing pwm control 0-0290/pwm2 ...
  0-0290/fan1_input ... speed was 3668 now 3668
    no correlation
  0-0290/fan2_input ... speed was 3276 now 3276
    no correlation

No correlations were detected.
There is either no fan connected to the output of 0-0290/pwm2,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n
...


lo stesso...

Code:

....
Testing pwm control 0-0290/pwm3 ...
  0-0290/fan1_input ... speed was 3668 now 3668
    no correlation
  0-0290/fan2_input ... speed was 3276 now 3308
    no correlation

No correlations were detected.
There is either no fan connected to the output of 0-0290/pwm3,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n
...


sempre lo stesso... :(

Code:

...
Testing is complete.
Please verify that all fans have returned to their normal speed.

The fancontrol script can automatically respond to temperature changes
of your system by changing fanspeeds.
Do you want to set up its configuration file now (y)? y
What should be the path to your fancontrol config file (/etc/fancontrol)?
/etc/fancontrol does not exist, shall I create it now (y)? y
chown: `root.root' syntax is obsolete; use `:' since this will be removed in the future
Loading configuration from /etc/fancontrol ...

Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit           4) Show configuration
select (1-n): 4

Common Settings:
INTERVAL=10

select (1-n):

omega root #


cosa è successo?? il mio config è solo una linea??

quindi ho deciso di crearne uno io:
Code:

omega root # cat /etc/fancontrol
INTERVAL=10
FCTEMPS=*-0290/pwm2=*-0290/temp2_input *-0290/pwm1=*-0290/temp1_input
FCFANS=*-0290/pwm2=*-0290/fan2_input *-0290/pwm1=*-0290/fan1_input
MINTEMP=*-0290/pwm2=38 *-0290/pwm1=40
MAXTEMP=*-0290/pwm2=50 *-0290/pwm1=55
MINSTART=*-0290/pwm2=0 *-0290/pwm1=0
MINSTOP=*-0290/pwm2=0 *-0290/pwm1=0


ma facendo partire fancontrol lo stesso non succede nulla alle mie ventole :( :( :( :( :( :( :( :(

Code:

omega root # fancontrol
Loading configuration from /etc/fancontrol ...


Common settings:
  INTERVAL=10

Settings for *-0290/pwm2:
  Depends on *-0290/temp2_input
  Controls *-0290/fan2_input
  MINTEMP=38
  MAXTEMP=50
  MINSTART=0
  MINSTOP=0

Settings for *-0290/pwm1:
  Depends on *-0290/temp1_input
  Controls *-0290/fan1_input
  MINTEMP=40
  MAXTEMP=55
  MINSTART=0
  MINSTOP=0

Enabling PWM on fans...
Starting automatic fan control...


e neanche forzando il valore 0 in pwm1 or pwm2... :cry:
Code:

omega root # cat /sys/bus/i2c/devices/0-0290/pwm1
255
omega root # echo 0 > /sys/bus/i2c/devices/0-0290/pwm1
omega root # sensors | grep fan1
fan1:     3590 RPM  (min =    0 RPM, div = 8)
omega root #


This is a campaign in favor of my ears.
We plead you to participate
_________________
Linux Registered User n.340423
Linux User Group Ischia
www.tush.it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum