Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xmms = cp ? [fixad]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Oct 16, 2004 4:25 am    Post subject: xmms = cp ? [fixad] Reply with quote

tjo!

jag instade nyss xmms 1.2.10-r5, den beter sig väldigt konstigt.. inget ljud, låtarna går i super fart, sen byter den låt helt plötsligt mm. Det funkar att spela .mp3 i mpg123

sen skapas det även en kopia av .mp3 låten som lägger sig i home katalogen .wav, rippar den till wav ? men jag har inte ställt in att den ska göra så. hur ställer man det till rätta ? hittade inget!!

vad kan detta vara ? jag har aldrig haft problem med xmms tidigare..

finns en grej som heter "disk writer plugin" i Audio i/o plugins -> output plugin.
ska den avaktiveras, men hur ? om det ens är den. aja bara en tanke

Tack :roll:
_________________
ibook 12" G3 800mhz 30gb 384ram


Last edited by soujirou on Sat Oct 16, 2004 3:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
creideiki
n00b
n00b


Joined: 19 Feb 2003
Posts: 61
Location: Linköping, Sweden

PostPosted: Sat Oct 16, 2004 8:49 am    Post subject: Reply with quote

Det där beror på att "Disk writer plugin" är vald som output-plugin, ja. Byt till någon annan i listan, t.ex. ALSA. Du kan bara ha en åt gången, så disk writer avaktiveras när du väljer en annan.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Oct 16, 2004 9:18 am    Post subject: Reply with quote

okej.. men det finns ingen annan =/

fattas det nåt för mig ?

tack
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
creideiki
n00b
n00b


Joined: 19 Feb 2003
Posts: 61
Location: Linköping, Sweden

PostPosted: Sat Oct 16, 2004 1:34 pm    Post subject: Reply with quote

Då är det något som fattas, ja. Vilket ljudsystem använder du? För OSS och ALSA sätter du motsvarande USE-flagga och bygger om media-sound/xmms, för aRts installerar du media-plugins/xmms-arts och för JACK media-plugins/xmms-jack.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Oct 16, 2004 3:03 pm    Post subject: Reply with quote

jag kör oss

ska man ändra i make.conf ?
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O3 -mcpu=750 -pipe"
CHOST="powerpc-unknown-linux-gnu"
CXXFLAGS="${CFLAGS}"
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
creideiki
n00b
n00b


Joined: 19 Feb 2003
Posts: 61
Location: Linköping, Sweden

PostPosted: Sat Oct 16, 2004 3:14 pm    Post subject: Reply with quote

Är det där hela din /etc/make.conf? I så fall har du ganska mycket att ändra... Det korta svaret för att få just det här att fungera är att lägga till
Code:
USE="oss"

eller, om du redan har en USE-definition, att lägga till "oss" i den. T.ex. så här:
Code:
USE="X kde qt oss"

Det långa svaret är att du bör läsa Working with Gentoo, läsa /etc/make.conf.example, kopiera /etc/make.conf.example till /etc/make.conf och ändra tills det blir bra.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Oct 16, 2004 3:22 pm    Post subject: Reply with quote

japp det är allt jag har i den.. så nu la jag till det.. behöver jag göra nåt mer för att fixxa xmms ?
måste jag insta om det ? för jag har fortf. bara "disc writer" som output plugin samt arts. men arts i detta fallet klagar.

Please check that:

Your soundcard i configured properly "yes it is, the sound works with mpg123"
You have the correct output plugin selected "yes i just change it to arts"
No other program is blocking the soundcard "checked"
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
creideiki
n00b
n00b


Joined: 19 Feb 2003
Posts: 61
Location: Linköping, Sweden

PostPosted: Sat Oct 16, 2004 3:28 pm    Post subject: Reply with quote

Ja, du måste installera om. USE-flaggor (som du för övrigt kan läsa om här) slår på eller stänger av valfri funktionalitet vid kompilering.

aRts skall man bara köra genom om man måste. Måste gör man om man kör KDE och inte kan få varken OSS eller ALSA att spela ljud direkt. Prova dem först.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Sat Oct 16, 2004 3:40 pm    Post subject: Reply with quote

tack så mycket.. nu funkar det =)


du får gärna kolla på mitt andra problem med,,, du verkar kunna en del =)

angånde konstig färg i xorg
http://forums.gentoo.org/viewtopic.php?t=237976

tack igen
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum