Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X + xvidtune problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fedorko
n00b
n00b


Joined: 12 May 2002
Posts: 14
Location: Chicago, IL

PostPosted: Sun May 12, 2002 8:44 pm    Post subject: X + xvidtune problem Reply with quote

Hi,
I have just installed gentoo and I seem to have a problem with X-windows
I have configured it using xf86config as mentioned in the Gentoo Linux
Desktop Config Guide,
and I think I got all the parameters right.
When I startx it comes up and screen is readable (with difficulty) but
looks very unhappy
The display glitches and monitor resets itsefl every few seconds. When
I run xvidtune
and just hit 'Apply' -display becomes normal
curiosly when I hit 'Fetch' and 'Show' before I do 'Apply' I get a line:
"1024x768" 75.00 1024 1048 1184 1328 768 771 777 806 -hsync
-vsync
after I do 'Apply' (and display stabilizes) and 'Show' I get exactly the
same line
I edited XF86Config and put in the exact sync rates shown by xvidtune
and a line:
Modeline "1024x768" 75.00 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
in the Monitor section.
When I restart X the problem returns...
-what am I doing wrong?

my config:
ati 3Drage pro (don't laugh)
monitor magitronic C-SV1500PS

thank you,
Wojtek
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Mon May 13, 2002 3:05 am    Post subject: Reply with quote

Make sure you get the newest video drivers for your card. I'm sure you probably have though as that's an obvious first step. With my card just downloading the official drivers fixed the problem.

However, before the drivers solved the problem I did the exact same thing you are did. My guess is that you were probably editing the wrong XF86Config file. XF86Config-4 is the file that newer versions of X use. It's located in the same directory as your XF86Config file. Try that and see if it works.
Back to top
View user's profile Send private message
fedorko
n00b
n00b


Joined: 12 May 2002
Posts: 14
Location: Chicago, IL

PostPosted: Mon May 13, 2002 4:24 am    Post subject: Reply with quote

No i haven't tried to update drivers - not sure where to get them - can you point me?
+ not sure why would I need any new drivers for a card that is 4 years old - I'm pretty sure that drivers included were up to date...
I'm just not sure what is xvidtune doing and how can I replicate it...
Also the file that I am editing is the right one - if I screw up -like syntax- I know immediatelly...

any other suggestions....
thanks,
Wojtek
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Tue May 14, 2002 5:49 pm    Post subject: Reply with quote

Alright, first you would go to ATI.com or search google to make sure you have the latest drivers. But I think I may have found your problem.

I was just reading Lockergnome's Penguin Shell newsletter and it's been having discussion on XF86Config. In your config make sure you remove the: DisableVidModeExtension if it's there.

"This flag essentially kills the functionality of xvidtune, another X configuration tool we've discussed in Penguin Shell. Well, it doesn't quite kill the functionality. Instead, it allows the user to run xvidtune, but refuses to save any resulting changes. Common practice is to set this flag in XF86Config once the perfect video setting has been configured, preventing future changes from occurring." -Penguin shell
Back to top
View user's profile Send private message
fedorko
n00b
n00b


Joined: 12 May 2002
Posts: 14
Location: Chicago, IL

PostPosted: Fri May 17, 2002 2:32 am    Post subject: Reply with quote

Hi,
thanks for your response
The actual solution to the problem is unbeliveably simple and I don't belive I didn't get it sooner
-It was one of the few first messages posted on the newbie list at XFree86.org - I just somehow didn't think to look there:
one adds:
Option "NoCompositeSync"
in the Device section of XF86Config

cheers!
Wojtek
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum