Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mini-HowTo] Ivman, sustituto de supermount kernel>2.6.8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Sun Oct 10, 2004 5:02 pm    Post subject: [Mini-HowTo] Ivman, sustituto de supermount kernel>2.6.8 Reply with quote

Ivman HowTo versión 0.2.1

Introducción

Uno de los cambios que se hicieron en las releases de las gentoo-dev-sources es el quitar el parche de supermount y de bootsplash, por eso me decidí a hacer/traducir algunos howtos para la comunidad hispanoparlante. El de fbsplash (sustituto de bootsplash) ya esta, así que ahora toca el de ivman (sustituto de supermount), y de paso de Udev (sustituto devfs).

Migrar a Udev

1. Configuramos nuestro kernel para retirar devfs:

Code:
# cd /usr/src/linux
# make menuconfig

y lo dejas así:

    General setup --->
    [ * ] Support for hot-pluggable devices
    File systems --->
    Pseudo filesystems --->
    [ ] /dev file system support (OBSOLETE)


1 Bis. Si usas Genkernel puedes pasarle la opción --udev para que lo configure automaticamente:
# genkernel --save-config --menuconfig --udev all

2. Ahora editas tu archivo /etc/conf.d/rc
Code:
# nano -w /etc/conf.d/rc

Editas las siguientes variables en "no", si tienes dispositivos que no crea udev y los creas manualmente, puedes poner en "yes" RC_DEVICE_TARBALL:

    RC_DEVICE_TARBALL="no"
    RC_DEVFSD_STARTUP="no"


3. Como udev utiliza hotplug y/o coldplug para crear los dispositivos necesitamos instalarlo. Coldplug carga los modululos de los dispositivos ya conectados, hotplug los carga dinamicamente, es decir cuando los enchufas, aunque a veces con uno tienes suficiente.

Code:
# emerge hotplug coldplug
# rc-update add hotplug default (puede ser tambien en boot, fixme)
# rc-update add coldplug boot (puede ser tambien en default, fixme)


4. Desinstalar devfsd:

Code:
# emerge -C devfsd


5. Borrar todo rastro de devfs, para esto inicia con un livecd y haz:

Code:
# loadkeys es
# mkdir test
# mount /dev/hdx test/
# cd test/dev
# rm *
# mknod -m 660 console c 5 1
# mknod -m 660 null c 1 3
# cd ../..
# umount test
# rmdir test
# reboot


Si inicias y todo va correctamente, Felicidadez!! haz migrado a udev, si tienes algún problema ppstealo aquí o en otro hilo, el problema más comun es/era el enlace al mouse, si no te arrancan las X o te arrancan pero sin ratón, edita tu xorg.conf y cambia la dirección del dispositivo a /dev/psaux.

Instalar Ivman

Esto es de lo más fácil, no tendrás problema alguno.

1. Instalamos hal (hardware abstraction layer ??), lo cual instalará como dependencia dbus

Code:
# emerge hal


2. Ahora Ivman en si, te recomiendo la versión ~x86 ( >= 0.5) ya que sus features son mas completas.

Code:
# echo "sys-apps/ivman" >> /etc/portage/package.keywords (solo si quieres ~x86)
# emerge ivman


3. Iniciamos los servicios y los agregamos al inicio.

Code:
# /etc/init.d/hal start
# /etc/init.d/ivman start
# rc-update add hal default
# rc-update add ivman default


Configurar Ivman

Con lo anterior ya debes poder usar el automontaje, pruebalo inserta un cd y ve como se monta, ahora solo presiona el boton de eject y ve como lo saca (siempre y cuando no lo este usando una app). Sin embargo querrás tunearlo para que se adapte a tus necesidades. Para eso es este apartado:

---> En Construcción <---

Referencias: http://forums.gentoo.org/viewtopic.php?t=185508&postdays=0&postorder=asc&start=0
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918


Last edited by navegante on Tue Feb 22, 2005 6:57 pm; edited 6 times in total
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Sun Oct 10, 2004 5:40 pm    Post subject: Reply with quote

He tenido que hacer un:
USE="apache2" emerge subversion
porque si no me decia que apache lo bloqueaba. Voy a seguir, a ver si lo consigo.
Gracias por el howto :wink:.

Para echarlo a andar he tenido que hacer un:
ln -s /var/lib/dbus/system_bus_socket /var/lib/run/dbus/system_bus_socket
por que si no no tiraba.

PD: ¿no hay ninguna forma de desmontar el cd cuando le das al boton de extraer? :?
Back to top
View user's profile Send private message
artic
Veteran
Veteran


Joined: 22 Nov 2003
Posts: 1208

PostPosted: Sun Oct 10, 2004 7:45 pm    Post subject: Reply with quote

Muy bueno el mini-howto,estan muy bien para q los gentozeros tengan en español y paso a paso,el como configurar todo.Haber si siguen apareciendo minis como este,en vez de post de crakear.
La verdad es q a mi no me gusta el supermount personalmente.Usando rox te automatiza las tareas al entrar en el directorio ya sea dvd,cdrom,etc.....,y me imagino q el iniciar esos elementos ralentizara unos seg el arranke,por el resto muy bien pa kien guste.
Salu2
_________________
Pwd by Gentoo | 2.6.28-gentoo-x64 | kde4.2| ext4 | xorg 7.4 |
Back to top
View user's profile Send private message
episode96
Apprentice
Apprentice


Joined: 08 Mar 2004
Posts: 173

PostPosted: Mon Oct 11, 2004 11:34 am    Post subject: Reply with quote

Gracias por el How-to :D

No he conseguido que compilaran las versiones cvs y he usado las de Portage. Por cierto, un par de apuntes:

:arrow: Ademas de añadir los ebuilds a /etc/portage/package.unmask hay que añadirlos a /etc/portage/package.keywords
:arrow: Se te ha colado una ',' en la URL del ebuild: http://bugs.gentoo.org/show_bug.cgi?id=66013 :wink:

Espero que todo esto madure un poco más y se integre de forma plena en los escritorios.
Back to top
View user's profile Send private message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Tue Nov 02, 2004 5:15 am    Post subject: Reply with quote

He actulizado el articulo ya que ahora ya tenemos todas las apps en el portage y dentro de poco el ivman será estable :D. En unos días retiro completamente las partes antiguas, las deje como referencia. Saludos.
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Tue Nov 02, 2004 7:43 am    Post subject: Reply with quote

ahora ya va perfecto :wink:
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Sun Nov 07, 2004 11:38 am    Post subject: Reply with quote

Hola a todos:

He estado intentando poner ivman segun esta guia, pero me he encontrado con algunos problemas:

- Despues de emerger todo, no habia tal archivo /etc/conf.d/ivman
- Cuando intenté montar cosas, a pesar de tener en el IvmConfigMappgins.xml una entrada para mapear "hdc" y "hdd" a "cdrom0" y "cdrom1", se me crean entradas en el fstab cada vez que lo arranco.
- Se me automontan los cdroms, sin embargo, no se desmontan... tengo que ir como root para hacerlo.
A continuación os pongo el output del ivman en modo debug, y también el IvmConfigMappings, y el fstab:

Code:


kke's Volume Manager, http://ivman.sf.net
hal_interface.c:42 (hal_device_added) New Device: /org/freedesktop/Hal/devices/block_WXPVOL_ES
hal_interface.c:80 (hal_device_added) Changed: /dev/hdc
libhal.c 840 : Error sending msg: No property storage.drive_type on device withid /org/freedesktop/Hal/devices/block_WXPVOL_ES
manager.c:232 (ivm_media_changed) Forcing media type
manager.c:186 (ivm_cdrom_policy) In cdrom_policy
manager.c:205 (ivm_cdrom_policy) Device: /dev/hdc
manager.c:213 (ivm_cdrom_policy) Its data
IvmConfigActions.c:214 (get_actions) Nodeset is null
manager.c:150 (ivm_device_mount) Mounting /dev/hdc
manager.c:159 (ivm_device_mount) Mapped to /dev/cdroms/cdrom0
mount: dispositivo de bloques /dev/cdroms/cdrom0 está protegido contra escritura; se monta como sólo lectura
hal_interface.c:168 (hal_property_modified) Mounted: OL_ES"   "/mnt/dvd"
manager.c:290 (ivm_unlock_device) Unlocking tray of /dev/hdc
manager.c:301 (ivm_unlock_device) /dev/hdc unlocked
manager.c:112 (ivm_check_dvd) Checking for DVD in '/dev/hdc' mounted on '/mnt/dvd'
hal_interface.c:235 (hal_device_condition) Event Recieved  but no action taken
 Name: VolumeMount/org/freedesktop/Hal/devices/block_WXPVOL_ES
hal_interface.c:187 (hal_property_modified) Devices table has 1 entries
hal_interface.c:261 (print_device)      "/org/freedesktop/Hal/devices/block_WXPV


Si os fijais.. parece que no hay evento de eject.

IvmConfigMappings:

Code:

<ivm:Map device="/dev/hdc" maps="/dev/cdroms/cdrom0" />
<ivm:Map device="/dev/hdd" maps="/dev/cdroms/cdrom1" />



Fstab:

Code:
/dev/cdroms/cdrom0      /mnt/dvd        auto            noauto,user,exec,unhide
        0 0
/dev/cdroms/cdrom1      /mnt/grabadora  auto            noauto,user,exec
        0 0



Alguno tiene alguna idea sobre que puede pasar? Que estoy haciendo mal?

Un saludo y gracias!!!!
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Sun Nov 07, 2004 5:18 pm    Post subject: Reply with quote

A mi me pasaba mas o menos eso con las cvs, hasta que me pase a las versiones ya existentes en el portage y se soluciono. Hicistes el etc-update ¿no?
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Sun Nov 07, 2004 6:13 pm    Post subject: Reply with quote

Si, lo hice, pero nada... de hecho he probado con lo que hay en el portage (tanto en ARCH como en ~ARCH) y en el cvs de ivman y nada... sigue pasando lo mismo... no me desmonta... el caso es que si que lo desmonta si se monta en /media/... con /dev/hdc... no se no se... sera cosa de udev?

Un saludo y gracias!
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Sun Nov 07, 2004 6:49 pm    Post subject: Reply with quote

Te pongo las versiones con las que me funciona bien:
* sys-apps/hal
Latest version available: 0.2.98-r1
Latest version installed: 0.2.98-r1

* sys-apps/dbus
Latest version available: 0.22-r1
Latest version installed: 0.22-r1

* sys-apps/ivman [ Masked ]
Latest version available: 0.3
Latest version installed: 0.3
Back to top
View user's profile Send private message
Tanisete
Guru
Guru


Joined: 12 Mar 2004
Posts: 312

PostPosted: Sun Nov 07, 2004 9:14 pm    Post subject: Reply with quote

Bueno, a ver, he encontrado una forma con la cual funciona... a ver que opinais:

He sustiutido en las lineas del fstab anterior, "/dev/cdroms/cdrom0" por "/mnt/hdc" y asi si funciona. Esto me hace pensar dos posibles causas:

a) Mi IvConfigMappings.xml estaba mal. Era este:

Code:

<ivm:Map device="/dev/hdc" maps="/dev/cdroms/cdrom0" />
<ivm:Map device="/dev/hdd" maps="/dev/cdroms/cdrom1" />


b) Hal o ivman se lian con los mappings, y si les mola al montar, pero no al desmontar...

Hay algo de malo en tener esa linea de esa forma? Es mejor ponerla a /dev/cdroms?

Un saludo a todos!!
Back to top
View user's profile Send private message
pibelss
Tux's lil' helper
Tux's lil' helper


Joined: 08 May 2004
Posts: 102
Location: Burgos,Castilla y Leon, Spain, Europe,...

PostPosted: Mon Nov 08, 2004 8:56 am    Post subject: Reply with quote

Hola, tengo un problema al hacer el emerge de ivman y no entiendo por que puede ser. Portage me responde con lo siguiente:
Code:
bash-2.05b# emerge ivman
Calculating dependencies ...done!

!!! Error: the sys-kernel/linux-headers package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

bash-2.05b# emerge -p ivman

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] sys-kernel/linux-headers (from pkg sys-kernel/linux26-headers-2.6.8.1)
[ebuild  N    ] dev-python/pyrex-0.9.2.1
[ebuild  N    ] sys-apps/dbus-0.22-r1
[ebuild  N    ] sys-fs/udev-030
[ebuild  N    ] dev-lang/swig-1.3.21
[ebuild  N    ] sys-libs/libcap-1.10-r4
[ebuild  N    ] sys-kernel/linux26-headers-2.6.8.1
[ebuild  N    ] sys-apps/hal-0.2.98-r1
[ebuild  N    ] sys-apps/ivman-0.3

Utilizo el kernel 2.6.9-rc1 con los parches nitro 2.6.9-rc1-nitro4
¿Alguien me puede ayudar?
Gracias
Back to top
View user's profile Send private message
AnFe
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2004
Posts: 138

PostPosted: Mon Nov 08, 2004 5:51 pm    Post subject: Reply with quote

haz #emerge -C linux-headers
luego #emerge linux26-headers
y por ultimo otra vez #emerge ivman

un saludo
Back to top
View user's profile Send private message
psm1984
l33t
l33t


Joined: 14 Oct 2003
Posts: 919

PostPosted: Mon Nov 08, 2004 8:31 pm    Post subject: Reply with quote

AnFe wrote:
haz #emerge -C linux-headers
luego #emerge linux26-headers
y por ultimo otra vez #emerge ivman

un saludo


Te recomiendo que primero hagas un
quickpkg linux-headers
y si se puede un
emerge -B linux26-headers
para luego el
emerge -C linux-headers
emerge -K linux26-headers
Lo digo porque hubo gente que se quedo sin kernel-headers.
Back to top
View user's profile Send private message
Mich buchanan
n00b
n00b


Joined: 17 Jun 2004
Posts: 41
Location: Spain

PostPosted: Thu Nov 18, 2004 9:07 am    Post subject: Reply with quote

Hola buenas, acabo de intentar activar ivman, creo q he hecho todo que tenía que hacer, he cambiado el sistema para udev, y he instalado dbus, hal e ivman, los servicios se inician bien excepto ivman:

Quote:
baywatch-1 mich # /etc/init.d/ivman start
* Starting D-BUS system messagebus ... [ ok ]
* Starting Hardware Abstraction Layer daemon ... [ ok ]
* Starting Automounter ...
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/computer
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3059
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3227
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3104
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3038
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3038/0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3038/1
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3038/2
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_571
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/ide_host_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/ide_0_1
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3149
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/scsi_0_0_0_0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1102_7002
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1102_2
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_10ec_8139
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_10ec_8139/0
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_10b7_1700
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_b198
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_10de_322
libhal.c 911 : Error sending msg: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pci_1106_3189


Tenéis idea de por qué no llega a iniciarse correctamente el servicio?
Sin embargo aunque nunca llegue a dar el [ok], si que me monta los cds, al menos uno de ellos, por lo que el otro debe de estar mal configurado en el fstab me imagino.

Actualizo: monta y desmonta las dos unidades de DVD y DVDR perfectamente, pero el ivman sigue como colgado sin llegar a dar el [ OK ]

Y si se me ocurre añadir ivman al runlevel default, al arrancar se queda con estos errores y no termina el arranque.
Back to top
View user's profile Send private message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Tue Feb 22, 2005 6:17 pm    Post subject: Reply with quote

Actualización de la guia (más bien una reescritura de la misma), le falta la ultima parte que creo es la más importante, denme chance y la completo, pero para alguien que había preguntado sobre esto, aquí esta. Saludos.
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918
Back to top
View user's profile Send private message
TieferFeld
Guru
Guru


Joined: 01 May 2004
Posts: 550
Location: irgendwie, irgendwo, irgendwann

PostPosted: Wed May 25, 2005 12:37 pm    Post subject: Reply with quote

Esto... ¿no sería conveniente emerger udev en algún punto?
_________________
Du bist was du isst!
Back to top
View user's profile Send private message
ArsDangor
Guru
Guru


Joined: 20 May 2003
Posts: 477

PostPosted: Wed May 25, 2005 11:09 pm    Post subject: Re: [Mini-HowTo] Ivman, sustituto de supermount kernel>2. Reply with quote

Interesante howto. En cuanto tenga tiempo me lo aplico. :)
navegante wrote:

Code:
# echo "sys-apps/ivman" >> /etc/portage/package.keywords (solo si quieres ~x86)
# emerge ivman
En esa línea te falta especificar la keyword que le quieres aplicar al paquete. Sería
Code:
echo "sys-apps/ivman ~x86" >> /etc/portage/package.keywords
aunque por lo que acabo de ver, hay una versión de ivman marcada como x86, por lo que eso no haría falta a quienes quieran estar en estable.

Salu2, y gracias por el how-to.
_________________
Cómo usar Portage correctamente
Back to top
View user's profile Send private message
FuckingFreaky
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2004
Posts: 128

PostPosted: Sat May 28, 2005 5:55 pm    Post subject: Reply with quote

¿Alguien sabe por qué no está esto en el wiki en español? Alguna forma de avisar para que lo pongan ahí? Creo que es un how to de utilidad para todos los hispanoparlantes, no?

Aparte... ahora al iniciar al principio me salen unos cuantos mensajes de "Scanning modulenoséqué not found". ¿Alguien sabe qué puede ser? Lo que es el sistema me va perfecto de momento, sin ningún error ni nada.

Un saludo!
Back to top
View user's profile Send private message
g0su
Guru
Guru


Joined: 14 May 2003
Posts: 437
Location: Dresden, Deutschland

PostPosted: Tue Sep 13, 2005 1:44 am    Post subject: Reply with quote

Me imagino que el señor navegante lo tendra en tareas pendiente, de todas formas usted puede igual que cualquier persona, si asi lo desea, portarlo usted mismo al wiki.

Navegante solo un punto, el demonio de hal es hald y no hal, por lo que es rc-update hald default.

Muchas gracias por la guia puesto que ya tengo automount en el portatil X)

Nota: confirmo su perfecto funcionamiento en power pc, el ivman ahi que pasarlo a ~ppc y el resto esta en estable.
_________________
Busco desarrollador con complejo de proxy, interesados MP
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum