Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200410-06 ] CUPS: Leakage of sensitive information
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Sat Oct 09, 2004 6:29 pm    Post subject: [ GLSA 200410-06 ] CUPS: Leakage of sensitive information Reply with quote

Gentoo Linux Security Advisory

Title: CUPS: Leakage of sensitive information (GLSA 200410-06)
Severity: normal
Exploitable: local
Date: October 09, 2004
Bug(s): #66501
ID: 200410-06

Synopsis

CUPS leaks information about user names and passwords when using remote printing to SMB-shared printers which require authentication.

Background

The Common UNIX Printing System (CUPS) is a cross-platform print spooler.

Affected Packages

Package: net-print/cups
Vulnerable: <= 1.1.20-r2
Vulnerable: = 1.1.21
Unaffected: >= 1.1.20-r3 < 1.1.21
Unaffected: >= 1.1.21-r1
Architectures: All supported architectures


Description

When printing to a SMB-shared printer requiring authentication, CUPS leaks the user name and password to a logfile.

Impact

A local user could gain knowledge of sensitive authentication data.

Workaround

There is no known workaround at this time.

Resolution

All CUPS users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=net-print/cups-1.1.20-r3"
# emerge ">=net-print/cups-1.1.20-r3"


References

CAN-2004-0923


Last edited by GLSA on Sun May 07, 2006 4:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum