Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Install bluetooth +Nokia 6230
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
matroskin
Apprentice
Apprentice


Joined: 21 Jan 2003
Posts: 211

PostPosted: Wed Dec 08, 2004 5:23 pm    Post subject: gammu works !!!! Reply with quote

hi all
I've got gammu to work
here is working config file ~/.gammurc
Code:
[gammu]
#connection = blueobex
#connection = phonetblue
connection = bluephonet
# your phone's mac address
device= 00:EE:EE:EE:EE:EE
port = 00:EE:EE:EE:EE:EE
model = 6230
use_locking = no
gammucoding = utf8

save it and run
Code:
gammu --identify
gammu --nokiavibratest
Back to top
View user's profile Send private message
matroskin
Apprentice
Apprentice


Joined: 21 Jan 2003
Posts: 211

PostPosted: Wed Dec 08, 2004 5:32 pm    Post subject: Reply with quote

and yet another wammu tip
run it as
Code:
LANG=POSIX wammu

and prevent numerous locale bugs
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Tue Feb 01, 2005 5:51 pm    Post subject: Some functions not available for your OS Reply with quote

Hi,

i managed to install all the bluetooth stuff and obex filetransfer works great using kde's bluetooth utility.

now i wanted to be able to manage/backup my sms, contacts etc.

i emerged wammu and gammu and configured .gammurc and .Wammu the way you guys discribed it. but, no matter what i try, i always get a message telling me:

"Some functions not available for your OS (disabled in config or not written)."

any ideas?

thanks!
sander.

gammu version: 0.99.22
wammu version: 0.8
python-gammu version: 0.7
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Tue Feb 01, 2005 6:06 pm    Post subject: Reply with quote

sorry... kick me! ;-)

i forgot to add the bluetooth flag to my USE flag before emerging gammu. i reemerged and now everything works fine!

cheers,
sander.
Back to top
View user's profile Send private message
holochip
n00b
n00b


Joined: 02 Feb 2005
Posts: 5

PostPosted: Wed Feb 02, 2005 2:45 am    Post subject: Reply with quote

hi,
pls help i do everything what you suggest and i have (i think) functionaly wammu BUT
(HERE IS WHAT I SEE IF I WANT TO CONNECT PHONE

[Gammu - 0.99.22 built 03:27:35 Feb 2 2005 in gcc 3.3]
[Connection - "atblue"]
[Model type - "at"]
[Device - "00:0E:07:E7:81:43"]
[Run on - Linux, kernel 2.6.10]
[Module - "A2D|iPAQ|at|M20|S25|MC35|TC35|C35i|S300|5110|5130|5190|5210|6110|6130|6150|6190|6210|6250|6310|6310i|6510|7110|8210|8250|8290|8310|8390|8850|8855|8890|8910|9110|9210"]
00:0E:07:E7:81:43
Channel 1 - "Dial-up Networking"
Channel 4 - "HS Voice Gateway"
Channel 2 - "Serial Port"
Channel 3 - "Serial Port 2"
Channel 6 - "OBEX Object Push"
Channel 8 - "OBEX IrMC Sync Server"
Channel 9 - "OBEX Basic Imaging"
Channel 7 - "OBEX File Transfer"
Channel 5 - "HF Voice Gateway"
Channel 15 - "OBEX SyncML Client"
Channel 15
Segmentation fault

LAST LINE IS THE PROBLEM :o))

same is for gammu --identify

i have SonyEricsson k700i and i want run it on pIII 500
PLS HELP :) thx for anything IDEA :)

SORRY FOR MY ENGLISH :)
Back to top
View user's profile Send private message
kwyjibo
n00b
n00b


Joined: 21 Feb 2005
Posts: 14
Location: Switzerland

PostPosted: Wed Feb 23, 2005 10:16 pm    Post subject: Reply with quote

i worked through benoitc's howto, but having some problems....

what is working
Applications -> SystemTools -> Bluetooth Manager
Devices -> Scan will find my 6230
http://mypage.bluewin.ch/jets/6230.png

After that, I can send files from my 6230 or from Natilus via "send via bluetooth"

rfcomm connect works:
Code:
# rfcomm connect 00:11:9f:69:c5:2b
Connected /dev/bluetooth/rfcomm/0 to 00:11:9F:69:C5:2B on channel 9
Press CTRL-C for hangup



what is not working
Applications -> SystemTools -> Bluetooth File Transfer doesn't start (no reaction at all)

obexftp connects, but won't download files:
Code:
# obexftp -b 00:11:9f:69:c5:2b -l Fotos -g Bild000.jpg
Browsing 00:11:9F:69:C5:2B ...
Channel: 10
No custom transport
Connecting...bt: 1
done
Receiving Fotos...|<?xml version="1.0"?>
<!DOCTYPE folder-listing SYSTEM "obex-folder-listing.dtd"
 [ <!ATTLIST folder mem-type CDATA #IMPLIED> ]>
<folder-listing version="1.0">
    <parent-folder />
    <file name="Bild000.jpg" size="25882" modified="20050129T134114" user-perm="RWD"/>
    <file name="Bild001.jpg" size="30619" modified="20050129T134136" user-perm="RWD"/>
    <file name="Bild002.jpg" size="38918" modified="20050129T161154" user-perm="RWD"/>
    <file name="Bild003.jpg" size="37415" modified="20050129T161216" user-perm="RWD"/>
    <file name="Bild004.jpg" size="18589" modified="20050204T200318" user-perm="RWD"/>
    <file name="Bild005.jpg" size="60477" modified="20050205T011210" user-perm="RWD"/>
    <file name="Bild006.jpg" size="69451" modified="20050205T012934" user-perm="RWD"/>
    <file name="Bild007.jpg" size="79147" modified="20050206T021126" user-perm="RWD"/>
    <file name="Bild008.jpg" size="79627" modified="20050206T021140" user-perm="RWD"/>
    <file name="Bild009.jpg" size="39897" modified="20050206T033522" user-perm="RWD"/>
    <file name="Bild010.jpg" size="33017" modified="20050206T033544" user-perm="RWD"/>
    <file name="Bild011.jpg" size="16086" modified="20050212T124540" user-perm="RWD"/>
</folder-listing>
done
Receiving Bild000.jpg... failed: Bild000.jpg
Disconnecting...done


gnome-obex-server doesn't work
Code:
# gnome-obex-server

** (gnome-obex-server:2081): WARNING **: OBEX server register error: -1

** (gnome-obex-server:2081): WARNING **: Unable to initialize OBEX source

** (gnome-obex-server:2081): WARNING **: Couldn't initialise OBEX listener


any help would be much appreciated
Back to top
View user's profile Send private message
noup
l33t
l33t


Joined: 21 Mar 2003
Posts: 917

PostPosted: Thu Feb 24, 2005 1:33 am    Post subject: Reply with quote

kwyjibo wrote:

Applications -> SystemTools -> Bluetooth File Transfer doesn't start (no reaction at all)

I'm not on my bluetooth-enabled computer right now, but if i recall correctly, Bluetooth File Transfer opens an icon in the system tray. Do you have the system tray applet in your panel?

Quote:

obexftp connects, but won't download files:
Code:
# obexftp -b 00:11:9f:69:c5:2b -l Fotos -g Bild000.jpg

I think you're not using it correctly. What you are instructing it to do is to list the "Fotos" folder and retrieve /Bild000.jpg file, but you're not specifying that the Bild000.jpg file is in the Fotos folder.
What you want is perhaps:
Code:

$obexftp -b 00:11:9f:69:c5:2b -g Fotos/Bild000.jpg

or
Code:

$obexftp -b 00:11:9f:69:c5:2b -c Fotos -g Bild000.jpg

As i said, i can't test it right now but i think this is the right way to run it.

Quote:

gnome-obex-server doesn't work
Code:
# gnome-obex-server

** (gnome-obex-server:2081): WARNING **: OBEX server register error: -1

** (gnome-obex-server:2081): WARNING **: Unable to initialize OBEX source

** (gnome-obex-server:2081): WARNING **: Couldn't initialise OBEX listener


Can't help you with this one, i don't even think i've used gnome-obex-server before. :)
_________________
noup.
Back to top
View user's profile Send private message
kwyjibo
n00b
n00b


Joined: 21 Feb 2005
Posts: 14
Location: Switzerland

PostPosted: Thu Feb 24, 2005 10:40 pm    Post subject: Reply with quote

noup wrote:

What you want is perhaps:
Code:

$obexftp -b 00:11:9f:69:c5:2b -g Fotos/Bild000.jpg

or
Code:

$obexftp -b 00:11:9f:69:c5:2b -c Fotos -g Bild000.jpg

As i said, i can't test it right now but i think this is the right way to run it.



cheers, mate! both ways worked perfectly 8O
Back to top
View user's profile Send private message
mathes.s
Apprentice
Apprentice


Joined: 18 Apr 2003
Posts: 277
Location: Brunswick, Germany

PostPosted: Tue Apr 05, 2005 3:04 pm    Post subject: Reply with quote

Hi,
is anyone here who got the 6230 syncing with kdes Kontact or with korganizer via bluetooth using kitchensync?

I use kde3.4 and the 3.4 Verions of the Progrmas mentioned above. I can connect my phone via bluetooth and I can control amarok via bemused, but I don't know how to sync with this Programs.

Mathes
Back to top
View user's profile Send private message
mathes.s
Apprentice
Apprentice


Joined: 18 Apr 2003
Posts: 277
Location: Brunswick, Germany

PostPosted: Fri Apr 08, 2005 4:15 pm    Post subject: Reply with quote

Hi,
is really no one here whop got kitchensync running with the 6230?

Mathes
Back to top
View user's profile Send private message
noup
l33t
l33t


Joined: 21 Mar 2003
Posts: 917

PostPosted: Fri Apr 08, 2005 10:03 pm    Post subject: Reply with quote

mathes.s wrote:
Hi,
is really no one here whop got kitchensync running with the 6230?

Mathes

Isn't that a bit specific? i mean, i don't think of too many people with a gentoo+nokia6230+kitchensync combination... i would help you if i could, but i use gnome. :)
_________________
noup.
Back to top
View user's profile Send private message
mndar
n00b
n00b


Joined: 04 Apr 2005
Posts: 49

PostPosted: Mon Oct 10, 2005 2:01 am    Post subject: can connect but only the first time Reply with quote

I have a Nokia 6820
I have installed bluez-utils, bluez-libs,obexftp and kdebluetooth. I am able to find my phone with hcitool scan, check the services using sdptool browse <address>. When I try to get any file with obexftp, I am asked for the passkey on my cell phone. On entering it, I get a message Paired with COMP123 and I recieve the file. Everything is file until this point.
After this, whenever I try to get or put any file or even get the listing, it fails. My cellphone Requests authorization to connect to COMP123. On saying yes, I get a message Bluetooth connection Failed on my cellphone. But if I remove COMP123 from the paired list on my cell phone, I am able to get the file, but not after pairing. Thus any transfer works only when the devices are not paired. I have tried using /usr/lib/kdebluetooth/kbluepin, but the samething happens.
The same thing happens with KDEbluetooth. However with this, I am able to transfer files to the cell phone using OBEX object push. How do I fix this. It used to wi\ork very well earlier. What should I check?
_________________
Gentoo on Freerunner 2014-02-25 http://mndar.phpnet.us/freerunner/gentoo/
GStreamer XOverlay and VideoOverlay http://mndar.phpnet.us/gstreamer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum