Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with glib and gettext
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
Eldomir
n00b
n00b


Joined: 09 Nov 2003
Posts: 63
Location: Madrid/Spain/EU

PostPosted: Fri Sep 24, 2004 8:49 pm    Post subject: Problem with glib and gettext Reply with quote

I have a problem trying to emerge glib. When it runs the configure script, it complains because I don't have gettext:

Code:
configure: error:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html


But on the other hand, emerge -s gettext:

Code:
*  sys-devel/gettext
      Latest version available: 0.12.1-r1
      Latest version installed: 0.12.1-r1
      Size of downloaded files: 5,592 kB
      Homepage:    http://www.gnu.org/software/gettext/gettext.html
      Description: GNU locale utilities
      License:     GPL-2


Any idea why this is happening?
_________________
"Give a man a fire and he will be warm for a day. Set a man on fire and he will be warm for the rest of his life"
-- Terry Pratchett
Back to top
View user's profile Send private message
Eldomir
n00b
n00b


Joined: 09 Nov 2003
Posts: 63
Location: Madrid/Spain/EU

PostPosted: Sat Sep 25, 2004 8:27 am    Post subject: Reply with quote

Ok, I just did an emerge sync and it appears now gettext doesn't have the mac os keyword anymore, so that explains it (it was there when I emerged it a couple of days ago).
_________________
"Give a man a fire and he will be warm for a day. Set a man on fire and he will be warm for the rest of his life"
-- Terry Pratchett
Back to top
View user's profile Send private message
phaidros
n00b
n00b


Joined: 27 Jul 2003
Posts: 26
Location: germany

PostPosted: Thu Sep 30, 2004 1:38 pm    Post subject: Reply with quote

as found in:
http://bugs.gentoo.org/show_bug.cgi?id=64779

Quote:

------ Additional Comment #1 From Lina Pezzella 2004-09-28 18:50 PST -------

it looks like gettext was compiled without 'nls'. This should be hardcoded into the ebuild, so it shouldn't have happened. Make sure you've
emerged sync recently, then recompile gettext, and try glib again. If it still fails, try 'USE=nls emerge gettext glib'.



USE="nls" for gettext worked for me. sadly I can't find out which versions I have installed cause qpkg is broken and won't get fixed coz depreceated and the tools insteas - equery - is to cryptic and functionless for me : /

ps: in case an ebuild has no ppc-macos or ~ppc-macos flag you can install it by
Code:
emerge /path/to/ebuild.ebuild
(depreceated, but still working)
or just set the needed keyword with
Code:
ekeyword ~ppc-macos /path/to/ebuild.ebuild
emerge ebuild


regards
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum