Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem with emerge system[SOLVED]
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Wed Sep 29, 2004 8:36 pm    Post subject: problem with emerge system[SOLVED] Reply with quote

I ve Been installing Gentoo Mac os and after done emerge --sync(yes I got the same problem like others in this forum..) my response on emerge system was:

Code:
Calculating system dependencies ...done!
>>> emerge (1 of 4) net-misc/wget-1.9.1-r2 to /
>>> md5 src_uri ;-) wget-1.9.1.tar.gz
>>> Checking wget-1.9.1.tar.gz's mtime...
>>> WORKDIR is up-to-date, keeping...
 * Using GNU config files from /usr/share/gnuconfig
 *  Updating config.sub                                                   [ ok ]
 *  Updating config.guess                                                 [ ok ]
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
configuring for GNU Wget 1.9.1
checking build system type... powerpc-apple-darwin7.5.0
checking host system type... powerpc-apple-darwin
checking whether make sets $(MAKE)... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for powerpc-apple-darwin-gcc... no
checking for gcc... no
checking for powerpc-apple-darwin-cc... no
checking for cc... no
checking for cc... no
checking for powerpc-apple-darwin-cl... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

!!! ERROR: net-misc/wget-1.9.1-r2 failed.
!!! Function econf, Line 425, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


..so I don't solved the problem yet..any suggestions??


Last edited by paperp on Thu Oct 07, 2004 9:45 am; edited 1 time in total
Back to top
View user's profile Send private message
BennyP
Guru
Guru


Joined: 09 May 2003
Posts: 497
Location: Toronto, Canada

PostPosted: Thu Sep 30, 2004 2:10 am    Post subject: Reply with quote

have you installed apple's developer cd??
what is your $PATH?
_________________
Could it be?
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Thu Sep 30, 2004 6:05 am    Post subject: Reply with quote

First , tnks , then yes I got Xcode 1.2 installed , but I don't know How find the PATH , I come from Linux and it's just 3 days I'm playng with Mac... :(



EDIT: I've found that I got a gcc3 executable file in /usr/bin , maybe this means that the PATH where emerge system seeks the compiler is wrong and I must move my gcc3 in another directory??
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Sat Oct 02, 2004 1:16 pm    Post subject: Reply with quote

up,up,up....
Back to top
View user's profile Send private message
pindar
Apprentice
Apprentice


Joined: 30 Apr 2004
Posts: 220

PostPosted: Sat Oct 02, 2004 1:44 pm    Post subject: Reply with quote

Well, if you come from linux, you should know how to find out your PATH. Please post the output from these two commands:
Code:
echo $PATH
which gcc

/usr/bin is where gcc usually resides, so don't move it into another directory.
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Tue Oct 05, 2004 1:37 pm    Post subject: Reply with quote

Ok , now I feel very embarassed myself.... :oops:
..but yes , I should...the fact is tha the GentooLike impact is more friendly..I don't know , anyway
Quote:

emanuele-cecchis-Computer:~ emanuelececchi$ echo $PATH
/bin:/sbin:/usr/bin:/usr/sbin:/usr/lib/portage/bin/
emanuele-cecchis-Computer:~ emanuelececchi$ which gcc
no gcc in /bin /sbin /usr/bin /usr/sbin /usr/lib/portage/bin/


Thamk you for your time. :roll:
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Tue Oct 05, 2004 2:11 pm    Post subject: Reply with quote

....yes now I'M getting everything in works , the problem was the packets one has to install from Xcode Tools , it was'nt clear , for me , who the first onewho the last one...now it's compiling and I feel at home!!
Thanks Guys :D
Back to top
View user's profile Send private message
paperp
Guru
Guru


Joined: 27 Feb 2004
Posts: 544
Location: Toscana , Italy

PostPosted: Thu Oct 07, 2004 9:44 am    Post subject: Re: problem with emerge system[SOLVED] Reply with quote

paperp wrote:
I ve Been installing Gentoo Mac os and after done emerge --sync(yes I got the same problem like others in this forum..) my response on emerge system was:

Code:
Calculating system dependencies ...done!
>>> emerge (1 of 4) net-misc/wget-1.9.1-r2 to /
>>> md5 src_uri ;-) wget-1.9.1.tar.gz
>>> Checking wget-1.9.1.tar.gz's mtime...
>>> WORKDIR is up-to-date, keeping...
 * Using GNU config files from /usr/share/gnuconfig
 *  Updating config.sub                                                   [ ok ]
 *  Updating config.guess                                                 [ ok ]
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
configuring for GNU Wget 1.9.1
checking build system type... powerpc-apple-darwin7.5.0
checking host system type... powerpc-apple-darwin
checking whether make sets $(MAKE)... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for powerpc-apple-darwin-gcc... no
checking for gcc... no
checking for powerpc-apple-darwin-cc... no
checking for cc... no
checking for cc... no
checking for powerpc-apple-darwin-cl... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

!!! ERROR: net-misc/wget-1.9.1-r2 failed.
!!! Function econf, Line 425, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


..so I don't solved the problem yet..any suggestions??
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum