Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[date]changement d'horaire(non résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Tue Nov 02, 2004 8:42 am    Post subject: [date]changement d'horaire(non résolu) Reply with quote

Hello,

Mon système n'a pas passé à l'heure d'hiver automatiquement, enfin, celui du laptop, car celui de mon pc fixe si ... pourtant, ils sont les deux configurés de la même manière pour l'horloge (/etc/localtime font le lien vers la même chose, et la variable clock est mise à local dans /etc/rc.conf) ...

J'ai trouvé ce topic : http://forums.gentoo.org/viewtopic.php?t=172917&highlight=heure+dhiver, mais rien n'y fait, avec UTC, le comportement est toujours le même sur mon portable ...

Ce qui est vachement bizarre, c'est que ça marche sur l'un et pas sur l'autre alors qu'ils sont configurés normalement de la même manière pour celà ...

Une idée ??? Merci
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 9:33 am    Post subject: Reply with quote

Bah moi j'ai jamais réussi à avoir l'heure correcte sur mon pc...
Regardez :
Code:
$ ls -l /etc/localtime                                   
lrwxrwxrwx  1 root root 32 sep 29 17:57 /etc/localtime -> /usr/share/zoneinfo/Europe/Paris


Code:
$ cat /etc/rc.conf | grep CLOCK                           
# Set CLOCK to "UTC" if your system clock is set to UTC (also known as
# Greenwich Mean Time).  If your clock is set to the local time, then set CLOCK
CLOCK="local"


Code:
$ date                                                   
mar nov  2 13:23:46 CET 2004

_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
Farnsworth
Guru
Guru


Joined: 04 Feb 2003
Posts: 355
Location: Aix en Pce, France

PostPosted: Tue Nov 02, 2004 11:31 am    Post subject: Reply with quote

Personellement j'utilise ntp... eh bien rien de mieux, une heure de difference pour ntp ca fait trop pour qu'il se mette a jour :?
bref si quelqu'un a LA solution ...
(pas une modif de la cron please :D)
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Tue Nov 02, 2004 2:37 pm    Post subject: Reply with quote

Heu, si tu emerges ntp, maintenant il y a ntpd, ntp-date, bref, si la difference est trop grande, il va tout connement changer la date au lieu de l'ajuster (c'est subtil, je pige pas trop) ...

Faut juste choisir un bon serveur et demarrer ntpd au demarrage.
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 2:45 pm    Post subject: Reply with quote

Personne ne sait alors comment régler convenablement la date ?
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
Mac Cloud
Apprentice
Apprentice


Joined: 27 Sep 2004
Posts: 214
Location: In a galaxy far far away...

PostPosted: Tue Nov 02, 2004 2:45 pm    Post subject: Reply with quote

bosozoku wrote:
Personne ne sait alors comment régler convenablement la date ?

Code:
#date -s

:lol:
_________________
Vous prouver que j'ai raison serait admettre que je puisse avoir tort.
Beaumarchais
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 2:55 pm    Post subject: Reply with quote

Oui je sais....
Mais c'est écrasé au reboot !
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
Mac Cloud
Apprentice
Apprentice


Joined: 27 Sep 2004
Posts: 214
Location: In a galaxy far far away...

PostPosted: Tue Nov 02, 2004 2:58 pm    Post subject: Reply with quote

bosozoku wrote:
Oui je sais....
Mais c'est écrasé au reboot !

d'ou le :lol: à la fin du post
_________________
Vous prouver que j'ai raison serait admettre que je puisse avoir tort.
Beaumarchais
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 3:08 pm    Post subject: Reply with quote

Mac Cloud wrote:
bosozoku wrote:
Oui je sais....
Mais c'est écrasé au reboot !

d'ou le :lol: à la fin du post

Ah ok, j'ai pensé à de la moquerie :oops:
Je suis rassuré :)
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Tue Nov 02, 2004 3:52 pm    Post subject: Reply with quote

Perso, je suis aussi en CLOCK="local" et pour me mettre à l'heure, un petit ntpdate ntp.tuxfamily.net et tout a roulé (j'ai bien sûr emerger ntp).

Sinon, comme soluce bien bourrine, il y a la mise à jour de l'heure directe dans le bios ... :twisted: A priori, ça devrait fonctionner quelque soit le système ... :roll:
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5532
Location: ~Brussels - Belgique

PostPosted: Tue Nov 02, 2004 5:49 pm    Post subject: Reply with quote

solution 1: changer dans le BIOS

solution 2:
Code:
date --set 'xxxxx'
hwclock --systohc

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Tue Nov 02, 2004 6:19 pm    Post subject: Reply with quote

Je suis en local et ca a changer tout seul sur mes 2 PC...
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Tue Nov 02, 2004 6:44 pm    Post subject: Reply with quote

ben moi sur mon pc fixe je suis en local et ça s'est passé super bien ...

sur le laptop j'ai exactement la même chose, et là ça a merdé ... je comprends pas la différence et c'est ça qui m'énerve !!! d'autant plus que sur mon laptop, l'heure du BIOS est exacte !!!!
Back to top
View user's profile Send private message
Farnsworth
Guru
Guru


Joined: 04 Feb 2003
Posts: 355
Location: Aix en Pce, France

PostPosted: Tue Nov 02, 2004 9:04 pm    Post subject: Reply with quote

Trevoke wrote:
Heu, si tu emerges ntp, maintenant il y a ntpd, ntp-date, bref, si la difference est trop grande, il va tout connement changer la date au lieu de l'ajuster (c'est subtil, je pige pas trop) ...

Faut juste choisir un bon serveur et demarrer ntpd au demarrage.


Je connais ntp, et c'est bien ce que j'utilise, avec le fichier ntp.conf qui contient les serveurs qui vont bien, mais ca n'a pas mis a l'heure, il y avait 3600sec (logique :D) de decalage avec le serveur (lancer ntpdc et taper peers).
Mais il me semble que c'est le fonctionnement normal, en cas de trop grande difference d'heure (plus de 1000s il me semble, a confirmer) la mise a jour n'est pas faite.
donc ca ne resoud pas le probleme :cry:

edit: le man de ntpd:

Code:
       Most operating systems and hardware of today incorporate a time-of-year
       (TOY)  chip  to maintain the time during periods when the power is off.
       When the machine is booted, the chip is used to initialize the  operat-
       ing  system  time.  After the machine has synchronized to a NTP server,
       the operating system corrects the chip from time to time. In case there
       is  no TOY chip or for some reason its time is more than 1000s from the
       server time, ntpd assumes something must be terribly wrong and the only
       reliable  action  is for the operator to intervene and set the clock by
       hand. This causes ntpd to exit with a panic message to the system  log.
       The  -g  option  overrides  this check and the clock will be set to the
       server time regardless of  the  chip  time.  However,  and  to  protect
       against  broken  hardware,  such  as when the CMOS battery fails or the
       clock counter becomes defective, once the clock has been set, an  error
       greater than 1000s will cause ntpd to exit anyway.


apparemment l'option -g au lancement de ntpd resoudrait le probleme...

Re-edit: les logs de ntp du jour apres le changement d'heure:

Code:
30 Oct 14:27:04 ntpd[7386]: ntpd exiting on signal 15
 1 Nov 19:54:26 ntpd[7386]: ntpd exiting on signal 15
 1 Nov 20:05:24 ntpd[7381]: synchronized to 212.85.158.2, stratum=3
 1 Nov 20:16:11 ntpd[7381]: time correction of -3617 seconds exceeds sanity limit (1000); set clock manually to the correct UTC time.
 1 Nov 20:16:20 ntpd[8441]: parent died before we finished, exiting


Berf, je pense qu'il faut modifier le fichier /etc/init.d/ntpd comme suit:

Code:
start() {
        checkconfig || return $?

        ebegin "Starting ntpd"
        touch /var/run/ntpd.pid
        if ! chown ntp:ntp /var/run/ntpd.pid ; then
                eend 1 "unable to chown pid file"
                return 1
        fi
        /usr/bin/ntpd -g -p /var/run/ntpd.pid ${NTPD_OPTS}
        eend $? "Failed to start ntpd"
}


On le voit pas tres bien mais il y a un '-g' sur la ligne qui lance le demon ntpd ;)


Last edited by Farnsworth on Tue Nov 02, 2004 9:18 pm; edited 4 times in total
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Tue Nov 02, 2004 9:10 pm    Post subject: Reply with quote

man daylight ?
chaipo moi...
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Tue Nov 02, 2004 9:30 pm    Post subject: Reply with quote

Moi j'ai été impressionné, dimanche matin en me levant je me disais que j'allais devoir regler l'heure de tt les ordi.... et bien non, j'ai 3gentoo et elles ont toutes les 3 été mise à l'heure automatiquement :D bravo !
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 10:03 pm    Post subject: Reply with quote

j'ai CLOCK=local, ca veut dire qu'il prend l'heure du bios ?
Pourquoi il prend pas l'heure du /etc/localtime ? Putain j'en ai marre de c'est heure à la con :evil:


PS : désolé pour cette vulgarité mais j'en ai vraiment marre ! J'ai rien installé pour l'horloge, uniquement réglé la variable dans le rc.conf et il m'affiche n'importe quoi....
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
scout
Veteran
Veteran


Joined: 08 Mar 2003
Posts: 1991
Location: France, Paris en Semaine / Metz le W-E

PostPosted: Wed Nov 03, 2004 12:17 am    Post subject: Reply with quote

zdra wrote:
Moi j'ai été impressionné, dimanche matin en me levant je me disais que j'allais devoir regler l'heure de tt les ordi.... et bien non, j'ai 3gentoo et elles ont toutes les 3 été mise à l'heure automatiquement :D bravo !

Et oui, si t'en en clock=UTC ça passe comme dans du beurre
_________________
http://petition.eurolinux.org/ - Petition against ePatents
L'essence de la finesse
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Wed Nov 03, 2004 12:20 am    Post subject: Reply with quote

Mais en UTC c'est le méridien de greenwich alors ca marche pas bien, c'est décalé par rapport à l'horaire francais (meridien de paris);
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
Argian
l33t
l33t


Joined: 01 May 2004
Posts: 682
Location: Nîmes

PostPosted: Wed Nov 03, 2004 2:10 am    Post subject: Reply with quote

bosozoku wrote:
Mais en UTC c'est le méridien de greenwich alors ca marche pas bien, c'est décalé par rapport à l'horaire francais (meridien de paris);
UTC + le bon fuseau horaire ==> l'heure juste :D (Enfin, à /etc/adjtime près. Et aussi, un dual boot avec windows, windows risque de ne pas aimer l'UTC)
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Wed Nov 03, 2004 6:41 am    Post subject: Reply with quote

scout wrote:
zdra wrote:
Moi j'ai été impressionné, dimanche matin en me levant je me disais que j'allais devoir regler l'heure de tt les ordi.... et bien non, j'ai 3gentoo et elles ont toutes les 3 été mise à l'heure automatiquement :D bravo !

Et oui, si t'en en clock=UTC ça passe comme dans du beurre


Personnellement, j'ai remarqué que sur mes 3 machines, les deux qui ont changé d'heure sont des desktops et qu'ils sont restés allumés tout le WE. Le portable qui était éteint n'a pas changé d'heure automatiquement. Je précise que les 3 machines sont en clock="local".

Peut être un début de réponse...
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
Mac Cloud
Apprentice
Apprentice


Joined: 27 Sep 2004
Posts: 214
Location: In a galaxy far far away...

PostPosted: Wed Nov 03, 2004 7:39 am    Post subject: Reply with quote

Talosectos wrote:
scout wrote:
zdra wrote:
Moi j'ai été impressionné, dimanche matin en me levant je me disais que j'allais devoir regler l'heure de tt les ordi.... et bien non, j'ai 3gentoo et elles ont toutes les 3 été mise à l'heure automatiquement :D bravo !

Et oui, si t'en en clock=UTC ça passe comme dans du beurre


Personnellement, j'ai remarqué que sur mes 3 machines, les deux qui ont changé d'heure sont des desktops et qu'ils sont restés allumés tout le WE. Le portable qui était éteint n'a pas changé d'heure automatiquement. Je précise que les 3 machines sont en clock="local".

Peut être un début de réponse...

En effet mon portable ne c'est mis a l'heure qu'aujourd'hui (pas de ntp) perso peut-etre que le "calendrier" inclu dans le bios était-il faux ?
_________________
Vous prouver que j'ai raison serait admettre que je puisse avoir tort.
Beaumarchais
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Sat Nov 06, 2004 6:30 pm    Post subject: Reply with quote

chez moi toujours rien sur mon portable, et c'est vraiment rageant, c'est le petit détail à la con qui fait chier et qui fait dire au Windows Users : "'t'arrives même pas à régler l'heure avec Linux ..."

personne ne s'est penché vraiment à fond sur le problème ? Parce qu'il doit bien y avoir une explication quand même !!!
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5532
Location: ~Brussels - Belgique

PostPosted: Sun Nov 07, 2004 12:07 am    Post subject: Reply with quote

Pourquoi ne la changes-tu pas simplement à la main ? Avec Windows 95 (SR1), j'avais aussi l'air malin quand il changeait l'heure le mauvais dimanche :P
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4671
Location: Theux (Belgium)

PostPosted: Sat Nov 13, 2004 11:45 am    Post subject: Reply with quote

Bonjour.

J'avais aussi ce genre de blème avec ma machine. J'ai constaté que l'heure se décalait de plus en plus. Je pense avoir résolu le problème en exécutant au démarrage le démon ntpd *et* le client ntp, ntp-client.

Pourquoi?

Le démon NTP se charge d'ajuster l'heure si le décalage n'est pas trop important, c'est-à-dire qu'il ralentit ou accélère le battement de l'horloge interne. Il ne change pas la date en modifiant sa valeur directement; c'est ce que fait ntp-client. Voilà pourquoi il faut les placer tous les deux dans les scripts de démarrage:

Code:
rc-update -a ntp-client default
rc-update -a ntpd default


Note: avant d'exécuter ntp-client, il faut modifier le fichier de configuration /etc/conf.d/ntp-client. Notez aussi que cela revient à exécuter la commande ntpdate à chaque démarrage mais c'est bien plus propre puisque c'est uniquement pour synchroniser l'heure au démarrage du PC. Le reste, c'est le démon NTP qui s'en charge.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum