Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200409-28 ] GTK+ 2, gdk-pixbuf: Multiple image decoding vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Tue Sep 21, 2004 9:12 pm    Post subject: [ GLSA 200409-28 ] GTK+ 2, gdk-pixbuf: Multiple image decodi Reply with quote

Gentoo Linux Security Advisory

Title: GTK+ 2, gdk-pixbuf: Multiple image decoding vulnerabilities (GLSA 200409-28)
Severity: normal
Exploitable: remote
Date: September 21, 2004
Bug(s): #64230
ID: 200409-28

Synopsis

The GdkPixbuf library, which is also included in GTK+ 2, contains several vulnerabilities that could lead to a Denial of Service or the execution of arbitrary code.

Background

GTK+ (GIMP Toolkit +) is a toolkit for creating graphical user interfaces. The GdkPixbuf library provides facilities for image handling. It is available as a standalone library as well as shipped with GTK+ 2.

Affected Packages

Package: x11-libs/gtk+
Vulnerable: < 2.4.9-r1
Unaffected: >= 2.4.9-r1
Unaffected: < 2.0.0
Architectures: All supported architectures

Package: media-libs/gdk-pixbuf
Vulnerable: < 0.22.0-r3
Unaffected: >= 0.22.0-r3
Architectures: All supported architectures


Description

A vulnerability has been discovered in the BMP image preprocessor (CAN-2004-0753). Furthermore, Chris Evans found a possible integer overflow in the pixbuf_create_from_xpm() function, resulting in a heap overflow (CAN-2004-0782). He also found a potential stack-based buffer overflow in the xpm_extract_color() function (CAN-2004-0783). A possible integer overflow has also been found in the ICO decoder.

Impact

With a specially crafted BMP image an attacker could cause an affected application to enter an infinite loop when that image is being processed. Also, by making use of specially crafted XPM or ICO images an attacker could trigger the overflows, which potentially allows the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All GTK+ 2 users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=x11-libs/gtk+-2.4.9-r1"
# emerge ">=x11-libs/gtk+-2.4.9-r1"
All GdkPixbuf users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=media-libs/gdk-pixbuf-0.22.0-r3"
# emerge ">=media-libs/gdk-pixbuf-0.22.0-r3"


References

CAN-2004-0753
CAN-2004-0782
CAN-2004-0783
CAN-2004-0788
GNOME Bug 150601


Last edited by GLSA on Sun May 07, 2006 4:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum