Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200409-24 ] Foomatic: Arbitrary command execution in foomatic-rip filter
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Mon Sep 20, 2004 4:29 pm    Post subject: [ GLSA 200409-24 ] Foomatic: Arbitrary command execution in Reply with quote

Gentoo Linux Security Advisory

Title: Foomatic: Arbitrary command execution in foomatic-rip filter (GLSA 200409-24)
Severity: high
Exploitable: remote
Date: September 20, 2004
Bug(s): #64166
ID: 200409-24

Synopsis

The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server.

Background

Foomatic is a system for connecting printer drivers with spooler systems such as CUPS and LPD. The foomatic-filters package contains wrapper scripts which are designed to be used with Foomatic.

Affected Packages

Package: net-print/foomatic
Vulnerable: <= 3.0.1
Unaffected: >= 3.0.2
Architectures: All supported architectures

Package: net-print/foomatic-filters
Vulnerable: <= 3.0.1
Unaffected: >= 3.0.2
Architectures: All supported architectures


Description

There is a vulnerability in the foomatic-filters package. This vulnerability is due to insufficient checking of command-line parameters and environment variables in the foomatic-rip filter.

Impact

This vulnerability may allow both local and remote attackers to execute arbitrary commands on the print server with the permissions of the spooler (oftentimes the "lp" user).

Workaround

There is no known workaround at this time.

Resolution

All foomatic users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=net-print/foomatic-3.0.2"
# emerge ">=net-print/foomatic-3.0.2"
PLEASE NOTE: You should update foomatic, instead of foomatic-filters. This will help to ensure that all other foomatic components remain functional.

References

Foomatic Announcement
Mandrakesoft Security Advisory
CAN 2004-0801


Last edited by GLSA on Wed Apr 08, 2009 4:16 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum