Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[fluxbox] xterm ne lance pas /etc/profile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue Feb 22, 2005 12:26 pm    Post subject: [fluxbox] xterm ne lance pas /etc/profile Reply with quote

Tout est dit : quand je lance une xterm dans une session fluxbox, je me retrouve avec un prompt à la con : bash 2.05$
et manifestement il n'a pas "sourcé" /etc/profile ...
ceci que je sois root ou simple quidam.
Une idée ?
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Feb 22, 2005 12:28 pm    Post subject: Reply with quote

dans ton bashrc , tu decommente la ligne qui source /etc/profile
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Feb 22, 2005 12:53 pm    Post subject: Reply with quote

kernel_sensei wrote:
dans ton bashrc , tu decommente la ligne qui source /etc/profile

Ou tu le rajoutes parce que moi il y était même pas commenté.
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue Feb 22, 2005 1:10 pm    Post subject: Reply with quote

j'ai pas de .bashrc dans mon home (j'avais évidemment vérifié avant de poster ;) ) et dan s/etc j'ai pas de bashrc ... ou qu'il est sencé être ?
Back to top
View user's profile Send private message
ultrabug
Developer
Developer


Joined: 24 Jan 2005
Posts: 698
Location: Paris

PostPosted: Tue Feb 22, 2005 1:19 pm    Post subject: Reply with quote

fais un simple :

Code:
echo "source /etc/profile" >~/.bashrc


ca suffira :)
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 990
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Tue Feb 22, 2005 1:20 pm    Post subject: Reply with quote

si jamais il est dans /etc/skel . copie-le aussi dans ton home

[EDIT] : à part ça chez moi il n'est pas activé comme ça (j'ai pas source /etc/profile dans .bashrc ) pourtant j'ai jamais de problème.

voilà ce que j'ai si ça peut aider quelqu'un:
Quote:
# /etc/skel/.bashrc:
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/skel/.bashrc,v 1.8 2003/02/28 15:45:35 azarah Exp $

# This file is sourced by all *interactive* bash shells on startup. This
# file *should generate no output* or it will break the scp and rcp commands.

# colors for ls, etc.
eval `dircolors -b /etc/DIR_COLORS`
alias d="ls --color"
alias ls="ls --color=auto"
alias ll="ls --color -l"

# Change the window title of X terminals
case $TERM in
xterm*|rxvt|Eterm|eterm)
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
;;
screen)
PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\033\\"'
;;
esac

##uncomment the following to activate bash-completion:
#[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion

En gros rien de spécial


Last edited by fb99 on Tue Feb 22, 2005 1:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue Feb 22, 2005 1:28 pm    Post subject: Reply with quote

histoire de comprendre :
au bureau je suis sous gnome. pas de .bashrc dans mon home mais quand je lance un term : /etc/profile a été "sourcé"
à la maison je suis sous fluxbox idem : pas de .bashrc dans mon home mais quand je lance un term : /etc/profile n'est PAS "sourcé"
y'a un truc qui m'échappe ! Même si pour résoudre mon pb je n'ai qu'à copier le /etc/skel/.bash* dans mon home ; j'aurais bien aimé comprendre 8O
Une idée du pourquoi ?
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Tue Feb 22, 2005 8:57 pm    Post subject: Reply with quote

man xterm wrote:
Code:

 -ls     This option indicates that the shell that  is  started  in  the
               xterm  window  will be a login shell (i.e., the first character
               of argv[0] will be a dash, indicating  to  the  shell  that  it
               should read the user's .login or .profile).



je suis pas sur de t'aider beaucoup, mais au moins tu auras ton prompt préféré
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum