Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Prob avec "emerge libdv-0.99-r1" (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 2:27 pm    Post subject: [emerge] Prob avec "emerge libdv-0.99-r1" (résolu Reply with quote

Bonjour, suite a un problème de vision des fichiers *.ogm,

Plusieurs d'entre vous m'on conseiller d'utilisé Mplayer.
J'ai donc fait un emerge mplayer mais voila le prob en question;
a la dépendance libdv-0.99-r1, emerge me met ceci comme message:

Code:

make[2]: *** [playdv] Error 1
make[2]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/playdv'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99'
make: *** [all] Error 2

!!! ERROR: media-libs/libdv-0.99-r1 failed.
!!! Function src_compile, Line 39, Exitcode 2
!!! compile problem
!!! If you need support, post the topmost build error, NOT this status message.


Que pouvez-vous me conseiller de faire?

Merci d'avance pour votre aide


Last edited by kingboxer on Fri Jan 14, 2005 8:40 pm; edited 2 times in total
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Fri Jan 14, 2005 2:53 pm    Post subject: Reply with quote

Quote:
!!! If you need support, post the topmost build error, NOT this status message.


EDIT: regarde si un de ces bugs ne correspond pas: http://bugs.gentoo.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-0=product&type0-0-0=substring&value0-0-0=libdv&field0-0-1=component&type0-0-1=substring&value0-0-1=libdv&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=libdv&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=libdv
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 3:50 pm    Post subject: Reply with quote

re bonjour,

j'ai un peu regarder les bugs mais je ne comprends pas grand chose...
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 4:01 pm    Post subject: Reply with quote

J'ai apparament le même problème avec emerge imlib2-1.2.0

Bizarre, bizarre
Back to top
View user's profile Send private message
Polo
l33t
l33t


Joined: 27 Jan 2004
Posts: 649
Location: Angers, France

PostPosted: Fri Jan 14, 2005 4:03 pm    Post subject: Reply with quote

libdv , c'est pour utiliser entre autres une caméra dv, non?
si tu n'a pas besoin de ca, ce bug fourni un patch pour ajouter un use dv a mplayer...
tu peux essayer d'installer ce patch, de mettre "-dv" dans tes uses flags, et logiquement, libdv ne devrait pas se compiler..... (sauf si un autre paquet en dépend, évidemment...)
Back to top
View user's profile Send private message
zdra
Veteran
Veteran


Joined: 30 Nov 2003
Posts: 1693
Location: Bruxelles, Belgique

PostPosted: Fri Jan 14, 2005 4:20 pm    Post subject: Reply with quote

zdra wrote:
Quote:
!!! If you need support, post the topmost build error, NOT this status message.

Si tu pouvais poster l'erreur de compilation ce serait bien ! Poste à partir de la 1er apparition du mot "error" dans tout le blabla qu'il affiche lors de la compilation ;) Bien souvent lors d'une compilation l'erreur interraissante c'est la 1er, les autres ne sont qu'une conséquence de cette erreur....
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 5:05 pm    Post subject: Reply with quote

Code:

make[2]: *** [playdv] Error 1
make[2]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/playdv'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99'
make: *** [all] Error 2


Voila les erreurs de complilation, de la premiere a la derniere

P.S: Je n'ai pas compris ce qu'a dit polo ou du moins je ne vais pas comment le faire pratiquement

Merci deja pour vos replys
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Fri Jan 14, 2005 5:08 pm    Post subject: Reply with quote

kingboxer wrote:
Code:

make[2]: *** [playdv] Error 1
make[2]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/playdv'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99'
make: *** [all] Error 2


Voila les erreurs de complilation, de la premiere a la derniere

P.S: Je n'ai pas compris ce qu'a dit polo ou du moins je ne vais pas comment le faire pratiquement

Merci deja pour vos replys

et les lignes au dessus ?
parce que make[2] : *** [playdv] Error 1 ça signifie qu'un truc a merdé avant!
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 5:14 pm    Post subject: Reply with quote

Code:

make[3]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/libdv '
make[2]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/libdv '
Making all in playdv
make[2]: Entering directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/play dv'
source='playdv.c' object='playdv.o' libtool=no \
depfile='.deps/playdv.Po' tmpdepfile='.deps/playdv.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..     -g -O2 -Wall -I/usr/inclu de/SDL -D_REENTRANT -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/gl ib/include -I/usr/X11R6/include -c `test -f 'playdv.c' || echo './'`playdv.c
source='display.c' object='display.o' libtool=no \
depfile='.deps/display.Po' tmpdepfile='.deps/display.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..     -g -O2 -Wall -I/usr/inclu de/SDL -D_REENTRANT -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/gl ib/include -I/usr/X11R6/include -c `test -f 'display.c' || echo './'`display.c
source='oss.c' object='oss.o' libtool=no \
depfile='.deps/oss.Po' tmpdepfile='.deps/oss.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..     -g -O2 -Wall -I/usr/inclu de/SDL -D_REENTRANT -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/gl ib/include -I/usr/X11R6/include -c `test -f 'oss.c' || echo './'`oss.c
/bin/sh ../libtool --silent --mode=link i686-pc-linux-gnu-gcc  -g -O2 -Wall -I/u sr/include/SDL -D_REENTRANT -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/us r/lib/glib/include -I/usr/X11R6/include   -o playdv  playdv.o display.o oss.o -L /usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -L/usr/lib -L/usr/X11R6/lib -lgtk - lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -lXv ../libdv/libdv.l a -lpopt -lm
libtool: link: cannot find the library `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4 /libstdc++.la'
make[2]: *** [playdv] Error 1
make[2]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99/playd v'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libdv-0.99-r1/work/libdv-0.99'
make: *** [all] Error 2


Cette fois j'espere avoir été complet ;-)
Back to top
View user's profile Send private message
Polo
l33t
l33t


Joined: 27 Jan 2004
Posts: 649
Location: Angers, France

PostPosted: Fri Jan 14, 2005 5:16 pm    Post subject: Reply with quote

ce topic indiquait le meme problème... je t'invite a y faire un tour :lol:

[EDIT]
d'apres kernel_sensei sur ce topic il faut faire
Code:
fix_libtool_files.sh 3.3.4
esperons que ca marche....
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 8:32 pm    Post subject: Reply with quote

Merci tout est ok ;-) je peux enfin matter Mary Poppins en .ogm ;-)
Back to top
View user's profile Send private message
Polo
l33t
l33t


Joined: 27 Jan 2004
Posts: 649
Location: Angers, France

PostPosted: Fri Jan 14, 2005 8:39 pm    Post subject: Reply with quote

c'est pas pour etre relou, mais il faudrai mettre (résolu), et pas (réglé)
Back to top
View user's profile Send private message
kingboxer
Apprentice
Apprentice


Joined: 26 Nov 2004
Posts: 155

PostPosted: Fri Jan 14, 2005 8:41 pm    Post subject: Reply with quote

Merci j'ai changé sur tes conseils
Back to top
View user's profile Send private message
Polo
l33t
l33t


Joined: 27 Jan 2004
Posts: 649
Location: Angers, France

PostPosted: Fri Jan 14, 2005 8:43 pm    Post subject: Reply with quote

c'est nickel.
Bon film :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum